17:00:22 <rluethi> #startmeeting training-guides
17:00:23 <openstack> Meeting started Mon Jan 26 17:00:22 2015 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:27 <openstack> The meeting name has been set to 'training_guides'
17:00:33 <rluethi> hi there
17:00:36 <vigneshvar> hi
17:01:00 <vigneshvar> i have just joined and want to contribute to training guides
17:01:00 <rluethi> hi sayali
17:01:10 <sayali> Hello rluethi
17:01:11 <rluethi> vigneshvar: welcome
17:01:25 <vigneshvar> i spoke with pranav and he gave me some guidence
17:01:36 <matjazp> hey
17:01:43 <rluethi> vigneshvar: ah, I think he might have mentioned you
17:01:45 <rluethi> hi matjazp
17:02:00 <rluethi> pranav coming, does anyone know?
17:02:02 <sayali> hello vigneshvar matjazp
17:02:14 <vigneshvar> hello everyone
17:02:20 <matjazp> hi vigneshvar
17:02:33 <rluethi> let's start then.
17:02:45 <rluethi> #topic follow-up action items 19 Jan
17:03:00 <rluethi> http://eavesdrop.openstack.org/meetings/training_guides/2015/training_guides.2015-01-19-17.00.html
17:03:22 <wojdev> hi, here is Wojtek, taled with Pranav, last week @ Suse meetup
17:03:32 <rluethi> hi wojdev
17:03:42 <rluethi> matjazp: is the dependency still an issue?
17:04:22 <matjazp> rluethi: yes, I was waiting a bit to decide what would the naming convention be
17:04:47 <rluethi> matjazp: there is no hurry, is there?
17:05:17 <matjazp> rluethi: nope
17:05:43 <rluethi> matjazp: cool. if you need feedback again, let us know.
17:05:53 <matjazp> rluethi: but I would like to just start merging asap..
17:05:59 <rluethi> matjazp: I also hope you are getting the promised help :).
17:06:28 <rluethi> right, the branching update. sarob and pranav aren't here, bummer.
17:06:58 <rluethi> I think we developed an agreement that we merge again everything that is cool for Icehouse and Juno.
17:07:09 <rluethi> we still hold back on Juno-only stuff.
17:07:25 <matjazp> rluethi: we should just merge sean's patches and start the ball rolling again
17:07:52 <rluethi> matjazp: which ones would that be? can you post a list to the ML?
17:08:04 <rluethi> matjazp: I suppose that would be the fastest way.
17:08:19 <matjazp> rluethi: will do
17:08:53 <rluethi> #action matjazp posts list of patches that should be reviewed and merged ASAP to get the ball rolling again
17:09:39 <rluethi> anything else on last week's action items?
17:09:59 <rluethi> #topic Sayali's new specs
17:10:31 <sayali> yes they need some attention now ;)
17:10:33 <rluethi> Sayali posted two new specs, take a look everyone and comment.
17:10:51 <rluethi> #link https://review.openstack.org/#/c/144635/
17:11:14 <sayali> Audio Visual Spec: https://review.openstack.org/#/c/143270/
17:11:17 <sayali> Color Support for osnbash: https://review.openstack.org/#/c/144635/y
17:11:31 <rluethi> right, thank you :-).
17:11:59 <rluethi> sayali: anything people should know about the specs?
17:12:17 <sayali> Ah nope nothing as of now
17:12:20 <vigneshvar> Hi guys i would like to make my initial contributions on audio visual, if any specific action items can be mentioned i can take it
17:12:22 <rluethi> k.
17:12:24 <dguitarbite> hello
17:12:27 <dguitarbite> sorry for being late
17:12:28 <rluethi> #topic requirements for labs scripts
17:12:35 <rluethi> hi dguitarbite
17:12:54 <vigneshvar> hi dguitarbite
17:13:03 <rluethi> matjazp sent me an email with some info after I added this to the agenda.
17:13:05 <dguitarbite> hi vigneshvar
17:13:11 <sayali> vigneshvar: cool, we are currently working of some videos to demonstrate osbash
17:13:14 <dguitarbite> rluethi: yes, tell me
17:13:31 <dguitarbite> vigneshvar: lets discuss this after the current topic
17:13:33 <rluethi> the issue is that we are currently considering the future architecture of osbash.
17:13:42 <vigneshvar> dguitarbite: sure
17:14:04 <rluethi> and the requirements (such as those mentioned by matjazp) are an influence on these considerations.
17:14:11 <matjazp> rluethi: should we put those on etherpad? or Wiki?
17:14:16 <dguitarbite> rluethi: I do not understand future part
17:14:17 <rluethi> for instance, do we need several compute/network nodes?
17:14:26 <dguitarbite> can you please specify? Also CC me into the email
17:15:01 <rluethi> if we merge all config/scripts.<node> into one file, that has several advantages, but it makes adding lots of compute nodes more complicated.
17:15:36 <matjazp> dguitarbite: I can foward that mail to the ML?
17:15:46 <dguitarbite> rluethi: lets move this discussion for later on, I just want to say that we should try to get to more openstack'y conf. files
17:15:55 <dguitarbite> so that it serves these issues while being useful for stacktrain
17:16:01 <rluethi> dguitarbite: duly noted.
17:16:26 <rluethi> everyone: if the osbash scripts are not suitable for you for some reason, let us know.
17:16:40 <dguitarbite> we need to be able to keep our cluster scalable and also consider use-cases where people will want to run VMs which are heavy like Windows VMs etc.
17:16:43 <rluethi> I suck at mindreading, and I don't know about dguitarbite .
17:17:04 <dguitarbite> rluethi: I am a born psysic (nah!)
17:17:06 <dguitarbite> ;)
17:17:45 <rluethi> so, since we have several new guys in this meeting, I am taking the liberty of inserting another topic:
17:17:52 <rluethi> #topic introductions
17:18:07 <rluethi> hi new guys, who are you, and what are your interests in training-guides?
17:18:09 <dguitarbite> yes, unless there are any other urgent topics, lets focus on welcoming new comers
17:18:26 <rluethi> dguitarbite: beat you to it :-).
17:18:47 <dguitarbite> rluethi: damn, cant beat German's at efficiency ;)
17:19:07 <vigneshvar> Hi, I am vigneshvar, i have been contributing to some blueprints in Nova, I can do shell scripts and python code
17:19:08 <rluethi> dguitarbite: I'll try not to take offense from that :)
17:19:23 <vigneshvar> I would like to initially contribute on some AV
17:19:35 <rluethi> vigneshvar: cool, exactly what the doctor ordered.
17:19:42 <dguitarbite> rluethi: I thought you where swiss-german (anyhow ... you may kill me after the meeting)
17:19:50 <matjazp> vigneshvar: nice... welcome, btw :)
17:19:55 <vigneshvar> :)
17:20:16 <wojdev> Hi, I am Wojtek, I am working on bringing openstack course to WSB Schools of Business in Poland. I am interested in contributing to the d
17:20:17 <wojdev> guide
17:20:38 <wojdev> . Skill set: bash, python, chef, vagrant, test-kitchen.. java
17:20:39 <wojdev> :D
17:21:02 <rluethi> very nice. this is a good way to start a week. :-)
17:21:04 <dguitarbite> welcome guys :D good to see you here
17:21:22 <matjazp> wojdev: WSB? Is that Uni?... oh.. and welcome :)
17:21:28 <sayali> yes it surely is nice to see you guys :)
17:21:30 <wojdev> Yes. It is a university
17:21:39 <rluethi> newcomers are always encouraged to try the osbash scripts and report any problems/issues.
17:21:48 <wojdev> I feel encouraged
17:21:55 <wojdev> and .. inspearied
17:21:57 <vigneshvar> rluethi: Yap started exploring
17:22:32 <matjazp> wojdev: nice.. how far are you with your course? planning? next academic year?
17:22:35 <rluethi> also, if you guys have questions, the core reviewers are usually available and response to queries via IRC and/or email.
17:22:54 <wojdev> Sorry, guys I have to leave
17:23:06 <matjazp> wojdev: sure, see you around
17:23:13 <dguitarbite> wojdev: lets catch up over the docs mailing list
17:23:35 <vigneshvar> you guys are on any specific channel
17:23:40 <vigneshvar> ?
17:23:45 <rluethi> openstack-doc
17:23:46 <sayali> openstack-doc
17:23:52 <vigneshvar> thanks
17:24:18 <sayali> vigneshvar: As I understand you would like to help make some videos for the AV project?
17:24:24 <matjazp> vigneshvar: also on docs ML, use tag [training-guides]
17:24:41 <vigneshvar> sayali: yes
17:24:47 <vigneshvar> sayali: you are right
17:25:11 <vigneshvar> matjazp: sure will check the mailing list
17:25:37 <sayali> vigneshvar: cool, if you are already familiar with any openstack deployment you could suggest that and take that up
17:26:39 <sayali> here is the link to the etherpad where you can find AV related stuff: https://etherpad.openstack.org/p/openstck-training-guides%28Audio_Visual_Content%29
17:26:48 <rluethi> Talking about introductions, maybe we should have short descriptions with IRC handles on our Wiki so we can point newcomers to that (so they know who is who and what they are working on).
17:27:19 <vigneshvar> sayali: i have seen you have done for openstack on virtualbox
17:27:21 * rluethi wonders if it is possible to rename etherpads (openstck)
17:27:28 <vigneshvar> sayali: yes will look into that etherpad
17:27:58 <sayali> yeah rluethi I think its time I should correct that :D
17:28:06 <rluethi> Okay guys, I consider introductions done.
17:28:08 <sayali> vigneshvar: yep thats the first
17:28:12 <rluethi> #topic any other business
17:28:35 <rluethi> dguitarbite: any news you would like to share (e.g. on branching)?
17:28:48 <dguitarbite> yes, waiting for the infra team
17:29:01 <rluethi> heh. fun.
17:29:06 <dguitarbite> Andreas says that the people responsible for branching are travelling
17:29:16 <dguitarbite> it should happen anytime now, keep tight
17:29:46 * rluethi is not holding his breath
17:29:53 <vigneshvar> i would also like to contribute on scripts - bug fixes
17:30:12 <vigneshvar> any pointers on where i can fit in
17:30:59 <rluethi> vigneshvar: that is a very good question.
17:31:19 <rluethi> vigneshvar: we may have to adapt our processes as we become a larger group.
17:31:33 <matjazp> rluethi: maybe a new, smaller feature?
17:31:40 <rluethi> vigneshvar: we have several splits that lets us work without too many collisions.
17:31:53 <rluethi> e.g., between client-side and host-side.
17:32:05 <rluethi> also (hopefully soon) VirtualBox vs. KVM.
17:32:16 <rluethi> matjazp: lbaas?
17:32:17 <vigneshvar> rluethi: Ok..
17:32:50 <vigneshvar> do we also track bugs in launchpad
17:32:51 <matjazp> rluethi: yes, it looks smaller then other we talked about
17:33:39 <rluethi> matjazp, vigneshvar: lbaas looks good because it would be useful and it's at the end of the install process, so not many dependencies.
17:33:40 <matjazp> vigneshvar: do you know LBaaS?
17:34:01 <matjazp> rluethi: exactly my thoughts
17:34:18 <vigneshvar> yes i have used neutron-LBaaS
17:34:24 <vigneshvar> matjazp: yes i have used neutron-LBaaS
17:34:44 <rluethi> matjazp: is there an install document on docs.openstack for lbaas, one that we could follow?
17:34:49 <matjazp> vigneshvar: what do you think? could you add that to the labs scripts
17:34:53 <rluethi> matjazp: and will it work with our current three node setup?
17:35:27 <vigneshvar> matjazp: Yes its possible.. I have just started with osbash
17:35:27 <matjazp> rluethi: sure, I've been demoing it with allinone
17:36:02 <matjazp> rluethi: shopuld we just file a bug for this? missing LBaaS ;)
17:36:35 <rluethi> matjazp: if you can send a URL or your own install instructions to vigneshvar (and maybe other devs), that would be awesome.
17:36:49 <vigneshvar> I think filing bugs or making it part of spec would be useful
17:36:52 <rluethi> matjazp: yeah, at least I prefer a bug over a spec in this case.
17:36:53 <matjazp> rluethi: I7ve been using it on Devstack
17:37:09 <rluethi> matjazp: that's cheating, you traitor.
17:37:12 <dguitarbite> matjazp: +1 for bug
17:37:19 <matjazp> +1 for bug... BP or Spec is too heavy
17:37:28 <vigneshvar> matjazp: +1 for bug
17:37:40 <sayali> +1 bug, specs take too long
17:37:46 <matjazp> rluethi: yes, I7ve been cheating you guys with DevStack ;)
17:37:50 <rluethi> #action matjazp files a bug to get LBaaS added to osbash scripts
17:38:01 <dguitarbite> matjazp: not fair!
17:38:42 <matjazp> well... for developers, DevStack is a must anyway
17:38:42 <rluethi> #action vigneshvar will look at fixing the lack-of-LBaaS bug in osbash
17:39:10 <rluethi> vigneshvar: if you could report your impressions next week, that would be great
17:39:18 <matjazp> dguitarbite: DevStack is like a gold standard for Developers :)
17:39:20 <vigneshvar> rluethi: Yap i will take it.
17:39:23 <vigneshvar> rluethi: sure
17:39:35 <sayali> we shuld work on adding devstack support to osbash soon ;)
17:39:36 <rluethi> vigneshvar: cool
17:39:36 <dguitarbite> matjazp: yes, but its only for developers IMHO
17:39:55 <rluethi> sayali: we might, eventually.
17:39:59 <dguitarbite> matjazp: not everyone is developer!
17:40:30 <matjazp> dguitarbite: DevStack has ALL the new stuff you want to demo... I don't see it as a competing "product", more as a complementary tool
17:40:40 <ProgrammedToKill> Serial killers do not actually exist. People do not wake up one day and decide to become a 'serial killer.' It's total bullshit. Why were serial killings such a rampant phenomenon in the sixties and seventies, only to almost completely disappear in the present day as suddenly as they had appeared? Why are we now seeing more than one 'mass shooting' every few months? This isn't the way natural behaviors manifest.
17:41:04 <rluethi> okay, I guess this is a sign that it's time to wrap up.
17:41:17 <rluethi> anything else that can't wait until next week? :)
17:41:29 <dguitarbite> need for speed
17:41:31 <vigneshvar> is there a one stop URL where we can find pending tasks
17:41:48 <dguitarbite> vigneshvar: hold on
17:41:48 <rluethi> vigneshvar: file:///home/rl/todo.txt
17:42:09 <dguitarbite> #link https://etherpad.openstack.org/p/openstack-training-developing-topics
17:42:09 <vigneshvar> dguitarbite: Ok
17:42:11 <ProgrammedToKill> Gen. Douglas MacArthur said that the people must always be kept in fear, whether it is some foreign enemy ("terrorists") or some mysterious domestic enemy like 'serial killers' or 'school shooters.' Most "conspiracy theorists" are well-aware that tragedies like 9/11 and the train bombings in London were orchestrated by the military-intelligence services for this purpose. Why should "serial killings" be any differe
17:43:05 <dguitarbite> rluethi: I am not sure if your URL Will work
17:43:13 <ProgrammedToKill> I think in many cases the "serial killer" is innocent of some or in some cases all of the killings attributed to them. A bunch of contract hits related to organised crime, police corruption, government assassinations and cult sacrifices are all attributed to some hapless 'nut' in order to clear the books of a bunch of inconvenient unsolved cases.
17:43:17 <dguitarbite> and also I am a bit irritated by spammers, lets call this a day
17:43:21 <rluethi> once again, welcome to all the news folks, see you on openstack-doc
17:43:31 <rluethi> dguitarbite: agreed.
17:43:39 <ProgrammedToKill> dude i'm not a spammer just look at the patterns
17:43:39 <sayali> see you
17:43:41 <rluethi> that's all, folks! thanks for coming.
17:43:49 <ProgrammedToKill> why do ALL OF THEM COME FROM MILITARY-INDUSTRIAL-INTELLIGENCE FAMILIES?
17:43:51 <vigneshvar> see you all
17:43:54 <rluethi> #endmeeting