17:00:41 <sarob> #startmeeting training-guides
17:00:42 <openstack> Meeting started Mon Feb  2 17:00:41 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:45 <openstack> The meeting name has been set to 'training_guides'
17:00:47 <sarob> roll call
17:01:05 <dbyte> hi
17:01:17 <vigneshvar> hello all
17:01:26 <sayali> hello
17:01:34 <sarob> heloo!
17:01:47 <sarob> evening matjazp
17:01:52 <matjazp> hi all
17:02:01 <sarob> agenda can be found here #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:02:19 <matjazp> sarob: long agenda this time...
17:02:31 <sarob> matjazp better than short
17:02:36 <sarob> lets dig in
17:02:53 <sarob> #topic publishing in new branch
17:03:11 <sarob> dbyte: take it away!
17:03:40 <dbyte> sarob, publishing should be done soonish, here are the patches:
17:03:42 * sarob we have stable icehouse, yah!
17:03:45 <dbyte> #link https://review.openstack.org/#/c/152114/
17:03:58 <dbyte> #link https://review.openstack.org/#/c/152118/
17:04:05 <dbyte> one more patch to come soonish
17:04:21 <dbyte> conversion of RST to HTML/PDF will have to wait till we decide for sure to use Landslide or Heiroglyph
17:04:48 <matjazp> dbyte: what the difference in source RST?
17:05:07 <dbyte> some syntax will change
17:05:13 <matjazp> dbyte: I mean, maybe the format for slides is so similar that we dont need to wait
17:05:13 <dbyte> but I cannot decide which one to go with
17:05:20 <dbyte> it has to be a team decison with a spec
17:05:25 <dbyte> to convience the infra team
17:05:41 <dbyte> publishing the jenkins job will have to wait
17:05:44 <matjazp> dbyte: I'm afraid that we're gonna stall again
17:05:48 <dbyte> not the RST content development
17:05:58 <sarob> does this patch #link https://review.openstack.org/#/c/132395/
17:06:02 <sarob> from reed
17:06:08 <dbyte> matjazp, I cannot help it, last time I created the required tools but it was not accepted
17:06:17 <sarob> finish the hieroglyph port changes for upstream?
17:07:07 <matjazp> is reed happy with Upstream training port to Hiero?
17:07:36 <sarob> i will need the syntax changes for rst for hieroglyph
17:08:02 <sarob> ill work on reed's patch and ping the group if it is ready
17:08:19 <sarob> im fine with hieroglyph at this point
17:08:29 <sarob> i just want to start publishing slides
17:08:55 <sarob> dhellman you around?
17:09:32 <sarob> #action sarob review and post hieroglyph patch https://review.openstack.org/#/c/132395/
17:10:13 <sarob> dbyte you going to rebase #link https://review.openstack.org/#/c/150472/
17:10:43 <dbyte> yes
17:11:02 <dbyte> I mean
17:11:04 <dbyte> no need for that
17:11:05 <dbyte> https://review.openstack.org/#/c/151938/
17:11:08 <dbyte> here is the correct patch
17:11:35 <sarob> cool
17:11:47 <sarob> so we are fully branched
17:12:38 <sarob> moving on?
17:12:46 <dbyte> yes
17:12:59 <sarob> #topic conversion of XML books to RST slides
17:13:47 <sarob> #link http://lists.openstack.org/pipermail/openstack-docs/2015-January/005755.html
17:14:11 <sarob> ill run down the points in the email
17:14:30 <sarob> we need to branch faster i think is the first one
17:14:40 <sarob> so we can push the backlog
17:14:45 <dbyte> sarob, next time it will be faster
17:14:57 <sarob> dbyte: cool ;)
17:15:00 <dbyte> I have to setup infra related stuff this time ... its a bit painful
17:15:10 <sarob> dbyte: understood
17:15:21 <sarob> second point #link https://review.openstack.org/#/c/141226/
17:16:04 <sarob> my understanding of landslide is that I needed to create the structure for each subdir
17:16:26 <sarob> if there is a better way im open to it
17:16:50 <sarob> not sure about what cruft hieroglyph will bring to the party
17:16:57 <dbyte> sarob, we do not need landslide branding in every folder
17:17:15 <dbyte> just keep the css and other landslide related content in the /doc/training-guides/ folder
17:17:20 <sarob> dbyte: just root dir to publish from?
17:17:33 <dbyte> yes, there is no need to repeat the content
17:17:39 <sarob> dbyte: okay cool
17:18:16 <sarob> #action sarob #link https://review.openstack.org/#/c/141226/ cleanup extra css, leaving only root
17:19:02 <matjazp> sowe're going forward with landslide
17:19:04 <sarob> third point was to include removing the xml content with the rst patches
17:19:15 <matjazp> and not wait for hiero?
17:19:25 <matjazp> or did I misunderstood?
17:19:41 <dbyte> if we want landslide, it is possible to push landslide
17:19:47 <dbyte> we will also have PDF support with that!
17:19:52 <sarob> matjazp: im assuming landslide until the team or infra decides differently
17:20:00 <matjazp> ok, agree
17:20:15 <dbyte> the tools for landslide are already made
17:20:19 <sarob> matjazp: im going to check out reed's hieroglyph patch though
17:20:46 * sarob no like wait
17:20:54 <matjazp> dbyte: yes, I agree.. I was afraid that we're gonna wait for hiero and get into another stall
17:21:51 <sarob> about the third point #link https://blueprints.launchpad.net/openstack-training-guides/+spec/merge-unused-content-back-into-the-existing-docs
17:22:11 <dbyte> matjazp, I am neutral to the tools used :)
17:22:26 <sarob> plus #link https://blueprints.launchpad.net/openstack-training-guides/+spec/convert-the-xml-into-rst
17:23:55 <sarob> the last point is to break the rst down into a smaller, less detail slides
17:24:04 <sarob> i agree with this
17:24:24 <sarob> it was part of our original summit decussion
17:24:30 <matjazp> sarob: not only that, I guess we still need some kind of more detailed text
17:24:32 <sayali> yes slide should only have pointers..not too much content
17:24:39 <dhellmann> sarob: pong
17:24:49 <sarob> so im going to pare down the rst slides
17:24:57 <sarob> leaving only the unused xml
17:24:57 <matjazp> sarob: like presenters notes or smth like that
17:25:23 <sarob> matjazp: did we ever figure out how to do presenters notes?
17:25:32 <matjazp> sarob: in landslide, yes
17:25:52 <sarob> matjazp: example?
17:26:10 * sarob dont remember
17:26:11 <matjazp> sarob: I can make one
17:26:17 <sarob> matjazp: sweeet
17:26:22 <matjazp> sarob: you have tags
17:26:27 <matjazp> for it
17:27:10 <sarob> dhellman: there was some discussion about using hieroglyph
17:27:24 <dhellmann> in hieroglyph you use the "note" directive for presenter notes -- https://raw.githubusercontent.com/pyatl/talks/master/2014-09/stdlib-tour/source/index.rst
17:27:48 <dhellmann> sarob: ok, did you determine if it meets your needs?
17:28:23 <sarob> dhellman: reed was looking into it #link https://review.openstack.org/#/c/132395/
17:28:32 <matjazp> dhellmann: yes, I see it's similar as in landslide
17:28:58 <sarob> dhellman: we are ready to publish in landslide today however
17:29:31 <sarob> dhellman: we plan on looking at hieroglyph but not to stall our current work
17:30:13 <dhellmann> ok, as long as you've looked at it -- there are a zillion of these tools
17:30:16 <sarob> matjazp: lets discuss presenter notes on docs channel after the meeting
17:30:53 <matjazp> sarob: huh, not today unfortunately.. ML?
17:31:16 <sarob> dhellmann: ill continue to work on it in parallel if it could help simpliy tools support
17:31:46 <sarob> matjazp: sure, or inline in the patch https://review.openstack.org/#/c/142259/
17:31:47 <dhellmann> yeah, if everything else is going to be in restructured text, that would make sense
17:31:53 <matjazp> ok
17:32:38 <sarob> #action sarob simply #link https://review.openstack.org/#/c/142259/ details, removing rst used xml, leaving behind unused xml
17:32:42 <sarob> moving on
17:33:03 <sarob> #topic review queue
17:33:07 <sarob> #link https://review.openstack.org/#/q/status:open+project:openstack/training-guides,n,z
17:34:09 <sarob> patch #link https://review.openstack.org/#/c/151895/
17:34:19 <sarob> dbyte or rluethi?
17:36:04 <sayali1> there are still some patches fixing xml content..
17:36:33 <sarob> sayali1: yup link matjazp #link https://review.openstack.org/#/c/148315/
17:36:45 <matjazp> sayali1: should we redirect them to the stable/icehouse?
17:37:08 <sarob> sayali1: oops, i misunderstood
17:37:11 <dbyte> sarob, needs more discussion
17:37:12 <matjazp> sarob: that patch is for RST
17:37:57 <sarob> matjazp: yup
17:37:57 <sayali1> matjazp: we will have to but it would be better if we can avoid it completly
17:38:29 <sarob> sayali1: stable patches should be fine
17:38:38 <matjazp> sayali1: yes, sure, but if someone submits a patch, its better to merge it somwhere than to abandon it
17:39:18 <sarob> sayali1 matjazp keeping the stable branches cleaned up is good, right?
17:39:19 <sayali1> true, so we keep reviewing the patches.
17:39:47 <sayali1> sarob: yes it definately isn't bad :)
17:39:49 <matjazp> if they are for a master branch, just point them to the stable
17:40:19 <sarob> matjazp: im going to follow your lead on #link https://review.openstack.org/#/c/148315/ for the rest of the assoc tests
17:40:46 <matjazp> sarob: wait a bit ... naming conventions
17:40:59 <matjazp> roger had a point that currently its a mess
17:41:53 <sarob> matjazp: in this patch?
17:41:59 <matjazp> yes
17:42:19 <matjazp> what to name the log document with everything and where to put it
17:42:28 <sarob> periods, whitespace, nova underscore
17:42:37 <sarob> i dont see naming conventions
17:42:53 <matjazp> there are none at the moment
17:43:04 <matjazp> for slides, we start with a numbers
17:43:33 <matjazp> but what about that longer document with all the Q&A (that's gonna end in Moodle someday)?
17:44:06 <sarob> matjazp: yup
17:44:16 <matjazp> We can put them in a separate dir or just leave them in root
17:44:25 <matjazp> currently it's confusing
17:44:47 <matjazp> that's why I havent submitted another patch
17:45:24 <sarob> matjazp: okay, how about the assessment as starting with 00-
17:45:54 <sarob> matjazp: that way it is always in the right place
17:45:59 <matjazp> why 00? trainers will look at slides by numbers
17:46:01 <sarob> matjazp: or 99-
17:46:07 <matjazp> 99- is better
17:46:15 <sarob> matjazp: cool
17:46:28 <matjazp> but its still a terrible convention... dir would be better? or not?
17:46:48 <sarob> matjazp: im fine either way
17:47:02 <matjazp> OK, I'll figure it aout and submit a patch
17:47:17 <sayali1> dir seems more organized..
17:47:19 <sarob> matjazp: i have a natural aversion to lots of subdirecties, but im good either way
17:47:30 <matjazp> we can use that as a guide for other chapters
17:47:45 <sarob> matjazp: sounds good
17:48:07 <sarob> matjazp: i will push all the non-quiz xml
17:48:18 <matjazp> sarob, ok, I will do the rest
17:48:24 <sarob> matjazp: sweet
17:48:42 <sarob> #action sarob will patch non-quiz xml with rst
17:48:57 <sarob> #action matjazp will patch quiz xml with rst
17:49:41 <sarob> lets review the rest of queue on our own time
17:49:49 <sarob> so we can finish the agenda
17:49:52 <sarob> #topic Discuss list of videos to be made for next release
17:50:12 <sarob> sayali1: #link http://lists.openstack.org/pipermail/openstack-docs/2015-January/005765.html
17:50:29 <sayali1> yes I wanted some inputs from everyone on that list..
17:50:57 <vigneshvar> who is doing the sript osbash - linux
17:51:01 <sayali1> I thought it would be nice to have a list so when we have new contributors they can pick from the list
17:51:15 <matjazp> is osx and linux so different that it need separate videos?
17:51:41 <sayali1> I was going to do that but I am waiting for a patch from roger before I can make the osbash videos
17:51:46 <matjazp> sayali1: also, we don't have heat yet
17:52:21 <sayali1> matjazp: no it is not different but if we want we can make them seperate
17:52:37 <sayali1> vigneshvar: would you like to do the osbash video?
17:52:41 <matjazp> why complicate?
17:52:56 <vigneshvar> sayali1: ya i can make
17:52:57 <matjazp> vigneshvar: hey, great work on LBaaS!
17:53:12 <vigneshvar> matjazp: Thanks
17:53:21 <sarob> sweet!
17:53:34 <sayali1> matjazp: not complicate, just variety ;) But I don't mind not doing it too.
17:53:38 <matjazp> we can talk on ML about what to add to Labs... Roger? dbyte ?
17:53:45 <vigneshvar> what about heat ?
17:53:48 <vigneshvar> ok
17:54:06 <matjazp> we have 7 mins left
17:54:11 <matjazp> and log agenda
17:54:13 <sarob> right
17:54:14 <matjazp> nong
17:54:19 <matjazp> long
17:54:27 <sayali1> heat was just a suggestion..we can have other videos..
17:54:28 * matjazp has fat fingers
17:54:46 <vigneshvar> i meant adding heat to oslabs
17:54:54 <sarob> sayali1: work through on the ML?
17:54:56 <sayali1> vigneshvar: ok we will dicsuss that post the meeting then
17:54:59 <matjazp> sayali1: no, I like heat.. I has a great potential for a nice demos
17:55:10 <vigneshvar> sayali1: sure
17:55:21 <vigneshvar> matjazp: +1
17:55:26 <sarob> few minutes about summit prep
17:55:27 <sayali1> sarob: yes but I didn't get any replies so I put it in the agenda
17:55:44 <sayali1> matjazp: yes I thought it would be nice to have a demo on that
17:56:01 <sarob> sayali1: you did the right thing
17:56:12 <sayali1> matjazp: we don't have to keep the content stricty to cover training-guides right>
17:56:47 <vigneshvar> few suggestions about noise reduction - videos . I will share it over #openstack-doc
17:56:50 <sarob> matjazp: agreed, but ideally cover training guides first
17:57:00 <sayali1> vigneshvar: sure
17:57:15 <sarob> 4 minute to highlight summit planning?
17:57:30 <matjazp> just postpone it for next meeting?
17:57:34 <sarob> #topic summit planning
17:57:43 <dbyte> matjazp, sure
17:57:46 <dbyte> lets talk in ML
17:58:00 <sarob> #topic any other business
17:58:09 <sarob> summit talk
17:58:12 <matjazp> there's a long queue of bugs
17:58:30 <matjazp> we should triage it and mark easy one for new contributors
17:58:39 <sarob> do we want to submit a summit talk?
17:58:41 <vigneshvar> matjazp: +1
17:58:49 <sayali1> yes I agree too
17:59:05 <sayali1> sarob: firstly who all would be attending the summit this time?
17:59:11 <matjazp> sarob: what's the deadline?
17:59:15 <vigneshvar> sarob: would be good
17:59:16 <sarob> this week
17:59:30 <matjazp> huh.. no time... ML?
17:59:31 <sarob> few minutes to discuss on docs channel?
17:59:35 <sayali1> thats close, but a talk/demo would be good
17:59:44 <vigneshvar> yes
17:59:45 <sarob> then ill post to ML
17:59:48 <sayali1> yep
17:59:50 <sarob> times up
17:59:57 <sarob> thanks everyone!
18:00:07 <sarob> #endmeeting