17:00:46 <sarob_> #startmeeting training-guides
17:00:46 <openstack> Meeting started Mon Feb  9 17:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is sarob_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:49 <sarob_> roll call
17:00:51 <openstack> The meeting name has been set to 'training_guides'
17:00:54 <vigneshvar> hi
17:00:57 <rluethi> surprise, it's me.
17:01:03 <sayali1> hello
17:01:05 <vigneshvar> :)
17:01:14 <sarob_> rluethi: welcome
17:01:22 <sarob_> evening/morning all
17:01:28 <rluethi> thanks :). hi everyone
17:01:44 <sayali1> nice to have you back rluethi :D
17:02:16 <rluethi> sayali1: nice to be back. we'll see how long I'll last :)
17:02:25 <matjazp> hey all
17:02:49 <sarob> evening matjazp
17:03:15 <sarob> project meeting agenda #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:03:44 <rluethi> hey, that agenda looks familiar
17:04:24 <matjazp> rluethi: we didn't finish everything last week
17:04:44 <sarob> me either :(
17:04:45 <rluethi> matjazp: I see
17:05:50 <sarob> #topic review action items from last week
17:06:01 <sarob> ill go first and quick
17:06:05 <sarob> #link https://review.openstack.org/#/c/132395/
17:06:28 <sarob> this is going to be a parallel discussion for awhile
17:06:42 <sarob> we are going forward with landslide for the time being
17:07:08 <sarob> next thingy
17:07:08 <sarob> #link https://review.openstack.org/#/c/141226/
17:07:25 <sarob> I cleaned up this patch
17:07:42 <sarob> only assoicate dir with landslide stuff
17:07:46 <sarob> next
17:08:00 <sarob> #link https://review.openstack.org/#/c/142259
17:08:34 <rluethi> cool, looks better now.
17:08:34 <sarob> i cut down this patch by half
17:08:51 <sarob> im working on ch5 right now
17:09:13 <sarob> based on new material from our sfo trainer, salman
17:09:35 <sarob> i will come back to ch1 prob next week
17:09:51 <sarob> for another pass based on newish stuff
17:10:10 <sarob> for now id like to merge ch1 as is
17:10:29 <sarob> matjazp you have the last action item
17:10:43 <matjazp> yes..
17:10:51 <matjazp> #link https://review.openstack.org/#/c/148315/
17:10:57 <matjazp> submitted a new patch
17:11:01 <dguitarbite> hello
17:11:04 <dguitarbite> sorry for the delay
17:11:07 <sarob> on new quiz structure patch #link https://review.openstack.org/#/c/148315/
17:11:14 <vigneshvar> hello
17:11:15 <sarob> dguitarbite: evening
17:11:23 <dguitarbite> sarob: morning
17:11:34 <matjazp> take a look and tell me what you think.. this would be "template" for all quizzes...
17:12:15 <rluethi> sarob, I think ch1 is still way too wordy. the things we merge should serve as good examples.
17:12:37 <matjazp> We could also use "notes" folder for all that stuff we won't put on slides but we already have written for "old" guides
17:13:00 <dguitarbite> #link https://review.openstack.org/#/c/150608/
17:13:07 <dguitarbite> this one is ready for merging
17:14:28 <sarob> matjazp: needs to be dependent on landslide patch
17:14:40 <sarob> matjazp: so i can check the output
17:15:08 <matjazp> sarob: oh, right, I just used local TExtMate preview
17:15:09 <sarob> rluethi: give me some inline pointers on what you would like to see
17:15:22 <rluethi> dguitarbite, looks ready to me, all you need is to lift your WF -1.
17:16:03 <rluethi> sarob, what I mean is that slides are usually not whole paragraphs of text.
17:16:09 <dguitarbite> I think I did that
17:16:12 <dguitarbite> refresh the browser :)
17:16:20 <sarob> rluethi: ah, i see
17:16:25 <dguitarbite> merge away!
17:16:31 <sarob> rluethi: i will take another cut down pass
17:16:31 <rluethi> sarob, your audience will either read the slide or listen to you, not both.
17:16:35 <dguitarbite> I like deleting things (BOFH!!!)
17:16:57 <matjazp> sarob: just put this text in notes
17:17:11 <matjazp> sarob: we can distill slides in a later patch
17:17:17 <sarob> rluethi: you are right
17:17:53 <sarob> rluethi: i will take another pass at cutting it down
17:18:09 <rluethi> sarob, IIRC upstream university slides are pretty good in this regard.
17:18:39 <sarob> rluethi: you should like the slides i am converting from salman
17:18:49 <sarob> rluethi: alot shorter
17:18:54 <rluethi> sarob, excellent
17:19:00 <sarob> lets move on
17:19:13 <sarob> #topic review outstanding patches
17:20:00 <rluethi> I submitted the first of two series for converting the labs scripts to Juno.
17:20:38 <sayali1> rluethi: I have reviewed most of them just against the install guides. I will test them soonish.
17:20:50 <sarob> rluethi: should i be reviewing each of the script changes one by one?
17:20:58 <rluethi> sayali1, Thanks.
17:21:07 <dguitarbite> rluethi: I will test the patches and merge asap
17:21:11 <sarob> rluethi: seems a few of them should be used together
17:21:22 <rluethi> sarob, your choice. I split them so reviewers don't have to review one giant changeset.
17:21:54 <rluethi> sarob, since there are no functional changes, each patch can stand on its own.
17:22:05 <sarob> okey dokey
17:23:15 <sarob> dguitarbite: you have a third patch to enable landslide automajik
17:23:38 <dguitarbite> sarob: It will take some time, need to fix the pending infra jobs first
17:24:09 <sarob> dguitarbite: which pending infra jobs would that be?
17:24:41 <sarob> like deleting the existing html?
17:25:08 <dguitarbite> sarob: at present publishing to docs.openstack.org is disabled
17:25:16 <dguitarbite> it will be up online very soon
17:25:28 <sarob> okay
17:25:46 <dguitarbite> only if someone can merge this https://review.openstack.org/#/c/150608/
17:25:49 <dguitarbite> :D
17:26:27 <matjazp> dguitarbite: done
17:26:30 <dguitarbite> so the present jobs in infra is to disable the translations
17:26:32 <dguitarbite> matjazp: thanks
17:26:34 <sarob> yup
17:26:50 <dguitarbite> infra disable translations for all other branches than icehouse
17:27:00 <matjazp> git repo will be so empty without xml ;)
17:27:18 <dguitarbite> once that is done, we will reuse the curret jobs to publish the rst content and its just updating our repository which is fairly simple
17:27:18 <sarob> matjazp: ill start filling it up
17:27:29 <matjazp> sarob: we all neet to fill it up asap
17:27:35 <dguitarbite> matjazp: not the .git folder!
17:27:39 <dguitarbite> but in a way yes
17:28:27 <sarob> matjazp: we should lean toward quantity rather than quality at this stage
17:28:48 <rluethi> sarob: hear, hear!
17:29:00 <sarob> ill update the associate guide patches over the next hours
17:29:03 <dguitarbite> oh god!
17:29:16 <rluethi> sarob, kidding. I think quality is more important.
17:29:19 * sarob yes my son
17:29:19 <dguitarbite> sarob: I guess we were working in eliminating the quantity to get to quality
17:29:40 <sarob> dguitarbite: thats my aim
17:29:54 <sarob> dguitarbite: salman is helping alot
17:30:04 <sarob> dguitarbite: by running the local classroom
17:30:07 <dguitarbite> sarob: ok, :)
17:30:11 <sarob> dguitarbite: getting feedback
17:30:54 <sarob> last thing on outstanding patches
17:31:17 <sarob> the few patches from jan
17:31:25 <sarob> whats the plan for them
17:32:04 <sarob> can they be rebased to the icehouse branch?
17:32:16 <rluethi> for the test script, the plan is to clean it up and merge it.
17:32:17 <sarob> or should?
17:32:20 <dguitarbite> I already have rebased the required pacthes
17:32:30 <dguitarbite> I need to take a look soonish
17:32:37 <sarob> dguitarbite: okay
17:32:39 <dguitarbite> not sure, which patches you arerefering to
17:32:43 <dguitarbite> can you link them?
17:33:00 <sarob> #link https://review.openstack.org/#/c/148039/
17:33:03 <dguitarbite> i can not see any patches from jan in the review system
17:33:24 <rluethi> dguitarbite: go to the 2nd page
17:33:31 <dguitarbite> yes, saw them :
17:33:36 <dguitarbite> there is a -1
17:33:50 <dguitarbite> I cannot do anything in thiscaseand also this patch is not valid for backport
17:34:20 <sarob> so after this rst, slide patch pass
17:34:31 <sarob> lets abandon dead patches
17:35:16 <sarob> moving on to bugs
17:35:29 <sarob> #topic bug queue
17:35:30 <matjazp> https://review.openstack.org/#/c/148039/ is ok, but screeenshot needs to be retaken when swift data is in the wiki
17:35:57 <sarob> matjazp: okay
17:35:58 <matjazp> maybe Kato can update Wiki and retake screenshot
17:36:11 <sarob> outstanding bugs #link https://bugs.launchpad.net/openstack-training-guides
17:36:18 <sarob> 59 of them
17:36:28 <sarob> mostly on the xml content
17:36:57 <matjazp> sarob: not only that, we need to deliberately create few "low-hanging-fruit" patches for newcomers
17:37:05 <matjazp> to expand community
17:37:14 <sarob> once the rst gets merged, i will clean the bug list up
17:37:45 <sayali1> we can assign some of these as low-hanging-fruit too
17:37:46 <sarob> many will be changed to invalid
17:38:02 <matjazp> sarob: they are valid for icehouse
17:38:03 <rluethi> matjazp: do you have anything in mind for low-hanging fruit?
17:38:18 <sarob> matjazp: oh, good point
17:38:57 <dguitarbite> sarob: not exactly invalid but low priority and to icehouse
17:39:17 <sarob> hmm, ill figure out how to assign them to icehouse branch
17:39:24 <matjazp> rluethi: It could be anything  that's easy enough for a newcomer to start contributing and that way feel more involved in a community
17:40:19 <sarob> matjazp: are there repeatable easy bugs that we can create for classroom work?
17:40:35 <sarob> matjazp: or should they be real bugs?
17:40:38 <matjazp> sarob: hmmm doubt it
17:40:50 <dguitarbite> sarob: not sure, but we might get some dummyfolder for the same
17:41:04 <sarob> #action sarob assign xml content bugs to icehouse branch
17:41:11 <sarob> #undo
17:41:22 <matjazp> I use openstack-dev/sandbox for showing students how to use gerrit
17:41:29 <sarob> #action sarob assign xml content bugs to icehouse branch and lowpriority
17:42:33 <sarob> something to think about i guess
17:42:51 <sarob> next week lets noodle it some
17:43:19 <dguitarbite> noodle?
17:43:38 <sarob> #action team to think about bugs for new contributors, how to keep them
17:44:01 <sarob> stupid american saying to use your head = noodle
17:44:11 <sarob> have no idea where it comes from
17:44:12 <matjazp> dguitarbite: noodle - a very thin, long strip of pasta or a similar flour paste, eaten with a sauce or in a soup ;)
17:44:37 <sarob> ;)
17:44:48 <vigneshvar> matjazp: +1
17:44:48 <dguitarbite> matjazp: ahh yes I am in Eu, I eat it regularly ;)
17:44:54 <sarob> to noodle = to think hard
17:45:16 <sarob> kinda wierd, but part of the american lexicon
17:45:32 <dguitarbite> sarob: kool
17:45:41 <sarob> lets move on before i say more silly things
17:45:57 <sarob> #topic discuss videos
17:46:33 <sarob> whatca got for us sayali?
17:46:35 <sayali1> what do you guys thik about point 5?
17:46:40 <sayali1> think*
17:47:19 <sarob> this would be so the install guides can referrence the video too
17:47:31 <sayali1> also rluethi wanted to ask if we should go ahead with the osbash videos or wait a little more till we are done with the distro specific patches?
17:47:40 <sarob> or specifically?
17:48:17 <sayali1> sarob: works both ways
17:48:30 <sarob> sayali1: then i like much
17:48:35 <dguitarbite> sayali1: I think we could have both juno and icehouse for videos!
17:48:40 <dguitarbite> need to plan it out properly
17:48:42 <rluethi> sayali1: I think you should just go ahead. Labs-scripts are only moving slowly, unfortunaley.
17:48:55 <sarob> sayali1: id wait until the distro patches are in
17:49:09 <sarob> sayali1: would be a bummer to do over again
17:49:19 <dguitarbite> sarob: I believe doing it once should be good
17:49:20 <sayali1> yeah thats the problem with videos
17:49:27 <dguitarbite> just to show the differences
17:49:31 <sayali1> thats why i won't mind waiting a bit
17:49:32 <matjazp> what will be the difference once the distro patches are finished?
17:49:40 <dguitarbite> like the openstack videos
17:49:58 <vigneshvar> thats my question too
17:49:59 <matjazp> basic usage of osbash will be the same, no?
17:50:01 <sayali1> matjazp: the way we run osbash will be different
17:50:04 <dguitarbite> matjazp: yes
17:50:04 <sayali1> nope
17:50:08 <rluethi> matjazp: it's not only the distro patches, there are a few others. the CLI will change a bit.
17:50:29 <dguitarbite> rluethi: for Icehouse it will not
17:50:42 <dguitarbite> we are safer to not worry about that right now
17:50:48 <rluethi> dguitarbite: correct.
17:51:03 <sarob> we only want to make videos for juno right?
17:51:14 <sayali1> so we have a ice house version of the videos too?
17:51:15 <sarob> maybe even kilo?
17:51:26 <vigneshvar> rluethi: where to find what needs to be done on labs. i can contribute there
17:51:31 <rluethi> sarob: we only have icehouse scripts right now, so that's what we have to make videos.
17:51:32 <sarob> probably look the same for both
17:51:49 <dguitarbite> vigneshvar: lets have a chat after the meeting
17:52:05 <vigneshvar> dguitarbite: ok
17:52:19 <rluethi> vigneshvar: what dguitarbite said :).
17:52:19 <sayali1> ok then I think we can go ahead with the windows and linux videos for osbash for icehouse
17:52:33 <sarob> rluethi: i understand, im just thinking sayali1 shouldnt need to redo anything for awhile
17:52:37 <dguitarbite> about windows, osbash is not working
17:52:38 <rluethi> sayali1: good idea.
17:52:47 <dguitarbite> we might want to wait a bit for windows
17:52:51 <rluethi> dguitarbite, ?
17:53:03 <dguitarbite> rluethi: it gets stuck
17:53:07 <dguitarbite> windows 7 and 8
17:53:08 <rluethi> It worked when I tested it, which was not that long ago.
17:53:11 <dguitarbite> I tried them all
17:53:18 <dguitarbite> with latest or older versions
17:53:26 <rluethi> meh.
17:53:32 <dguitarbite> I have the list in my home
17:53:45 * dguitarbite is old school using paper and pen :
17:53:57 <sayali1> vigneshvar: you could go ahead with the linux one atleast
17:54:06 <vigneshvar> sayali1:  done
17:54:11 * sarob thinks paper is silly
17:54:31 <sayali1> vigneshvar: if you need any help let me know.
17:54:45 <vigneshvar> sayali1: sure thanks
17:54:58 <sayali1> should we do the one on OS X for icehouse?
17:55:28 <rluethi> sayali1: I'd wait for the next batch. OS X is only for the looks, it's functionally the same as Linux.
17:55:35 <vigneshvar> sayali1: also i tried removing noise from devstack video, but it was nt so clean
17:55:49 <sayali1> rluethi: exactly my thoughts. :)
17:55:56 <sayali1> vigneshvar: ok no issues
17:56:20 <sarob> lets use the last 5 minutes for summit stuff
17:56:25 <sayali1> yep
17:56:33 <vigneshvar> yes
17:56:50 <dguitarbite> sure
17:57:08 <sayali1> we were supposed to dicuss about the talk at the summit over the ML?
17:57:09 <sarob> #topic summit talk
17:57:33 <dguitarbite> may be we want to move to docs channel
17:57:36 <dguitarbite> not enought time
17:57:37 <sarob> sayali1: yeah,
17:58:02 <sarob> i have asked for a 20 person room for design session
17:58:15 <sarob> plus i created a summit talk #link https://www.openstack.org/summit/vancouver-2015/call-for-speakers/TalkDetails/3182
17:58:27 <sarob> id like to add y'all as speakers
17:58:30 <sayali1> I doubt I will make it to the summit this time.
17:58:43 <dguitarbite> sarob: I will not be able to travel ehtier
17:58:50 <sarob> :(
17:58:54 <dguitarbite> *either my body is falling apart
17:59:00 <dguitarbite> need to rest for a few months
17:59:04 <rluethi> not looking so good on my part, either.
17:59:11 <vigneshvar> i need to try the travel program
17:59:20 <dguitarbite> sarob: but we can give you online presence
17:59:28 <sarob> :)
17:59:48 <sarob> still run the design session with you guys remotely
17:59:54 <sarob> we
17:59:56 <sarob> are
17:59:57 <sarob> out
17:59:58 <sarob> of
18:00:00 <sarob> time
18:00:06 <dguitarbite> yes
18:00:06 <dguitarbite> we
18:00:07 <dguitarbite> are
18:00:08 <dguitarbite> !
18:00:11 <sarob> cheers my friends
18:00:11 <dguitarbite> docs
18:00:17 <dguitarbite> bye :)
18:00:18 <sarob> see you on gerrit
18:00:22 <rluethi> bye
18:00:25 <sayali1> bye
18:00:26 <vigneshvar> bye
18:00:28 <sarob> #endmeeting
18:01:29 <sarob_> #endmeeting