17:00:40 <sarob> #startmeeting training-guides
17:00:41 <openstack> Meeting started Mon Feb 16 17:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:44 <openstack> The meeting name has been set to 'training_guides'
17:00:51 <sarob> roll call
17:01:00 <sarob> o/
17:01:00 <rluethi> I am here
17:01:06 <vigneshvar> me too
17:01:22 <sarob> \o/
17:01:26 <rluethi> small crowd, huh.
17:01:57 <rluethi> sayali and matjaz won't be here today.
17:02:01 <sarob> holiday in US, but look at me working away ;)
17:02:25 <sarob> agenda https://wiki.openstack.org/wiki/Meetings/training-guides#Weekly_training-guides_Meeting
17:02:35 <dguitarbite> hello
17:02:44 <rluethi> hey
17:02:57 <vigneshvar> hi
17:03:18 <sarob> evening
17:03:44 <sarob> so from last weeks meeting #link http://eavesdrop.openstack.org/meetings/training_guides/2015/training_guides.2015-02-09-17.00.html
17:03:56 <sarob> i needed to fix some series up
17:04:00 <sarob> thats done
17:04:15 <sarob> https://launchpad.net/openstack-training-guides
17:04:51 <sarob> i removed dead milestones
17:05:07 <rluethi> well done.
17:05:12 <sarob> asssigned most of the bugs to the icehouse-rc2 milestone
17:05:21 <sarob> we are currently on icehouse-rc2
17:05:39 <vigneshvar> i was down with fever , so have not completed my work on AV
17:05:44 <sarob> this should allow us to move forward to juno-rc1
17:05:58 <sarob> vigneshavar: not a problem
17:06:19 <dguitarbite> vigneshvar: AV team lead is absent today ;)
17:06:28 <vigneshvar> :P
17:06:31 <sarob> #topic state of training guides landing page
17:07:46 <sarob> remember that annegentle talked to us about our landing page becoming one of the training entries
17:07:52 <rluethi> we used to have better visibility. This should definitely get better in the future. The question is how bad it is to have low visibility now.
17:08:00 <sarob> here #link http://www.openstack.org/marketplace/training
17:08:11 <dguitarbite> I guess, really bad
17:08:12 <rluethi> sarob, yeah, but that hasn't happened yet, has it?
17:08:49 <sarob> rluethi: no
17:08:53 <dguitarbite> sarob: please press this issue and get a section for free community training
17:08:56 <dguitarbite> up there asap
17:09:32 <sarob> so my preference is for online community training button
17:09:41 <sarob> mid right side of the page
17:09:54 <sarob> under online openstack help section
17:10:42 <dguitarbite> sarob: may be a bit bigger section?
17:10:51 <dguitarbite> if that is possible
17:10:56 <dguitarbite> otherwise I agree with you
17:10:57 <sarob> button text = community training
17:11:13 <sarob> i will ask
17:11:29 <sarob> it makes sense
17:11:39 <dguitarbite> thanks :)
17:11:50 <dguitarbite> we could notify hackathons and free training like upstream training from there
17:11:53 <dguitarbite> if possible
17:11:56 <dguitarbite> or on the training landing page
17:11:58 <dguitarbite> as required
17:12:35 <sarob> dguitarbite: so feedback thingy as well as landing page redirect?
17:13:06 <dguitarbite> sarob: I am not sure, if just the button would suffice if we have our own landing page there
17:13:15 <dguitarbite> then we can have feedback etc. on the landing page itself
17:14:02 <sarob> dguitarbite: if we get organized with the user groups enough, then i would put community training directly into the course list
17:14:22 <sarob> dguitarbite: inline with the rest of the commercial training
17:14:42 <sarob> dguitarbite: no reason why we couldnt do both
17:14:54 <sarob> dguitarbite: start with just the landing page redirect button
17:15:09 <sarob> dguitarbite: and then as we set new user group training sessions
17:15:28 <sarob> dguitarbite: put them inline with the rest of the training couses
17:15:51 <sarob> what do you all think?
17:16:43 <dguitarbite> sarob: +1
17:16:44 <rluethi> for me, the number 1 priority is cleaning up our content. then guide people there.
17:17:03 <vigneshvar> sarob: +1
17:17:21 <sarob> rluethi: totally agree
17:17:23 <dguitarbite> rluethi: I agree with you too, but I want to also make a note of the overhead (time required) for such actions
17:17:38 <dguitarbite> so, I am with sarob on this to prepare before hand
17:17:52 * rluethi nods
17:18:05 <sarob> rluethi: we need our first batch of juno slides to be published before the button can go live
17:18:19 <rluethi> sarob, yes
17:20:49 <sarob> #action sarob to work with foundation on adding landing page button #link http://www.openstack.org/marketplace/training in the online help section
17:21:57 <sarob> #action sarob will add new user group training sessions to #link http://www.openstack.org/marketplace/training alongside the commerical training
17:22:25 <sarob> soooo
17:22:41 <sarob> #topic current patches in review
17:23:58 <sarob> majazp has starting picking up the quiz patches
17:24:13 <dguitarbite> from my side this one is really essential https://review.openstack.org/#/c/153609/
17:24:19 <sarob> ch1 https://review.openstack.org/#/c/142259/
17:25:02 <sarob> ch1 #link https://review.openstack.org/#/c/142259/
17:25:24 <sarob> ch3 #link https://review.openstack.org/#/c/141236/
17:25:38 <sarob> ewww, messy
17:25:57 <sarob> ch5 #link https://review.openstack.org/#/c/154239/
17:26:16 <sarob> ch7 #link https://review.openstack.org/#/c/142344/
17:26:27 <rluethi> dguitarbite: It would have been nice to have some context along with the patch. I didn't know whether this patch is ready for merging.
17:26:44 <sarob> and ch9 #link https://review.openstack.org/#/c/142350/
17:26:49 <dguitarbite> context in the sense?
17:27:07 <sarob> dguitarbite: context?
17:27:13 <rluethi> sarob: I thought if you want to have a link in the summary, the link cmd has to be at the beginning of the line.
17:28:13 <rluethi> dguitarbite: The patch says "temporarily disabled", and I wonder if/when if will be re-enabled.
17:28:16 <sarob> rluethi: i dont think so
17:28:45 <rluethi> sarob: okay. must be brain misfiring.
17:28:51 <dguitarbite> rluethi: does the new commit message make it clear?
17:28:58 <sarob> rluethi: which patch says temp disabled?
17:29:14 <rluethi> sarob, https://review.openstack.org/#/c/153609/2/tox.ini,cm
17:29:34 <sarob> rluethi: you might be right on the link thing, ill double check after the meeting
17:30:12 <dguitarbite> rluethi: it is currently disabled (till we get the rst based tool chain in)
17:30:13 <rluethi> dguitarbite: thank you! exactly what the doctor ordered.
17:30:18 <sarob> rluethi: oh, different subject
17:30:32 <dguitarbite> :) I am just a compounder ;)
17:31:45 <sarob> any reason not to merge the slides 1, 3, 5, 7, 9?
17:32:04 <dguitarbite> and for 2, 4, 6, 7, 10?
17:32:30 <sarob> dguitarbite: those are quizzes
17:32:59 <sarob> dguitarbite: matjazp and i are working on those with his new format
17:33:09 <dguitarbite> ok
17:33:25 <dguitarbite> sarob: I need to take a look at the patches again
17:33:34 <sarob> dguitarbite: okey dokey
17:33:36 <dguitarbite> are you linking the required manuals links in the slides
17:33:47 <dguitarbite> terribly sorry caught up with lot of work
17:34:00 <sarob> dguitarbite: which manuals links are those?
17:34:23 <sarob> dguitarbite: np bro, we all have day jobs
17:35:15 <dguitarbite> I meant to link the revelent sections from other books in openstack manuals from inside the slide
17:35:32 <dguitarbite> somethign like for more information on (lets say neutron) follow xyz link
17:35:47 <sarob> dguitarbite: sounds like a good idea
17:35:59 <sarob> dguitarbite: can we save that for the kilo release?
17:37:12 <sarob> id like to just release/branch the straightforward slides within a week or so
17:37:20 <sarob> as juno-rc1
17:37:37 <dguitarbite> sarob: yes, but I suggest adding a comment in the slides, I can voluenteer to add the links
17:37:43 <dguitarbite> during the review process
17:37:49 <sarob> then we can fix up the slides and get all caught up for kilo release on schedule
17:38:08 <dguitarbite> sarob: yes, I agree
17:38:09 <sarob> dguitarbite: fine by me
17:38:55 <dguitarbite> sarob: for making it to the schedule, can we stick to Associate and Operator slides? or is only Associate Slide for Juno and then Operators for Kilo?
17:39:17 <sarob> dguitarbite: makes sense to me
17:39:36 <sarob> how about setting a target juno-rc1 branch date
17:40:04 <sarob> 02 march 2015
17:40:10 <sarob> sounds good to me
17:40:28 <sarob> unless y'all want to target sooner
17:40:46 <dguitarbite> 02 March is good :)
17:40:57 <rluethi> lab-scripts for juno should be merged by then.
17:41:18 <sarob> rluethi: agreed
17:41:30 <sarob> two weeks then
17:41:43 <sarob> yesss?
17:41:51 <dguitarbite> sarob: sounds good to me
17:42:00 <dguitarbite> we can also use that date for Icehouse RC2
17:42:15 <dguitarbite> and then use Kilo release for Juno RC2 and deprecate Icehouse
17:42:29 <sarob> dguitarbite: thats alot of bugs for two weeks
17:42:49 <sarob> #link https://launchpad.net/openstack-training-guides/+milestone/icehouse-rc2
17:42:53 <sarob> 52 bugs
17:43:23 <dguitarbite> sarob: ok, high priority bugs only for RC2
17:43:37 <dguitarbite> then we can have other bugs for RC3 and then stop the support
17:43:39 <sarob> kilo-3 targeted as 19 mar
17:43:50 <sarob> i think we could still meet that too
17:44:18 <dguitarbite> ok, 19th March then
17:44:27 <dguitarbite> the infra team will be raising their Eyebros on us ;)
17:44:44 <sarob> kilo-2 i will release as soon as juno branches
17:45:01 <sarob> to keep launchpad cleaned up
17:45:05 <dguitarbite> sarob: kilo-2??
17:45:39 <sarob> the bugs, blueprints are assigned to milestones
17:45:46 <sarob> in launchpad
17:46:22 <sarob> we have been technically working on kilo items while icehouse code is out
17:46:34 <sarob> a bit messy
17:46:40 <sarob> when we branch juno
17:46:54 <sarob> launchpad and github will be in synch
17:47:07 <dguitarbite> or bereaucratically
17:47:12 <sarob> just like a real grown up project
17:47:21 <sarob> dguitarbite: what you said
17:47:42 <sarob> its very confusing to people outside of the project what is going on
17:47:57 <dguitarbite> sarob: I agree
17:48:27 <sarob> we can roll into vancouver all organized like
17:49:44 <sarob> so we'all need to review some patches in the queue
17:49:52 <sarob> so we can branch juno
17:50:37 <sarob> #topic branching, new publishing
17:50:48 <sarob> dguitarbite: so whats the process for branching?
17:51:00 <sarob> dguitarbite: i didnt follow it closely enough
17:51:13 <dguitarbite> once the basic set of RST are in Ill push the RST to HTML/PDF tools
17:51:27 <dguitarbite> for keeping the sanity, I do not want to lock the repo
17:52:00 <sarob> hey sayali
17:52:11 <sayali> hello
17:52:19 <rluethi> hi, sayali
17:52:26 <vigneshvar> hiii
17:52:34 <dguitarbite> hi sayali
17:52:37 <sarob> dguitarbite: why not push the new rst landslide publishing now?
17:52:39 <sayali> sorry about the extreme delay!
17:53:08 <sarob> dguitarbite: the landing page needs to be created anyway
17:53:35 <sarob> dguitarbite: id want to add that to the patch https://review.openstack.org/#/c/153609/
17:54:07 <dguitarbite> sarob: I am horrible UI/UX dev
17:54:23 <dguitarbite> I dont have the time to learn HTML/CSS stuff
17:54:24 <sarob> i can push it
17:54:28 <dguitarbite> sarob: that would be great
17:54:39 <sarob> dguitarbite: first pass just needs to be an index
17:54:53 <dguitarbite> sarob: ok
17:55:24 <sarob> check out my comment #link https://review.openstack.org/#/c/153609/
17:56:02 <dguitarbite> sarob: I see what you mean, but it will be out of scope of one patch\
17:56:19 <sarob> dguitarbite: ah as you need infra patch as well?
17:56:21 <dguitarbite> this patch will just disable the XML publishing content, may be part of multi series patches
17:56:26 <dguitarbite> sarob: yes
17:56:43 <sarob> dguitarbite: we need that asap right?
17:57:02 <dguitarbite> but this patch is necessary because we are triggering XML publishing jobs on upstream zuul/jenkins workflow for no reason
17:57:08 <dguitarbite> lets save some community juice
17:57:09 <sarob> dguitarbite: can you just revive your rst landslide patch from before?
17:57:18 <dguitarbite> sarob: I plan to do that
17:58:16 <sarob> okay
17:58:58 <sarob> #action dguitarbite push infra rst landslide publishing patch
17:59:14 <sarob> #action branch juno target 02 march 2015
17:59:24 <sarob> im all done
17:59:28 <vigneshvar> 1 more min left
17:59:34 <sarob> last words?
17:59:38 <dguitarbite> #action icehouse RC1 target 02 march 2015
17:59:48 <dguitarbite> #action icehosue RC2 target 17th March 2015
17:59:49 <rluethi> happy president's day?
17:59:51 <sarob> dguitarbite: yup
18:00:03 <dguitarbite> happy green day
18:00:06 <sarob> rluethi: thx
18:00:17 <rluethi> later, guys
18:00:17 <sarob> time has been spent
18:00:19 <dguitarbite> bye
18:00:21 <sarob> until next week
18:00:26 <sarob> #endmeeting