17:00:43 <sarob> #startmeeting training-guides
17:00:44 <openstack> Meeting started Mon Feb 23 17:00:43 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <sarob> roll call
17:00:48 <openstack> The meeting name has been set to 'training_guides'
17:00:50 <rluethi> hey
17:00:52 <sayali> hello
17:00:59 <sarob> \o/
17:01:39 <matjazp> hey
17:01:46 <sarob> heloo hello
17:02:06 <vigneshvar> hi
17:02:19 <sarob> dguitarbite?
17:02:29 <sarob> vigneshvar: hello
17:02:45 <vigneshvar> sarob: hello :)
17:03:02 <matjazp> hi sarob, vigneshvar
17:03:18 <vigneshvar> hi matjazp
17:03:40 <sarob> dguitarbite might be sleepy after getting the gate working
17:04:11 <sarob> #topic state of the gate
17:04:39 <sarob> thanks to matjazp ajaeger dguitarbite for working on gate issues
17:04:49 <sarob> #link http://docs.openstack.org/icehouse/training-guides/content/
17:05:07 <sarob> #link http://docs.openstack.org/training-guides/content/
17:05:56 <sarob> matjazp any update on getting the new landing page plus slides working?
17:06:22 <matjazp> sarob: dont know for landing page
17:07:40 <sarob> matjazp: you were working on fixing up some failing build pages though
17:08:12 <matjazp> sarob: yes, I fixed broken repo https://review.openstack.org/#/c/158140/
17:08:16 <matjazp> its merged
17:08:55 <rluethi> matjazp: thank you.
17:09:01 <sarob> matjazp: nice
17:09:48 <sarob> so the last bit is trunk/training-guides publishing needs to fixed
17:10:21 <sarob> right now it looks like it is the icehouse content
17:10:24 <sarob> or it didnt get removed
17:10:31 <sarob> after the last publish
17:10:40 <sarob> prob the later
17:10:44 <matjazp> we don't have enough content
17:11:07 <matjazp> for trunk to get published
17:11:17 <matjazp> we need a complete set of lides
17:11:20 <matjazp> slides
17:12:16 <sarob> true
17:12:23 <matjazp> all of the xml-to-rst bp
17:12:34 <matjazp> then can we enable publishing
17:13:06 <sarob> jump agenda a bit
17:13:21 <sarob> since we are discussing
17:13:25 <sarob> #topic state of juno content
17:13:41 <sarob> #link https://review.openstack.org/#/q/status:open+project:openstack/training-guides,n,z
17:14:35 <rluethi> labs-scripts for Juno are merged.
17:14:45 <rluethi> we are ready to branch kilo :-).
17:14:50 <sarob> rluethi: excellent
17:14:51 <sayali> yes :D
17:15:49 <sarob> can you guys take a look at the chapter content
17:16:02 <sarob> give a merge
17:16:10 <sarob> if its ready
17:16:24 <sarob> then we can get publishing back on track
17:16:36 <sayali> sure
17:17:21 <sarob> we are dangerously close to getting ourselves ready for inclusion into openstack.org/training
17:17:26 <sarob> landing page
17:17:50 <sarob> i dont want to make the argument until our publishing is all ready
17:18:15 <matjazp> sarob: but do we know where we will be included?
17:18:26 <matjazp> sarob: where the link will be?
17:18:49 <sarob> i am going to make the argument for mid right hand side of the training page
17:19:31 <sarob> in the openstack online help panel
17:20:05 <dguitarbite> hello
17:20:06 <sarob> as i work through the ambassador group and my new user group assistants
17:20:18 <dguitarbite> apologizes for being late, was busy with a few meetings
17:20:20 <sarob> dguitarbite: evening
17:20:29 <sarob> dguitarbite: thx for gate!
17:20:33 <dguitarbite> morning/evening guys
17:20:45 <sarob> dguitarbite: no prob
17:20:47 <rluethi> hi dguitarbite!
17:20:50 <sayali> dguitarbite: hello
17:20:56 <sarob> dguitarbite: you have been doing late night work
17:20:57 <dguitarbite> sarob, ajager needs the real thanks
17:21:15 <sarob> dguitarbite: good enuf
17:21:30 <sarob> dguitarbite: beers all around in vancouver if possible
17:21:39 <dguitarbite> sarob, thanks
17:21:44 <dguitarbite> :) always ready for beers
17:21:50 <sarob> dguitarbite: roger that
17:22:04 <rluethi> who called me?
17:22:09 <dguitarbite> lolz ;)
17:22:10 <sarob> well the other roger
17:22:18 <sarob> roger roger
17:22:41 <sarob> so the general idea for the training landing page
17:23:10 <sarob> is to get our link into the openstack online help panel
17:23:33 <sarob> and as we get user groups spun up on using the assoc and dev content
17:23:58 <sarob> we get their sessions into the course pull downs like any other training
17:24:22 <sarob> i think it is simple and doesnt step on any commercial toes
17:25:19 <sarob> dguitarbite: how can i help with the landing page and trunk publishing fixup?
17:25:24 <matjazp> sarob: we can get "lost" among other commercial training offers
17:25:54 <dguitarbite> sarob, we need to first merge the RST and have the content ready to be published
17:26:08 <sarob> dguitarbite: agreed
17:26:09 <dguitarbite> then we need some more HTML/CSS juice to pump on openstack.org
17:26:35 <dguitarbite> without the final content it will be difficult to setup the infra or even convience the infra team for the publishing etc.
17:26:36 <sarob> dguitarbite: we are very close to having all of juno content ready
17:26:56 <sarob> dguitarbite: need some reviews and a bit more fix up
17:27:26 <dguitarbite> sarob, yes, I will be reviewing this week
17:27:34 <sarob> dguitarbite: coolo
17:28:50 <sarob> dguitarbite: so id like to help if I can with the publishing details like landing page and publish
17:28:52 <dguitarbite> sarob, yes, now the priority goes for working on the RST
17:28:59 <sarob> fixup, if I can be of use
17:29:05 <dguitarbite> I think the juno labs scripts are mostly merged and stable
17:29:11 <sarob> when we are ready later this week
17:29:31 <dguitarbite> sarob, the landing page part sounds good, I am really terrible at HTML/CSS part
17:29:40 <sarob> dguitarbite: me too
17:30:04 <sarob> dguitarbite: i can use bluehost tools to get us started
17:30:12 <sarob> dguitarbite: for juno
17:30:17 <dguitarbite> bluehost?
17:30:22 <sarob> dguitarbite: then we can lean on reed and others
17:30:26 <sarob> dguitarbite: my isp
17:30:36 <sarob> dguitarbite: and hosting provider
17:30:51 <sarob> dguitarbite: isp says it all
17:31:30 <sarob> lets see if we can beat the 02mar juno branch by a day or two
17:31:44 <reed> sarob, which website do you have in mind?
17:31:55 <sarob> reed: morn
17:32:25 <sarob> reed: we need to create a landing page for the training guides trunk publishing page
17:32:31 <dguitarbite> sarob, I am not sure if that would work or is a feasible option
17:32:42 <dguitarbite> we should try to host the content on openstack.org itselves
17:32:54 <dguitarbite> since we are not going to hog a lot of memory/storage for sure
17:33:01 <sarob> dguitarbite: you misunderstand
17:33:26 <sarob> dguitarbite: i only meant i was planning on using their html gen tools
17:33:31 <sarob> dguitarbite: not hosting
17:33:43 <sarob> dguitarbite: i personally use bluehost for hosting
17:33:46 <reed> dguitarbite, www.openstack.org is not the best place for it, at the moment at least
17:33:47 <sarob> dguitarbite: for sarob.com
17:33:51 <annegentle> reed: sarob: in Paris we had talked about a link on the marketplace but still housed on docs.openstack.org
17:33:57 <dguitarbite> sarob, ok
17:34:06 <sarob> annegentle: yup
17:34:19 <sarob> annegentle: once our landing page is ready
17:34:30 <reed> annegentle, the marketplace has a clear scope focusing on commercial offerings, so that option is not available
17:34:43 <sarob> annegentle: im going to ask for our link to be added to the training page under openstack online help
17:34:52 <reed> we could put it in groups.openstack.org
17:35:02 <reed> and a link from www.o.o/community
17:35:03 <annegentle> reed: got it
17:35:17 <annegentle> reed: I had hoped for a "community" sidebox on the marketplace
17:35:40 <reed> maybe even host parts of the guides directly on www.o.o/community
17:36:31 <sarob> reed: you dont think the community training could have a link in the online help section?
17:36:44 <reed> where is the online section? :)
17:36:53 <reed> online *help*
17:36:59 <sarob> http://www.openstack.org/marketplace/training/
17:37:11 <sarob> reed: middle right
17:38:05 <sarob> reed: right under getting started would be the place
17:38:07 * reed loading the site... taking forever
17:38:29 * sarob tap tap tap
17:38:45 <dbyte_> sorry bad network
17:39:08 <sarob> reed annegentle: lets sideline this to docs so we can finish our training agenda
17:39:14 <annegentle> reed: sarob: yes
17:39:26 <annegentle> reed: sarob: yes to sidelining, needs more discussion
17:39:40 <annegentle> sarob: cuz I'm kinda "not yes" on additions there :)
17:39:53 <sarob> #topic path forward for merging upstream training
17:40:14 <reed> www is not loading on my side
17:40:15 <sarob> reed: stay for this one if you can
17:40:22 <matjazp> sarob: I had to change some rst files to get them compliant to doc8 checks
17:40:36 <rluethi> #link https://review.openstack.org/#/c/132395/
17:40:38 <sarob> #link https://review.openstack.org/#/c/132395/
17:40:47 <rluethi> beat you to it :)
17:40:49 * sarob got beat
17:40:59 <sarob> ouch
17:41:09 <rluethi> so, still needs rebasing, doesn't it?
17:41:34 <sarob> Patch in Merge Conflict
17:41:39 <reed> and it needs testing outside of my env :) I think it works for me
17:42:21 <rluethi> is this upstream university only, or intended for all slides?
17:42:52 <matjazp> I would like one solution for all content
17:43:04 <sarob> sooo does this mean this rst will still publish for landslide
17:43:36 <sarob> cause i thought we were going to push landslide for at least through kilo
17:43:41 <sarob> then revisit
17:44:06 <sarob> as long as the rst works both ways im all goodness
17:44:09 <reed> rluethi, it should work for everything
17:44:24 <reed> sarob, no landslide in my patch
17:44:39 <matjazp> reed: what's the difference in syntax between hiero an landslide? not much?
17:44:50 <reed> matjazp, not much, no
17:44:59 <rluethi> reed: can you rebase it on current master? there are merge conflicts, for instance in tox.ini, that I'm not sure how to resolve.
17:45:01 <sarob> #action sarob work with reed annegentle on training guide inclusion into online help section of openstack.org/training page
17:45:16 <reed> rluethi, ok
17:45:30 <rluethi> reed: thanks!
17:45:42 <reed> #action reed to fix merge conflicts in https://review.openstack.org/#/c/132395/
17:45:43 <sarob> #action team review all existing rst patches, we need to merge them this week
17:45:46 <dbyte_> matjazp, significant enough difference
17:45:53 <matjazp> dbyte_: like?
17:46:06 <rluethi> so, everyone, are we ready to move to sphinx?
17:46:06 <dbyte_> matjazp, many minor details need to be changed
17:46:09 <dbyte_> in the RST side
17:46:21 <sarob> #action branch juno 02 march 2015
17:46:24 <dbyte_> but overall sphinx should be better
17:46:42 <rluethi> I don't have a strong opinion either way, but I'd rather not have two tools for the same thing in the same repo.
17:47:03 <sarob> #action landslide is the publishing tool through kilo, will revisit at the liberty summit
17:47:09 <dbyte_> rluethi, +1
17:47:14 <reed> sarob, I finally loaded the marketplace/training page: you'll have to propose that to Marketplace manager (Heidi)
17:47:27 <sarob> reed: understood
17:48:25 <rluethi> sarob: that's not an action :)
17:48:44 <sarob> #undo
17:48:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa280b10>
17:49:00 <sarob> #info landslide is the publishing tool through kilo, will revisit at the liberty summit
17:49:02 <sarob> thx
17:49:17 <rluethi> it would be an agreement (#agreed), if we had an agreement.
17:51:10 <sarob> rluethi: two meetings ago with dhellman we discussed
17:51:15 <sarob> rluethi: agreed, or at least i thought we did
17:51:30 <rluethi> sarob: fair enough :)
17:52:22 <matjazp> this is all a moot point.. if differences in rst syntax are small, we can switch easily anytime
17:52:35 <reed> I've already changed the slides not to use landslide
17:52:54 <reed> at least that's what I thought...
17:53:26 <reed> i'll have to sync up with the teachers of upstream training, will let them decide
17:54:00 <sarob> reed: is there a difference in the published material?
17:54:08 <sarob> reed: the result?
17:54:20 <reed> no, they all suck the same
17:54:23 <rluethi> matjazp: I sort of agree, but small differences may still trip up contributors, and newbies are likely going to be confused if different rst files are processed by different tools.
17:54:39 <sarob> reed: i cant see a difference since it is using the same rules
17:54:40 <reed> the results are sucky either using landslide or the other thing
17:54:54 <matjazp> rluethi: yes, thats why I said that we can switch to hiero anytime
17:55:21 <sarob> rluethi: yes we need one way to publish at a time
17:55:27 <matjazp> anytime could also mean right after reed merges his hiera patch :)
17:56:20 * sarob bangs head on table and passes out
17:56:53 <rluethi> any other parting thoughts?
17:56:54 * dbyte_ oh no now who will end the meeting!
17:57:08 <sarob> i only want to get the publishing automation to be consistent and supportable
17:57:32 <sarob> we need to get publishing up and running
17:57:43 <sarob> so our customers can access the content
17:58:03 <sarob> and we can find new customers through the user groups
17:58:50 <rluethi> meh. They don't pay me enough for me to call them customers.
17:59:00 <matjazp> I feel like we're running in circles here
17:59:14 <sarob> #action reed will check on upstream training rst can be published through landslide through kilo release
17:59:31 <sarob> dguitarbite has the landslide automation ready to go
17:59:36 <reed> no, please, don't drive me nut with formats
17:59:47 <sarob> #undo
17:59:48 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa35e7d0>
17:59:53 <reed> I think it's a waste of time to debate over format
18:00:00 <matjazp> reed: agreed
18:00:06 <reed> whatever works works
18:00:11 <sarob> #action sarob will check on upstream training rst can be published through landslide through kilo release
18:00:22 <sarob> reed: agreed
18:00:30 <matjazp> reed: exactly
18:00:33 <sarob> right on time
18:00:37 <rluethi> end meeting.
18:00:40 <reed> :)
18:00:43 <reed> thanks
18:00:45 <sarob> cheers everyone!
18:00:51 <dbyte_> bye :)
18:00:54 <sarob> #endmeeting