17:00:01 <rluethi> #startmeeting training-guides
17:00:02 <openstack> Meeting started Mon Mar  2 17:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <openstack> The meeting name has been set to 'training_guides'
17:00:29 <rluethi> Good morning, good afternoon, or good evening, as the case may be.
17:00:54 <sayali> Hello, good evening
17:01:01 <rluethi> hi
17:01:03 <matjazp> hey hey
17:01:21 <dguitarbite> hello
17:01:21 <matjazp> we're without sean, right?
17:01:26 <rluethi> correct.
17:01:30 <dguitarbite> matjazp: yes, do I smell something?
17:02:10 <rluethi> well, sean left us with an agenda.
17:02:20 * matjazp has showered, honestly ;)
17:02:24 <rluethi> #topic state of juno slides
17:03:06 <rluethi> So I gather matjazp is going to merge the slides as-is, to be cleaned up soonish!?
17:03:07 <matjazp> rluethi: I was going to merge fist 2 patches
17:03:40 <matjazp> rluethi: right. they are not slides as is, but patches should be smaller
17:04:01 <rluethi> I am somewhat concerned that merged large files to be cleaned up later means delaying clean-up indefinitely.
17:04:13 <dguitarbite> I agree
17:04:43 <rluethi> But since I don't work on slides, I value highly the opinions of those who do.
17:05:09 <matjazp> rluethi: I'm more worried that if we want to push "perfect" solution, it is still WAY off
17:05:15 <rluethi> So, matjazp, dguitarbite, can we merge one or two and have these cleaned up before we merge more.
17:05:35 <matjazp> and I want to enable community to work on PARTS of slides with smaller patches
17:05:36 <dguitarbite> Is there some kind of emergancy?
17:05:38 <rluethi> matjazp: yeah, that's certainly a valid concern, too.
17:06:10 <rluethi> dguitarbite: if we have no content other than the scripts and upstream U, it will become an emergency eventually.
17:06:55 <dguitarbite> rluethi: I agree with you
17:07:07 <rluethi> so I guess the question is: what is the best path to get the necessary clean-up done ASAP?
17:07:19 <dguitarbite> but it can also be If it cannot be cleaned up as of now, it may not be cleaned up even when its merged.
17:07:47 <rluethi> so who can do the clean-up, realistically speaking?
17:08:20 <matjazp> well... now the content is "locked up" in a review and maybe some who would like to help "stays out" of such a large patch
17:08:26 <rluethi> I don't see myself working on anything other than the scripts, at least for the the time being.
17:08:47 <rluethi> matjazp: sounds plausible.
17:08:51 <dguitarbite> I am busy with hosting events in India on top of labs scripts, python port, openstack koans
17:09:15 <dguitarbite> but I agree with matjazp, lets merge them there are no other concerns
17:09:17 <matjazp> noone likes to fiddle with other ppls patches
17:09:18 <rluethi> so, it would have to be sean or matjazp, is that it?
17:09:48 <matjazp> I can help, but I would rather see it as a smaller patches anyway
17:09:59 <sayali> I have too many un finished patches of my own atm :/
17:10:25 <rluethi> matjazp: my point is that if you can help with small patches, then it might be a good idea to merge.
17:10:49 <rluethi> if it's only sean, _he_ should have no problem fiddling with his own patches.
17:11:13 <matjazp> rluethi: I'm still hoping that community will help if they see it
17:11:34 <rluethi> matjazp: I am afraid they will take what they see as an example of how to do it.
17:12:12 <sayali> I agree with rluethi
17:12:12 <rluethi> matjazp: I will make no attempt at blocking your merging the patches, I am just stating my concerns.
17:12:19 <matjazp> I believe it is better to have something in the repo that someone can adapt and make better than to have blank slate
17:13:05 <rluethi> matjazp: you have a point. but how many people dare to take the axe to existing content and trim it down?
17:13:30 <rluethi> matjazp: a few brief slides that can be extended would seem to be a better starting point.
17:14:32 <matjazp> rluethi: that means to axe a mayority of seans patch
17:15:19 <rluethi> matjazp: that's my point. you did say that they are still way too long for slides.
17:15:33 <rluethi> matjazp: if we can't cut them down, do you think the community will?
17:16:01 <rluethi> matjazp: I could see the community extending them, but reworking them in a different, more terse style?
17:16:15 <matjazp> community == we (at first :)
17:16:46 <rluethi> matjazp: can we at least have a leading or trailing slide that says "please rework these slides to look more like upstream training (link here)" ?
17:17:18 <matjazp> rluethi: ok, I will try with an example and we'll see how it goes, OK?
17:17:24 <rluethi> matjazp: or is there a simple way to separate slide text from notes?
17:17:42 <rluethi> matjazp: that would be awesome.
17:18:04 <rluethi> matjazp: (I meant your suggestion)
17:18:15 <matjazp> sure
17:18:47 <rluethi> matjazp: if we can separate text from slides, I might be tempted to have a go myself.
17:19:04 <rluethi> basically, throw everything in notes and a few key terms back into the slide.
17:19:16 <matjazp> rluethi: yes, that was my intention
17:19:25 <rluethi> perfect.
17:19:55 <matjazp> rluethi: I just wanted to do that in a different patch... hence... merge as is
17:20:06 <matjazp> not all chapters, just one or two
17:20:29 <rluethi> matjazp: like i said, I have no intention of blocking you. if you do it this way, I will be a very happy camper.
17:21:11 <rluethi> #action matjazp will merge some slide decks and rework them so they can serve as examples
17:21:36 <rluethi> #topic landing page
17:21:44 <rluethi> updates?
17:22:17 <rluethi> anyone?
17:23:18 <matjazp> didn't sean work on it?
17:23:23 <rluethi> from last weeks, meeting, I take it it was mostly sean's thing.
17:23:24 <sayali> no idea
17:23:30 <rluethi> so there.
17:23:35 <matjazp> you know.. a separate button or smth like that
17:23:41 <rluethi> #action sarob will report next week
17:23:55 <rluethi> #topic Merge sphinx or landslide, and if so, only for upstream or for all slides?
17:24:29 <rluethi> did we make any progress since matjazp fixed the blocker last week?
17:25:04 <rluethi> I think we sort of agreed that we don't want to have two different programs for building slides in the long run, at least.
17:25:13 <rluethi> but there may be a transition period or something!?
17:25:24 <rluethi> sorry, memory is blurry.
17:25:27 <rluethi> does anyone remember?
17:25:47 <matjazp> rluethi: yes, sean wants to go with landslide, reed doesn't care about format
17:25:49 <rluethi> oh, it was another sarob item.
17:26:04 <rluethi> hi vigneshvar
17:26:06 <matjazp> format shouldn't matter
17:26:42 <vigneshvar> hi
17:26:55 <rluethi> matjazp: I understand there are slight differences, and everyone else seems to be using sphinx, so in the long run we should probably have sphinx!?
17:27:01 <reed> I think sarob and I overlapped and did both work to move in the other's direction
17:27:19 <dguitarbite> vigneshvar: hi
17:27:25 <rluethi> reed: what do you suggest we do?
17:27:59 <reed> what's the easiest for you? I really don't care
17:28:47 <matjazp> we have infra already set up for landslide?
17:28:50 <rluethi> I don't have a stake in it, either, but like I said it _seems_ that we should do sphinx at some point because that's what OpenStack projects use.
17:29:06 <matjazp> whats the status on that? we have landslide.sh that builds slides
17:30:26 <rluethi> maybe we should not have a vote on this while sarob is not here.
17:30:39 <matjazp> I guess that's why sean wanted to use landslide for now and change to whatever later
17:31:37 <rluethi> reed: would that be okay with you? use landslide for everything for now and transition to sphinx in the next cycle?
17:33:26 <rluethi> reed?
17:34:17 <rluethi> #info no resolution on landslide/sphinx, needs to be revisited next week
17:34:23 <reed> ok with the vote
17:34:25 <dguitarbite> reed: Another question is how much transition work has been done on upstream content?
17:34:29 <rluethi> #undo
17:34:31 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x85cc990>
17:34:41 <dguitarbite> reed: in terms of porting the slides format
17:34:49 <reed> dguitarbite, not a lot, and they suck anyway
17:35:07 <dguitarbite> reed: so landslide sounds good to you?
17:35:12 <reed> I'll have to sync up with the teachers next week to see what they like to use
17:35:16 <rluethi> reed: I gathered from your comments last week that both formats suck equally. correct?
17:35:36 <reed> dguitarbite, I can't stand neither, frankly :)
17:35:42 <matjazp> reed, i7m just curious, do you see any other format/solution that could be better?
17:35:49 <dguitarbite> reed: :)
17:36:07 <dguitarbite> matjazp: I have been through this, its near to impossible
17:36:14 <dguitarbite> to get anything closer to the current systems
17:36:22 <reed> matjazp, the best option is google docs, quite frankly
17:36:45 <reed> i'll have to talk to the teachers and see what they are confortable doing
17:37:07 <reed> if they have time they may help fix the slides and go in a repo, whatever format will do
17:37:16 <rluethi> reed: when would you be able to report back what the teachers think?
17:37:27 <reed> otherwise I expect they'll just fix things 'one off'
17:37:34 <reed> rluethi, give me two weeks
17:37:40 <dguitarbite> we should have this conversation over the docs ML IMO
17:38:31 <rluethi> #action reed will ask teachers re: landslide/sphinx and report back on March 16
17:38:42 <rluethi> cool, thanks, reed.
17:38:47 <reed> np
17:38:49 <rluethi> #topic any other business
17:39:39 <sayali> AV videos need some attention now
17:40:01 <rluethi> can you elaborate?
17:40:04 <matjazp> rluethi: maybe wee need to clean up bugs list
17:40:15 <sayali> We need the osbash on windows  and linux videos soonish
17:40:34 <matjazp> ppl are taking old bugs and wonder where to put them
17:40:45 <sayali> dguitarbite: is your issue with windows solved yet?
17:40:54 <rluethi> matjazp: didn't sean and dguitarbite clean up bugs?
17:40:56 <dguitarbite> sayali: I did not look into it further
17:41:13 <dguitarbite> sayali: My machine is old and fragile, I will try this at the end of this month if I get time
17:41:30 <dguitarbite> rluethi: some bugs were ported back from openstack-manuals
17:41:30 <sayali> Also, I will make a image for training-guides videos which can be used in all the vidoes
17:41:34 <sayali> videos*
17:41:35 <matjazp> rluethi: not enough.. see ML
17:41:50 <dguitarbite> rluethi: matjazp: these bugs are out of our domain
17:42:11 <sayali> dguitarbite: ok, I will try it on my end too then.
17:42:12 <dguitarbite> I have a strong belief that it was a rare situation, we need to take action if that repeats
17:42:19 <dguitarbite> sayali: thanks :)
17:42:25 <sayali> is vigneshvar around?
17:42:33 <rluethi> sayali: he was.
17:42:49 <dguitarbite> he as poor internet connectivity at his place
17:42:56 <sayali> ah ok.
17:44:28 <rluethi> matjazp: I have to admit I haven't looked much at the bug db, because every time I look it seems to be all ancient docs bugs.
17:44:55 <matjazp> rluethi: yes, and thats the problem.
17:45:07 <rluethi> matjazp: can't we just mark all icehouse docs bugs "won't fix"?
17:45:21 <matjazp> if someone want's to help, they should see new bugs for current content
17:45:48 <rluethi> matjazp: yes. unless sayali wants to use them as low-hanging fruit bugs for training :-).
17:46:36 <sayali> rluethi: we decided to send dummy patches to training-guides instead for the workshops
17:47:01 <matjazp> sayali: I use openstack-dev/sandbox
17:47:18 <sayali> also we can abandon bugs right?
17:47:18 <rluethi> okay, so matjazp (and everyone else), close all Icehouse bugs "won't fix"?
17:47:23 <dguitarbite> rluethi: audience skill set is not upto the mark for actual bug fixes for our time constraints
17:47:26 <matjazp> sayali: everyone there is a core, so the can test beeing core too :)
17:48:02 <sayali> matjazp: oh that's cool. I will check it out!
17:48:50 <matjazp> sayali: just try not to merge or just clean up afterwards after them
17:49:25 <sayali> matjazp: okay
17:50:17 <vigneshvar> once after this topic, i would like to update on the AV work
17:50:28 <sayali> vigneshvar: sure, go ahead
17:50:33 <rluethi> shoot.
17:50:38 <vigneshvar> sorry for the delay i have not completed yet
17:50:58 <vigneshvar> but i have found some useful tools used for video editting
17:51:02 <vigneshvar> in linux
17:51:24 <vigneshvar> with that we can make multiple videos as "scenes"
17:51:34 <vigneshvar> and merge them to single video
17:51:35 <sayali> vigneshvar: ok, you can put the link for those on the AV etherpad.
17:51:44 <vigneshvar> sayali: sure
17:51:57 <sayali> ok, so you can stop the video as you like?
17:52:17 <vigneshvar> the advantage of taking as "scenes" is, it is easy to update parts of video
17:52:40 <sayali> Also, I think we should have both the videos for osbash in this month
17:53:03 <vigneshvar> i will be completing one soon, i have almost done with video
17:53:09 <sayali> vigneshvar: right, that sounds good. Ill take a look.
17:53:12 <vigneshvar> i need to add audio now
17:53:32 <vigneshvar> with that tool i can add audio separate
17:54:01 <sayali> ok great. We need to add a training-guides logo kind of thing on each video
17:54:14 <sayali> So that they all look uniform, as we had discussed earlier
17:54:28 <sayali> I will add that and send it to everyone
17:54:44 <rluethi> somebody draw a stack train.
17:54:46 <vigneshvar> sayali: sure
17:54:47 <sayali> then you could use it in the video too
17:55:02 <sayali> rluethi: for?
17:55:14 <rluethi> "a logo kind of thing"
17:55:28 <vigneshvar> the tool is called openshot
17:55:34 <dguitarbite> rluethi: ahh, you got me excited there for a second ;)
17:55:51 <sayali> rluethi: haha I was thinking more on the lines of using the OpenStack logo with training guides written under it
17:56:05 <rluethi> sayali: how ordinary.
17:56:42 * sayali will try to make it more interesting :D
17:57:27 * rluethi is looking forward to seeing new AV material
17:57:51 <rluethi> I think this might be a good time to call it a day.
17:58:00 <sayali> yep
17:58:15 <rluethi> gents, ladies, it's been a pleasure.
17:58:18 <rluethi> #endmeeting