17:00:54 <sarob> #startmeeting training-guides
17:00:55 <openstack> Meeting started Mon Mar 16 17:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:59 <openstack> The meeting name has been set to 'training_guides'
17:01:19 <sarob> roll call
17:02:00 <rluethi> yo
17:02:52 <sarob> reed: can we get an update on the sphinx/landslide teacher feedback
17:02:57 <sarob> agenda
17:03:01 <sarob> #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:03:07 <reed> hi sarob
17:03:15 <sarob> reed: heloo
17:03:25 <sarob> \o/
17:04:26 <sarob> reed: whatz up
17:04:35 <reed> nobody has strong opinions it seems, so I would suggest to just use hiero: it's simple to implement, requires no bash script
17:05:09 <sarob> reed: do we have pub automation?
17:05:37 <sarob> reed: i guess its already in use for the dev docs
17:05:38 <reed> there was another suggestion to use reveal.js to render the RST on the fly (no build) but I didn't find a way to test that
17:05:59 <reed> sarob, I didn't test that part, sorry, I have no clue how to do that
17:06:17 <reed> and I'm quite sure that my patch is a mess anyway, I don't know what I'm doing :)
17:06:45 <sarob> rluethi: you guys were batting different .js pub options last meeting
17:07:26 <reed> reveal.js wants markdown not rst natively
17:07:27 <sarob> i just want to publish slides
17:08:40 <sarob> dhellman: what are we using to publish html from dev RST right now?
17:09:06 <clarkb> sphinx
17:09:09 <dhellmann> sarob: we use sphinx to convert rst to html
17:09:33 <sarob> ah, of course
17:09:35 <sarob> duh
17:09:56 <sayalilunkad> hello
17:10:01 <sayalilunkad> sorry for the delay
17:10:08 <sarob> sayalillunkad: np
17:11:03 <dguitarbite> hello
17:11:09 <sayalilunkad> long day today. Had the openstack workshop
17:11:40 <reed> lets go sphinx-hiero, cut the knot and move on
17:11:58 <sarob> clarkb: has infra looked at using hieroglyph or landslide for RST to HTML?
17:11:59 <dguitarbite> reed: Im in :)
17:12:07 <clarkb> sarob: I thought reed had
17:12:46 <sarob> dguitarbite: good timing
17:13:19 <reed> let me look for my patch
17:13:38 <reed> #link https://review.openstack.org/#/c/132395/
17:14:09 <reed> I reorganized the dir structure to imitate infra/developer docs
17:14:48 <sarob> reed: guess i forgot the code was in there too
17:15:08 <dguitarbite> sarob:  thanks
17:15:37 <sarob> so i just want to branch juno at this poing
17:15:41 <sarob> errg
17:15:43 <sarob> point
17:15:59 <reed> my patch needs someone with more knowledge to test it at this point
17:16:20 <reed> from the rst->html perspective, so that I can ask the upstream trainers to review the content
17:16:31 <sarob> dguitarbite: do you have a few cycles to test https://review.openstack.org/#/c/132395/
17:17:37 <dguitarbite> sarob: just a moment, let me check
17:18:00 <sarob> ill approve of whatever works and gets html slides created
17:18:04 <dguitarbite> yes, I do
17:18:11 <sayalilunkad> yep
17:18:14 <dguitarbite> I am in India, working on a Hackathon based on training guides
17:18:21 <dguitarbite> with sayalilunkad and vigneshvar
17:18:25 <sarob> sweeet guys
17:18:37 <dguitarbite> It will take a few days - 2-3 weeks for me to back on track
17:18:52 <sarob> more and more good stuff
17:18:56 <sarob> happenning
17:19:06 <dguitarbite> but if you guys can work (RST content), I can manage to scrape some time and get the infra stuff for sphinx in with the jobs
17:19:16 <dguitarbite> so that we can have Juno released by the end of this month
17:19:22 <sarob> dguitarbite: +1
17:19:38 <dguitarbite> I can cover for Roger here
17:19:50 <dguitarbite> I think 2 weeks (end of this month) should be good time to get Juno Stable
17:19:57 <sarob> and published to openstack.org/marketplace/training
17:20:22 <sarob> im okay with that
17:20:25 <dguitarbite> for the labs scripts
17:20:46 <sarob> that will give us a month for kilo
17:21:03 <sarob> to be all caught up
17:21:27 <sarob> lets move on
17:21:38 <dguitarbite> sarob: we need not rush through Kilo\
17:21:44 <dguitarbite> we can do it a month after the summit
17:21:59 <sarob> dguitarbite: hmm, sure
17:22:11 <sarob> i guess im kinda rushy right now
17:22:12 <dguitarbite> and then release the L release
17:22:16 <dguitarbite> on time
17:23:38 <sarob> #info juno branch rescheduled for end of march2015
17:23:59 <dguitarbite> btw I will be making it to Canada for the summit this Summer :)
17:24:06 <dguitarbite> just got the travel support
17:24:07 <sayalilunkad> me too :)
17:24:19 <sarob> #action dguitarbite working on testing https://review.openstack.org/#/c/132395/
17:24:36 <sarob> dguitarbite: excellent. beers all around!
17:24:46 <sarob> #topic landing page
17:25:37 <sarob> i have approval to add training-guides to the /marketplace/training online help section
17:25:48 <sayalilunkad> awesome
17:25:50 <dguitarbite> sarob: that is aweosme!
17:26:00 <sarob> but i have not had time to design a landing page yet :(
17:26:37 <sarob> i will work with lauren and heidi from the foundation
17:26:43 <sayalilunkad> ok
17:27:11 <sarob> on getting non sponsorship paying training classes into the schedule there
17:27:31 <sarob> its a bit of an issue the non-paying part
17:27:55 <sarob> something to noodle on
17:28:09 <dguitarbite> sarob: I dont understand
17:28:33 <sarob> which what?
17:29:39 <dguitarbite> non sponsersip paying training classes part
17:29:50 <sarob> #info training guides URL will be added to the openstack.org/marketplace/training online help section once the landing page and juno is branched
17:29:56 <sarob> dguitarbite: ah
17:30:10 <sarob> dguitarbite: in the marketplace
17:30:18 <dguitarbite> ok
17:30:29 <sarob> dguitarbite: its pay sponsorship dues to be listed there
17:30:37 <sarob> dguitarbite: pay to play
17:30:47 <dguitarbite> why?
17:30:58 <dguitarbite> yuk, will that be our content?
17:31:00 <sarob> dguitarbite: good question
17:31:13 <sarob> dguitarbite: content?
17:31:14 <dguitarbite> I need some explaination, may be talk later?
17:31:41 <sarob> dguitarbite: sure
17:31:47 <dguitarbite> sarob: ok :)
17:32:17 <sarob> generally
17:32:46 <sarob> if a company pays openstack foundation annual sponsorship dues
17:33:09 <sarob> they get listed in the openstack.org/marketplace
17:33:29 <dguitarbite> ok, I think I get what you mean
17:33:39 <dguitarbite> may be we could talk to the foundation
17:33:48 <dguitarbite> or present our project in peroson during the summit
17:33:52 <dguitarbite> *person
17:33:55 <sarob> well, those two are the foundation staff
17:34:02 <sarob> ;)
17:34:19 <dguitarbite> sarob: ahh yes :D
17:34:43 <dguitarbite> sorry, Im tired, jet lagged and have a +40 degree change in temperature, its summer in India already :
17:35:02 <sarob> we need to think through way that sponsorship still gets a benefit with free options side by side
17:35:15 <sarob> dguitarbite: i totally get it
17:35:17 <dguitarbite> sarob: yes, I would like to keep it open and free
17:35:24 <dguitarbite> I work on this project in my personal time
17:35:39 <dguitarbite> as do the rest of the team (atleast I believe so)
17:35:51 <sarob> i think so too
17:36:12 <dguitarbite> :)
17:36:19 <sarob> although im working on blending training into my current gig
17:36:32 <sarob> blending, yes
17:36:50 <dguitarbite> Kool! You will be like a customer too then
17:36:59 <sarob> yes indeedy
17:37:26 <sarob> sooo
17:38:19 <sarob> #info sarob will continue to talk with foundation staff on blending commercial and open source training in the marketplace
17:38:48 <sarob> #topic new landing page for docs.openstack.org
17:39:09 <sarob> once we have juno mostly ready
17:39:30 <sarob> i will ask that we be added back into docs.openstack.org
17:39:41 <sayalilunkad> yes that would be good
17:39:43 <sarob> from trunk and branches
17:40:15 <sarob> cause we are soo awesome
17:40:36 <sayalilunkad> haha
17:40:45 <sayalilunkad> 8-)
17:41:09 <sarob> #info as juno branch is readied, sarob will get training back into docs.openstack.org
17:41:16 <sarob> movin on
17:41:25 <sarob> #topic state of patches
17:41:38 <sarob> #link https://review.openstack.org/#/q/status:open+project:openstack/training-guides,n,z
17:43:08 <sarob> im going to get back into the swing of things
17:43:41 <sarob> lets merge patches this week
17:43:48 <dguitarbite> sarob: what do you think of moving to sphinx?
17:43:55 <sayalilunkad> yes
17:44:08 <dguitarbite> sarob: If reed's tools are ready ( I need to check ), it would be better to move to Sphinx
17:44:10 <sarob> my resistance has been broken
17:44:21 * dguitarbite the dark side has won!
17:44:37 * rluethi is on a lousy internet connection
17:44:39 <reed> live long and prosper
17:44:49 <reed> oh, wait... that's the other one
17:44:49 <sarob> my brain waves have gone sine
17:44:53 <dguitarbite> reed: ;)
17:45:25 <sarob> ah, sweet compliance
17:45:52 <sarob> lets get stuff merged
17:46:05 * dguitarbite I am not in heaven either rluethi!
17:46:41 <sayalilunkad> this week is a bit busy though since we have two openstack workshops
17:46:55 <sarob> understood
17:46:56 <rluethi> dguitarbite: you don't deserve heaven, my patches are still unreviewed.
17:47:17 <sarob> bam
17:47:24 <sayalilunkad> sorry rluethi the workshop was very exaustive! So couldnt get time to review them
17:47:28 <dguitarbite> rluethi: I already sold my soul to satan in exchange for rock and roll, I guess its coming closer :D
17:47:39 <sarob> rluethi: ill take a pass through as well
17:47:56 <sayalilunkad> We had an audience of 120 people! We went insane! you are gonna have a blast on skype :P
17:47:59 * sarob waves jazz hands
17:48:17 <rluethi> sayalilunkad: just get me a better line than the one I had right now
17:48:17 * dguitarbite drools!!!! (jazz)
17:50:02 <sayalilunkad> rluethi: ;p
17:50:15 <sayalilunkad> potatoe potato
17:50:22 <sarob> im all spent
17:50:38 <sarob> #topic any other business
17:51:31 <sarob> get a survey out to your audience if you can
17:51:38 <sarob> more feedback
17:51:40 <sarob> MORE
17:51:48 <sayalilunkad> ok, will do that
17:51:50 <sarob> MOOOOre
17:52:09 <sarob> sayalilunkad: need me to create a need one?
17:52:31 <sarob> im a monkeywizard
17:52:43 <sayalilunkad> we have the old one
17:52:51 <sarob> okey dokey
17:53:12 <sayalilunkad> I didn't end up really distributing the previous one
17:53:20 <sarob> no problems
17:53:49 <sarob> you guys doing the workshop is awesome enough
17:54:05 <rluethi> sayalilunkad: pro-tip: not distributing the surveys diminishes their usefulness.
17:54:26 * sarob falls down
17:54:26 <sayalilunkad> i know :/ I did a stupid thing last time
17:54:35 * dguitarbite follows
17:54:39 <sayalilunkad> won't let them leave without filling it this time ;)
17:54:59 * sarob asks for a beer on the floor
17:55:14 <sarob> im getting punchy
17:55:58 <sarob> anything else my friends?
17:56:36 <sarob> okey dokey
17:56:51 <sarob> i will call this meeting to a close
17:56:53 <dguitarbite> im good
17:56:58 <rluethi> me, too
17:57:03 <sayalilunkad> me too
17:57:03 <sarob> cheers!
17:57:10 <sarob> #endmeeting