17:01:53 <sayalilunkad> #startmeeting Training Guides
17:01:54 <openstack> Meeting started Mon Apr 13 17:01:53 2015 UTC and is due to finish in 60 minutes.  The chair is sayalilunkad. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:56 <Chubby> Hello all
17:01:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:58 <openstack> The meeting name has been set to 'training_guides'
17:02:10 <sayalilunkad> Hello everyone
17:02:14 <rluethi> close enough :-)
17:02:35 <rluethi> good evening, miss chair.
17:02:48 <sayalilunkad> agenda: https://wiki.openstack.org/wiki/Meetings/training-guides
17:02:55 <sayalilunkad> good evening rluethi :)
17:03:40 <sayalilunkad> Roll call?
17:04:02 <matjazp> I guess it's just us... anyone else?
17:04:16 <rluethi> just the three of us?
17:04:23 <sayalilunkad> ok, let's start with the items on the agenda then.
17:04:25 <Chubby> hi
17:04:29 <Chubby> I am here
17:04:33 <Chubby> Utsav
17:04:34 <rluethi> hi Chubby
17:04:36 <matjazp> hi Chubby
17:04:40 <sayalilunkad> Hello Chubby
17:04:45 <Chubby> Hello
17:04:56 <sayalilunkad> #topic reviews
17:05:16 <sayalilunkad> pending reviews list: https://review.openstack.org/#/q/status:open+project:openstack/training-guides,n,z
17:05:19 <matjazp> could you guys look at upstream cleanup patches?
17:05:39 * rluethi feels guilty
17:05:51 <rluethi> I'll try to find some time.
17:05:52 <sayalilunkad> matjazp: yes we can start reviewing those since the infra patch has been merged
17:05:54 <matjazp> I'm rolling a training guides hiero patch later today
17:06:17 <rluethi> The cleanup patches are important work which is (in spite of appearances) very appreciated.
17:06:51 <matjazp> It'll will have to be with rst cleanup, I'm afraid.. no other way to look at generated slides. So it will be a larger patch
17:07:19 <Chubby> I have a doubt its related to https://review.openstack.org/#/c/164534/
17:07:57 <rluethi> Chubby: It is not related, as far as I can tell.
17:08:30 <matjazp> Chubby: filter is on labs, right? so its not related
17:08:32 <sayalilunkad> Chubby: we will take up that patch after the current discussion
17:08:33 <rluethi> Chubby: In fact, I hope it is not related, because the patch you linked looks like it can be merged independently.
17:08:44 <matjazp> labs=labs folder
17:08:50 <Chubby> okay
17:09:34 <rluethi> matjazp: I am totally lost wrt to the state of the slides. how do I test/build the cleanup slides?
17:10:04 <sayalilunkad> rluethi: you can test them using tox
17:10:21 <matjazp> rluethi: tox
17:10:49 <matjazp> tox -e upstream-slides
17:11:09 <matjazp> otherwise it will build labs and it takes much longer
17:11:12 <rluethi> matjazp: okay. thanks.
17:11:35 <sayalilunkad> the readme has been updated in this patch https://review.openstack.org/#/c/171548/2/doc/upstream-training/README
17:12:17 <sayalilunkad> ok anything else about the slides?
17:12:59 <matjazp> training slides are going really slow... would need some help after we merge hiero patch (upcoming)
17:13:52 <sayalilunkad> what is our aim till the release for the slides?
17:13:56 <matjazp> I hope that after infra is set and some content is in repo pace will pick up
17:14:52 <matjazp> you mean like a deadline? milestone?
17:15:14 <sayalilunkad> no I mean content wise till say kilo release
17:16:34 <matjazp> well in fact content for the associate slide is pretty much independent from the releases - associate guide is basic stuff that is same for all releases (or at least similar)
17:17:25 <matjazp> so when we have a first set of slides in, they don't change much I guess
17:17:44 <sayalilunkad> okay and are we aiming to complete any other slides soonish? So we know what area needs to be focused on slides wise.
17:18:19 <matjazp> sayalilunkad: other slides? we should finish associate guide first
17:19:03 <sayalilunkad> matjazp: ok so we can focus on it's completion till the summit.
17:19:38 <sayalilunkad> moving on, this patch https://review.openstack.org/#/c/164534/3
17:20:14 <rluethi> looks good to me, I wonder what Pranav wanted to discuss.
17:20:28 <matjazp> looks good to me too..
17:20:33 <sayalilunkad> Andreas left a comment on patchset 3 to not add another job for bashate check
17:20:43 <sayalilunkad> https://review.openstack.org/#/c/164534/3/tox.ini
17:20:54 <Chubby> why cant we add it to slides?
17:21:24 <rluethi> sayalilunkad: thanks. maybe we should ask Andreas where we should ask the check?
17:21:29 <sayalilunkad> Chubby: it looks out of place there. But that was the suggested method.
17:22:21 <matjazp> maybe we should have finer grained tasks in the gate? one for labs, other for slides?
17:22:22 <sayalilunkad> rluethi: well he did review the patch and +1 it in the job for slides. But pranav again asked for a seperate job
17:22:33 <sayalilunkad> matjazp: yes I feel the same
17:22:39 <sayalilunkad> Is Andreas around?
17:22:43 <Chubby> I mean why we need to create new entry, we can work it by adding it to slides
17:23:34 <rluethi> well, we can always change it later. just be sure to add comments explaining why the current solution looks like this, so later generations have the information to determine whether they can change the setup.
17:24:30 <sayalilunkad> But do we merge it in the job for slides for now?
17:25:42 <rluethi> sayalilunkad: fine with me. it will work, just look a bit odd. all I care about is that we document things that are not obvious.
17:27:06 <sayalilunkad> #action change bashate job to merge with slides also add document stating reason to do that. patch https://review.openstack.org/#/c/164534/3/tox.ini
17:27:22 <matjazp> we could also merge as is (separate task) and add this as another gate check ("labs")? so we can have slides and lab jobs?
17:27:22 <Chubby> rleuthi: okay, I will add comments.
17:28:24 <sayalilunkad> matjazp: for now, what I understand is Andreas is against doing that.
17:28:30 <rluethi> Chubby: thanks.
17:28:55 <rluethi> Chubby: comments are cheap, they don't slow things down, so take all the space you need :-).
17:28:56 <sayalilunkad> We can discuss with him and then do that.
17:30:21 <Chubby> rluethi: I will fill them up completely :)
17:30:22 <sayalilunkad> rluethi: About the heat patch, sorry I missed your review on it! I will update it as per the comments.
17:30:37 <matjazp> well he has a point... more separate jobs means more infra pressure.
17:30:53 <sayalilunkad> matjazp: yes, exactly why.
17:31:26 <sayalilunkad> matjazp: I think till we *really* don't need it we can keep it the same.
17:32:07 <sayalilunkad> This patch here for osbash on windows: https://review.openstack.org/#/c/172630/
17:32:10 <sayalilunkad> needs testing
17:32:28 <sayalilunkad> So anybody with windows machines can please do the honor. ;)
17:33:14 <Chubby> I have windows
17:33:17 <Chubby> I will do it
17:33:17 <rluethi> sayalilunkad: apparently, these rare machines are very hard to come by.
17:33:42 <rluethi> thanks, Chubby.
17:33:51 <sayalilunkad> rluethi: I'm glad they are ;)
17:34:01 <Chubby> your welcome :)
17:34:06 <rluethi> sayalilunkad: I wish they were :-).
17:34:34 <matjazp> rluethi: everything has it's place under the sun :)
17:34:53 <rluethi> matjazp: doesn't mean I have to be happy about it.
17:34:57 <sayalilunkad> so, any other patches that need attention?
17:35:25 <matjazp> rluethi: hey, MS is at least trying lately to be more opensource friendly, so kudos for that
17:35:30 <rluethi> not urgent, but this patch will need testing: https://review.openstack.org/#/c/170731/
17:36:27 <sayalilunkad> ok sure, will do it soon.
17:37:18 <sayalilunkad> Moving on, for the next topic ie automation status I think we will need pranav so should we keep it for next time?
17:37:51 <rluethi> sayalilunkad: unless somebody else wants to fill in?!
17:38:03 <sayalilunkad> sure
17:38:11 <sayalilunkad> #topic automation status
17:38:41 <rluethi> thought so. nobody. next :-).
17:39:07 <sayalilunkad> #topic videos
17:39:54 <sayalilunkad> The osbash on windows video needs to be added to the official channel but that can be done by pranav as it is linked to his youtube account
17:40:02 <sayalilunkad> I will put an action for that
17:40:32 <sayalilunkad> #action Pranav needs to adds osbash on windows video to youtube channel
17:41:11 <sayalilunkad> I will be making 2 videos by EOM. Osbash on OS X and the ones for test scripts
17:41:11 <matjazp> should we have a "public" acccount for that?
17:41:43 <matjazp> one that is not linked to anyone?
17:42:03 <matjazp> how do other groups manage shared passwords/accounts?
17:42:15 <sayalilunkad> matjazp: well it has to be linked to a google account. I'm not sure how we can create a public account.
17:42:39 <sayalilunkad> matjazp: we could ask reed
17:42:45 <matjazp> openstack-training-guides@gmail.com ;)
17:42:54 <sayalilunkad> reed: ping
17:43:03 <matjazp> maybe fondation has one already?
17:43:28 <sayalilunkad> matjazp: foundation has one but last time we asked they said it would be better to keep it seperate for now.
17:45:03 <matjazp> discuss at next meeting?
17:45:04 <sayalilunkad> #action Discuss about creating common account for AV videos
17:45:10 <sayalilunkad> matjazp: yep.
17:45:33 <sayalilunkad> #action Summit session
17:45:38 <sayalilunkad> #undo
17:45:39 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x8b32110>
17:45:50 <sayalilunkad> #topic Summit session
17:46:43 <sayalilunkad> For this topic, we were to discuss about the summit session so we would need to discuss with the upstream guys as well
17:47:07 <sayalilunkad> matjazp: will you be at the summit?
17:50:26 <sayalilunkad> ok, I think we will have to push this too to the next meeting.
17:50:41 <sayalilunkad> #topic any other business
17:51:01 <sayalilunkad> Anything else anybody wants to discuss?
17:51:17 <rluethi> I'm good.
17:51:55 <sayalilunkad> rluethi: I will be adding ceilometer as well to osbash, just to cover all the core services.
17:52:15 <sayalilunkad> So I was thinking if we should make an option to enable/disable these services.
17:52:21 <rluethi> sayalilunkad: excellent! I've been waiting for that.
17:52:43 <sayalilunkad> rluethi: shall be done then :)
17:53:05 <matjazp> what is the memory requirements for all that?
17:53:10 <rluethi> sayalilunkad: people can just comment out the services in the config file. it doesn't get much easier than that.
17:53:28 <sayalilunkad> rluethi: yep. By default we can keep them disabled.
17:53:34 <sayalilunkad> heat and ceilometer.
17:53:52 <sayalilunkad> matjazp: It will run on the existing configuration for osbash.
17:54:29 <rluethi> sayalilunkad: If they are disabled by default, then they are not tested by default. I guess we could make a separate configuration file.
17:54:49 <matjazp> regarding summit: still not sure if I can attend :/ some issues with funding&other stuff
17:54:54 <rluethi> sayalilunkad: scripts.cluster and scripts.cluster_all or something.
17:55:19 <sayalilunkad> rluethi: that might get a little confusing.
17:55:28 <matjazp> all these services in 4GB?
17:56:04 <rluethi> matjazp: those services shouldn't take much RAM.
17:56:10 <sayalilunkad> 2.5 GB as of now
17:56:33 <sayalilunkad> As in 1GB controller, 1GB compute and 512 MB network node.
17:56:51 <sayalilunkad> rluethi: Just that compute cannot launch more that one instance
17:57:23 <sayalilunkad> So we could make that a little more if we want to test heat and stuff.
17:57:35 <rluethi> sayalilunkad: yup, for more instances we would need more RAM on compute.
17:58:15 <rluethi> sayalilunkad: let's find out how we can manage several configs in parallel.
17:58:22 <rluethi> time's almost up.
17:58:25 <matjazp> rluethi: hmm.. installed services and "running and working not too slow" are not the same
17:58:50 <sayalilunkad> rluethi: yeah, so I will test launching a normal instance and a heat stack and get back with how much we need to increase it by.
17:58:53 <rluethi> matjazp: true. are there complaints? is it slow for you?
17:59:38 <sayalilunkad> rluethi: yes we need to do that. I will shoot an email to plan for that discussion.
17:59:47 <matjazp> I'm just thinking out loud... I had some perf issues with devstack
18:00:16 <rluethi> sayalilunkad: endmeeting
18:00:23 <sayalilunkad> ok time is almost up
18:00:30 <sayalilunkad> #endmeeting