17:01:49 <sayali1> #startmeeting training-guides
17:01:50 <openstack> Meeting started Mon Apr 20 17:01:49 2015 UTC and is due to finish in 60 minutes.  The chair is sayali1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:54 <openstack> The meeting name has been set to 'training_guides'
17:02:04 <sayali1> Hi
17:02:55 <dguitarbite> hello
17:03:18 <matjazp> hey
17:03:40 <sayali1> looks like it's just the three of us today
17:04:05 <sayali1> agenda: https://wiki.openstack.org/wiki/Meetings/training-guides#Agenda_20_April
17:05:30 <sayali1> #topic reviews
17:05:58 <matjazp> upstream training patches?
17:06:18 <sayali1> ya quite a few there
17:06:24 <dguitarbite> matjazp: I have cherrypicked them to include the new CI changes
17:06:38 <matjazp> dguitarbite: sure, thnx
17:07:00 <sayali1> dguitarbite: thanks.
17:07:02 <dguitarbite> matjazp: welcome ;)
17:07:07 <dguitarbite> just saving some time and effort
17:07:46 <matjazp> can you please also look at #link https://review.openstack.org/#/c/175312/
17:08:12 <matjazp> new look for the slides
17:08:22 <dguitarbite> I did review this one
17:08:31 <dguitarbite> do you want me to rebase this one too
17:08:42 <sayali1> matjazp: Ah nice.
17:08:47 <dguitarbite> I am not sure if they will be checked by the CI system yet
17:09:09 <sayali1> matjazp: you took some work off my back :D
17:09:11 <matjazp> pranav, can we look at the generated slides on the gate?
17:09:23 <dguitarbite> matjazp: moment
17:10:00 <dguitarbite> Im afraid no!
17:10:04 <matjazp> sayali1: np, but it still needs tweaking... Google's slides2 theme in much better, but we should wait for a new version of the hieroglyph package
17:10:33 <matjazp> dguitarbite: that would ease reviewing immensley
17:11:01 <dguitarbite> matjazp: we need to wait for that feature
17:11:04 <sayali1> matjazp: what theme is being used right now?
17:11:13 <matjazp> it's so slow at the moment because you have to pull the patch and run tox manually
17:11:52 <dguitarbite> matjazp: the priority would be to publish the first set of slides on docs.openstack.org
17:11:56 <matjazp> sayali1: default, "slides", I only tweaked h1 and h2 font colors and added a background image
17:12:18 <dguitarbite> after that we can get more breathing room for luxuries and also convincing the docs team for this feature.
17:12:59 <matjazp> dguitarbite: yes, and a job that copy generated html on the gate so you can look directly at the output will enable much quicker reviewing
17:13:13 <sayali1> matjazp: ok, it is good we atleast have the basic done for now. We can improve it with time.
17:13:49 <matjazp> sayali1: yes, it still needs an OpensTack logo in the footer
17:14:22 <sayali1> matjazp: ok
17:14:47 <matjazp> dguitarbite: why can't we copy generated html to the log files?
17:15:33 <dguitarbite> matjazp: the infra is under heavy use, they limit the functionality, copying html to log files is a no go.
17:15:47 <dguitarbite> for publishing the html slides upstream, we need to add another gate
17:15:48 <matjazp> oh, and generated index.html is crap. that shouldn't be in the form of slides, it should be a normal web page?
17:16:10 <dguitarbite> this will take a long time esp. since the release is near and also we have the summit.
17:16:33 <dguitarbite> I would suggest you to wait for a month. Also my priority is to fix the cluster,
17:17:50 <sayali1> any other patches that need attetion?
17:18:06 <sayali1> attention*
17:18:57 <matjazp> I would like to merge upstream patches as soon as possible. If new theme is ok, I would copy that there too.
17:19:23 <dguitarbite> You have my +1 from the jenkins jobs :)
17:20:09 <matjazp> dguitarbite: :) does that count?
17:20:43 <dguitarbite> matjazp: I will check the patches soonish and give my +1 on top of that :)
17:20:46 <dguitarbite> and yes it counts
17:21:01 <sayali1> matjazp: just checked the theme. It looks good. Just that there is some overlap between the slides. Is that intentional?
17:21:30 <sayali1> and yes we need to add the logo
17:21:47 <matjazp> sayali1: I didn't look much at the content
17:21:57 <matjazp> sayali1: that should be a new patch
17:22:03 <sayali1> matjazp: not the content
17:22:12 <sayali1> the slides layout
17:22:21 <matjazp> sayali1: where?
17:22:52 <sayali1> matjazp: I can see the begenning of the next slide when I am on one slide
17:23:00 <sayali1> it is for almost every slide
17:23:16 <matjazp> that's the feature of the hieroglyph, it can be disabled
17:23:32 <matjazp> it's intentionsl, so you can see what is next
17:23:39 <matjazp> intentional
17:23:45 <sayali1> matjazp: oh. ok then.
17:24:31 <sayali1> matjazp: will you be adding the logo for these?
17:24:44 <sayali1> or should that be another patch?
17:24:55 <matjazp> sayali1: it's not so easy, so it's for another patch
17:25:02 <sayali1> matjazp: cool
17:25:11 <matjazp> you must do a custom html layout
17:25:23 <matjazp> and insert logo there
17:25:53 <sayali1> matjazp: ok
17:25:57 <matjazp> at least I think so... footer is copied from conf files?
17:26:56 <matjazp> hmm.. maybe we should also ask reed if new theme is ok with him?
17:27:13 <sayali1> matjazp: I don't have any idea about this, will need to check it out
17:27:25 <sayali1> matjazp: yes we should
17:27:29 <matjazp> reed, you around?
17:27:45 <reed> yes
17:28:08 <matjazp> reed: can you please look at https://review.openstack.org/#/c/175312/ if that theme is ok for upstream training?
17:28:12 <reed> guys, do you use a mailing list?
17:28:39 <matjazp> reed: sure, but during a meeting its easier to ping you ;)
17:28:41 <dguitarbite> reed: we are on docs
17:28:57 <reed> matjazp, is there a publishing job somewhere? or do I have to pull and review locally?
17:29:18 <sayali1> reed: it needs to be done locally
17:29:26 <matjazp> reed; sadly, no publishing job :( pranav said infra is too crowded for that at the moment
17:29:42 <reed> I'll add that to my todo list
17:29:56 <clarkb> publishing jobs should already exist
17:30:03 <clarkb> just need to apply it to your project
17:30:38 <matjazp> clarkb: any restrictions on the size?
17:30:44 <dguitarbite> clarkb: its there for xml/maven
17:30:51 <dguitarbite> I am not sure if we have it for RST
17:31:01 <clarkb> dguitarbite: we publish every project's RST already
17:31:14 <clarkb> dguitarbite: so if a new project comes along it just needs to use the existing templates right?
17:31:15 <dguitarbite> clarkb: ok
17:31:52 <matjazp> clarkb: we generate html with heiroglyph, is that still ok?
17:32:02 <clarkb> matjazp: thats sphinx right? should be fine
17:32:17 <dguitarbite> matjazp: it should be fine
17:32:19 <dguitarbite> just a few tweaks
17:32:20 <matjazp> clarkb: yes, it's an add-on
17:32:21 <dguitarbite> required
17:32:49 <sayali1> let's add that to the todo then
17:33:03 <matjazp> dguitarbite: maybe you can look at this?
17:33:18 <sayali1> #todo create CI job for RST content
17:34:09 <dguitarbite> matjazp: I will!
17:34:23 <sayali1> #action dguitarbite create CI job for RST content
17:34:24 <matjazp> sayali1: can you make this an action?
17:34:33 <sayali1> matjazp: done ;)
17:34:36 <matjazp> :)
17:34:39 <matjazp> you
17:34:42 <matjazp> are
17:34:45 <matjazp> quick ;)
17:34:52 <sayali1> :D
17:35:12 <sayali1> moving on
17:35:29 <sayali1> #topic docs status
17:36:57 <sayali1> dguitarbite: I think you wanted to take this up?
17:37:43 <dguitarbite> sayali1: Not anymore. We have already discussed a few of these.
17:37:52 <sayali1> ok.
17:37:54 <dguitarbite> matjazp: pointed out the the link some time back.
17:38:11 <sayali1> cool
17:38:21 <sayali1> #topic labs infra
17:38:45 <sayali1> let's talk about this patch: https://review.openstack.org/#/c/175374/
17:39:21 <sayali1> dguitarbite: sorry about making you patch this! Not required anymore right?
17:39:45 <matjazp> disks are thin provisioned, right? so why be so stingy with the disk space?
17:40:41 <sayali1> matjazp: I thought we needed to increase the ram and memory since we added a few additional services but that is no longer required so it's better we keep it the way it was
17:40:55 <sayali1> also dguitarbite I think we can abandon the patch instead.
17:40:59 <dguitarbite> matjazp: there is a reason for that, wait a moment
17:41:15 <dguitarbite> sayali1: there is no need for that I have improvised
17:41:19 <matjazp> I'm not thinking about ram, just disk space
17:42:40 <dguitarbite> matjazp: there is a script which zeroes out the disks for improved sanity
17:42:56 <dguitarbite> this negates the diskspace saved due to thin provisioning
17:43:01 <dguitarbite> so we cannot keep the disk space higher
17:43:14 <dguitarbite> and this also increases the time taken for building the base-disk :)
17:43:29 <matjazp> why is that necessary?
17:43:40 <matjazp> zeroing disks?
17:43:44 <dguitarbite> zero_empty.sh
17:43:51 <dguitarbite> under /labs/scripts
17:44:00 <sayali1> dguitarbite: cool
17:44:33 <dguitarbite> matjazp: wait another minute
17:45:40 <sayali1> rluethi: hey!
17:45:51 <rluethi> hi everyone, sorry I'm late.
17:45:55 <dguitarbite> commit 05bb9668f4c67012711b4a966c22636d88c08906
17:45:55 <dguitarbite> Author: Roger Luethi <rl@patchworkscience.org>
17:45:55 <dguitarbite> Date:   Wed Jun 18 09:53:54 2014 +0200
17:45:55 <dguitarbite> Scripts to clean disk and shut down
17:45:55 <dguitarbite> 
17:45:56 <dguitarbite> This changeset adds two simple scripts: one fills the unused space
17:45:57 <dguitarbite> of the root disk with zeroes to allow for better compression of the
17:45:59 <dguitarbite> resulting disk image, the other shuts the computer down.
17:46:01 <dguitarbite> 
17:46:03 <dguitarbite> Partial-Bug: 1312764
17:46:04 <openstack> bug 1312764 in OpenStack Training Guides "training-labs scripts cannot build a training cluster" [High,Fix released] https://launchpad.net/bugs/1312764 - Assigned to Roger Luethi (rl-o)
17:46:05 <dguitarbite> Implements: blueprint openstack-training-labs
17:46:05 <sayali1> rluethi: np
17:46:07 <dguitarbite> Change-Id: I2e80518733b0e1e17a59192c6e2522f423709551
17:46:09 <dguitarbite> apoligizes for the spam, could notget a URL
17:46:33 <dguitarbite> rluethi: hello, thanks for saving me... matjazp asked me why is zero_empty.sh important
17:46:52 <dguitarbite> I think for compression of the resultant disks ... can you tell him the reasons?
17:47:20 <matjazp> I was just asking if we use thin or thick provisioned disks
17:47:26 <rluethi> dguitarbite, matjazp: yes, it's to allow for better compression of the disk images.
17:48:19 <dguitarbite> matjazp: I think I said so already!
17:48:30 <matjazp> if you write to the blocks, thin disks get large (basically thick provisionied?
17:48:59 <matjazp> or dou you explicitly (with virtbox api convert them after the zeroing?)
17:49:16 <rluethi> it's thin provisioning, but dd is writing out to the full capacity, so it takes longer for larger disks.
17:49:35 <rluethi> then we tell virtualbox to compress the whole thing.
17:50:11 <matjazp> so maybe it should be thick provisioned from the start and then convert to thin disks?
17:50:51 <rluethi> matjazp: feel free to experiment and let us know your results :-)
17:51:08 <rluethi> matjazp: the code is in lib/osbash/virtualbox.install_base
17:51:27 <dguitarbite> matjazp: you cannot conver from thick to thin
17:53:38 <matjazp> you can clone from one form to the other
17:53:48 <matjazp> but this debate is not important
17:54:10 <matjazp> I was just commenting the mentioned review
17:54:28 <dguitarbite> maybe we should not zero out the disks
17:54:37 <dguitarbite> it is more of a limitation as of now
17:54:43 <dguitarbite> as we are not able to add bigger images etc.
17:56:48 <sayali1> time check
17:57:16 <sayali1> rluethi: I think telemetry works now, dguitarbite fixed it
17:57:29 <sayali1> rluethi: test it when you can
17:57:31 <rluethi> sayali1: sounds great, i'll give it a try
17:58:03 <dguitarbite> in all fairness it was sayali1 's work
17:58:35 <sayali1> dguitarbite: good catches though. Thanks :)
17:58:44 <sayali1> anything else?
17:59:41 <matjazp> i'm good
17:59:55 <sayali1> I think we can wrap up then.
18:00:09 <matjazp> bye all
18:00:10 <sayali1> bye, see you'll next week.
18:00:12 <rluethi> bye
18:00:16 <sayali1> #endmeeting