17:02:26 <matjazp> #startmeeting training-guides
17:02:26 <openstack> Meeting started Mon Aug 17 17:02:26 2015 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:30 <openstack> The meeting name has been set to 'training_guides'
17:02:36 <matjazp> roll call
17:02:43 <rluethi> here
17:03:16 <matjazp> anyone else?
17:03:58 <rluethi> everyone's on vacation maybe?
17:04:02 <rluethi> no idea.
17:04:12 <matjazp> hmmm
17:04:29 <matjazp> I would really like do discuss a status of the project
17:04:39 <rluethi> let's do that, then.
17:04:55 <rluethi> #topic status of project
17:04:58 <matjazp> #topic status of the project
17:05:26 <matjazp> roger, you know more than me about this?
17:06:21 <matjazp> I am a bit in the dark about it
17:06:23 <rluethi> I doubt it. I heard that something was going on while you were on vacation, but I'm not sure what the plan is, either.
17:06:43 <rluethi> What I do know is that the labs scripts are getting a repo of their own.
17:07:00 <matjazp> yes, we talked about it
17:07:08 <rluethi> As you know, the scripts is the part I have been really involved with.
17:07:32 <rluethi> And we were fortunate to have a small but fairly dedicated team working on the scripts.
17:07:51 <matjazp> but from what I understand, this is not a second repo under Training guides, but it is separate project, or Specailty team at Docs
17:08:09 <rluethi> And then we even got newcomers like vigneshvar to help us out.
17:08:51 <rluethi> something like that, I think. I am not sure myself. I have to admit I didn't pay too much attention.
17:09:21 <matjazp> you don't know the details of it?
17:09:37 <rluethi> I believe the idea is to have the labs scripts be more visible and used by other projects outside training-guides, e.g. install-guides.
17:10:18 <matjazp> so what is the status of the rest of the project?
17:10:21 <rluethi> there's been a blueprint that just got accepted, I'm sure you saw that.
17:11:45 <rluethi> I am wondering about that, too. sarob seems to be AWOL, reed has sort of moved on, so it seems to be just you know who works on training content.
17:11:52 <rluethi> That is my impression, anyway.
17:12:10 <rluethi> So I guess I should ask _you_ what the plans are for the rest of the project.
17:12:30 <matjazp> well I still want to work on it
17:13:18 <rluethi> I think the content was moving in the right direction, but too slowly. No surprise there, lacking manpower.
17:13:30 <rluethi> You can't do it all alone.
17:14:01 <matjazp> yes, that's true.
17:14:30 <rluethi> I suspect I may be out of the loop, but my guess is that you should talk to Lana and present your vision for the project.
17:14:48 <matjazp> that's why I wanted to talk about all this with the rest of the team
17:15:00 <rluethi> Because you look like the likely lead for the training-guides project.
17:15:23 <matjazp> I am surprised about the lack of transparency, though
17:16:17 <annegentle> matjazp: I don't think the point has been to hide anything, it's just hard to communicate
17:16:29 <annegentle> time zones, channels, lack of responses from Sean
17:16:34 <annegentle> it's all difficult to coordinate
17:16:43 <rluethi> It is my understanding that there were some efforts behind the scenes to resolve everything, and when that didn't work, decision making kept going on outside of public channels for some time.
17:16:48 <matjazp> sure, but sean is not the only team member
17:17:27 <annegentle> rluethi: I don't think behind the scenes is a good description
17:17:34 <rluethi> A bit unfortunate. I think the labs team was better informed because we keep in touch anyway.
17:17:54 <annegentle> matjazp: absolutely
17:18:14 <annegentle> matjazp: the email from Aug 5th is the summary
17:18:33 <annegentle> matjazp: can you write back on that thread with your concerns?
17:18:37 <rluethi> annegentle: sorry, I just meant that there private discussions. I also prefer private discussions when I want to gather input and find a solution to a problem.
17:18:40 <annegentle> matjazp: and any solutions you have/ideas to offer
17:19:05 <matjazp> annegentle: 1. to establish who still wants to work on the guides
17:19:35 <annegentle> rluethi: Please, private discussions are not the OpenStack way. Please refrain from characterizing them that way. People needed to vent, and we always have outlets for that. However we also bring issues into the open. Once people get a chance to talk through them.
17:19:36 <matjazp> 2. reignite the effort
17:20:03 <annegentle> matjazp: great, please write back on the ml thread. The topic is Labs/Training Guides
17:20:34 <annegentle> matjazp: I think 1. is definitely attainable. However if the answer does not give enough ignition then 2 cannot happen, and we'll need to work through that.
17:21:27 <annegentle> matjazp: you'll also need to consider that labs are going to be separate from guides
17:21:43 <annegentle> matjazp: so take that into account when characterizing effort and recruiting :)
17:21:51 <rluethi> annegentle: I think we have a misunderstanding here. If I have a problem, I try to resolve it quietly with those involved and don't make a public example of them. I appreciate it if others do the same. I don't like if actual decisions are take in secret and then presented as fact to the public.
17:21:52 <annegentle> rluethi: does that separation help clarify?
17:22:15 <matjazp> annegentle: yes, I intend to. But first I wanted to talk with others about that. You know, to count the ppl who wants to be involved
17:22:24 <annegentle> rluethi: yeah I think we're in agreement I just reacted to the wording -- it's a balancing act
17:22:29 <annegentle> matjazp: sure
17:22:34 <annegentle> matjazp: sounds good then
17:22:49 <annegentle> matjazp: you know what to communicate, rluethi: you also know what to communicate
17:23:23 <rluethi> annegentle: do I?
17:23:27 <annegentle> if you think docs specialty teams is the way to go, then yes.
17:23:54 <matjazp> annegentle: I didn't really care that much about the "official" status of the project
17:24:00 <annegentle> rluethi: how you arrived at that conclusion is not relevant to the way forward
17:24:23 <rluethi> I just want the labs scripts to work and be useful to as many people as possible.
17:24:29 <annegentle> matjazp: ah, that's good input. Because anything published on docs.openstack.org is considered "official" and has been problematic when maintenance stalls.
17:24:34 <annegentle> rluethi: yep
17:24:53 <annegentle> do you see why we're trying to find a way forward?
17:25:04 <matjazp> annegentle: sure, as do I
17:25:29 <matjazp> I do think it is unfortunate that we didn't talk about all this on these meetings
17:25:29 <annegentle> matjazp: so a team forming will need to work within OpenStack frameworks, ya know?
17:25:48 <annegentle> matjazp: me too, but IRC is tough (I probably sound interruptive, for example)
17:25:54 <annegentle> matjazp: and timezones, oh the timezones
17:27:27 <matjazp> annegentle: ok. so to sum it up
17:28:01 <matjazp> 1. Labs are now outside the training guides
17:28:47 <matjazp> 2. Training guides needs to refocus
17:29:49 <matjazp> 3. We use Docs ML to talk about the future of it
17:30:00 <annegentle> to me there are still outstanding items to discuss/communicate: Training guides from Icehouse are no longer published.
17:30:20 <annegentle> There are some slide decks that we need to find out what to do with, are they being maintained, by whom.
17:30:37 <matjazp> annegentle: yes, the scope of the project needs to be rewritten
17:30:51 <annegentle> and, user group training seems to be the focus of the project? That's still a bit unclear
17:30:56 <annegentle> matjazp: can you bring this to the ml?
17:31:07 <annegentle> I mean, do you have enough info to kick off the discussion?
17:31:43 <matjazp> annegentle: sure, I guess I do.
17:32:12 <annegentle> and, do you understand the discussion points? I mean, I'm happy to help facilitate but both Lana and I are not the point person for training.
17:32:46 <annegentle> heh that was weird sentence construction there :)
17:33:13 <annegentle> trying to say, we want to resolve it, but need someone else to be the starting point/contact point
17:33:35 <annegentle> and I think you can do that matjazp
17:33:45 <annegentle> frees up rluethi and co to concentrate on labs
17:34:27 <matjazp> well I'm still willing to work on it, thats for sure
17:34:42 <annegentle> matjazp: excellent, let's see what comes of the discussion
17:36:19 <matjazp> ok, lets try to continue that discussion and see where it takes us
17:36:32 <annegentle> Okay sounds good. Do you want an action for the notes?
17:36:50 <annegentle> meeting note
17:36:52 <annegentle> s
17:36:54 <annegentle> can't type!
17:37:02 <annegentle> I'll do some info summaries
17:37:12 <matjazp> #action matjazp starts a discussion about the training guides on the ML
17:37:30 <annegentle> #info Training labs becoming specialty team within docs
17:38:23 <annegentle> #info Training guides are no longer published from icehouse branch; need a plan for training guides team, contributors, maintenance
17:38:42 <annegentle> #action matjazp to send query to openstack-docs mailing list asking about training-guides plans
17:38:56 <annegentle> #undo
17:39:00 <annegentle> heh my action is slow
17:39:24 <matjazp> np, thnx for infos
17:40:53 <matjazp> I guess thats it? anyone else?
17:41:04 <rluethi> I have some labs infos.
17:41:11 <matjazp> rluethi: shoot
17:41:18 <rluethi> new topic? :-)
17:41:21 <matjazp> ah
17:41:25 <matjazp> #topic labs
17:41:46 <rluethi> I did a forward port of my KVM patch.
17:42:10 <rluethi> It doesn't do everything (e.g. no snapshots), but it builds a basedisk and a cluster.
17:42:30 <rluethi> and to switch the scripts from VirtualBox to KVM, only one variable has to be set.
17:42:59 <rluethi> I did this mostly because some prefer testing with KVM _and_ the CI infrastructure doesn't do VirtualBox.
17:43:22 <rluethi> so we should be able to have CI in the forseeable future.
17:43:29 <matjazp> rluethi: and vbox cant do nested virtaulization :)
17:43:47 <rluethi> it can, just veeeery slowly :-).
17:44:11 <matjazp> rluethi: its now usabe for anything besides pinging in cirros ;)
17:44:16 <matjazp> now=not
17:44:41 <rluethi> matjazp: pinging in cirros happens to be precisely what I need.
17:45:35 <rluethi> so yeah, that was it. big announcement :-).
17:45:37 <matjazp> rluethi: yes, but the scenarios have to support more: eg. we tried to run windows on this, but gave up after 40 min bootup time
17:45:51 <rluethi> don't do that, then.
17:46:16 <rluethi> on the labs cluster, or on virtualbox in general?
17:46:19 <matjazp> rluethi: I don't (anymore :)
17:46:46 <matjazp> labs cluster
17:46:50 <rluethi> wow.
17:47:05 <rluethi> well, then the KVM patch should help.
17:47:32 <rluethi> problem with KVM is that it seems to be configured differently on every distro.
17:47:43 <rluethi> virtualbox, if it's installed, always works the same.
17:47:45 <matjazp> yes, it enables a HW supported nested virtualization, so it is much quicker
17:48:00 <rluethi> except on opensuse tumbleweed where I ran into weird problems.
17:48:45 <rluethi> the training-guides repo is frozen, but I'll send you a patch if you are interested.
17:49:12 <rluethi> (frozen wrt to the labs scripts)
17:49:13 <matjazp> sure, always interested to try that
17:50:32 <rluethi> okay, give me some days to cut a patch without all the debug junk.
17:50:47 <rluethi> feel free to ping me should I forget.
17:50:56 <matjazp> rluethi: sure, thnx
17:51:18 <rluethi> so, are we done for today?
17:51:26 <matjazp> looks like it
17:51:39 <matjazp> bye
17:51:44 <matjazp> #endmeeting