17:01:10 <matjazp> #startmeeting training-guides
17:01:15 <openstack> Meeting started Mon Aug 24 17:01:10 2015 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:18 <openstack> The meeting name has been set to 'training_guides'
17:01:51 <matjazp> #link agenda https://wiki.openstack.org/wiki/Meetings/training-guides#Weekly_training-guides_Meeting
17:02:03 <matjazp> roll call
17:02:12 <annegentle> hey matjazp
17:02:15 <Sayali_> Here
17:02:20 <matjazp> hey annegentle
17:02:40 <rluethi> here
17:03:08 <matjazp> hey Sayali_, rluethi
17:03:30 <matjazp> #topic status of the project
17:03:40 <cloudtrainme> Here and new to the party!
17:03:51 <matjazp> hey cloudtrainme
17:04:27 <cloudtrainme> Hello, hello.
17:04:55 <Sayali_> Hello cloudtrainme and welcome :)
17:05:04 <matjazp> cloudtrainme: maybe a short intro from your side?
17:05:29 <cloudtrainme> Sure thing.  I work for Rackspace on the OpenStack training team.
17:05:48 <matjazp> cloudtrainme: you're a trainer?
17:05:49 <cloudtrainme> Been doing OpenStack training since 2011
17:06:18 <rluethi> so where were you in the past year or so when we needed you? :-)
17:06:42 <matjazp> cloudtrainme: nice, I'm really glad that you joined
17:06:48 <cloudtrainme> lol...I know..I know...here now, I've got some catching up to do
17:06:51 <cloudtrainme> ready to jump in
17:07:01 <matjazp> cloudtrainme: great to hear that..
17:07:18 <matjazp> we're just starting to discuss a status of the project
17:07:35 <matjazp> so we need to define a new scope
17:07:58 <matjazp> labs are now a separate project, we need to update our scope
17:08:15 <matjazp> we have to focus areas: upstream training and training slides
17:08:55 <matjazp> upstream training is actively maintained, training slides had stalled
17:09:07 <matjazp> we need to restart the effort
17:09:42 <matjazp> any comments?
17:10:25 <rluethi> labs is a separate project, but still needs feedback from users in training-guides.
17:11:00 <cloudtrainme> are the slides in Github?
17:11:08 <matjazp> rluethi: sure
17:11:15 <matjazp> rluethi: I see no problems here
17:11:32 <matjazp> cloudtrainme: yes, slides are in openstacks git
17:11:53 <matjazp> #link https://wiki.openstack.org/wiki/Training-guides
17:12:13 <matjazp> some useful, (but now a bit outdated) info about the project
17:12:29 <rluethi> isn't there a mirror on github, too, for those who prefer to work against github?
17:12:54 <matjazp> rluethi: read only mirror?
17:13:10 <rluethi> matjazp: something like that.
17:13:42 <rluethi> matjazp: I know there used to be mirrors of openstack projects on github, and we used to have github URLs all over the documentation.
17:14:07 <annegentle> rluethi: yeah that was basically unmaintainable and a mess :)
17:14:24 <annegentle> plus I don't think the RST toolchain lets you do that
17:14:30 <matjazp> maybe we can discuss these statuary changes (scope of the project) on ML? We have bigger visibility there, and more community members can chip in
17:14:51 <annegentle> matjazp: other than slides, what do trainers need?
17:15:02 <annegentle> matjazp: I've always wondered why re-write docs
17:15:43 <matjazp> annegentle: slides are not really rewritten docs
17:15:46 <rluethi> annegentle: that's pretty much why we dropped the docs from training-guides.
17:16:05 <rluethi> annegentle: and what matjazp said.
17:16:08 <annegentle> matjazp: right, slides are a good deliverable. Docs, not so much "good" from a maintenance / accuracy concern.
17:16:46 <annegentle> matjazp: wondering if a deliverable focus is the conversation we need to have
17:17:09 <annegentle> matjazp: or, is it a "framework for trainers to get to know each other" that's needed?
17:17:32 <matjazp> annegentle: sean had a separate group for trainers
17:17:44 <annegentle> matjazp: I think your ML post is for slides only, just clarifying
17:17:55 <matjazp> annegentle: it was at https://wiki.openstack.org/wiki/Meetings/trainers
17:17:56 <annegentle> matjazp: ah, even better -- I like your narrow scope then
17:18:46 <matjazp> annegentle: yes, this is a small community, so we need to focus on some things. When we have larger commmunity, we can expand
17:18:51 <annegentle> matjazp: good on ya
17:19:08 <matjazp> we were spread to thin in the past
17:19:13 <annegentle> matjazp: also I hadn't realized your email didn't go to the -docs mailing list, sorry
17:19:49 <matjazp> annegentle: well, you said to reply to that thrread, and I thought that was deliberate
17:20:08 <matjazp> annegentle: i just hit reply all ;)
17:20:17 <annegentle> matjazp: heh I thought the original thread was also to the -docs mailing list
17:20:27 <annegentle> so just count me befuddled and confused about To: headers :)
17:20:47 <annegentle> matjazp: great email, sounds like good next step
17:21:02 <matjazp> annegentle: I intended to repost it to docs ML, but I wanted to solicit some feedback from the cores first
17:21:24 <annegentle> matjazp: sure, give it a turn of the sun to get the other side of the world I spose
17:21:59 <matjazp> annegentle: hehe, feeling a bit poetic today?
17:22:03 <annegentle> matjazp: heh
17:22:51 <matjazp> ok, so we agree, that we need to refocus and define a scope of the project again on Docs ML?
17:23:07 <annegentle> matjazp: ayup
17:23:20 <matjazp> #action matjazp sends an email about the scope of the project to the Docs ML
17:23:28 <matjazp> can we move on?
17:24:24 <matjazp> #topic bug queue
17:24:32 <matjazp> I cleaned up the project's bug queue (it went from 59 to 6)
17:25:01 <matjazp> roger, sayali : there is still 4 labs bugs there, I don't know where to move them? manuals queue?
17:25:53 <annegentle> matjazp: link please?
17:26:30 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/
17:26:54 <matjazp> some spring.. uh.. summer cleaning :)
17:27:47 <matjazp> speciality teams use openstack-manuals' queue, right?
17:28:05 <annegentle> matjazp: not really, security has its own queue for example
17:28:15 <annegentle> rluethi: where would you like to track bugs for the labs?
17:28:39 <rluethi> annegentle: I dunno (yet). What do you suggest?
17:29:00 <annegentle> matjazp: rluethi  since it's a separate repo I suggest bugs.launchpad.net/<reponame>
17:29:29 <rluethi> annegentle: makes sense. do we need to do something to set this up?
17:29:43 <matjazp> like https://bugs.launchpad.net/openstack-labs?
17:29:43 <annegentle> rluethi: yep, all can be done on launchpad
17:30:04 <matjazp> whats the labs new repo name?
17:30:50 <annegentle> rluethi: match the repo name and the github org sorts for "where is this?" I believe
17:30:52 <rluethi> matjazp: "openstack-labs" is the last I heard.
17:30:59 <matjazp> #action rluethi sayali make new bugs queue and move labs bugs there
17:31:00 <rluethi> annegentle: neat
17:31:47 <matjazp> is that ok?
17:32:36 <annegentle> rluethi: ah, I don't have it in an email thread
17:32:43 <rluethi> matjazp: ok. I am a bit under water right now, so please ping me if it's not done soonish.
17:33:05 <annegentle> rluethi: I'd suggest training-labs
17:33:13 <matjazp> rluethi: sure, there's no hurry
17:33:40 <annegentle> repo: openstack/training-labs, launchpad: openstack-training-labs
17:33:51 <rluethi> annegentle: I think we wanted to move away from the term "training" because the labs scripts are not only for training.
17:35:07 <annegentle> rluethi: hm. what about devstack's scripts then?
17:35:24 <annegentle> rluethi: those are used in labs
17:35:36 <annegentle> rluethi: not bikeshedding really trying to avoid confusion
17:36:01 <rluethi> annegentle: not really, only a devstack library. but I'm afraid we are hijacking the training-guides meeting here.
17:36:10 <annegentle> rluethi: ok
17:36:18 <matjazp> move on?
17:36:30 <annegentle> matjazp: sure
17:36:33 <matjazp> #topic prepare Upstream material for the Tokyo summit
17:36:45 <annegentle> rluethi: just "not openstack-manuals" is my message then :)
17:36:46 <matjazp> annegentle: I am a bit in the dark here
17:37:05 <rluethi> annegentle: no worries
17:37:13 <matjazp> Tim will be doing this in Tokio, right?
17:37:16 <annegentle> matjazp: the slides are used for upstream training currently
17:37:22 <annegentle> matjazp: who's tim?
17:38:03 <matjazp> Tim Freund
17:38:23 <matjazp> isn't he replacing reed there?
17:38:30 <annegentle> matjazp: ah, didn't know the name
17:38:32 <matjazp> for Upstream training in Tokyo
17:38:42 <matjazp> or am I wrong?
17:38:43 <annegentle> matjazp: so typically the Foundation staff work with the community, did Tim add it to the agenda?
17:39:08 <matjazp> I remember I read this somewhere
17:39:22 * matjazp is looking where
17:39:31 <annegentle> matjazp: openstack-dev mailing list
17:40:07 <annegentle> was it this?
17:40:08 <annegentle> http://lists.openstack.org/pipermail/openstack-dev/2015-August/071690.html
17:40:28 <matjazp> yes, I guess so
17:40:37 <matjazp> or some other PR regarding it
17:41:03 <matjazp> we usually refreshed the material right before the upstream training
17:41:15 <matjazp> I can ping Tim if we do the same this year
17:41:49 <annegentle> yep
17:41:57 <Sayali_> Sorry lost connection
17:42:01 <matjazp> or if you know anything else about it
17:42:06 <annegentle> matjazp: not a thing :)
17:42:35 <matjazp> #action matjazp pings Tim about Upstream training update plan
17:43:08 <matjazp> #topic shorter versions of the upstream training
17:43:34 <matjazp> Sean already has some material for 2 or 4 hour versions, more suitable for user groups
17:43:49 <matjazp> to avoid duplication of the content between longer and shorter versions of the slides, I propose to build this shorter versions with an automated process of “cherrypicking” the right slides from the longer version (so we can just define the which slides from the longer version would appear in 2 and which in 4 hour versions). This way, it will be easier to maintain.
17:44:47 <matjazp> longer Upstream for the "classic" Upstream training at Summits, shorter for more focused at user groups trainings
17:46:09 <matjazp> I guess this means some new code for a special utility... any takers?
17:47:06 <matjazp> a granularity is a whole slide
17:48:23 <matjazp> comments? is idea ok? or unnecessary?
17:49:05 <matjazp> we can also maintain two or three versions of the slides, but I'm afraid it means much more work
17:49:29 <matjazp> and we already don't have a lot of contributors
17:49:52 <cloudtrainme> A single version sounds wise from my rookie perspective.
17:50:15 <annegentle> matjazp: have to agree with Tony, you don't have resources yet to do versions
17:50:33 <matjazp> cloudtrainme: yes, I think so too.
17:50:38 <annegentle> matjazp: plus it's more to explain to both consumers and maintainers
17:51:25 <matjazp> ok, so the idea is ok, now we need someone that implements it :)
17:52:50 <matjazp> sean already has shorter versions tested in his user groups meetings, we also need to merge this with the original conetnt
17:52:52 <matjazp> content
17:54:01 <matjazp> ok.. looks like we agree it's a good idea, but we need to find someone to implement it. I can file a bug
17:54:21 <matjazp> in the mean time, we update/maintain just the longer version
17:54:50 <matjazp> #topic any other business?
17:55:49 <matjazp> cloudtrainme: if you need help with understanding anything here, please just ask
17:56:18 <cloudtrainme> I appreciate the welcome...I'll be sure to reach out on things I'm not clear about.
17:56:51 <annegentle> thanks matjazp for picking up!
17:56:57 <matjazp> cloudtrainme: no problem
17:57:21 <matjazp> anything else?
17:57:22 <rluethi> yeah, a big round of applause for matjazp!
17:57:56 <annegentle> hip, hip hooray matjazp!
17:58:05 <matjazp> hey, lets just revive this and I'm good :)
17:58:34 <matjazp> were out of time
17:58:50 <rluethi> and we are done, too.
17:58:50 <matjazp> thanks for comming
17:58:56 <rluethi> bye, everyone
17:59:01 <cloudtrainme> bye all
17:59:05 <matjazp> bye all
17:59:09 <matjazp> #endmeeting