17:01:12 <matjazp> #startmeeting training-guides
17:01:13 <openstack> Meeting started Mon Aug 31 17:01:12 2015 UTC and is due to finish in 60 minutes. The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:18 <openstack> The meeting name has been set to 'training_guides'
17:01:28 <timfreund> hello
17:01:31 <matjazp> agenda: https://wiki.openstack.org/wiki/Meetings/training-guides
17:01:37 <matjazp> roll call
17:01:38 <sayali> hello
17:01:42 <rluethi> hi
17:01:48 <cloudtrainme> o/
17:01:49 <matjazp> hi all
17:01:50 <cloudtrainme> hi
17:02:12 <matjazp> nice, bigger attendance :)
17:02:29 <matjazp> ok lets start with the agenda
17:02:46 <matjazp> #topic status update
17:03:23 <matjazp> I was waiting for the official announcement from Lana on Docs weekly email, but it was not made this week
17:03:30 <matjazp> so new stuff
17:03:39 <matjazp> I took over as a project lead
17:04:14 <matjazp> I guess the official announcement will be in mail in the next Docs weekly ML
17:04:25 <sayali> congrats matjazp :)
17:04:32 <cloudtrainme> matjazp: congrats
17:04:40 <matjazp> thnx
17:04:51 <rluethi> well deserved
17:05:24 <matjazp> we have some things to decide about scope, but thats onother topic
17:05:35 <janonymous> o/
17:06:14 <matjazp> we're also now under Docs project, as a speciality team
17:06:16 <matjazp> I feel this is normally something that all members of the team should participate in. But given the current status of the project and a smaller scope, I think for the moment, this is the only realistic option.
17:06:54 <matjazp> we can pursue a "full" project status later, if we decide so
17:06:54 * rluethi nods
17:07:24 <matjazp> move on?
17:07:43 <matjazp> #topic Patches, bugs
17:08:23 <matjazp> I wrote 7 new bugs for upstream training, some of them as low-hanging-fruit, to attract new contributors
17:08:37 <matjazp> but 4 are already taken, so the plan is working ;)
17:09:08 <timfreund> :-) That will be very helpful: the students are familar with the material by the end of the class, so it'll be an easy way for them to jump in.
17:10:06 <matjazp> timfreund: yes, but looks like they will be already submitted by the Tokyo...
17:10:45 <timfreund> We have feedback from past classes that I can turn into bugs, too. There's always room to improve.
17:11:08 <matjazp> I only looked at first few chapters, there's more to submit
17:11:15 <matjazp> timfreund: yes, please do
17:11:59 <matjazp> timfreund: but if you wan't to "reserve" these for the students, maybe you can also assign them right after you submit
17:12:09 <janonymous> is there a link for reference?
17:12:26 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/
17:12:54 <timfreund> sure, I can assign them to myself to reserve them, and then change the assignment to students that register and have no bug or area of interest in mind.
17:13:26 <matjazp> I also just submitted a new index page for training guides, but besides that queue is empty
17:13:53 <janonymous> thanks, just wanna go through. Is it bugs only?
17:13:56 <matjazp> timfreund: yes, that is the option. We need to have few simple fixes reserved for them
17:14:37 <matjazp> janonymous: reviews (patches) are in Gerrit, as usual
17:15:35 <matjazp> janonymous: https://review.openstack.org/#/q/project:openstack/training-guides,n,z
17:16:19 <matjazp> ok. since we're discussing Upstream...
17:16:23 <matjazp> #topic Upstream updates for Mitaka
17:16:59 <matjazp> As I said, I went through first few chapters and submitted update bugs
17:17:14 <matjazp> we need to do the same for other chapters
17:18:00 <timfreund> I will send a note to the people who have volunteered as classroom assistants and mentors to see if they can spare some time to do the same.
17:18:02 <janonymous> Thanks i got the docs , i wanna go through it once :)
17:18:56 <matjazp> timfreund: excelent.. material is pretty stable, right?
17:19:08 <matjazp> besides updates for Mitaka
17:19:16 <timfreund> yes
17:19:39 <matjazp> #action timfreund sends a note to the volunteers tor upstream training
17:20:05 <matjazp> which brings us to the next item on agenda
17:20:12 <matjazp> #topic Upstream material publishing
17:20:53 <matjazp> are we ready to publish the material on the official pages?
17:20:58 <matjazp> I believe so
17:21:26 <matjazp> now it's under draft
17:21:34 <matjazp> #link http://docs.openstack.org/draft/upstream-training
17:22:25 <matjazp> I propose we adopt continuous updates and we publish this in docs index
17:22:45 <timfreund> No objections if we can keep continuous updates visible.
17:22:56 <cloudtrainme> nice...first time I've seen this content.
17:23:14 <matjazp> it makes no sense to adopt branches
17:24:09 <timfreund> right: only having the most recent material published should help avoid confusion among potential new contributors.
17:24:22 <matjazp> timfreund: exactly
17:24:48 <matjazp> timfreund: and it also makes no sense to teach old, deprecated practices that are no longer valid
17:25:30 <matjazp> so we are in agreement here, right?
17:25:52 <cloudtrainme> Does that mean we wouldn't provide training on older releases?
17:26:16 <timfreund> cloudtrainme: I think that's just for the upstream training material
17:26:19 <matjazp> this is just for Upstream
17:26:25 <cloudtrainme> ah...got it
17:26:33 <matjazp> #info we adopt continuos publishing model for Upstream training
17:27:15 <matjazp> #info we start the activity for publishing the Upstream training slides in the official Docs index
17:27:59 <matjazp> can we move on?
17:28:05 <cloudtrainme> yes
17:28:31 <matjazp> ok, I will submit some bugs for this
17:29:05 <matjazp> #action matjazp looks into what needs to be done for official publishing of upstream training material
17:29:25 <matjazp> #topic Project's scope and priorities
17:29:56 <matjazp> ok, as Labs are no longer a part of this project, we need to update project's scope
17:30:25 <matjazp> as I see it, maybe one of the problems was that we were spread to thin in the past
17:30:35 <matjazp> we tried to do too much
17:31:19 <matjazp> so maybe we should focus on a fewer items first, and then when community expands, add new stuff
17:31:44 <cloudtrainme> I think that makes sense.
17:31:50 <matjazp> so what I propose is to focus on key items first:
17:31:56 <matjazp> 1. Upstream training
17:32:23 <matjazp> 2. Training guides for begginers ("associate training")
17:32:58 <matjazp> what else?
17:33:44 <matjazp> sayali: rluethi : what do you think?
17:35:09 <sayali> matjazp: sounds good
17:35:15 <matjazp> do we have enough ppl to add something?
17:35:18 <rluethi> sounds like a good start, yes
17:35:25 <rluethi> like what?
17:35:49 <matjazp> some of the other areas we had?
17:36:12 <matjazp> like multimedia or online quizzes
17:36:18 <rluethi> oh, IC
17:36:26 <matjazp> but I'm afraid that we will loose focus
17:36:29 <rluethi> I'd say postpone these.
17:36:30 <sayali> matjazp: i think we should focus on kthe guides content to begin with
17:37:08 <rluethi> matjazp: I suppose that 2. Training guides is really slides, not a manual, right?
17:37:14 <matjazp> ok, so we agree on 1. and 2. to be proiorities, and we add to it later
17:37:52 <matjazp> rluethi: yes, slides
17:38:09 <matjazp> like upstream training
17:39:19 <matjazp> WE can add one topic at the time
17:39:31 <matjazp> Networking is already in the repo
17:39:49 <matjazp> we add similar chapters for other "core" projects
17:40:18 <matjazp> with focus on begginers, user groups, etc.
17:41:06 <matjazp> these slides should also be as "generic" as possible (to reduce work with releases)
17:42:33 <matjazp> #info Project focus is on 1. Upstream training and 2. Training slides. We add other stuff later
17:43:30 <matjazp> #action matjazp sends a new focus to the Docs ML
17:44:28 <matjazp> anything else here?
17:45:21 <matjazp> ok moving on
17:45:42 <matjazp> #topic Training slides
17:46:45 <matjazp> I submitted a nicer index page for this content in https://review.openstack.org/#/c/218943/
17:47:03 <matjazp> but it's still in the gate, so you can't look at it online
17:47:19 <matjazp> it is similar like upstream's
17:47:58 <matjazp> anyone wants to start a new chapter?
17:48:09 <matjazp> a few slides about nova?
17:48:26 <matjazp> or any other topic
17:48:35 <rluethi> Alas time is failing me.
17:49:17 <matjazp> would it be beneficial if we wrote bugs for it?
17:49:29 <sayali> matjazp: I think its a good idea to create bugs or something similar so people interested can take up the work
17:49:40 <cloudtrainme> Yes. I think I can help out and having a bug would be helpful.
17:49:47 <matjazp> like a bug for a chapter
17:49:59 <sayali> matjazp: yes you should
17:50:17 <matjazp> and we don't need complete coverage of the topic, just something to start with
17:50:50 <matjazp> #action matjazp submits a bug for each proposed chapter/topic
17:51:32 <matjazp> cloudtrainme: do you already have a topic you would like to tackle wiht?
17:52:10 <cloudtrainme> matjazp: I'm pretty open, but something simple would be good for my first time out.
17:52:41 <matjazp> cloudtrainme: yes, focus is on simple stuff. we need to start somewhere
17:53:21 <cloudtrainme> matjazp: I can likely tackle some high level nova slides or swift slides.
17:53:57 <matjazp> cloudtrainme: excellent!
17:54:25 <matjazp> #action cloudtrainme looks into nova
17:54:37 <matjazp> cloudtrainme: would you like to submit a bug for it?
17:55:03 <cloudtrainme> matjazp: Indeed. I can submit the bug.
17:55:07 <matjazp> just some generic text, like a description of Nova
17:55:36 <matjazp> #action cloudtrainme submits a bug for Nova's slides
17:56:25 * matjazp looks at the ball as it starts rolling :)
17:56:38 <matjazp> #topic any other business
17:56:54 <matjazp> Tim, can we do anything else for Upstream?
17:58:20 <timfreund> I think you've set us up for success so far. I'll circle back once I reach out to the mentors and assistants if anything comes up.
17:58:26 <timfreund> thank you!
17:58:52 <matjazp> anyone else?
17:59:01 <matjazp> huh.. time's almost up
17:59:34 <matjazp> bye all, thnx for coming!
17:59:38 <cloudtrainme> bye
18:00:03 <sayali> bye!
18:00:13 <matjazp> #endmeeting