17:00:35 <matjazp> #startmeeting training-guides
17:00:36 <openstack> Meeting started Mon Sep  7 17:00:35 2015 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:39 <openstack> The meeting name has been set to 'training_guides'
17:00:44 <matjazp> hi all
17:00:47 <matjazp> roll call
17:03:08 <matjazp> anyone here?
17:03:54 <cloudtrainme> Hi matjazp: I'm here
17:04:00 <mgrohar> here
17:04:02 <matjazp> hey cloudtrainme
17:04:08 <matjazp> hey mgrohar
17:04:32 <mgrohar> hi all
17:04:34 <matjazp> should we start or should we wait a bit more?
17:04:59 <matjazp> agenda #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:05:58 <matjazp> lets review action items from previous meeting
17:06:15 <matjazp> timfreund: you around?
17:07:00 <matjazp> I had sent a status mail on Doc ML
17:07:21 <matjazp> upstream publishing is on the agenda, so wil talk about it later
17:08:10 <matjazp> #info matjazp submitted bugs to serve as a guides what needs to be done in Training guides
17:08:44 <matjazp> #info Docs community was notified about new scope and other changes to the project
17:09:26 <matjazp> cloudtrainme: did you managed to  make some slides about nova? need help?
17:10:00 <cloudtrainme> I submitted the bug, but haven't been able to knock out the slide yet.  Sorry.  I'll aim to get that done this week.
17:10:28 <matjazp> no problems
17:10:42 <matjazp> lets just go to agenda
17:10:57 <matjazp> #topic Upstream material and Tokyo
17:11:20 <matjazp> there is some activity about that
17:11:42 <matjazp> mgrohar submitted his first patch
17:12:04 <mgrohar> yes, first one
17:12:17 <matjazp> Miha, can you please just introduce yourself?
17:12:39 <mgrohar> ok
17:13:00 <mgrohar> so I work at University od Ljubljana
17:13:54 <mgrohar> have been in OpenStack couple of years
17:14:41 <mgrohar> we run a small openstack cloud and I also have some training experiences as an instructor
17:15:19 <mgrohar> looking forward to do some additonal work in the training-guides project
17:15:31 <matjazp> great :)
17:15:32 <cloudtrainme> mgrohar: Welcome.  Congrats on your first patch!
17:15:34 <codebauss> i'd like a bit more info on contributing to the training guides, is there a link
17:16:10 <matjazp> codebauss: sure: #link https://wiki.openstack.org/wiki/Training-guides
17:16:19 <matjazp> wiki is a bit old
17:16:35 <matjazp> but you can also ask me or anyone on Doc ML
17:17:25 <matjazp> mgrohar is also my coworker, so I guess I nagged him enough to cave in and start contributing ;)
17:17:57 <matjazp> ok, tim is not here so we can skip to the next item on the agenda
17:18:00 <cloudtrainme> matjazp: well done!  I need to do the same
17:18:22 <matjazp> cloudtrainme: hmm.. can I make it an action item ;)
17:18:47 <cloudtrainme> matjazp:  LOL...why yes you can
17:19:13 <codebauss> thx matjazp
17:19:17 <matjazp> cloudtrainme: it helps to just sit with them together and pick a small low-hanging-fruit and make the patch
17:20:02 <matjazp> #action cloudtrainme tries to persuade his coworkers to join the project
17:20:47 <matjazp> codebauss: np. ask if you get stuck. pick a low-hanging-fruit bug as a first patch.
17:21:05 <matjazp> #topic Upstream training publishing and landing page
17:21:36 <matjazp> ok, so as I see it, we need to set our goals first... where and how we want to publish upstream material
17:21:42 <matjazp> alternatives are
17:22:19 <matjazp> a section under http://docs.openstack.org/ (like Install guides, API reference, etc.)
17:23:09 <matjazp> or/and http://www.openstack.org/marketplace/training under "OpenStack Online Help" in the right of this page
17:23:41 <matjazp> there are already 4 links to dofferent docs
17:23:55 <matjazp> what do you think? we shoot for both?
17:24:32 <cloudtrainme> I was going to say both.
17:24:40 <cloudtrainme> I know docs gets a lot of traffic
17:24:40 <mgrohar> both seem fine
17:24:52 <cloudtrainme> Does the marketplace get good traffic?
17:25:18 <matjazp> we need to discuss this on Docs ML, should we get a separate section
17:25:50 <matjazp> cloudtrainme: dont know, I wa just trying to fit this somewhere that is the most logical choice
17:26:07 <cloudtrainme> matjazp: makes sense
17:26:26 <matjazp> and of course: do we need another special landing page or not.
17:27:05 <matjazp> I mean, do we just publish links on slides on the docs page, or to the separate page that has link to the slides
17:27:13 <matjazp> am I making sense?
17:28:34 <mgrohar> i think no additonla lp is needed if we have the docs page
17:29:08 <cloudtrainme> agreed.  as long as we clearly indicate that these are training slides...not full blown docs.
17:29:35 <matjazp> cloudtrainme: yes, how do we do this?
17:29:51 <matjazp> cloudtrainme: with a another landing page, it is trivial
17:30:12 <matjazp> cloudtrainme: but if we just publish direct links, that is harder
17:31:05 <cloudtrainme> when you say another landing page are you suggesting a new link like training.openstack.org?
17:31:06 <matjazp> maybe we name the section "Training slides" and not "Training guides"
17:31:50 <matjazp> cloudtrainme: no, a page that shows when user clicks on the link on the Docs page
17:33:07 <cloudtrainme> matjazp: maybe a new lp does make sense if it allows us to distinguish the training slides better.
17:33:58 <mgrohar> what would be the content of the new lp? direct links to slide sets?
17:34:00 <matjazp> we could also change the current landing page (that is generated by the hieroglyph as a slide)
17:34:19 <matjazp> mgrohar: yes, some text explaining things and links to the slides
17:35:47 <matjazp> current landing page (see http://docs.openstack.org/draft/upstream-training) is in the form of a slide deck, we could make this a custom landing page with text and direct links
17:37:07 <mgrohar> ok, in that case a new lp is more appropriate imo
17:37:59 <matjazp> if we cut out "draft" from that URL, it could also be the landing page, with links to the slide chapters.
17:38:46 <matjazp> and then we just publish links to that on Docs.openstack.org under "Training gjuides"  section
17:39:31 <matjazp> and put a link on the marketplace/training pointing to docs section
17:39:46 <matjazp> makes sense?
17:40:22 <cloudtrainme> matjazp: sounds like a good plan to me.
17:40:27 <matjazp> ok
17:40:40 <mgrohar> yep, ok
17:40:50 <matjazp> #info we make a new anding page instead of the current that is in the form of the slides
17:41:24 <matjazp> #info we publish upstream in the docs.openstack.org, under a separate section
17:42:20 <matjazp> #info we put a link  to that on the marketplace/training landing page under "OpenStack Online Help"
17:42:27 <matjazp> moving on
17:42:43 <matjazp> #topic Training slides
17:43:08 <matjazp> I see now that I need to write down a TOC for this
17:43:39 <matjazp> we assumed we will just convert old XML format (old Icehouse training guides material) to the RST slide format
17:43:58 <matjazp> but this stalled (except some work on the netwirking)
17:44:20 <matjazp> #action matjazp puts training slides TOC on the wiki
17:45:00 <matjazp> idea is to have small units (modules) that explain a single topic
17:45:22 <matjazp> and then just put them together for a training session
17:46:09 <matjazp> it will be easier to update this way, but it also means it can lack coherence
17:46:19 <matjazp> TOC should help with the bigger picture
17:46:39 <matjazp> sonds ok?
17:46:44 <matjazp> sounds
17:46:50 <mgrohar> ok
17:46:58 <cloudtrainme> yup
17:47:30 <matjazp> idea is also that we reause as much diagrams and stuff from the existing guides and put links to that in the presenter notes
17:47:51 <matjazp> existing guides= existing openstack docs
17:49:17 <mgrohar> makes sense
17:49:45 <matjazp> ok, moving to the last topic
17:49:48 <matjazp> #topic Sharing screenshots of slides in reviews and bugs
17:50:25 <matjazp> in the review process, I found that there is no "official" openstack way to share screenshots in the review comments
17:50:41 <matjazp> like when you need to show that something renders wrong
17:51:37 <matjazp> we have we have paste.openstack.org for text
17:51:47 <matjazp> but not for pic
17:52:18 <matjazp> we could use something like skitch and publish on iloud or google drive
17:52:26 <matjazp> but that is ephemeral
17:53:16 <matjazp> so the question is, because of the transparency, do we need something that lasts longer?
17:54:46 <cloudtrainme> something that last longer would be ideal, but I'm not sure what solutions are out there besides google, or dropbox.
17:54:55 <cloudtrainme> Be cool to use OpenStack Swift somehow.
17:55:33 <matjazp> cloudtrainme: yes, we can take this to the Docs ML and see what others think
17:56:05 <matjazp> cloudtrainme: I'm sure there are opensource "imagebin" (pastebin clones)
17:56:46 <matjazp> cloudtrainme: suggest that to the openstack-infra folks
17:56:54 <cloudtrainme> matjazp: agreed.  asking on the Docs ML may help us find other options.
17:57:36 <matjazp> #action: matjazp sends a wueistion regarding pics "pastebin" (ala paste.openstak.org) to the docs ML
17:57:54 <matjazp> #topic AOB
17:58:01 <matjazp> anything else?
17:58:12 <mgrohar> no
17:58:37 <cloudtrainme> nothing here
17:58:49 <matjazp> ok, thank you guys for you time
17:58:57 <matjazp> see you next week
17:59:01 <matjazp> bye!
17:59:03 <mgrohar> bye
17:59:07 <cloudtrainme> Have a good week all.  See you next time.
17:59:15 <matjazp> #endmeeting