17:01:56 <matjazp> #startmeeting training-guides
17:01:57 <openstack> Meeting started Mon Sep 14 17:01:56 2015 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:01 <openstack> The meeting name has been set to 'training_guides'
17:02:12 <matjazp> roll call
17:02:14 <cloudtrainme> Hello
17:02:18 <mgrohar> here
17:02:29 <matjazp> hi cloudtrainme mgrohar
17:02:38 <rluethi> hi all
17:02:44 <matjazp> hey roger
17:02:48 <jmckind> hello
17:03:04 <matjazp> hi jmckind
17:03:18 <matjazp> lets look at last week's action items
17:03:56 <matjazp> cloudtrainme: any luck with "hunting down" some coworkers? ;)
17:04:31 <cloudtrainme> jmckind: is one of my co-workers
17:04:33 <jmckind> I am one of those and a rookie, so be kind... :)
17:04:46 <matjazp> jmckind: welcome!
17:04:49 <cloudtrainme> Also, there is one more logging in now.
17:04:56 <jmckind> thanks!
17:05:26 <matjazp> cloudtrainme: nice
17:05:41 <matjazp> cloudtrainme: we should give you more action items in the future ;)
17:06:01 <cloudtrainme> lol...those are easy action items
17:06:14 <matjazp> I've put a simple TOC for Training sildes on Wiki
17:06:19 <matjazp> #link https://wiki.openstack.org/wiki/Training-guides#Training_slides_-_Modules
17:06:27 <bgmccollum> o/ Here cloudtrainme
17:06:33 <matjazp> Wiki page is still a mess, I have to cleann it up a bit
17:06:43 <matjazp> bgmccollum: welcome
17:06:48 <bgmccollum> matjazp: thanks
17:07:17 <matjazp> bgmccollum jmckind if you guys need anything, please just ask
17:07:44 <matjazp> ok... the last action item is still there for me
17:08:18 <matjazp> #action matjazp sends a question regarding pics "pastebin" (ala paste.openstak.org) to the docs ML
17:09:06 <matjazp> btw... i think one way to do it is to use paste.openstack.org to store base64 encoded image and then a simple web service to decode and show it
17:09:37 <matjazp> something like our.new.service/showpic?q=paste.openstack.org/123456
17:10:36 <cloudtrainme> matjazp: this was for storing images right?  Trying to remember.
17:10:43 <matjazp> cloudtrainme: yes
17:11:10 <matjazp> we need something to store pics (like paste.openstack.org for text
17:11:30 <bgmccollum> so an imgbin service? lots to choose from...
17:11:45 <matjazp> if we share link to dropbox or other cloud service, it gets deleted and there is no real archive for reviews
17:12:58 <matjazp> bgmccollum: I guess we need something like openstacks paste service.. not ephemeral, but more or less permanent
17:14:28 <matjazp> ok, moving on to the agenda
17:14:34 <bgmccollum> matjazp: possibly a solution using swift?
17:14:37 <matjazp> #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:15:09 <matjazp> bgmccollum: it's a possibility, yes
17:16:06 <matjazp> bgmccollum: I don't know if something like it exists for "general" audience
17:16:46 <matjazp> bgmccollum: and there are endless complications regarding copyright issues
17:17:57 <matjazp> bgmccollum: so it is easier to just base64 encode an image, paste it to existing paste.openstack.org and than just publish a link using this paste to decode on the fly...
17:18:42 <bgmccollum> matjazp: gotcha...
17:18:49 <matjazp> anyway, it is not an priority, just a nice to have feature that enables easier slide reviews
17:19:24 <matjazp> like when you want to show that something renders wrong on a particular OS or browser
17:19:55 <matjazp> #topic Upstream training landing page
17:20:19 <matjazp> #link https://review.openstack.org/#/c/222587/
17:20:28 <matjazp> this is a first shot at a new landing page
17:20:49 <matjazp> I kept the old one as slide-index.html
17:21:17 <matjazp> you can look both at the review
17:21:39 <matjazp> I published direct links to the pages generated at the gate
17:21:46 <jmckind> will review...
17:22:51 <matjazp> you can look at this generated slides if you click at the Jenkins gate (gate-training-guides-tox-doc-publish-checkbuild)
17:23:25 <cloudtrainme> on that topic, when we are developing slides, whats the best way to generate them locally?
17:23:48 <matjazp> just run tox -e upstream-slides
17:24:00 <matjazp> or tox -e training-slides
17:24:06 <cloudtrainme> matjazp: got it.  thanks.
17:24:10 <matjazp> look at the tox.ini for the right target
17:24:40 <matjazp> when you upload a patch, this tox.ini has two actions that gets executed
17:25:32 <matjazp> currently publishing is at docs.openstack.org/draft/training-guides
17:25:50 <matjazp> and docs.openstack.org/draft/upstream-training
17:26:40 <matjazp> if this new landing page is ok, we can proceed to start the process of publishing th eupstream material to docs.openstack.org (without draft
17:27:26 <matjazp> and we chose to continuously publish all patchsets, so when we merge a patch, it gets published immediately
17:28:23 <matjazp> we have a list of bugs at https://bugs.launchpad.net/openstack-training-guides/
17:29:19 <bgmccollum> excellent...
17:29:35 <matjazp> so you can just assign a bug to yourself to reserve a work that needs to be done
17:30:01 <matjazp> if anyone needs help with the process, just ping me
17:30:35 <matjazp> actually... or look at the slides of the upstream training :)
17:30:38 <jmckind> will do
17:31:27 <matjazp> it's complicated, I know.
17:31:56 <bgmccollum> grabbing my first bug
17:32:04 <matjazp> it's easier to just use powerpoint or keynote, but this is not a git frendly format
17:32:34 <jmckind> Yeah, we have had our own struggles with that
17:32:58 <matjazp> internally, in my lab, we settled for reveal.js
17:33:18 <bgmccollum> matjazp: you might be interested in madoko - https://www.madoko.net/
17:33:20 <matjazp> it's much more capable than Hieroglyph/Sphinx we use here
17:33:59 <matjazp> bgmccollum: nice.. will look at it, thnx
17:34:25 <mgrohar> hm, looks like madoko is using reveal.js
17:34:40 <matjazp> I guess we chose this mainly because we wanted to use RST instead of MD
17:35:35 <matjazp> but the transformation from RST to MD is not a complex task and can be automated, so we can switch to some other framework if we chose so
17:36:26 <matjazp> anyway. back to usptream training
17:37:35 <matjazp> the plan is to publish this new page at the docs index and also add a link to our deliverables to the openstack.org/marketplace/training, at the OpenStack Online Help box
17:39:16 <matjazp> I'll wait for Tim Freunds review (or other trainer for Tokyo Upstream training) to look at the landing page
17:40:10 <matjazp> anything else for upstream training?
17:40:47 <matjazp> one patch just got merged, there are several more to go. we have like 30 days to do it
17:41:23 <matjazp> and we still need to look at the other half of the upstream slides and enter bugs that nees to be updated before the ummit
17:41:28 <matjazp> ummit=summit
17:41:36 <matjazp> any takers?
17:42:48 <matjazp> ok, moving on to the training guides
17:43:03 <matjazp> #topic training slides
17:43:18 <matjazp> any news here?
17:44:08 <cloudtrainme> I'm working on the slide for Compute.
17:44:27 <cloudtrainme> It looks like they slides are numbered, ie 08-****
17:44:41 <cloudtrainme> is there a numbering system we should be folllowing?
17:44:41 <matjazp> cloudtrainme: yes, this is from old guide
17:45:10 <matjazp> cloudtrainme: do we even need nubbering?
17:45:14 <matjazp> numbering
17:45:33 <matjazp> we'll publish a landing page that list topics/modules
17:45:50 <cloudtrainme> yeah...i don't think we need the numbering as long as we have a TOC
17:46:05 <matjazp> maybe we don't need numbers, as we plan to reuse material between different guides
17:46:12 <cloudtrainme> if some topics build on others, we need to preserve the order.
17:46:44 <matjazp> cloudtrainme: yes, this order will be suggested on the landing page
17:47:02 <cloudtrainme> matjazp: perfect
17:47:32 <matjazp> cloudtrainme: if we mix'n'match slides together, numbers will just confuse things
17:47:52 <cloudtrainme> matjazp: I agree.  Let's drop the numbers.
17:48:09 <matjazp> and avery topic should be as small as possible, so it can be used/reused in different formats/slides
17:49:29 <matjazp> so is it an agreement? we loose the numbers in the name of the modules/chapters/topics
17:49:49 <matjazp> what do you think?
17:49:59 <mgrohar> makes sense to me
17:50:18 <cloudtrainme> #vote yes
17:50:58 <jmckind> works for me :)
17:51:12 <matjazp> anyway, if we stumble upon something, we can easily add the numbering scheme later
17:51:26 <matjazp> #info slide modules have no numbers in the names
17:51:53 <matjazp> #info order of the modules is preserved with the ordering of items on the landing page
17:52:07 <matjazp> nice
17:52:25 <matjazp> anything else for training slides?
17:53:12 <cloudtrainme> nothing here.
17:53:23 <matjazp> #topic AOB
17:53:47 <matjazp> anything else?
17:54:19 <mgrohar> no
17:54:30 <matjazp> will you guys all be at the summit?
17:54:46 <cloudtrainme> I'll be there.
17:54:48 <jmckind> yes, I am also signed up to help with the training the weekend before.
17:55:04 <matjazp> jmckind: with upstream training?
17:55:18 <jmckind> yes
17:55:53 <bgmccollum> ill be helping at the summit as well
17:56:15 <matjazp> jmckind: excelent. upstream is a month away so I guess it has a priority. we need to update the slides
17:56:43 <bgmccollum> I just submitted a review for an updated stackalytics screenshot
17:56:56 <matjazp> just enter a bug if you see anything tht needs to change
17:58:08 <jmckind> I will look at the upstream slides
17:58:29 <matjazp> ok, time's almost up
17:58:57 <matjazp> jmckind: please do and just add a bug if something needs to update
17:59:18 <matjazp> excellent meeting, thanks everyone
17:59:26 <matjazp> see you next week
17:59:32 <jmckind> thanks!
17:59:33 <matjazp> bye
17:59:36 <jmckind> bye
17:59:36 <bgmccollum> its on the calendar. thanks matjazp
17:59:39 <mgrohar> next week, bye
17:59:58 <matjazp> #endmeeting