17:01:47 <matjazp> #startmeeting training-guides
17:01:48 <openstack> Meeting started Mon Sep 21 17:01:47 2015 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:51 <openstack> The meeting name has been set to 'training_guides'
17:02:05 <matjazp> hey mgrohar bgmccollum
17:02:09 <matjazp> roll call
17:02:16 <mgrohar> hey
17:02:22 <bgmccollum> howdy
17:02:47 <matjazp> #link agenda https://wiki.openstack.org/wiki/Meetings/training-guides
17:03:03 <matjazp> #topic Action items review
17:03:14 <matjazp> ok, lets see last week's action items
17:03:38 <matjazp> you all know that you can see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2015/training_guides.2015-09-14-17.01.html
17:04:02 <cloudtrainme> sorry, I'm late..here.
17:04:09 <bgmccollum> have it pulled up :)
17:04:10 <matjazp> hey cloudtrainme
17:05:04 <matjazp> #info no repllies on ML about "screenshot pastebin", so let's wait a bit for this
17:05:28 <matjazp> nothing else I see
17:05:33 <matjazp> ok moving on
17:05:50 <matjazp> #topic Upstream training progress
17:05:52 <bgmccollum> matjazp: do you have a set of requirements we can work against for the imgbin?
17:06:15 <matjazp> bgmccollum: did you see my mail on ML?
17:06:26 <bgmccollum> which list?
17:07:11 <matjazp> #link http://lists.openstack.org/pipermail/openstack-docs/2015-September/007448.html
17:07:22 <matjazp> We're using Docs ML
17:07:45 <matjazp> #ilink http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-docs
17:07:59 <bgmccollum> thanks
17:08:33 <matjazp> ok back to upstream training
17:08:55 <matjazp> bgmccollum squashed 2 bugs last week. congrats! :)
17:09:21 <bgmccollum> thanks!
17:09:50 <matjazp> we also have a new landing page
17:09:59 <matjazp> it is already published at
17:10:26 <matjazp> #link http://docs.openstack.org/draft/upstream-training
17:11:02 <matjazp> #info upstream material has a new landing page, published as draft at http://docs.openstack.org/draft/upstream-training
17:11:37 <matjazp> #info old slide-only landing page is still there at http://docs.openstack.org/draft/upstream-training/slide-index.html
17:12:15 <cloudtrainme> New LP looks great.  I like it.
17:12:24 <matjazp> the question is do we fill all the stuff we have on the Wiki into this?
17:12:56 <matjazp> #link #link https://wiki.openstack.org/wiki/OpenStack_Upstream_Training
17:13:30 <cloudtrainme> What are the other Docs teams doing?  Are they still using Wiki?
17:13:46 <matjazp> not for docs
17:13:58 <matjazp> just for some bookkeeping stuff
17:14:26 <cloudtrainme> I like the idea of moving out wiki content to the LP, but I can be swayed if someone feels differently.
17:14:35 <matjazp> maybe it would be better if we also discuss this on the ML
17:15:03 <cloudtrainme> sounds good
17:15:13 <matjazp> and ping Tim and Loic for an opinion
17:15:26 <bgmccollum> wikis tend to get "forgotten" and outdated...having it in code seems like more eyeballs would catch changes
17:15:57 <matjazp> #action matjazp asks about moving stuff from Upstream's wiki to the repo on Doc ML
17:16:59 <matjazp> bgmccollum: yes, my thoughts exactly, but wiki is ideal for last minute changes... let7s see what the other trainers think of this
17:17:13 <mgrohar> agree with bgmccollum
17:18:04 <matjazp> ok, so I'll start the debate on ML, and you guys can chip in with replies to increase mail thread's visibility ;)
17:18:45 <matjazp> if you're not subscribing our ML, you should.. see link above
17:19:38 <matjazp> I'm marking training guide's msgs with "[training guides]" in the Subject
17:20:27 <matjazp> anyway, upstream is progressing nicely
17:21:04 <matjazp> currently there are only 5 bugs not assigned
17:21:19 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/?field.searchtext=upstream&orderby=-importance&search=Search&assignee_option=none&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branche
17:21:19 <matjazp> s=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on
17:21:24 <matjazp> huh
17:21:34 <matjazp> too long
17:22:25 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/?field.searchtext=upstream&search=Search&assignee_option=none
17:22:30 <matjazp> this should do it
17:23:00 <matjazp> but you can also see the whole list at https://bugs.launchpad.net/openstack-training-guides/
17:23:05 <matjazp> it's not so long
17:24:34 <bgmccollum> picked up the horizon screenshot
17:24:36 <matjazp> we still need to scan for bugs on the last few chapters
17:24:48 <matjazp> bgmccollum: great
17:25:10 <bgmccollum> also i have some content about eavesdrop, so i might pick that up as well time permitting
17:26:07 <matjazp> I made a quick scan up to devstack chapterscanned
17:26:55 <matjazp> I'll try to look it up and enter more bugs
17:27:18 <matjazp> anything else for upstream?
17:28:04 <matjazp> ok, moving on
17:28:14 <matjazp> #topic training slides
17:28:48 <matjazp> upstream training is a priority, as it is due in a month
17:29:04 <matjazp> cloudtrainme: any progress on nova?
17:29:21 <cloudtrainme> matjazp: I'm running into some issues with tox
17:29:34 <cloudtrainme> trying to build the slides but the training-slides target is failing
17:29:55 <matjazp> what's the error message?
17:30:00 <cloudtrainme> bgmccollum: are looking at it this morning.
17:30:06 <bgmccollum> cloudtrainme: try tox -r to recreate the venvs
17:30:13 <bgmccollum> then tox -e <env>
17:30:32 <matjazp> cloudtrainme: tox -e training-slides
17:30:51 <matjazp> and for upstream tox -e upstream-slides
17:32:02 <bgmccollum> This is the error: ERROR: InvocationError: '/Users/bgmccollum/Documents/training-guides/.tox/upstream-slides/bin/sphinx-build -b html doc/upstream-training doc/upstream-training/build/slides doc/upstream-training/index.rst'
17:32:08 <matjazp> "hard reset" is to just delete .tox dir ;)
17:33:45 <matjazp> this is if you build for upstream training
17:33:50 <bgmccollum> ImportError: No module named openstackdocstheme
17:33:59 <cbader> asselin, printenv returned nothing
17:34:37 <matjazp> this looks like it has no sphinx-build installed
17:34:46 <matjazp> maybe it didn't create venv right
17:35:25 <bgmccollum> cloudtrainme and I will continue to debug offline
17:35:41 <matjazp> I sometimes just delete .tox and start over
17:35:49 <bgmccollum> i reset hard and same
17:37:10 <matjazp> same error?
17:38:02 <cloudtrainme> I think my issue  is a venv error because when I run the sphinx commands or doc8 commands directly, they work.
17:38:50 <cloudtrainme> My error: ERROR: InvocationError: '/Library/Frameworks/Python.framework/Versions/2.7/bin/doc8 doc/training-guides'
17:40:07 <matjazp> I just tried a fresh clone of the repo and got the errorabout pip beeing too old
17:41:11 <matjazp> oh, and I'm using the latest brew'd python 2.x
17:41:46 <matjazp> and in the summary ERROR:   upstream-slides: could not install deps
17:41:51 <matjazp> something like that?
17:43:48 <bgmccollum> im rebuilding to see
17:44:08 <matjazp> does it install all the dependencies ok?
17:45:03 <cloudtrainme> I've seen complaints about docutils module not loaded
17:46:42 <bgmccollum> this is what i get running from a `git reset --hard` environment -- http://paste.openstack.org/show/473042/
17:46:53 <matjazp> it should load openstackdocs theme automatically
17:47:45 <bgmccollum> `openstackdocstheme` is not getting installed from what i can tell
17:48:43 <matjazp> this is a fresh clone of the repo on my comp http://paste.openstack.org/show/473055/
17:49:42 <matjazp> on os x, with Python 2.7.9 and pip 7.1.2
17:50:03 <matjazp> this is what it should look like
17:50:40 <matjazp> I just cloned a repo and run tox -e upstream-slides
17:51:17 <cloudtrainme> I'm on Python 2.7.6rc1 and pip 7.1.2
17:51:28 <cloudtrainme> going to upgrade Python and see what I get.
17:51:43 <bgmccollum> im on python 2.7.10 pip 7.1.2
17:51:53 <matjazp> it shouldn't matter
17:52:03 <bgmccollum> my upstream-slides venv doesn't have `openstackdocstheme` installed
17:52:46 <bgmccollum> that was recently added for the new landing page, yes?
17:52:58 <matjazp> if you look at the conf.py, it should load it automatically
17:53:14 <matjazp> html_theme_path = [openstackdocstheme.get_html_theme_path()]
17:53:42 <matjazp> oh.. do you have an old repo content?
17:53:55 <matjazp> just pull the latest stuff
17:53:58 <bgmccollum> is that something that needs to be install system wide, out-of-band of the venv requirements?
17:54:13 <bgmccollum> im in master, up to date
17:54:22 <matjazp> no, it is mentioned in the test-requirements.txt
17:54:47 <matjazp> so it get's loaded when you start tox
17:55:01 <bgmccollum> pip freeze for the tox env doesn't show it installed though
17:55:29 <matjazp> but if you have old tox env, maybe it is better to just recursively delete .tox folder
17:55:37 <matjazp> bgmccollum: that's it
17:55:44 <matjazp> recreate env
17:55:59 <matjazp> so that it loads all required stuff
17:56:27 <bgmccollum> i git reset --hard, git pull latest, basically nuked everything and its still not getting installed
17:56:44 <matjazp> but .tox remains
17:56:59 <matjazp> it is in git ignore
17:57:24 <matjazp> did you delete .tox folder?
17:57:47 <bgmccollum> i did...but let me try one more time
17:58:08 <matjazp> just clone again and start on the fresh copy
17:58:13 <matjazp> huh..
17:58:22 <matjazp> time's almost up
17:58:46 <cloudtrainme> matjazp: sorry to derail the meeting...I know we're out of time.
17:59:00 <matjazp> cloudtrainme: no problems, we were done anyway
17:59:10 <matjazp> ok, see you guys next week
17:59:23 <cloudtrainme> okay, we will reach out if we can't get this to work
17:59:25 <matjazp> ping me if you still have issues with the environment
17:59:26 <bgmccollum> thanks matjazp, we'll work though this
17:59:36 <cloudtrainme> thanks.  bye.
17:59:39 <matjazp> bye
17:59:43 <matjazp> #endmeeting