17:00:26 <matjazp> #startmeeting training-guides
17:00:28 <openstack> Meeting started Mon Aug 15 17:00:26 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:31 <openstack> The meeting name has been set to 'training_guides'
17:00:35 <matjazp> anyone here for the Training guides meeting?
17:01:11 <mrmartin> o/
17:01:23 <matjazp> hi Marton
17:01:31 <ildikov> o/
17:01:36 <mrmartin> hi
17:01:48 <matjazp> hi Ildiko
17:01:59 <ildikov> I have another one in parallel with this, but trying to convince folks to facilitate and I'll read later :)
17:02:09 <mrmartin> do we have an agenda?
17:02:11 <ildikov> hi :)
17:02:13 <matjazp> ildikov: ok
17:02:19 <matjazp> mrmartin: yes
17:02:24 <matjazp> #link https://etherpad.openstack.org/p/training-guides-meeting-agenda
17:03:02 <matjazp> besides usual stuff, I think we shoud focus on Upstream training
17:03:09 <matjazp> #topic Upstream training
17:03:26 <matjazp> #link https://etherpad.openstack.org/p/upstream-university-improvements
17:03:41 <ildikov> Thanks, I was just about to copy it in :)
17:03:55 <ildikov> There are plans for both content and tooling
17:04:12 <mrmartin> let's focus on content first
17:04:13 <ildikov> I think content is more relevant for this meeting, but if anyone wants to help out with tooling that would also be great
17:05:29 <matjazp> content: we should reuse as much as we can
17:05:39 <mrmartin> so we like to rebuild the content for the training, as the existing one is great, but have some limitations
17:05:59 <mrmartin> and as I understand also the format will change a bit.
17:06:04 <matjazp> sure, but we need to get some more contributors
17:07:27 <mrmartin> I'll ask Mark whether he can join this meeting or not, he also offered some help in Budapest and Austin
17:08:16 <matjazp> mrmartin: ok.. If we don't get some more hands on this, I'm afraid that the bigger restructuring will be too much for us
17:09:00 <mrmartin> yeah, I have the same feelings, so I suggest to do a bit more promotion for this effort as a no.1 step.
17:09:48 <kmARC> (sorry guys, I'm here too o/ )
17:09:50 <matjazp> ok. mails on the MLs, personal contacts, anyhing else?
17:09:52 <mrmartin> cool
17:10:06 <ildikov> matjazp: there are a few names on the etherpad, we should get them help out
17:10:23 <ildikov> kmARC: hi :)
17:10:38 <matjazp> ildikov: yes, but if you look at the tasks for this, it isquite a lot of work
17:10:45 <matjazp> kmARC: hi
17:11:11 <ildikov> matjazp: I think the final goal should be to revitalise the training, but do it step-by-step, so reuse and change the current content, where we can
17:11:34 <ildikov> matjazp: I agree, it' s alot of work
17:11:39 <matjazp> ildikov: exactly. Maybe we should identify the biggest pain points
17:11:52 <mrmartin> and also would be great to do a timing / schedule based on the new format
17:11:59 <matjazp> ildikov: I'm afraid we can't do them all in 2 months
17:12:02 <ildikov> matjazp: with mrmartin we were also thinking about doing a content sprint, a remote one if we can get people
17:12:42 <matjazp> ildikov: that could help
17:12:53 <mrmartin> yeah, and we are working on backing the training with some cloud instances, se we need to do the proper tooling for that also.
17:13:44 <matjazp> so I guess we should prioritise tasks
17:13:56 <ildikov> I hope kmARC can help out with this part ^^ :)
17:14:04 <mrmartin> I can imagine it will be a transition that won't be 100% ready for Barcelona.
17:14:15 <mrmartin> But we can setup the new foundations.
17:14:29 <matjazp> mrmartin: there were some offers at the user-committee ML for the hackatons, maybe we could "reuse" those
17:14:46 <ildikov> mrmartin: yeap, that's why we would need to go step-by-step, to still have every bit covered we would like to use on the training
17:15:13 <kmARC> so I'm happy to prticipate in any task that makes the slide deck better :)
17:15:23 <ildikov> matjazp: offers regarding tooling or?
17:15:36 <matjazp> ildikov: VMs
17:15:49 <kmARC> Also IBM Zurich Research lab can provide VM's to run devstack in them, if wanted. Mike Perez told us we should contact Dreamhost about it
17:15:53 <matjazp> ildikov: for hackaton participants
17:16:09 <ildikov> matjazp: we can get access from DreamHost it seems, so VMs are fine, we need someone who sets them up properly
17:16:17 <ildikov> kmARC: ^^
17:16:31 <mrmartin> yeah, but we can work on this tooling, boot scripts, ansible anything.
17:16:56 <matjazp> ok, but up untill now, installing devstack was part of the training
17:17:22 <kmARC> and it was always a failure
17:17:34 <matjazp> already intalled VMs were more or less the plan B, if local install didn't work
17:17:35 <kmARC> so we agreed that we should preinstall somehow
17:17:55 <ildikov> matjazp: we still have the material and we can keep the current version and use if someone wants guidance still
17:18:15 <ildikov> matjazp: and focus on the content for collaboration for now and update the Devstack parts if we have time
17:18:30 <matjazp> ildikov: or use what Ian suggested: a separate task, before the training
17:18:57 <ildikov> matjazp: you mean as a prerequisite?
17:19:25 <matjazp> ildikov: yes, but use VMs as pla b
17:19:29 <matjazp> plan B
17:19:36 <kmARC> I disagree
17:20:11 <mrmartin> disagree with what?
17:20:22 <kmARC> sorry, but it was _every time_ so painful, that basically what they "LEARNED", is how to issue that two commands that starts setting up devstack, and then an hour of useless waiting because of unreachable git servers, broken internet connections, etc. etc.
17:20:33 <kmARC> I think the preset VMs should be plan A
17:20:58 <mrmartin> oh ok, the bad news, that we cannot provide images actually for the cloud, so it means that someone need to run the boot scripts
17:21:17 <kmARC> I have preset Virtualbox ova's
17:21:18 <matjazp> ok, we could switch plans: VMs as plan A, local devstack install as a optional install, BEFORE the main training begins
17:21:30 <kmARC> https://github.com/kmARC/openstack-training-virtual-environment
17:21:43 <kmARC> it creates an ova in like 30 minutes, devstack preinstalled.
17:22:09 <kmARC> we hand out the ovas, and in 3minutes everyone has a ready set up vm with GUI, editors, git, git-review, etc.
17:22:42 <kmARC> I did this script a couple months ago, as a PoC, if needed, during the week I'll provide some screenshots, etc.
17:22:44 <mrmartin> if they have a properly setup vbox with proper network settings
17:22:58 <kmARC> the ova configures the networks too
17:23:15 <kmARC> so it is literally just a virtualbox. And then it runs on windows, mac, etc.
17:23:39 <kmARC> as a prerequisite, we can tell the audience that when they come they should have virtualbox preinstalled
17:23:40 <mrmartin> ok, this was one thing. as I remember a lot of people had issues with keys and CLA
17:23:41 <mrmartin> :)
17:24:00 <kmARC> it's way more than anythng what we already had
17:24:03 <kmARC> way more
17:24:11 <matjazp> kmARC: in this case, we don't need cloud VMs
17:24:24 <kmARC> I don't think so either
17:24:53 <kmARC> Please, remember again: Everytime, almost the first day is gone, when 1/3 of people don't even have a dev environment set up yet
17:25:00 <matjazp> what are they using in hackatons?
17:25:03 <mrmartin> ok, but if we are doing that way, we need to add this setup into the pre-training tasks, and mentors need to check that everyone have everything well prepared.
17:25:19 <kmARC> nope, they just need to have virtualbox. that's all
17:25:22 <kmARC> nothing else.
17:25:35 <kmARC> everything else will be in the vm, configured by the ova
17:26:13 <kmARC> I'll come up with some screenies during the week (sorry for seeming to be offline so far, I'm in the middle of moving to new apartment, etc.)
17:26:53 <ildikov> can this script be adapted to run on cloud VMs?
17:27:17 <kmARC> yes
17:27:46 <kmARC> altho half of it wouldn't make much sense, because it also sets up a GUI with X11 and XFCE (configured to look like windows xp sort of)
17:28:01 <kmARC> https://github.com/kmARC/openstack-training-virtual-environment/blob/master/install-base.sh
17:28:02 <mrmartin> cool
17:28:06 <matjazp> this still installs everything from the internet?
17:28:11 <kmARC> https://github.com/kmARC/openstack-training-virtual-environment/blob/master/install-devstack.sh
17:28:41 <mrmartin> anyway I don't care who is using the local vm and the remote cloud until they have a working environment for the training
17:28:51 <kmARC> so what it does, it installs everything from the internet, and packages an ova file. Before the training, we build the ova file at home, with fast internet, and on the training we only hand over the prebuilt ova
17:29:05 <kmARC> matjazp: ^^
17:29:35 <matjazp> kmARC: aha, ok, so internet connection can be crappy at the venue
17:29:55 <kmARC> please read it again what I wrote. They don't need internet, they will have the prebuilt ova
17:30:06 <mrmartin> some guys have issues with compatible wifi cards in their notebooks
17:30:20 <matjazp> kmARC: sure they do, for the training itself, not for devstack
17:31:07 <kmARC> ah okay. Yeah, but for browsing, internet is fine. Downloading gigs of data is not. That's why upstream training always sucked, because we demanded them to still download it... :-)
17:31:13 <mrmartin> ok, but it means, we can even hands on copies on usb drives for people who failed to install.
17:31:49 <kmARC> so what's the better, having different setups or just give out the ovas to EVERYONE so they have a standardized env
17:32:00 <matjazp> standardized
17:32:03 <kmARC> exactly
17:32:11 <matjazp> its so much esier on all the traineirs
17:33:09 <ildikov> nice :)
17:33:12 <ildikov> my only question is whether we still need/want the cloud VMs?
17:33:14 <mrmartin> what are the requirements for this ova?
17:33:17 <mrmartin> disk space, memory, etc?
17:33:37 <ildikov> as I need to sync up with people based on how we plan to organize the training
17:33:50 <kmARC> the only caveat what I could see two months ago is that devstack removed "rejoin-stack.sh" which means, that after reboot they need to do a "stack.sh" which tries to update the git repos, but at least doesn't download EVERYTHING again
17:33:54 <matjazp> mrmartin: there will ALWAYS be someone where this won't work, they can switch to cloud VMs
17:34:11 <ildikov> maybe it's still fine as a backup, I don't know whether everyone's laptop is fine for running a Devstack VM on it
17:34:15 <kmARC> requirements are here: https://github.com/kmARC/openstack-training-virtual-environment/blob/master/Vagrantfile
17:34:26 <kmARC> 2 vcpus, 4G RAM for the VM
17:34:33 <mrmartin> disk space?
17:34:36 <mrmartin> 10G?
17:34:37 <kmARC> so basically on a recent machine it should work
17:34:45 <ildikov> kmARC: rejoin-stack.sh never really worked
17:35:00 <kmARC> oh yes, regarding disk space the base system is around 800M, and devstack is another 2G
17:35:47 <mrmartin> would we like to keep the vm option for those who don't have a proper computer?
17:36:08 <matjazp> ok, so to summarize: we prefer local standard precreated VMs, cloud VMs as a backup
17:36:32 <kmARC> sure
17:36:43 <mrmartin> great
17:37:00 <matjazp> #info we prefer local standard precreated VMs, cloud VMs as a backup
17:37:17 <ildikov> ok, then we will keep the offer as an option and let people know they have options to choose from
17:37:25 <matjazp> who was talking about donating some cloud VMs?
17:37:32 <kmARC> me
17:37:33 <mrmartin> Dreamhost
17:37:37 <mrmartin> and IBM Zurich
17:37:46 <matjazp> excelent
17:37:48 <ildikov> matjazp: I talked to DreamHost last week
17:37:52 <mrmartin> ildikov do we know about anyone else?
17:38:07 <ildikov> matjazp: and we have kmARC from IBM
17:38:15 <matjazp> so waht are we talking about? max 20 VMs?
17:38:23 <ildikov> mrmartin: you mean provider who would offer access?
17:38:27 <mrmartin> yeap
17:38:41 <ildikov> mrmartin: not for this upstream training
17:38:52 <mrmartin> ok, no problem, they will join later
17:39:28 <ildikov> matjazp: I didn't get a maximum number, will double check it later
17:39:31 <matjazp> ildikov: Dreamhost offered for the next training, not this in Barcelona?
17:39:48 <mrmartin> for this one
17:39:50 <ildikov> mrmartin: but if we want to keep it as a backup option then I'll not sweat much on it now
17:40:01 <ildikov> matjazp: for Barcelona
17:40:21 <mrmartin> let's see how can we adapt kmARC's vagrant there
17:40:23 <matjazp> ildikov: ok, I'll pust an action for you
17:40:49 <matjazp> #action ildikov checks at Dreamhost for VMs for Barcelona
17:41:43 <matjazp> #action all: check https://github.com/kmARC/openstack-training-virtual-environment if it is ok for our purpose
17:42:01 <matjazp> that ok with all?
17:42:23 <mrmartin> as I remember for previous events, people with cloud access have issues not just with launching the instance, but some pre-configuration steps were also required there, like key upload, security group settings.
17:42:29 <kmARC> matjazp ^^ gimme another three days, check it out on saturday, I'll shape it up until then
17:42:57 <matjazp> kmARC: sure, you want rollback for the action item?
17:44:19 <kmARC> no it's fine. I think all of us who is concerned now knows :)
17:44:24 <matjazp> ok
17:44:25 <ildikov> mrmartin: yeap, there are a few steps, DreamHost can add instructions it's another question how much we can get people to do that prior to the training...
17:44:51 <matjazp> ildikov: we could automate it
17:44:51 <mrmartin> requires a guide and some script
17:45:27 <mrmartin> it is usually straightforward with OSX and Linux machines, but we need to care the Windows users too
17:45:36 <mrmartin> key handling is not so trivial there
17:45:56 <clarkb> also dreamhost won't boot ova's iirc they need raw images
17:46:10 <matjazp> mrmartin: maybe we should tell Windws users to use cloud VMs
17:46:13 <ildikov> matjazp: sure
17:46:14 <kmARC> clarkb sure, but I have the install scriot, which is a bash script
17:46:25 <kmARC> ahh
17:46:25 <mrmartin> even they are using cloud vm-s they need to ssh in somehow
17:46:30 <kmARC> noone needs to use the cloud vms
17:46:35 <kmARC> because in the ova, there will be linux
17:46:50 <kmARC> and from the vbox machine they can ssh anywhere
17:46:56 <ildikov> mrmartin: yeap, it's ssh with keys
17:47:02 <kmARC> and we can put the ~/.ssh in a shared folder with the host
17:47:04 <matjazp> mrmartin: yes, but if they install git, they have ssh there too
17:47:11 <kmARC> so even if they delete their vm's the keys will stay
17:48:24 <mrmartin> we need to find someone who have windows and can test / write this guide
17:48:35 <kmARC> you mean what guide?
17:49:00 <matjazp> how many were there with Win laptops?
17:49:19 <kmARC> a lot... -.-
17:49:26 <mrmartin> enterprise users mostly
17:49:38 <ildikov> we have 11 minutes left from today
17:49:40 <matjazp> mrmartin: what kmARC is saying, that even Win users will use Linux in their local VMs
17:49:45 <ildikov> I meeting the meeting time :)
17:50:03 <matjazp> ildikov: true
17:50:08 <matjazp> lets move on to the conetnt
17:50:08 <ildikov> so I think we could figure out the tooling details offline
17:50:15 <ildikov> and spend some time with how to shape the content
17:50:32 <mrmartin> do we have 10minutes left?
17:50:38 <kmARC> yes
17:50:42 <matjazp> we should match the existing content to the bullets in the etherpad
17:51:04 <matjazp> there are some pointers there already
17:51:27 <matjazp> maybe we can put links to the existing slides/pages
17:51:42 <matjazp> so we can see what needs to be developed from scratch
17:52:23 <matjazp> I also suggest to at least now we use the same process/tools as we do now, we can massmigrate slides to something else later
17:52:24 <mrmartin> and would be great assign timing for those
17:52:43 <kmARC> matjazp: my original idea regarding this was that we should have _ONE_ and only pdf with proper sections, chapters etc. so that they can download it and always jump to the page what's being discussed. It was a PITA when they needed to go to like 6/7 different presentations
17:53:19 <matjazp> big chunk of work are also excercises
17:53:35 <matjazp> kmARC: we have the landing page already?
17:53:51 <matjazp> kmARC: with links to everything
17:54:13 <matjazp> http://docs.openstack.org/upstream-training/upstream-details.html
17:54:26 <matjazp> we can update this
17:54:29 <ildikov> matjazp: we can think about having more exercises rather than lecture for the hands-on parts
17:54:55 <ildikov> matjazp: so less burden with writing up material
17:55:19 <kmARC> yeah, unfortunately this is a broken concept. I mean, the links. Everythime we start discussing some topics, and after like 5 minutes half of the audience will ust ask which exactly is the pdf being on the beamer
17:55:21 <matjazp> ildikov: I agree, and we can put those exercises in the landing page, as is the case for installing git
17:56:30 <ildikov> matjazp: yeap
17:57:11 <matjazp> kmARC: so what are you suggesting is that we switch back from slides + landing pages as glue to the Docs format as other guides?
17:57:44 <mrmartin> can we finish that until Barcelona?
17:57:55 <matjazp> mrmartin: I dont think so
17:58:01 <kmARC> I am open to whatever solution where we can only say: "Guys we are currently on page 32 in the slides"
17:58:05 <ildikov> matjazp: kmARC: I think we should check what's the minimum content we need to include for each part and try to add that and remove links
17:58:14 <mrmartin> if we like to rebuild the doc publication tooling it means some interaction with the infra team
17:58:19 <kmARC> ildikov: +1 agree
17:58:20 <matjazp> kmARC: we can make a single slide deck
17:58:29 <kmARC> yes, I think that's the most sensible
17:58:31 <ildikov> we can add exercises to those parts as well so we can teach people how to find the info after the training
17:58:33 <kmARC> keep it simple
17:59:31 <matjazp> hmm.. time's almost up
17:59:52 <mrmartin> ildikov what is the target date for the sprint?
17:59:52 <matjazp> lets discuss this content format over Docs ML, ok?
17:59:56 <ildikov> :(
18:00:15 <ildikov> I would suggest to take a look at the etherpad topics and add suggestions on what we can reuse there and how much time it would require to change
18:00:25 <matjazp> ildikov: agree
18:00:34 <ildikov> mrmartin: I could do first/second week of September
18:00:36 <matjazp> ok times up, se you all on ML
18:00:44 <mrmartin> ok
18:00:48 <matjazp> bye all, see you later
18:00:50 <kmARC> thanks guys. bye
18:00:53 <matjazp> #endmeeting