17:00:35 <matjazp> #startmeeting training-guides
17:00:39 <openstack> Meeting started Mon Sep 12 17:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:39 <matjazp> hey all
17:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:43 <openstack> The meeting name has been set to 'training_guides'
17:00:51 <matjazp> roll call
17:02:57 <ianychoi> hi, matjazp !
17:03:00 <matjazp> anyone here for the meeting?
17:03:18 <matjazp> hey ianychoi
17:03:33 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
17:03:41 <diablo_rojo_phon> Hello
17:03:52 <matjazp> hey diablo_rojo_phon
17:04:16 <ianychoi> Hello, diablo_rojo_phon !
17:04:28 <matjazp> #topic Review of action items from the previous meeting
17:04:38 <matjazp> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-09-05-17.00.html
17:05:39 <matjazp> aha, ianychoi has a patch for this in queue, if I'm not mistaken
17:06:03 <matjazp> so nothing to review here, we'll do patches later
17:06:17 <matjazp> #topic Upstream training
17:06:19 <ianychoi> Yep, I have just seen your +1 review, thanks matjazp !
17:06:36 <matjazp> #link https://etherpad.openstack.org/p/upstream-university-improvements
17:06:52 <matjazp> #info Upstream training virtual sprint September 12-13 and 16: https://wiki.openstack.org/wiki/VirtualSprints#Upstream_training_Sprint
17:07:12 <matjazp> Review queue:
17:07:20 <matjazp> DONE: Remove rejoin-stack.sh from the Devstack slides: https://review.openstack.org/#/c/366316/
17:07:40 <matjazp> still need eyes on:
17:07:44 <matjazp> Improvements to the contribution process section: https://review.openstack.org/#/c/366255/
17:07:46 <diablo_rojo_phon> Thank you!
17:08:03 <matjazp> #link Improvements to the contribution process section: https://review.openstack.org/#/c/366255/
17:08:13 <matjazp> #link New introduction block: https://review.openstack.org/#/c/366893/
17:08:26 <matjazp> #link Add #openstack-101 to meetbot channels: https://review.openstack.org/#/c/367005/
17:09:01 <matjazp> did I miss something?
17:09:15 <matjazp> oh, right, gerrit workflow reorder
17:09:33 <matjazp> diablo_rojo_phon: I think the order is fine as is
17:09:49 <matjazp> diablo_rojo_phon: why do you think it should be different?
17:09:58 <matjazp> #link https://review.openstack.org/#/c/368889/
17:11:19 <diablo_rojo_phon> It's different than the normal workflow.
17:11:26 <diablo_rojo_phon> Or mine anyway.
17:11:28 <matjazp> ianychoi: can you look at it and comment? Do you work differently?
17:12:00 <matjazp> diablo_rojo_phon: true, it could be different.. but as it is the same as  http://docs.openstack.org/infra/manual/developers.html#development-workflow, I think we should leave it? what do you think?
17:12:10 <diablo_rojo_phon> I do work differently. Not sure why you'd ask people to review before pushing the patch.
17:12:28 <matjazp> not review, just setup
17:12:29 <diablo_rojo_phon> But if it's just me I can abandon it.
17:12:56 <matjazp> diablo_rojo_phon: no, lets just leave it and we can gather some more comments
17:13:15 <diablo_rojo_phon> Okay sounds good.
17:14:23 <matjazp> revamping module 19 is nearly finished, right?
17:14:27 <ianychoi> IMO it doesn't matter
17:14:48 <ianychoi> Executing "git review -s" just before "git commit" would be fine
17:15:42 <diablo_rojo_phon> It's in progress. I just need to add exercises.
17:16:14 <matjazp> ianychoi: yes it would. I see git review -s as a part of the git repo clone process.. so the inner loop is different (modify, add, commit, review)
17:16:41 <matjazp> diablo_rojo_phon: do you think you can add exercises in a separate patch?
17:17:27 <matjazp> does it make sense?
17:17:50 <matjazp> I'm telling this because I prefer smaller patches
17:18:20 <diablo_rojo_phon> Yeah it will be a separate patch.
17:18:24 <ianychoi> diablo_rojo_phon, I would suggest in module 14 to add 1) run tox instead of unit tests 2) git review before "invite reviewers" 3) leaving a comment before exercise..
17:18:26 <matjazp> but it can go in one if you prefer
17:18:51 <matjazp> ianychoi: don't forget to comment in gerrit ;)
17:19:06 <ianychoi> matjazp, sure :)
17:19:35 <ianychoi> diablo_rojo_phon, I can do it if you agree with me, of course
17:21:32 <matjazp> so the focus of current virtual sprint is still contribution and intro, right?
17:23:56 <matjazp> btw: we didn't use RST "code-block" for console commands in upstream training, but I think it is better that we switch to it. For larger code blocks we would need to fix font size
17:25:47 <matjazp> what do you think?
17:26:04 <ianychoi> I agree with matjazp
17:27:41 <matjazp> ok, moving on
17:27:45 <ianychoi> Hmm.. okay
17:28:18 <matjazp> #info we use ".. code-block:: console" for console commands in slides
17:28:58 <matjazp> I have another pain point to discuss
17:29:14 <matjazp> Trainees can loose track of the slide deck that the presenter is showing on screen (when using full screen view, URL is usually not visible)
17:29:23 <matjazp> We could additionally generate one slide deck with all the slides (in PDF format?), so trainees can just sync with slide numbers?
17:30:01 <ianychoi> Hmm.. recently I am doing some research on using rst2pdf
17:30:24 <matjazp> ianychoi: yes, that was the trigger that reminded me of this issue
17:30:26 <ianychoi> I am not currently sure whether PDF slides are fine with rst2pdf.
17:30:42 <ianychoi> #link https://review.openstack.org/#/c/364477/
17:31:07 <ianychoi> I have proposed it as the next goal :)
17:31:21 <matjazp> I see
17:31:57 <matjazp> hmm, we could easily generate a single all-slides deck
17:32:37 <matjazp> or, as an alternative, presenter could deliberately leave URL bar visible
17:34:22 <matjazp> ok, for this sprint, we still concentrate on common items and code contribution
17:34:33 <matjazp> #link https://etherpad.openstack.org/p/upstream-uni-common-items
17:34:44 <matjazp> #link https://etherpad.openstack.org/p/upstream-uni-code-contribution
17:35:10 <matjazp> just mark what are you working on so that we dont duplicate effort
17:35:38 <matjazp> is there anything else that needs discuccing here?
17:36:13 <matjazp> discuccing=discussing
17:36:17 <diablo_rojo_phon> Sorry was in another meeting. I can make the Gerrit changes here shortly.
17:36:48 <matjazp> diablo_rojo_phon: np. you need anything else to discuss for upstream training?
17:37:05 <ianychoi> diablo_rojo_phon, okay I see
17:39:00 <matjazp> move on to aob?
17:39:08 <diablo_rojo_phon> No I don't think so. If anyone had ideas they'd like to see for code contribution exercises let me know :)
17:39:18 <ianychoi> Actually today and tomorrow are sprints day.
17:39:43 <ianychoi> So I encourage us to use #openstack-sprint channel for today and tomorrow :)
17:40:51 <matjazp> ok
17:40:58 <matjazp> #topic any other business
17:41:13 <matjazp> anything left to discuss?
17:41:40 <ianychoi> I have one for discussion: What would be a good name for openstack-dev/sandbox launchpad ?
17:42:12 <matjazp> lauchpad? you mean lounchpad project?
17:42:17 <ianychoi> The name should be like https://launchpad.net/openstack-dev-sandbox ?
17:42:47 <matjazp> its ok
17:42:57 <matjazp> it should be as close to the repo name as possible
17:43:35 <matjazp> so +1 for this
17:43:45 <ianychoi> Okay I see. Then I will try to make and correlate this launchpad with openstack-dev/sandbox repository :)
17:44:24 <matjazp> ok
17:45:18 <matjazp> anything else? or do we wrap it up?
17:45:42 <ianychoi> For me, that's all
17:46:09 <matjazp> #action ianychoi create openstack-dev/sandbox launchpad project
17:46:27 <matjazp> diablo_rojo_phon: you?
17:47:00 <ianychoi> #action ianychoi s/openstack-dev\/sandbox/openstack-dev/sandbox
17:47:08 <ianychoi> #action ianychoi s/openstack-dev\/sandbox/openstack-dev-sandbox
17:47:55 <matjazp> ianychoi: you can use #undo, for last item
17:48:12 <matjazp> if you mistype it
17:48:25 <ianychoi> matjazp, Aha.. I forgot it, thanks!
17:48:35 <matjazp> more action items for you :)
17:48:53 <matjazp> ok, let's wrap this
17:48:56 <ianychoi> Oops....... kkk
17:49:05 <ianychoi> yep thank you, matjazp and diablo_rojo_phon !
17:49:12 <matjazp> thanks for attending
17:49:21 <matjazp> and thanks for contributing!
17:49:28 <matjazp> see you next week
17:49:37 <matjazp> bye ianychoi diablo_rojo_phon
17:49:50 <matjazp> #endmeeting