17:00:57 <matjazp> #startmeeting training-guides
17:00:58 <openstack> Meeting started Mon Sep 19 17:00:57 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:02 <openstack> The meeting name has been set to 'training_guides'
17:01:07 <matjazp> hey all
17:01:09 <matjazp> roll call
17:01:16 <ildikov> o/
17:01:25 <ianychoi> Hello matjazp and ildikov !
17:01:57 <matjazp> hi ildikov ianychoi
17:02:02 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
17:02:40 <matjazp> #topic Review of action items from the previous meeting
17:02:47 <diablo_rojo> Hello :)
17:02:53 <matjazp> hey diablo_rojo
17:02:56 <ianychoi> Hello diablo_rojo !
17:02:59 <matjazp> http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-09-12-17.00.html
17:03:09 <diablo_rojo> On my laptop for now, but I will be switching to my phone at some point.
17:03:27 <ianychoi> Yes.. oops my actions... for launchpad...
17:03:30 <matjazp> ianychoi: did you managed to create lounchpad sandbox project?
17:04:20 <matjazp> np
17:04:30 <ianychoi> I managed to create it but there is also launchpad sandbox
17:04:33 <ianychoi> #link https://qastaging.launchpad.net/
17:04:35 <matjazp> #action ianychoi creates openstack-dev-sandbox launchpad project
17:04:56 <ianychoi> It is copied from launchpad as daily or weekly (I forgot exactly but anyway)
17:05:31 <ianychoi> So I am not currently sure whether it is good to create launchpad sandbox, since there is already qastaging.launchpad.net
17:05:45 <matjazp> #undo
17:05:46 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f23bd8a2850>
17:05:54 <matjazp> what is this qastaging?
17:05:56 <ianychoi> I think the purpose is different... but I would like to listen to opinions from you :)
17:06:32 <ildikov> I think it would be better to have one for OpenStack
17:06:36 <matjazp> +1
17:06:39 <diablo_rojo> Didn't know where was qastaging.launchpad, but I would think that is for something different than our purposes.
17:06:42 <ildikov> so that people are completely lost in the void
17:06:49 <matjazp> as similar to other official projects as possible
17:07:04 <ianychoi> I think the main purpose of qastaging.launchpad.net is to test launchpad itself.
17:07:14 <matjazp> I'll just add the action again
17:07:24 <matjazp> #action ianychoi creates openstack-dev-sandbox launchpad project
17:07:44 <ianychoi> So all agree that creating openstack-dev-sandbox is helpful?
17:07:49 <matjazp> yes
17:08:21 <matjazp> #topic Upstream training
17:08:25 <ianychoi> ildikov and diablo_rojo , thoughts?
17:08:43 <matjazp> oh... I was too quick :(
17:08:49 <ianychoi> That's fine :)
17:08:58 <ianychoi> And...
17:09:00 <ianychoi> #link https://review.openstack.org/#/c/367005/
17:09:13 <diablo_rojo> I can get all the comments on my patches addressed today
17:09:20 <matjazp> #link https://etherpad.openstack.org/p/upstream-university-improvements
17:09:34 <matjazp> #info Upstream training virtual sprint finished
17:09:37 <ianychoi> Actually AFAIK Marton Kiss contributes openstack-infra a lot and he will be one of leaders in upcoming upstream training.
17:09:56 <ianychoi> So, ildikov, could you write your comment on https://review.openstack.org/#/c/367005/ ?
17:10:28 <ildikov> ianychoi: yeap, on my TODO list to catch up on reviewing
17:10:34 <ianychoi> Then I will discuss with openstack-infra guys for this patch to be merged :)
17:10:37 <ildikov> ianychoi: I stopped with the Big tent one
17:11:16 <matjazp> we can go and take a look at the review queue
17:11:33 <ianychoi> Okay... thanks all. Yep Let's focus on upstream training then..
17:11:38 <ildikov> ianychoi: I actually thought that after the first +2 it will be an easy to get landed patch :)
17:11:43 <matjazp> #link https://review.openstack.org/#/q/project:openstack/training-guides+status:open,n,z
17:12:06 <matjazp> ildikov: I guess this is low priority
17:12:14 <ianychoi> ildikov, okay thanks for sharing your thoughts!
17:12:26 <ildikov> matjazp: which one do you mean the ircbot?
17:12:29 <matjazp> Patch #367005
17:12:36 <matjazp> for infra guys
17:13:08 <matjazp> we just need to merge this before training ;)
17:13:51 <ianychoi> AFAIK yolanda is one of best guys in infra but they are not familiar with detail contexts
17:14:21 <ildikov> matjazp: yeap, we can jump on infra and ask some time before the training, it should be good to go I think
17:14:36 <ianychoi> This is why I invited Marton as a reviewer. Infra guys usually merge with more input into comments.
17:14:37 <ildikov> I would like to get more eyes and hands on the content for now :)
17:14:59 <matjazp> ildikov: your patch is getting quite big
17:15:01 <ianychoi> I think ildikov 's comments would facilitate the merge of #367005
17:15:25 <matjazp> talking about https://review.openstack.org/#/c/366893/
17:15:36 <ianychoi> Yes quite big... but it can be one 'big' thought.. :)
17:16:36 <ianychoi> I initially proposed to divide it into three separated patches
17:16:46 <ildikov> matjazp: that's the end of it, I will add presenter notes in a follow up one
17:17:02 <ianychoi> For #366893, I am waiting for presenter notes :)
17:17:03 <matjazp> ildikov: yes I think we can merge it
17:17:16 <matjazp> ildikov: we can update and polish it later
17:17:27 <matjazp> ildikov: it is easier to review small patches
17:17:32 <ildikov> ianychoi: you mean we cannot merge the patch without having the follow up up and polished as well?
17:18:06 <matjazp> ildikov: I would prefer to merge it ASAP and polish it later
17:18:17 <ianychoi> ildikov, according to your comments, I understood that you will add 'notes' on this patch.
17:18:19 <ildikov> matjazp: yeap, but merge conflicts and rebasing is very inconvenient, and with the slide format it can still be handled from review perspective I think
17:18:25 <ildikov> matjazp: +1
17:18:42 <matjazp> ildikov: true, hence we need to make smaller patches
17:18:46 <ildikov> ianychoi: no, I will do that as a follow up patch, sorry if i wasn't clear :(
17:19:11 <ildikov> matjazp: for the existing material update that will be easier as I don't need to update the index.rst file
17:19:14 <ianychoi> Aha.. ildikov I see. So I waited for your another patchset..
17:19:16 <matjazp> so do we all agree? merge as soon it is in usable form and polish it later?
17:19:44 <diablo_rojo_phon> Yes
17:19:44 <ianychoi> For 366893, yep I will +2 now
17:20:00 <matjazp> that will enable us with a quicker turnaround and minimise rebasing
17:20:11 <matjazp> rebasing big patches sucks
17:20:35 <ianychoi> Let's check.. I pressed 'rebase' button
17:21:55 <ildikov> matjazp: +1, I didn't make a patch chain for exactly that reason
17:22:21 <ildikov> ianychoi: for the intro rebasing should be working, as it's completely new content
17:22:33 <ianychoi> Yep.. we may need more tight communication :)
17:23:31 <matjazp> ok, I'll +2 it when rebasing is finished, so we can merge and ildikov  will polish the text with later patches, ok?
17:23:40 <matjazp> moving on to next review..
17:23:43 <ianychoi> Yep
17:24:22 <ianychoi> #link https://review.openstack.org/#/c/370262/
17:24:33 <ildikov> matjazp: great, thanks!
17:24:59 <ianychoi> matjazp, your opinion on this commit?
17:25:27 <ianychoi> I have written several comments and it seems that alls were well addressed
17:25:38 <ildikov> ianychoi: matjazp I started to review it, I would order/articulate things on a few slides in a bit different way, but haven't checked the latest version fully yet
17:26:00 <matjazp> ildikov: same here, I'm looking at it now
17:26:19 <ianychoi> If you have time, ildikov, could you see briefly?
17:26:32 <matjazp> changes are not scattered around, but it is a large reworking of this chapter
17:26:40 <ianychoi> For introduction, ildikov 's opinion is important :)
17:27:22 <ildikov> I will try to finish my comments today before jumping on the plane
17:27:28 <ianychoi> I agree.. oh, image file name is the format I previously suggested, which is now wrong: 04-01-big-tent-and-core-services.png -> big-tent-and-core-services.png
17:27:52 <ildikov> ianychoi: I also got in trouble with numbering the sections
17:27:56 <ianychoi> Yep.. then, let's have more time for review #370262
17:28:05 <ildikov> ianychoi: we might consider removing numbering completely at some point
17:28:44 <matjazp> yup I agree, lets do one more round of reviews
17:28:47 <ianychoi> ildikov, what I am currently saying is for image file names, not section numbers.. but I agree that we need to re-arrange section numbers.
17:29:37 <ianychoi> Currently, my general suggestion is to use 01~10 for introduction, 11~20 for workflows and 21~30 for contribution process
17:29:51 * matjazp this is WIP https://review.openstack.org/#/c/370391/
17:30:56 <ianychoi> diablo_rojo, what is your deliverable plan for this patch? Might it would take too long for completion..?
17:31:21 <matjazp> this patch still has -1 https://review.openstack.org/#/c/368889/
17:31:44 <ildikov> I didn't add too many things to diablo_rojo_phon's patches
17:31:44 <matjazp> same as this https://review.openstack.org/#/c/366255/
17:31:59 <ildikov> overall they looked good to me, I just like nitpicking... :)
17:32:07 <diablo_rojo_phon> The comments that are out there  right now will get addressed today.
17:32:33 <diablo_rojo_phon> I see no reason why all of the ones I have out there right now couldn't get merged by Friday even.
17:32:44 <matjazp> ildikov: as a general rule, I would prefer to nitpick in later patches ;)
17:32:55 <diablo_rojo_phon> After those get merged, I will start a new patch to add exercises to module 19
17:33:28 <diablo_rojo_phon> I can message all of you when I get those patches up.
17:33:38 <matjazp> diablo_rojo_phon: excellent.. just please make one patch for each exercise, so we can review quickly
17:33:46 <diablo_rojo_phon> Can do.
17:33:59 <ianychoi> I see, thank you, diablo_rojo_phon
17:34:14 * matjazp likes overall progress :)
17:34:18 <ianychoi> And I would like to suggest such as hangout
17:34:26 <ianychoi> for kind explanation on two Etherpads
17:34:30 <diablo_rojo_phon> Feel free to go and make as many comments right now and when I come back from lunch I will address everything by the end of day.
17:34:30 <matjazp> we're on the roll here, nice work everyone
17:34:38 <ildikov> matjazp: I'm totally with you, I will do a better job with resist, when smth is really a nitpick
17:35:30 <ianychoi> Frankly speaking, now I am getting more busy as I18n role, but for me now it is difficult to submit a commit to upstream training because I am not fully familiar with two Etherpads..
17:35:31 <ildikov> things look good here, thanks everyone for all the work so far!!! :)
17:35:36 <ildikov> I plan to jump on the release cycle slides as a next step
17:35:52 <ianychoi> +1, ildikov :)
17:36:06 <ildikov> ianychoi: I can create a Doodle poll and we can do an alignment Hangout
17:36:50 <ianychoi> ildikov, nice :)
17:37:37 <ianychoi> matjazp, just FYI: +1 Jenkins for https://review.openstack.org/#/c/366893/
17:38:39 <ianychoi> And ildikov, could you ask current status on virtual environment to kmARC?
17:39:49 <ianychoi> #action ildikov will ask current status on virtual environment to kmARC
17:40:16 <ildikov> ianychoi: sure, will do
17:40:24 <ianychoi> ildikov, thank you!
17:40:29 <matjazp> ok https://review.openstack.org/#/c/366893/ is merging as we speak
17:40:48 <ildikov> I will also create the Doodle poll and we can have a quick chat
17:41:00 <ildikov> matjazp: what time zone are you in?
17:41:10 <ianychoi> #action ildikov will also create the Doodle poll and we can have a quick chat
17:41:37 <ildikov> I know the others mostly, soI thought to come up with exact proposals hoping for having a quick decision
17:42:18 <matjazp> ildikov: I'm in Slovenia, so if you're at home, same as you
17:43:42 <ildikov> matjazp: great, that sounds good
17:43:55 <ildikov> will do the Doodle poll right after the meeting then
17:44:20 <matjazp> ok, did we miss something for Upstream?
17:44:29 <matjazp> looking at agenda
17:45:06 <matjazp> did we discussed the use of ".. code-block:: console"  already?
17:45:33 <matjazp> oh.. we did
17:45:48 <matjazp> last meeting, so this is an old entry from last week
17:46:24 <matjazp> can we move on?
17:46:51 <ianychoi> Then... matjazp , will you attend to Barcelona upstream training?
17:47:15 <matjazp> #topic aob
17:47:43 <matjazp> ianychoi: I still don't know if I'll be there at all
17:47:57 <ianychoi> Because of my own business, I cannot go there for upstream training days on Barcelona..
17:47:58 <matjazp> ianychoi: It's always a last minute thing for me
17:48:06 <matjazp> ianychoi: too bad
17:48:18 <ianychoi> But I will stay just on Friday..
17:48:24 <ildikov> I asked for longer time slots for the training, so we should have 3 hours more
17:48:40 <ildikov> I will check this week whether the schedule got updated already or not
17:48:43 <ianychoi> So really hope to see all you on Friday... :)
17:48:59 <matjazp> ianychoi: so you'll be at the Summit, just not at the Upstream training?
17:49:13 <ildikov> It would also be great to find time during the Summit to plan a little bit for Boston
17:49:33 <ianychoi> matjazp, because of my own business, I will only stay on Friday..
17:49:44 <matjazp> ildikov: I agree
17:50:04 <ianychoi> I should lead I18n meetup :)
17:50:33 <matjazp> ianychoi: youl'll fly here just for one day?
17:50:44 <ianychoi> yep... sad news T.T
17:51:04 <ianychoi> and also happy news to see Barcelona :)
17:51:52 <ildikov> uh, that's much travel for that short time :(
17:51:59 <ildikov> but happy to see you there!
17:52:42 <ianychoi> Yeah~~ :)
17:55:12 <matjazp> that's it for this week?
17:55:19 <matjazp> can we wrap it up?
17:55:24 <ianychoi> +1
17:55:37 <ianychoi> Thank you very much for today meeting, matjazp ildikov and diablo_rojo_phon !
17:56:01 <diablo_rojo_phon> No problem :)
17:56:06 <matjazp> thanks all for your time and effort
17:56:12 <matjazp> see you next week
17:56:16 <matjazp> bye!
17:56:21 <ianychoi> Bye! :)
17:56:25 <diablo_rojo_phon> Bye!
17:56:50 <matjazp> #endmeeting