17:01:25 <matjazp> #startmeeting training-guides
17:01:26 <openstack> Meeting started Mon Sep 26 17:01:25 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:29 <openstack> The meeting name has been set to 'training_guides'
17:01:33 <matjazp> hi all
17:01:35 <ildikov> o/
17:01:37 <matjazp> roll call
17:01:42 <matjazp> hi ildikov
17:02:07 <ildikov> hi matjazp
17:03:46 <matjazp> anyone else
17:03:50 <matjazp> ?
17:03:57 <matjazp> ok, lets start
17:04:11 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
17:04:19 <diablo_rojo> Helo
17:04:19 <diablo_rojo> Hello
17:04:21 <matjazp> #topic Review of action items from the previous meeting
17:05:02 <matjazp> hey diablo_rojo
17:05:40 <matjazp> ianchoi is not here, so we'll skip his action items
17:05:54 <matjazp> #action ianychoi creates openstack-dev-sandbox launchpad project
17:06:11 <matjazp> ildikov: will ask current status on virtual environment to kmARC?
17:06:52 <matjazp> you guys did talk about virt env on Friday, right?
17:06:55 <ildikov> matjazp: yeap, we talked about it
17:07:21 <ildikov> I sent out a meeting minutes to the group, Mark is working on the env, he has memory issues with DevStack now
17:07:23 <matjazp> do we need to discuss something (I saw your report on mail)
17:07:39 <ildikov> 4Gbs do not seem to be enough
17:07:50 <matjazp> yup..
17:08:03 <matjazp> my experience with devstack is the same
17:08:09 <ildikov> if anyone has DevStack experience with Newton we can chat about it a bit, otherwise we can keep it as a reporting item
17:08:23 <ildikov> ah, I hoped it's just Mark's env :(
17:08:49 <matjazp> no, but it depends on the other components you bundle with install (Swift etc)
17:09:46 <matjazp> is it a problem for trainees? do they have laptops with 4 GB raM?
17:10:16 <matjazp> what was the status at the last upstream training? many onderpowerd laptops?
17:10:26 <matjazp> underpowerd
17:11:24 <matjazp> and another thing is that if you run it in virt box the performance is so bad that all you can run quickly on it is Cirros
17:11:37 <diablo_rojo> If the student has a vm with 4gb it will probably be an issue cause devstack is so memory greedy
17:11:52 <matjazp> diablo_rojo: yup, 4 GB laptop is a no go
17:12:27 <matjazp> diablo_rojo: we should put this info on the training pages ... 8 GB minimum?
17:13:08 <diablo_rojo> Yeah something like that.
17:13:16 <matjazp> plan b is still to use VMs in the  cloud
17:13:27 <diablo_rojo> I think it should go on that page in the things to do before the training session
17:13:37 <matjazp> for those that have porblems with HW
17:13:43 <matjazp> diablo_rojo: +1
17:14:26 <matjazp> ok, we can move to Upstream topic, ok?
17:14:35 <matjazp> #topic Upstream training
17:15:08 <matjazp> a lot of progress since last meeting :)
17:15:09 <ildikov> sorry, parallel meeting as usual
17:15:28 <ildikov> so yes, put the info on the page and we have DreamHost offering VMs for the training as a bacup
17:15:41 <ildikov> I will ask Mark to try to setup an enve there as well to test if he has a chance
17:15:52 <matjazp> review queue is almost empty. We just have this in it: https://review.openstack.org/#/c/370391/
17:15:55 <ildikov> matjazp: yeap, we're getting towards some progress
17:16:10 <ildikov> I added the current agenda to the main etherpad to show where we are
17:16:30 <ildikov> we are planning some additional modules on top of that, will list those later
17:16:36 <matjazp> #action ildikov asks Mark about testing Devstack in the cloud VMs
17:16:55 <matjazp> ildikov: great, nice work
17:17:26 <diablo_rojo> I will work on 370391 and should have it ready to go in the next day or two
17:17:50 <diablo_rojo> Question for everyone about that one
17:17:56 <matjazp> sure, just update it and we'll review it
17:18:01 <ildikov> matjazp: I added myself to the release cycle and also I will update the metrics/relevant actors one
17:18:07 <diablo_rojo> Do we want it to be the second to last module? So before the lego module?
17:18:22 <ildikov> I have a session about this topic on the conference, so I will do some prep for both that and the training
17:18:22 <diablo_rojo> Make it 20 instead of 21?
17:18:34 <ildikov> diablo_rojo: we will not have Lego this time
17:18:57 <ildikov> so what's missing from the agenda on the web page currently is the playing with the code parts
17:19:06 <ildikov> and in parallel docco and WGs things
17:19:12 <diablo_rojo> Right so the module I am adding about setting up and pushing a first patch should get moved to be before the lego module?
17:19:18 <diablo_rojo> ildikov ^^
17:19:32 <ildikov> so after teaching people how the generic contribution flow works we plan to teach them how to start with the code
17:20:11 <ildikov> diablo_rojo: I hate we have numbering on the files, so let's have the content and then we can decide on the agenda later
17:20:24 <ildikov> but overall before the lego module sounds good
17:21:28 <matjazp> if we don't have lego module this year, we can put this in a separate section
17:21:39 <matjazp> I wouldn't erase or archive it
17:21:54 <ildikov> matjazp: yeap, I added a questino to the etherpad already regarding how to archive it
17:22:14 <ildikov> by archiving I mean put it into a separate section but still keep it available
17:22:23 <ildikov> definitely do not erease it!
17:22:24 <diablo_rojo> ildikov, I agree. The numbers are going to keep changing so we should just get rid of them and decide the ordering of the slides.
17:22:47 <ildikov> diablo_rojo: yeap, my plan exactly :)
17:22:49 <diablo_rojo> matjazp, The lego stuff already is its own section, we can just move it to the end and then not cover it in Barcelona
17:23:44 <ildikov> diablo_rojo: I think a how to contribute block is there too already, so I would rename that section
17:23:47 <matjazp> one of the pain points from last training was also that slides were in a separate files - do we need to make one version with all slides in it?
17:23:56 <ildikov> diablo_rojo: but overall it's not difficult to do
17:24:22 <diablo_rojo> ildikov, not hard at all :)
17:24:25 <ildikov> matjazp: no, the last training was terrible because we did not prepare for it at all
17:24:33 <diablo_rojo> Lol
17:25:03 <matjazp> ildikov: :) no slide format can fix that ;)
17:25:11 <ildikov> matjazp: we are also brainstorming about getting more motion and interaction into the training
17:25:20 <ildikov> even those parts where we have more lectures
17:25:40 <ildikov> we need to teach people how to find info and how to communicate with each other and the community
17:25:57 <matjazp> that's what exercises need to do
17:26:00 <ildikov> so I don't want hours when someone talks to people based on slides and nothing else happens
17:26:31 <ildikov> matjazp: exactly, so we are not fixing slide formats :)
17:26:57 <ildikov> matjazp: as I mentioned in the meeting minutes I'm looking for ideas for exercises for ALL blocks
17:27:03 <matjazp> ildikov: if we put some extra exercises at the end of each slide deck, this will fix the "death from powerpoint" issue :)
17:27:29 <ildikov> I would like to form groups of 3-5 we will see how many people we will have and get them work together and kind of almost create the slides for themselves
17:27:45 <ildikov> at least that's the long term plan and we will see what we achieve for Barcelona
17:28:09 <ildikov> matjazp: TBH, I plan to add them at the beginning and not at the end where possible
17:28:13 <matjazp> ildikov: you're talking about groups of contributors to the upstream training?
17:28:38 <matjazp> or trainees?
17:28:40 <ildikov> start people think about things and then clarify items and give them best practices
17:28:52 <ildikov> matjazp: trainees
17:29:15 <ildikov> put them into groups and let them solve exercises
17:29:31 <matjazp> aha, ok... that makes more sense... since we don't have more than 5 contributors to the upstream training ;)
17:30:06 <ildikov> I'm looking for making the training more interesting and avoid people checking facebook in every 5 minutes :)
17:30:06 <matjazp> ildikov: the problem with this is that some groups will be much faster than others
17:30:27 <ildikov> we can figure that out based on the info what we are asking them about
17:30:49 <ildikov> and also some competition will not hurt :)
17:31:11 <ianychoi-web> Hello!
17:31:31 <matjazp> we should still have a basic structure and basic time frames for the exercises
17:31:32 <ildikov> ianychoi-web: hi :)
17:32:06 <ildikov> matjazp: so besides upgrading the content we should do that keeping exercises in mind
17:32:11 <matjazp> and show the solution at the end for groups that didn't finish it
17:32:13 <ildikov> and the aim of getting people participate
17:32:27 <matjazp> hi ianychoi-web
17:32:49 <ildikov> matjazp: I would ask the fastest group to share the solution
17:32:53 <ildikov> and things like that
17:33:11 <matjazp> ildikov: ok
17:33:17 <ildikov> sometimes the exercise could just simply be to discuss topics and then bring it to the whole group, like the agile parts
17:34:08 <ildikov> let them barinstorm in small groups and then bring the ideas to the whole class when they are done and let's see how people see the world and share our points with them if we didn't cover it yet kind of things
17:34:43 <matjazp> ildikov: don't forget to put this instructions/suggestions into presenter notes
17:34:45 <ildikov> I also checked on the initial registration data
17:35:10 <ildikov> matjazp: after we have some progress about thinking about the exercises it will go there
17:35:38 <ildikov> so based on the data we have 19 people interested mainly in code contribution, 3 in docco, 6 in WGs and UGs and 1 in OSOps
17:35:49 <matjazp> ildikov: or we can put this into the landing page, under "notes for trainers" or something like that
17:36:38 <matjazp> ildikov: yup, thats skewed heavily towards developers
17:36:40 <ildikov> so I'm in contact with WG chairs and the UC chair to get a possible round table discussion like thing
17:36:55 <ildikov> I'm also trying to get someone from the docco team to get a docco deep dive
17:37:09 <ildikov> and we are planning a code deep dive regarding how to get to know the code base, etc
17:37:14 <ildikov> these can run in parallel
17:37:44 <matjazp> docco? Is this Docs?
17:38:41 <ildikov> yes :)
17:38:51 <matjazp> just checking
17:39:08 <ildikov> sorry a group of people using it this and the other group in the other way
17:39:10 <ildikov> :)
17:39:16 <ildikov> I'm in both
17:39:30 <ianychoi-web> Hmm, on Austin Lana attended AFAIK..
17:39:32 <ildikov> and also 19 people are ineterested in long-term mentoring so far
17:39:43 <ildikov> I ping Emily who organises the mentors already
17:39:54 <matjazp> I don't see how contributing to docs is much different than contributing code
17:39:57 <ildikov> ianychoi-web: she did, but she cannot come this time sadly :(
17:40:11 <ianychoi-web> ildikov: T.T
17:40:32 <matjazp> ildikov: can we put this contact persons on the landing page?
17:40:38 <ildikov> matjazp: so for code we will teach people how to add log messages to the code and then restart the service and find the new log entry in the log file
17:41:01 <matjazp> aha, ok.. but the basic flow is the same
17:41:25 <matjazp> so maybe we shouldn't differentiate these trainees?
17:41:32 <ianychoi-web> For documentation, I think explaining writing style would be important: http://docs.openstack.org/contributor-guide/writing-style/general-writing-guidelines.html
17:41:45 <ildikov> matjazp: for docs it makes no sense, but showing how sphinx and the docs toolchain works does
17:42:00 <ildikov> ianychoi-web: and writing style as well
17:42:06 <ildikov> ianychoi-web: +1
17:42:30 <ildikov> matjazp: so when we "differentiate" that's one block and not the whole training
17:42:42 <ildikov> matjazp: most of the things will be for the whole group
17:43:11 <ildikov> but I don't want to torture a business development guy if he really comes for instance with code deep dive
17:43:24 <ildikov> as he will never do that after the training so that's not useful for him
17:43:46 <ildikov> but if we can find WG chairs who he can talk to, that is
17:43:47 <ildikov> just to mention an example
17:44:49 <ildikov> matjazp: ianychoi-web: diablo_rojo: makes sense? ^^
17:44:57 <matjazp> ildikov: it does
17:45:31 <diablo_rojo> Yeah it does
17:45:37 <ildikov> matjazp: cool, because so far everyone wanted to kill me due to this "differentiation" thing
17:45:37 <matjazp> ildikov: but in my experience, it's hard to personalize the training in the same room for ppl that have much different needs
17:45:38 <ianychoi-web> +1 :)
17:46:03 <matjazp> ildikov: it all sounds cool, but in practice, thi is hard
17:46:04 <ildikov> matjazp: but writing code and writing docs is different it's not my invention... :)
17:46:21 <ildikov> matjazp: that part will be hands-on anyway
17:46:33 <ildikov> so no one person talks to the whole group
17:46:44 <ildikov> and the trainees will be in groups already
17:47:08 <ildikov> so in theory at least it works :)
17:47:22 <diablo_rojo> In theory it should work :)
17:47:35 <matjazp> In theory it should work --- ;)
17:48:23 <ildikov> thanks for support, lol :D
17:48:42 <matjazp> youre welcome ;)
17:49:04 <ildikov> so please add exercise ideas to the etherpad to discuss next steps!
17:49:15 <matjazp> ok
17:49:25 <ildikov> also if anyone has bandwidth to check on remaining blocks to update please sign up on the etherpad
17:49:33 <ildikov> and upload patches! ;)
17:49:39 <ianychoi-web> And.... I have thought that it would be much better if we have an exercise for writing a patch to Stackalytics for "Company affiliation": https://wiki.openstack.org/wiki/Stackalytics#Company_affiliation
17:50:13 <ildikov> ianychoi-web: coolio :)
17:50:21 <diablo_rojo> Ten min warning
17:50:34 <ildikov> diablo_rojo: tnx :)
17:50:36 <ianychoi-web> And I have created LP: https://launchpad.net/openstack-dev-sandbox
17:50:39 <matjazp> move on?
17:50:40 <ianychoi-web> #link https://launchpad.net/openstack-dev-sandbox
17:51:23 <ianychoi-web> #link https://review.openstack.org/#/c/375834/
17:51:50 <matjazp> #topic  Re-think meeting time slot and try to find an earlier slot that fits with Asia too
17:51:54 <ianychoi-web> This patch is related to make a relationship between openstack-dev/sandbox repo and openstack-dev-sandbox launchpad..
17:51:55 <matjazp> need to move on
17:52:29 <ildikov> let's try to get to the meeting slot discussion to before ending the meeting
17:52:38 <matjazp> doodle?
17:52:42 <ildikov> ianychoi-web: thanks for those patches/updates!
17:52:44 <ianychoi-web> +1
17:53:07 <ianychoi-web> ildikov: please +1 for the gerrit review thanks!
17:53:19 <ildikov> ianychoi-web: sure, will do!
17:53:26 <ildikov> matjazp: Doodle works
17:53:31 <ildikov> matjazp: I can create a poll
17:54:04 <ildikov> would be great to decide before next week
17:54:12 <matjazp> #action ildikov creates doodle pool for new irc meeting time
17:54:16 <ildikov> so that it would be less painful to ianychoi-web to join
17:54:33 <ildikov> and also have my parallel meeting too
17:54:40 <ianychoi-web> Haha :)
17:56:03 <ildikov> did we cover everything?
17:56:10 <matjazp> i think so
17:56:26 <ianychoi-web> #link https://review.openstack.org/#/c/367005/
17:56:37 <ianychoi-web> Please also +1 for this review :)
17:56:43 <matjazp> thats it for this week?
17:57:03 <diablo_rojo> I think so
17:57:17 <matjazp> ok thanks all
17:57:51 <ianychoi-web> Thank you all! (in Korea, there is a kind of DNS problems, which prevented me from attending..)
17:58:09 <matjazp> #endmeeting