13:01:07 <matjazp> #startmeeting training-guides
13:01:08 <openstack> Meeting started Tue Oct  4 13:01:07 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:12 <matjazp> hey all
13:01:13 <openstack> The meeting name has been set to 'training_guides'
13:01:14 <matjazp> roll call
13:01:20 <ildikov> o/
13:01:37 <ianychoi_phone> Hi all!
13:01:39 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:01:49 <matjazp> hey ianychoi_phone ildikov
13:02:13 <csatari> hi
13:02:20 <kmARC> o/
13:02:24 <ianychoi_phone> :) Nice to see all in new time slot :)
13:02:30 <matjazp> ianychoi_phone: you can go to bed much earlier today ;)
13:02:34 <ianychoi_phone> Wow hi csatari and kmARC !
13:02:38 <ianychoi_phone> Yey~~!
13:02:41 <matjazp> hey csatari kmARC
13:02:58 <kmARC> yeah, I arrived on time to the beautiful Frankfurt
13:03:00 <ildikov> hi All :)
13:03:12 <ianychoi_phone> Wow Frankfurt..!
13:03:16 <ildikov> kmARC: I'm glad you made it :)
13:03:21 <matjazp> kmARC: you're at the airport?
13:03:51 <diablo_rojo_phon> Hello
13:03:57 <ildikov> that's a nice one, I had meeting there before :D
13:04:00 <ianychoi_phone> Hello diablo_rojo_phon !
13:04:06 <matjazp> hey diablo_rojo_phon
13:04:26 <kmARC> matjazp: No I'm already at hotel
13:04:33 <kmARC> I came by car
13:04:43 <matjazp> kmARC: much better than airport :)
13:04:45 <ildikov> this meeting slot looks good so far
13:04:54 * matjazp looks at the agenda
13:05:00 <ianychoi_phone> I agree thank a lot ildikov
13:05:04 <ildikov> matjazp: I will put up a patch to secure this channel, when you confirm it too
13:05:26 <matjazp> ildikov: yes, as soon as I get my winter schedule
13:05:42 <ildikov> ianychoi_phone: we cannot do it any earlier, or I need to look for a completely other slot that can fit to everyone :(
13:05:53 <matjazp> the problem is that my schedule changes twice a year (winter and summer term)
13:06:01 <ildikov> ianychoi_phone: but please let us know if it's still close to undoable for you
13:06:37 <ildikov> matjazp: got it, I hope this slot works out and then we will see how things go later
13:06:50 <ianychoi_phone> ildikov: That's completely fine to me. I hope that matjazp 's schedule will also fit :)
13:07:45 <ildikov> cool, tnx all for the quick votes, etc :)
13:07:50 <matjazp> ildikov: sadly, I can confirm just for one semester... the alternative is if this is outside business hours
13:07:53 <ildikov> we can move with the agenda :)
13:07:59 <matjazp> sure
13:08:05 <matjazp> #topic Review of action items from the previous meeting
13:08:06 <ianychoi_phone> Yep
13:08:16 <matjazp> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-09-26-17.01.html
13:08:23 <ildikov> matjazp: I will look up possible other slots, I'm fine with outside work hours too
13:08:44 <matjazp> ildikov: let's just wait and we'll adapt
13:09:10 <ianychoi_phone> For my action on LP, infra team said currently there is storyboard
13:09:12 <matjazp> ianychoi_phone: there is a controversy about that LP vs Storyboard?
13:09:12 <ildikov> matjazp: ack
13:09:42 <matjazp> we should teach what ever is "the ususal" way for most projects
13:09:47 <ianychoi_phone> The team said existing both would not be good
13:09:55 <ildikov> matjazp: majority is still using LP
13:10:13 <matjazp> so we should convince infra team to revert to LP
13:10:25 <matjazp> what do you all think?
13:10:26 <ildikov> the plan was a while ago to move to Storyboard, but I haven't heard that the plan would be executed so far
13:10:34 <ianychoi_phone> #link https://review.openstack.org/#/c/375834/
13:10:52 <ildikov> I think the plan is still to move away from LP and use something that's open source
13:11:08 <ianychoi_phone> I proposed this as an agenda on the next infra tram irc meeting
13:11:20 <ianychoi_phone> Can someone attend the meeting?
13:11:21 <ildikov> so I don't think convincing is an option here, but I can ask where we are with this
13:11:34 <matjazp> ildikov: ok so dillema is: teach what is used by most projects NOW or teach what will (?) be used in the future
13:12:02 <ildikov> a sandbox page would be useful somewhere, maybe at both places as for instance I don't know how storyboard works and would be nice to learn if we have a few projects using that
13:12:23 <ianychoi_phone> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
13:12:46 <ildikov> ianychoi_phone: I can attend that
13:13:05 <matjazp> Infra team is pushing towards storyboard for all projects?
13:13:16 <ildikov> matjazp: teach what we have now and that includes Stpryboard, so we should highlight that too
13:13:21 <ianychoi_phone> Since the meeting time is 4 am here.. it is difficult for me to attend..
13:13:26 <matjazp> #action ildikov attends infra team meeting regarding LP vs storyboard
13:13:45 <ianychoi_phone> matjazp: this is on-going plan, as what I heard..
13:14:04 <matjazp> ildikov: we can show both, no problems there, but sandbox can be linked to one or the oher
13:14:05 <matjazp> other
13:14:05 <ianychoi_phone> But still current lots of projects use LP..
13:14:12 <kmARC> (TBH I thought this Storyboard is dead long ago, since it's been pushed for like 1.5 years now, and nothing happened...)
13:14:20 <ildikov> ianychoi_phone: so the point here is that we shouldn't create a sandbox project in LP, right?
13:14:30 <matjazp> kmARC: I got the same feeling
13:14:56 <ianychoi_phone> ildikov: yep and also LP vs storyboard
13:15:12 <ianychoi_phone> #link https://storyboard.openstack.org/?#!/story/2000734
13:15:30 <ianychoi_phone> I briefly summarized possible discussions..
13:15:50 <matjazp> ok, lets discuss this at the next meeting, after ildikov talks with infra team, ok?
13:15:59 <ildikov> ianychoi_phone: ok, tnx
13:16:06 <ildikov> matjazp: +1
13:16:06 <ianychoi_phone> +1 :)
13:16:07 <SotK> kmARC, matjazp: StoryBoard is not dead (see https://specs.openstack.org/openstack-infra/infra-specs/specs/task-tracker.html for infra's migration plans)
13:16:38 <matjazp> will we have time to adapt the training for either one? or do we just teach LP for Barcelona anyways?
13:16:39 <kmARC> SotK: so is any other project using it besides infra_
13:16:40 <kmARC> ?
13:16:43 <ianychoi_phone> SotK: thanks for the link
13:17:12 <ianychoi_phone> AFAIK not yet..
13:17:50 <SotK> just infra and some other newly-formed since Austin projects iirc
13:18:25 <kmARC> SotK: so that's why we thought it's dead :-)
13:18:26 <SotK> new projects are welcome to use it these days (talk to infra)
13:18:26 <matjazp> #action LP vs Storyboard: we discuss about what we will use at the barcelona training at the next meeting
13:18:43 <SotK> kmARC: yep, it is an understandable conclusion :)
13:18:57 <ianychoi_phone> IMO since still lots of projects use LP, LP would be more relevant for upstream training and it is also good to introduce what storyboard is
13:19:36 <kmARC> aggree
13:19:41 <matjazp> ok, we can decide that next week. I hope it will give us enough time to prepare everything for Barcelona
13:19:57 <ianychoi_phone> I really hope so
13:20:14 <ildikov> ianychoi_phone: I agree, let's have a longer block on LP and introduce Storyboard too if someone would look into Infra and/or any new projects that are using that
13:20:30 <matjazp> ildikov: you had two action items from last week
13:20:40 <matjazp> doodle is done, obviously
13:21:03 <ildikov> yeap, I haven't talked to kmARC yet, so I'm happy he made it to the meeting :)
13:21:18 <matjazp> kmARC: how is the testing going?
13:22:14 <kmARC> I didn't have time for it, sorry :-( I moved last week. But now it's done, will do my part during this week
13:22:42 <ianychoi> kmARC, that's fine and also I have not uploaded any issues on your github T.T
13:22:45 <matjazp> do we ned to publicise this task (testing) more? send mail to the ML, etc?
13:22:55 <ildikov> kmARC: on the last meeting others confirmed that Devstack eats much memory, so I'm not sure how much improvement can be done on that part
13:23:23 <matjazp> ildikov: true... I switched to 6 GB VM because of that
13:24:03 <ildikov> kmARC: what would be great to do is get at least one instance up in DreamCompute
13:24:25 <ildikov> kmARC: just to see how things come together there if people would have issues with a 6GB VM
13:24:35 <matjazp> ildikov: yes, for trainees that will have troubles with their laptop
13:25:03 <ildikov> kmARC: can you by any chance give that one a try too?
13:27:06 <matjazp> damn, my irc client crashed
13:27:26 <kmARC> ildikov:
13:27:27 <kmARC> yes
13:27:33 <ianychoi> Hmm.. matjazp, no talk during your crash time :)
13:27:42 <ildikov> matjazp: you didn't miss any message :)
13:27:51 <kmARC> let's make a note on this
13:28:06 <matjazp> #action kmARC tests devstack in a cloud VM
13:28:25 <ildikov> kmARC: coolio, I will contact Stefano to give you access, will add you to the mail
13:28:29 <ildikov> kmARC: tnx!!!
13:28:55 <ianychoi> Good :)
13:28:59 <matjazp> #topic Upstream training - review queue
13:29:40 <matjazp> open patches: https://review.openstack.org/#/q/project:openstack/training-guides+status:open,n,z
13:30:58 <matjazp> regarding git review: I use brew to install it... and a lot of other macOS ppl use that too, so maybe we can add this? what do others use (if you use macOS)?
13:31:55 <ildikov> matjazp: I don't use git review, I'm happy with git push... :)
13:32:06 <ildikov> matjazp: but I think brew is quite common
13:32:19 <matjazp> ildikov: hey, that is not what are you teaching to the trainees ;)
13:32:23 <diablo_rojo_phon> I will have my open patch rebased in the next hour or so.
13:32:24 <ianychoi> matjazp, I am also revising git-review document, and two reviewers advised me to use another command rather than brew
13:32:25 <ianychoi> #link https://review.openstack.org/380964
13:32:43 <matjazp> ianychoi: yes, I saw that, but I'm still wondering abou it
13:33:07 <matjazp> macOS without brew is useless ;)
13:33:16 <ildikov> matjazp: I actually planned to explain them what's the command behind it, sometimes it's good to know as git review tends to swallow error messages...
13:33:54 <matjazp> ildikov: sure, but that could also overload them with detailed info.. be carefult about that
13:34:02 <ianychoi> matjazp, is brew a public package manager?
13:34:35 <matjazp> ianychoi: http://brew.sh/
13:34:53 <matjazp> brew = apt for mac
13:35:31 <ianychoi> For me, I do not care either pip or brew.. but some people say that for official documentation, pip is better
13:35:33 <matjazp> it is open source (if that is what are you asking)
13:35:50 <ianychoi> I do not have much detail knowledge on the detail reasonings..
13:36:11 <ianychoi> IMO for upstream training, brew can be used
13:36:28 <matjazp> never mind, we can discuss this in the patch comments
13:37:00 <matjazp> it is a bit personal preference, I guess
13:37:30 <ianychoi> Then, documenting both brew and pip would be nice for upstream training?
13:37:48 <matjazp> anything that we need to talk about in the review queue?
13:38:13 <ildikov> numbering maybe?
13:38:17 <matjazp> ianychoi: I believe so.. we do have brew in some other places
13:38:31 <diablo_rojo_phon> ildikov: you beat me to it :)
13:38:40 <diablo_rojo_phon> I think it needs to go away
13:38:54 <matjazp> #topic Upstream training - chapter numbering
13:38:57 <ianychoi> matjazp, I see.. I will propose a new patch for that :)
13:38:58 <ildikov> I mean the files of the slides are numbered currently and it makes the structure quite inflexible
13:39:14 <diablo_rojo_phon> Cause it's broken IE there was a huge gap in the numbering system and it just leads to more work renaming everytime a new section is added or moved
13:39:28 <matjazp> ildikov: I like Docs solution
13:39:52 <matjazp> we're talking about https://review.openstack.org/#/c/380789/
13:39:54 <matjazp> #link https://review.openstack.org/#/c/380789/
13:39:55 <ildikov> matjazp: Docs solution?
13:40:12 <ianychoi> matjazp wrote the comment on the review
13:41:09 <matjazp> yes, look at the last comment
13:41:54 <ildikov> Gerrit is slow at least in my browser today, sorry
13:42:15 <matjazp> ildikov: +1
13:42:35 <ianychoi> me too infra team needs to reboot gerrit instances..
13:42:46 <ildikov> matjazp: I like you proposal in general, although it might lead to very long filenames
13:42:52 <diablo_rojo_phon> Grouping is fine I suppose, but the actual numerical system I think is not helpful.
13:43:07 <matjazp> ildikov: not if we're careful
13:43:28 <ildikov> I agree, grouping does not affect flexibility as opposed to numbers
13:43:54 <ildikov> so I'm fine with that direction
13:44:10 <diablo_rojo_phon> I also fear the file names getting long, but we can go with it for now
13:44:12 <matjazp> ok.. I have to upgrade my irc client... sierra does not play nice with it ;)
13:44:57 <matjazp> #info we replace numbering scheme and use terms as grouping chapters together
13:45:37 <ianychoi> #link https://blueprints.launchpad.net/openstack-manuals/+spec/consistency-file-rename
13:45:48 <ianychoi> Just FYI :)
13:46:15 <ianychoi> Since we already use hyphens, it is fine
13:46:38 <ianychoi> I am also fine to removing numbers and use some terms as grouping file names..
13:47:05 <diablo_rojo_phon> Okay. I'll do that today.
13:47:12 <matjazp> #info we prefer hyphens over underbars in file names
13:47:20 <ildikov> cool!
13:47:47 <matjazp> #info file names must not be too long
13:48:18 <diablo_rojo_phon> All noted :)
13:48:23 <ildikov> :)
13:48:30 <ianychoi> Cool :)
13:48:38 <matjazp> do we need a hard limit for file name length? I don't like to define too much rules and conventions, and we're a small team so I guess it's not needed
13:49:00 <diablo_rojo_phon> I don't think it needs to be defined ahead of time
13:49:10 <diablo_rojo_phon> Just use your best judgement
13:49:20 <ildikov> diablo_rojo_phon: +1
13:49:32 <ianychoi> diablo_rojo_phon, +1
13:49:54 <matjazp> diablo_rojo_phon: I agree, that's why I didn't put it in the info
13:50:03 <diablo_rojo_phon> Cool.
13:50:23 <matjazp> ok, back to the review queue... anything else to discuss?
13:50:49 <diablo_rojo_phon> And to respond to the other comment about changing the how to contribute section. ildikov and I felt that name didn't have anything to do with the real content of the section.
13:51:13 <diablo_rojo_phon> I can change it back for now, but when that section gets updated, the name should get changed.
13:51:53 <matjazp> we can do it in a later patch
13:51:59 <ianychoi> ildikov,  "Administrivia" would be better term for 'how to contribute'?
13:52:05 <matjazp> I prefer smaller patches anyway :)
13:52:14 <ianychoi> +1 as matjazp
13:52:34 <ildikov> ianychoi: the name 'How to contribute' indicates that we will talk about the contribution process
13:52:41 <diablo_rojo_phon> Okay that's fine.
13:52:46 <matjazp> it also sometimes needlessly blocks a whole patch
13:52:49 <diablo_rojo_phon> ildikov: +1
13:53:02 <ildikov> ianychoi: that slide has nothing to do with that it only guides through the Foundation registration and corresponding items
13:53:16 <diablo_rojo_phon> And the CLA
13:53:24 <matjazp> ildikov: but you must do that before you can proceed
13:54:07 <matjazp> ildikov: so I guess it's debatable if this should be a part of the "contributing process" or not
13:54:11 <ianychoi> ildikov, okay. then another term such as 'Participation with identities'?
13:54:12 <ildikov> matjazp: yes, but it's still not the "How" to contribute part, but the administration/prerequisites
13:54:25 <ianychoi> Or 'Identify yourself'?
13:54:29 <csatari> What if we rename it to Contribution bootstrapping or something like this?
13:54:44 <matjazp> csatari: better term, yes
13:54:54 <csatari> To indicate, that this is not about the contribution itself, but about the first steps.
13:54:55 <matjazp> or requirements
13:55:15 <matjazp> Contribution requirements
13:55:15 <ildikov> I like Administrativa TBH :)
13:55:33 <diablo_rojo_phon> ildikov: same lol
13:55:41 <diablo_rojo_phon> All encompassing and just one word.
13:55:54 <ianychoi> But it is not for admistrative purposes.. isn't it?
13:56:00 <diablo_rojo_phon> It is.
13:56:40 <ildikov> ianychoi: it actually is from practical PoV
13:56:44 <matjazp> huh.. 4 min left
13:56:52 <diablo_rojo_phon> The CLA and registration with the foundation is all administration stuff that doesn't really have a lot to do with direct contributions, just being recognized and allowed to contribute. Like being registered to vote.
13:56:58 <matjazp> just submit a patch and we can discuss this there
13:57:01 <diablo_rojo_phon> In my understanding angway
13:57:20 <diablo_rojo_phon> Okay. I'll just change it back for now in this patch.
13:57:20 <matjazp> #topic aob
13:57:26 <ildikov> ok, let's move this discussion to Gerrit, we will not decide it here
13:57:30 <matjazp> anything else?
13:57:33 <matjazp> 2 min
13:57:41 <ianychoi> ildikov, diablo_rojo_phon okay. It may be because English is not my first language... thanks
13:58:05 <ildikov> we added a few notes to the main etherpad with diablo_rojo_phon: https://etherpad.openstack.org/p/upstream-university-improvements
13:58:27 <matjazp> #info  https://etherpad.openstack.org/p/upstream-university-improvements
13:58:35 <ianychoi> Oh I will see them
13:58:37 <matjazp> #undo
13:58:38 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f66f475a590>
13:58:39 <diablo_rojo_phon> ianychoi: no worries :) We can discuss it in a different patch.
13:58:44 <matjazp> #link  https://etherpad.openstack.org/p/upstream-university-improvements
13:58:51 <ianychoi> diablo_rojo_phon, thanks :)
13:58:52 <ildikov> we're still looking for exercise ideas, so if anyone has add it either to the etherpad or upload it in a patch as a content update
13:59:14 <matjazp> ok, time's up
13:59:23 <matjazp> thanks for participating
13:59:23 <ianychoi> okay
13:59:27 <ianychoi> thanks all today!
13:59:28 <ildikov> tnx
13:59:29 <matjazp> see you all next week
13:59:33 <matjazp> bye!
13:59:40 <ildikov> see you next week!
13:59:56 <csatari> bye
13:59:58 <kmARC> bye
14:00:08 <matjazp> #endmeeting