13:01:13 <matjazp> #startmeeting training-guides
13:01:13 <openstack> Meeting started Tue Oct 18 13:01:13 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:17 <openstack> The meeting name has been set to 'training_guides'
13:01:17 <matjazp> hey all
13:01:20 <matjazp> roll call
13:01:22 <ianychoi_phone> Hi
13:01:23 <ildikov> o/
13:02:17 <matjazp> hi ildikov, ianychoi_phone
13:02:41 <matjazp> let's wait a bit for others
13:02:48 <matjazp> how are you guys?
13:03:28 <ianychoi_phone> I am fine although I have got a cold..
13:03:31 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:03:52 <matjazp> ianychoi_phone: get better, Barcelona is near :)
13:03:54 <ildikov> a bit stressed by now, otherwise fine :)
13:04:39 <matjazp> ildikov : pressure not be will be off till the Summit ends, I'm suppose
13:04:43 <ianychoi_phone> ildikov: don't be stressful! It's just our life!
13:04:50 <matjazp> ildikov: lots on your plate, right?
13:05:02 <matjazp> #topic Review of action items from the previous meeting
13:05:13 <ildikov> yeap, it's the event pressure, but it will be fine
13:05:23 <ildikov> training starts at 1pm local time this Sunday!!! :)
13:05:43 <matjazp> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-10-11-13.01.html
13:05:44 <ildikov> I asked MArton and he's fine with me as training lead for Barcelona
13:05:56 <ianychoi_phone> Oh good
13:06:17 <matjazp> ildikov : I'll make an official announcement and get you +2 on the repo ASAP
13:06:31 <ildikov> matjazp: thank you!
13:06:53 <ianychoi_phone> Nice!
13:06:57 <ildikov> I also sent out the mails yesterday to ask for confirmation that students can attend the training
13:07:11 <matjazp> #info ildikov is a new Upstream training lead for Barcelona
13:07:13 <ildikov> I added links to the VM and laptop requirements
13:07:25 <ildikov> and also offered public cloud access if they need
13:07:48 <ianychoi_phone> Thanks i have seen the patch
13:07:49 <matjazp> #action matjazp makes an announcement and adds ildikov in the core team
13:07:55 <ildikov> I think we are getting to 30 with confirmations, but i couldn't check all the responses yet
13:08:21 <ildikov> ianychoi_phone: right, I added those to the main web page as well, not just to the mail
13:08:22 <ianychoi_phone> Confirmation for..?
13:08:39 <ildikov> ianychoi_phone: for attending
13:09:00 <ildikov> ianychoi_phone: we have a waiting list and also usually half of the registered students actually show up
13:09:02 <ianychoi_phone> Aha i see .. i think e-mailing is not late :)
13:09:04 <matjazp> I guess we won't know for sure until training starts
13:09:12 <ildikov> ianychoi_phone: I wanted to have an idea in advance what we can expect this time
13:09:32 <matjazp> ildikov : just 50%?
13:09:37 <ianychoi_phone> ildikov: announcing the location was fixed?
13:09:40 <ildikov> matjazp: not for sure, but at least I can have an idea what to say to the 13 people on the waiting list :)
13:09:56 <ildikov> matjazp: in Austin I'm not sure it was even 50%
13:10:09 <ildikov> matjazp: that was my first but according to others it's around that
13:10:13 <matjazp> ildikov : when we organize free trainings/workshops there are about 20% of no show students
13:10:26 <ildikov> people usually register before they confirm their travel, etc.
13:10:47 <ildikov> matjazp: are those local ones?
13:11:02 <matjazp> ildikov : yes, at my Uni, for our students
13:11:33 <matjazp> not just opentack workshops, I organize workshops for other CS topis too
13:11:38 <ildikov> matjazp: that matters much, in case of Summits people need to travel and companies cut travel budget sometimes even in the very last minute
13:12:09 <ildikov> anyway, waiting for responses now :)
13:12:16 <ildikov> I also sent out the mail to the docs list
13:12:36 <ildikov> I have a few people coming on Monday either in the morning or at the afternoon
13:12:39 <csatari> #info csatari
13:12:53 <matjazp> hey csatari
13:13:54 <ianychoi_phone> Hi csatari
13:14:32 <csatari> Hi matjazp , ianychoi_phone
13:15:27 <matjazp> #info we're organising a training guides meeting in Barcelona. sync is over Docs ML: http://lists.openstack.org/pipermail/openstack-docs/2016-October/009241.html
13:16:16 <matjazp> so we've covered everything but kmARC's item. ildikov do you know if he tested cloud VMs?
13:16:47 <ildikov> matjazp: I synced about the VM image with him lately
13:17:21 <ildikov> matjazp: I will ask him about the cloud environment later today/this week if he cannot make it to this meeting
13:17:37 <matjazp> ildikov: ok
13:17:47 <matjazp> we can move on
13:18:04 <matjazp> #topic Upstream training - review queue
13:18:23 <ildikov> we have three open items now I think
13:18:34 <ildikov> I'll upload at least one more hopefully today
13:18:39 <matjazp> great
13:18:45 <ildikov> and then I'll spend some time with figuring out the agenda
13:19:07 <matjazp> do we have something with urgent priorities?
13:19:16 <ildikov> other than that we can think about exercises still
13:19:19 <matjazp> training is in a few days
13:19:35 <ianychoi_phone> yep I thought we need finalize content soon
13:19:43 <matjazp> we can extend that final exercise
13:19:46 <ildikov> I will have a meeting with the coaches tomorrow so I'll double check the agenda plans with them
13:19:53 <matjazp> https://review.openstack.org/#/c/386728/
13:20:23 <ildikov> matjazp: yeap, I saw your comments
13:20:45 <matjazp> especially if we want to make this exercise longer
13:20:49 <ildikov> I think some of them can go to notes so that the trainers in the room know how to facilitate the session
13:21:00 <ildikov> I'm not sure about the length at this point TBH
13:21:12 <ildikov> that makes it a bit tough to adjust it
13:21:16 <ianychoi_phone> diablo_rojo wants to revise it?
13:21:48 <ildikov> ianychoi_phone: she's arrived to Spain this morning, I think she can check on it later in the afternoon (local time)
13:22:09 <ildikov> ianychoi_phone: I can update it if she's not available
13:22:33 <ianychoi_phone> I see :)
13:23:18 <ianychoi_phone> Kendall seems to be so busy..:)
13:23:39 <ildikov> well, I think this close to the event it's not just her :)
13:23:51 <matjazp> so do we leave Ian's step by step tutorial like it is?
13:24:06 <ildikov> I still think a shorter block would be better
13:24:33 <matjazp> you mean with fewer pics?
13:24:41 <matjazp> just bullets on the slides?
13:24:59 <ildikov> I would like to aim for 45 minutes long blocks if possible, so less slides + exercise ideally
13:25:10 <ildikov> matjazp: I would move a few pics to other sections
13:25:25 <ildikov> matjazp: so keep them, just not here
13:25:44 <ildikov> matjazp: ianychoi_phone: if we feel that it's too much now then merge as is
13:25:57 <ildikov> matjazp: ianychoi_phone: we can always re-organise it later
13:26:11 <matjazp> ildikov : yup, maybe that's better
13:26:15 <ildikov> either before or after the training as the content itself is useful
13:26:19 <matjazp> we're damn close to the training
13:26:27 <kmARC> IM HERE
13:26:29 <ianychoi_phone> ildikov: I suggest to merge first.. yep so close to the training
13:26:32 <matjazp> hey kmARC
13:26:34 <kmARC> (sorry :-) )
13:26:38 <ianychoi_phone> kmARC: hi
13:26:44 <ildikov> I know that we are close! ;) :)
13:26:51 <ildikov> kmARC: hi :)
13:27:10 <matjazp> kmARC : did you have time to test the cloud VMs?
13:27:12 <kmARC> So regarding cloud VM's
13:27:12 <ildikov> kmARC: did you have a chance to check the cloud env?
13:27:18 <kmARC> :-)
13:27:18 <matjazp> :)
13:27:21 <kmARC> yes I did
13:27:22 <ildikov> :)
13:27:41 <ianychoi_phone> !!
13:27:42 <openstack> ianychoi_phone: Error: "!" is not a valid command.
13:27:45 <kmARC> I did separate my scripts so that now it's able to setup GUI-less environments too
13:28:15 <kmARC> So basically that should work on the cloud VM (altho I didn't document it yet)
13:28:24 <kmARC> but unfortunately the GUI mode doesn't
13:28:28 <kmARC> it's painfully slow over VNC
13:28:30 <kmARC> :-(
13:28:35 <ildikov> :(
13:28:55 <ianychoi_phone> kmARC: i suggest xrdp instead of vnc personally :)
13:29:01 <ildikov> but well, should be fine for hackers :)
13:29:04 <kmARC> VNC is the openstack default
13:29:36 <ianychoi_phone> VNC console is default
13:29:46 <matjazp> kmARC : will you be able to add to the instructions a paragraph or two about using this in a cloud vm?
13:29:46 <ildikov> I think it's still a good experience even without GUI
13:30:01 <ianychoi_phone> ildikov: +1
13:30:10 <kmARC> ildikov: I'm not sure everyone would be satusfied or comfortable with a console-only setup. For someone whoose workflow needs GUI editors/IDEs, it won't work
13:30:32 <ildikov> kmARC: also does "it should work" equal to "it does work"? :)
13:31:10 <kmARC> well, I tried it, it installs, I had some network issues, so I'd say 95% it works (which usually means it's 50%: it either works or not)
13:31:14 <ildikov> kmARC: if we want them to do everything in that env that can be uncomfortable, but still a useful experience
13:31:48 <ildikov> kmARC: we will form group of students, so I hope we can mix up people with different envs, so everyone has a chance to see how things look like/work
13:31:50 <kmARC> ildikov: well, but then they need to use some console editor like nano/vim/emacs
13:31:55 <ildikov> kmARC: no better idea at this point
13:31:58 <matjazp> as a last resort: we can always make pairs at the training and pair the ones that don't have te right hw with one that it has
13:32:09 <ildikov> kmARC: vi is the best ;)
13:32:18 <kmARC> I also tried X forwarding, but that's even worse than VNC
13:32:33 <ildikov> matjazp: yeap, groups should solve the problem
13:33:03 <ildikov> kmARC: I don't like X forwarding
13:33:26 <kmARC> ildikov: TBH I'd love to teach thenm how to use vim (I am expert on that at least) but most probably a two-day wortkshop is not enough for it :-)
13:33:27 <matjazp> ianychoi_phone : the #openstack-101 bot support patch merged, right?
13:33:41 <ianychoi_phone> matjazp: right!
13:33:48 <ildikov> kmARC: lol :) most probably
13:34:09 <ianychoi_phone> I suggest all to test to open irc meeting on #openstack-101 before upstream training
13:34:50 <matjazp> #action ianychoi_phone tests #openstack-101 before upstream training
13:35:08 <matjazp> just test it if the bot works
13:35:21 <ianychoi_phone> Yep okay i will do that :)
13:36:09 <ildikov> :)
13:36:18 <ildikov> I can give it a try too after the meeting
13:36:31 <matjazp> #undo
13:36:32 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7fecfac9ad90>
13:36:41 <matjazp> #action ianychoi_phone and ildikov tests #openstack-101 before upstream training
13:36:49 <ildikov> matjazp: tnx :)
13:36:55 <ianychoi_phone> I suggest ildikov also tests it :)
13:36:58 <ianychoi_phone> Yep cool
13:37:08 <matjazp> kmARC : do you want to test #openstack-101 too ;)
13:37:31 <kmARC> I tested with utf-8 chars :-)
13:37:44 <csatari> It works well.
13:38:22 <matjazp> ok that covers the review queue
13:38:37 <matjazp> did we miss smthng?
13:38:59 <kmARC> okay sorry guys, bad news
13:39:15 <kmARC> I only managed to run devstack with two NICs if we want to start VMs
13:39:23 <kmARC> however on dreamhost I can't add another one
13:39:51 <ildikov> hmm
13:40:03 <ildikov> there are still things that we can do
13:40:06 <matjazp> kmARC : can we contact someone at Dreamhost?
13:40:08 <ianychoi_phone> Hmm...
13:40:33 <ildikov> kmARC: we can ask Stefano, if this is an issue for us now
13:40:34 <kmARC> (devstack would set up a bridge, which then in turn i guess needs promisc mode nics, which isn't something that you will get in a cloud environment, however if it's on a private network, like in the vagrant config, then it works)
13:40:39 <matjazp> kmARC : or is it not technically supported?
13:40:55 <kmARC> I think it can be a quota issue, so then I could create my own private network
13:41:07 <kmARC> but first let's decide how important it is for us to be able to run VMs
13:41:37 <ildikov> kmARC: we might test basic commands, but I think we can live without that
13:41:51 <kmARC> me too
13:41:53 <csatari> +1
13:41:57 <ildikov> kmARC: it's not an OpenStack training that's about the software itself
13:42:08 <ildikov> so no one should complain
13:42:13 <csatari> Yes and devstack is only one tool what we use.
13:42:23 <ildikov> let's think about exercises that does not require to start a VM
13:42:49 <csatari> list images
13:42:56 <ildikov> also we can still say that let's do a group exercise on one laptop with local VM
13:43:05 <csatari> or flavors
13:43:39 <matjazp> hmmm.. if Dreamhost can add a new nics easily, than we can still use it. If not, we can't do anything about it anyway... too close to the training
13:43:46 <ildikov> kmARC: we can also give the exercise to them to figure out why they can't start a VM ;)
13:43:53 <csatari> :)
13:44:03 <ianychoi_phone> :)
13:44:24 <matjazp> let's make that a closing exercise
13:44:30 <matjazp> debugging neutron
13:44:32 <ildikov> matjazp: right, we're pretty close for that
13:44:46 <ildikov> matjazp: that sounds like a cruel one :)
13:44:55 <matjazp> over IPv6 only network
13:45:51 <matjazp> anything else for upstream training?
13:45:57 <matjazp> or can we move on?
13:46:04 <csatari> I have one question
13:46:27 <csatari> I git review -d out this change: https://review.openstack.org/#/c/386752/
13:47:16 <csatari> After compiling it the training-guides/doc/upstream-training/build/slides/index.html us half chinese half korean and some english.
13:47:34 <csatari> Like: "OpenStack Upstream Training の開催日時および開催場所"
13:47:39 <matjazp> ?
13:47:41 <csatari> What do I do wrong.
13:47:51 <matjazp> ianychoi_phone: smthng with translation?
13:48:02 <ianychoi_phone> Hmm.. some translations are included but not the file nope
13:48:03 <matjazp> csatari : did you changed anything?
13:48:04 <ildikov> I don't use git review, what's '-d'?
13:48:14 <ianychoi_phone> ildikov: detach from gerrit
13:48:15 <matjazp> download a review in a branch
13:48:15 <csatari> Not yet
13:48:30 <ildikov> hmm, interesting
13:48:32 <ianychoi_phone> csatari: does you have some uncleaned files?
13:48:38 <csatari> git review -d 386752
13:48:49 <matjazp> Download change from Gerrit into a local branch. The branch will be named after the patch author and the name of a topic.  If the local branch already exists, it
13:48:49 <matjazp> will attempt to update with the latest patchset for this change.
13:48:56 <csatari> gets the review branch to my machine, so I can compile the docs/
13:49:10 <ianychoi_phone> Or sharing your tox execution logs to paste.openstack.o.o would be good
13:49:36 <csatari> I'm clean.
13:49:52 <ianychoi_phone> Strange.. at least Jenkins build is fine :)
13:50:22 <ianychoi_phone> http://docs-draft.openstack.org/52/386752/5/check/gate-training-guides-tox-doc-publish-checkbuild/8130760//publish-docs/upstream-training/
13:52:57 <ianychoi_phone> csatari: please share tox execution full log. Top lines from local library versions are helpful to debug your situation
13:53:40 <csatari> http://pastebin.com/U1gW1gA2
13:53:43 <matjazp> ok, it's 8 min to the end... anyone has anything else to discuss? this is the last meeting before training
13:53:55 <matjazp> we can debug this later
13:54:13 <matjazp> #topic aob
13:54:18 <csatari> +1
13:54:23 <ildikov> just please keep an eye on the review queue during the week
13:54:34 <matjazp> ildikov : sure
13:54:43 <ildikov> otherwise we should be fine, or well, it is what it is at this point
13:54:56 <matjazp> I hope to see you all there
13:55:03 <ianychoi_phone> Yep
13:55:25 <ianychoi_phone> I will be only Friday
13:55:44 <ianychoi_phone> But.. Prior meetings would be welcome!
13:55:54 <matjazp> ianychoi_phone : yes, I hope we'll meet at the docs meetup
13:56:32 <ianychoi_phone> matjazp: let's try to meet on lunch time first :)
13:57:20 <matjazp> ianychoi_phone : yup, we can all sync over ML
13:57:32 <ianychoi_phone> Yep
13:57:45 <matjazp> ok.. that's it, I guess
13:57:53 <matjazp> thanks for your time
13:58:02 <ildikov> yeap, ML should be fine for sync
13:58:02 <matjazp> see you all next week
13:58:11 <ildikov> see you guys next week
13:58:17 <ildikov> safe travels everyone!
13:58:18 <ianychoi_phone> Thank you all! Let's wish for successful upstream training!
13:58:19 <matjazp> bye
13:58:27 <ildikov> ianychoi_phone: tnx :)
13:58:53 <ianychoi_phone> :)
13:58:58 <ianychoi_phone> Bye all
13:59:03 <kmARC> bye bye
13:59:05 <ildikov> Bye
13:59:18 <matjazp> #endmeeting