13:01:18 <matjazp> #startmeeting training-guides
13:01:19 <openstack> Meeting started Tue Nov 15 13:01:18 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:23 <openstack> The meeting name has been set to 'training_guides'
13:01:28 <matjazp> hey all
13:01:28 <ildikov> o/
13:01:29 <matjazp> roll call
13:01:45 <matjazp> hey ildikov
13:01:46 <kmARC> o/
13:01:58 <ildikov> hi matjazp
13:02:15 <ianychoi> hi matjazp kmARC ildikov
13:02:28 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:02:37 <matjazp> hey kmARC ianychoi
13:03:05 <ianychoi> Hello all!
13:03:09 <matjazp> how are you guys? rested from BCN summit? ;)
13:03:43 <ianychoi> It was so great to see matjazp for the 1st time offline, although I could not see ildikov and kmARC
13:03:48 <ildikov> yeap, getting there :)
13:04:07 <ildikov> yeap, my bad sorry, I got too overloaded during the week :(
13:04:42 <ianychoi> ildikov, that's pretty fine (and I more want to go to Boston to see others!)
13:05:13 <matjazp> we have a usual agenda, so nothing special
13:05:31 <matjazp> there's nothing to review
13:05:41 <matjazp> no lingering action items
13:05:54 <matjazp> clean slate :)
13:06:02 <ianychoi> I think it would be much better if we discuss: 1) feedback from BCN upstream training 2) tagging current upstream training material
13:06:03 <ildikov> we had a retrospective meeting last week with the guys and girls who helped out on site
13:06:12 <matjazp> #topic Upstream training
13:06:18 <ildikov> here is the etherpad with the outcome: #link https://etherpad.openstack.org/p/upstream-training-barcelona-retrospective
13:06:40 <matjazp> ildikov : nice
13:07:10 <ildikov> additionally we have a feedback Google doc with responses from students for our survey #link https://docs.google.com/spreadsheets/d/1an2T3twz6rsJhL-sb08uce7hmtSNsc5TLY3F1mGYEUU/edit#gid=0
13:07:30 <ianychoi> Thanks a lot.. so nice!
13:07:30 <ildikov> diablo_rojo_phon can give access rights if anyone has issues to open the document
13:07:32 * diablo_rojo_phon sneaks in late
13:07:38 <matjazp> hey diablo_rojo_phon
13:07:43 <ildikov> diablo_rojo_phon: good morning :)
13:08:11 <ianychoi> diablo_rojo_phon, hihi!
13:08:26 <ildikov> the basic outcome of the retro and feedback form is more interactions and more hands-on practice
13:08:38 <matjazp> ildikov : does it make sense to distill this feedback to a few graphs and publish it somwhere? Superuser? ;)
13:08:40 <ildikov> this is where we would like ot move the training
13:09:05 <ildikov> matjazp: we have an article coming, it's under final edits
13:09:22 <diablo_rojo_phon> kmARC: and ildikov and I already have written an article for superuser
13:09:23 <matjazp> ildikov: great work!
13:09:34 <diablo_rojo_phon> It should be posted by the end of the week I think.
13:09:46 <ianychoi> Great work! I really miss an article for upstream training!
13:09:53 <ildikov> and also once more thanks to all of you for all the effort on this prior to the event!!!
13:10:13 <ildikov> diablo_rojo_phon: +1, thanks for the update
13:10:32 <ildikov> with diablo_rojo_phon we also plan to reach out to the dev community to have more people involved
13:10:35 <diablo_rojo_phon> ildikov: no problem :)
13:11:01 <ildikov> we would also like to bring parts of the training to local events, like OpenStack Days and make it easier to pick up modules for meetups as well
13:11:42 <ildikov> it would be great to have the training formatted more as a hands on practice with quizz and exercises
13:11:45 <matjazp> ildikov: we should prepare a few "scenarios" for using this material in shorter trainings (e.g. openstackDays, Meetups, Usergroups, etc.)
13:12:00 <ildikov> and have a solutions block for those who're all about reading :)
13:12:21 <matjazp> ildikov: hehehe.. beat me to it with typing
13:12:38 <ildikov> matjazp: I agree that it would be great to have more guidelines than what we have today
13:12:50 <ildikov> matjazp: we need to work more on the content first though IMHO
13:13:10 <ildikov> matjazp: :)
13:13:16 <ianychoi> For Korean, I am designing a study for 2hr (bi-weekly) x 6 days and all study participants are highly encouraged to paricipate Korean 2nd upstream training next Feb -> That is what I am planning, to stay upstream training with OpenStack Korea user group
13:13:33 <matjazp> ildikov: slice it to even smaller pieces, so we can combine it in different scenarios
13:13:51 <ildikov> ianychoi: sounds very nice, please give us feedback how it goes! :)
13:14:02 <matjazp> longer one for longer, full day trainings, shorter one for shorter events like user groups
13:14:03 <ianychoi> ildikov, sure :)
13:14:41 <ildikov> matjazp: on one hand yes and also cut the lecture parts as much as possible
13:15:39 <ianychoi> For PyCharm, the request URL can be seen on: https://wiki.openstack.org/wiki/Pycharm
13:16:06 <ianychoi> I think a kind of LP activities are needed to receive PyCharm license
13:17:31 <matjazp> ianychoi : why not use community edition?
13:19:08 <ianychoi> matjazp, hmm... yep for upstream training, community or educational version may be also good
13:20:04 <matjazp> ianychoi: developers are like snowflakes.. everyone is using a different IDE/editor ;)
13:20:46 <ianychoi> :-)
13:21:06 <ildikov> :)
13:22:33 <matjazp> ok, do we need to define some action items here? diablo_rojo_phon and ildikov will send a link to the article to the Docs ML, ok?
13:22:45 <ianychoi> +1
13:22:50 <ildikov> matjazp: yeap, we will do
13:23:07 <ildikov> we will use it as an advertisement on the dev ML too
13:23:21 <ildikov> we also need to remove duplications from the slides as we have some currently
13:23:47 <matjazp> #action diablo_rojo_phon ildikov publish link to the upcoming Superuser article on  ML
13:23:47 <diablo_rojo_phon> Easy enough to fix :)
13:23:48 <ildikov> I would go for deleting what's duplicated and then continue with rethinking and reorganizing what we have
13:23:54 <ianychoi> By the way, ildikov will you go to PTG and open a session for upstream training discussion and/or participation?
13:24:03 <matjazp> ildikov : just submit a bug
13:24:05 <ianychoi> Then I think I will also go there
13:24:06 <diablo_rojo_phon> ildikov: +1
13:24:22 <ildikov> yeap, both diablo_rojo_phon and I will be there
13:24:43 <ildikov> we planned to organize something, but we haven't figured it fully out yet
13:25:14 <ildikov> I hope we will have movement before
13:25:22 <ianychoi> I see. I indeed want to go to PTG at least from i18n team activities
13:25:29 <ianychoi> Lots of movement :)
13:25:34 <ildikov> we can reach out to people directly in Atlanta if we don't have enough people
13:25:59 <ildikov> ianychoi: cool, hope to see you there! :)
13:26:04 <ianychoi> Yep okay :)
13:26:22 <matjazp> ildikov: you mean a session about Upstream training and the actual training, right? will there even be a need for Upsteam training at the PTG?
13:26:27 <ildikov> matjazp: yeap, I will submit an umbrella one
13:26:46 <ianychoi> And.. are there anyone who would like to change all bug status to invalid and/or fix-released in openstack-dev-sandbox LP? If there no one, then I will do it
13:26:50 <ildikov> matjazp: actual training?
13:27:12 <ildikov> matjazp: PTG itself is for people who're already community memebrs and participating/contributing somewhat actively
13:27:20 <ianychoi> matjazp, I think it will not be an actual upstream training
13:27:25 <matjazp> ildikov : yes, exactly
13:27:27 <ildikov> matjazp: so we will not have training there, the next one will be in Boston
13:28:05 <matjazp> oh... i mistyped my line... "and NOT the actual training, right?"
13:28:08 <matjazp> now I see
13:28:12 <matjazp> what you mean
13:28:19 <matjazp> we're on the same page
13:28:25 <ildikov> matjazp: yeap, in that case you were right :)
13:28:40 <ianychoi> #link https://bugs.launchpad.net/openstack-dev-sandbox
13:28:53 <ianychoi> There are too many bugs from BCN upstream training
13:29:19 <matjazp> ianychoi : you volunteer to manage them? ;)
13:29:22 <ianychoi> I think changing all to invalid would be a good idea. Right?
13:29:26 <ianychoi> matjazp, sure :)
13:29:37 <matjazp> ianychoi : great :))
13:30:08 <matjazp> #action ianychoi cleans bug queue from BCN training  https://bugs.launchpad.net/openstack-dev-sandbox
13:30:18 <diablo_rojo_phon> Thank you ianychoi :)
13:30:21 <ianychoi> Thanks for adding an action, matjazp
13:30:25 <ildikov> ianychoi: yeap, I think 'invalid' will do
13:30:32 <ildikov> ianychoi: also thanks! :)
13:30:47 <ianychoi> diablo_rojo_phon, ildikov : It's my pleasure :-)
13:31:30 <matjazp> ok, anything else here? smthng we missed?
13:31:55 <ildikov> I think we touched on the basics
13:32:04 <ildikov> diablo_rojo_phon: kmARC: anything to add?
13:32:19 <diablo_rojo_phon> Nope :)
13:32:24 <kmARC> not from me either
13:32:24 <matjazp> moving on then
13:32:33 <matjazp> #topic training guides
13:33:12 <matjazp> will this also get some developer attention? ;)
13:33:39 <matjazp> I think the Upstream training is doing really great, can we also restart the effort here?
13:34:18 <ildikov> matjazp: the comments regarding the content above was kind of about that I guess
13:34:19 <matjazp> with some basic materials for USERS of OpenStack clouds
13:34:45 <matjazp> ildikov: what do you mean?
13:34:46 <ildikov> matjazp: like user guide type of training?
13:35:16 <matjazp> ildikov : well yes, teach users what cloud offers and how to use openstack
13:35:27 <ianychoi> I still think training guides itself is beneficial to users, and it needs to be more relevant to training purposes rather than other documentations (e.g., user-guide)
13:35:56 <ildikov> matjazp: I think I misunderstood the first part
13:36:30 <matjazp> idlikov: effort here == training guides material (minus Upstream training) ;)
13:36:58 <ildikov> matjazp: yeap, now I figured, I'm not that up to date with that though
13:37:23 <ildikov> matjazp: we could get some eyes on that from operators though I think
13:37:30 <ianychoi> For last six months, I wanted to more focus on training guides rather than upstream training, but It was happy for me to more focus on upstream training with ildikov diablo_rojo_phon kmARC matjazp csatari katomo and many other contributors :)
13:38:33 <matjazp> ianychoi : yes, Upstream training is doing great, what I'm asking is if we can do something about creating the training material for cloud users, not just prospective oepnstack developers
13:39:15 <matjazp> this is of course a complementary material with other efforts like cloud hackatons etc.
13:39:36 <ianychoi> Oh with hackathon would be a great idea
13:40:19 <ianychoi> matjazp, may be writing an app on a top of OpenStack using OpenStack REST API?
13:40:51 <matjazp> I can bet that all of us did openstack101 lectures, right? introduce openstack and how to use it to the beginners
13:41:29 <matjazp> ianychoi: thats covered with firstapp guide (or something like that)
13:42:10 <matjazp> http://developer.openstack.org/firstapp-shade/
13:43:49 <matjazp> I'm talking about creating slides that presenters can just take and use at the introductory openstack talks at user groups/student meetups/etc
13:44:07 <ianychoi> matjazp, thanks for the link. But I think documentation and training are different. To develop this, training guides material needs to be organized like a real training material, such as Microsoft Official course book
13:44:09 <ianychoi> #link https://www.microsoft.com/en-us/learning/course.aspx?cid=20483
13:44:23 <ianychoi> (Just a reference for such details)
13:44:37 <matjazp> ianychoi : yes, the link was for reference, it is not a training material per se
13:45:30 <kmARC> lol
13:47:16 <ianychoi> Then... I agree that more user and 101 side on training guides would be much beneficial, rather than current associate guide
13:47:23 <ianychoi> #link http://docs.openstack.org/draft/training-guides/
13:48:31 <matjazp> ok, time's almost up.. moving on, so we don't run out
13:48:42 <ianychoi> matjazp, how about using training guides material as 'training guides for upstream training mentors?'
13:49:23 <matjazp> ianychoi: to be a mentor, you need to already know a lot about openstack
13:49:47 <matjazp> ok, we can talk about this on the next meeting
13:49:49 <matjazp> #topic any other business
13:49:49 <ianychoi> matjazp, hmm good point :)
13:50:02 <ianychoi> And... I want to ask to all: Would it be a good idea to make a branch: stable/newton for current upstream training material? It seems that for the number of words, more than 30% has been changed. IMO branching would be a good idea.
13:50:17 <ildikov> what schedule will we use?
13:50:25 <matjazp> contonuos publishing
13:50:33 <matjazp> continuous
13:50:39 <ildikov> I still like ISO week better as it's consistent
13:50:50 <ianychoi> For translation (i18n) sides, branching is a good idea :)
13:51:08 <ildikov> ianychoi: I'm not sure versioning for training material is that useful
13:51:33 <ildikov> ianychoi: we would like people to get the latest most up to date version
13:51:41 <matjazp> to develop for openstack, you need to use what we use, no need to know what we were using in the past ;)
13:51:59 <matjazp> it just add to the confusion
13:52:08 <ildikov> matjazp:
13:52:11 <ildikov> +1
13:52:33 <matjazp> ildikov: I don't care what we use.. we can use ISO nr for weeks
13:52:50 <ianychoi> Hmm.. okay For i18n side, I wanted to have translators translation period for training guides, but good point from ildikov and matjazp :)
13:52:57 <ildikov> matjazp: I think we haven't agreed yet, that's why I'm asking
13:53:00 <matjazp> it was just easier for me to remember on the top of my head if we have IRC meeting this week or not
13:53:30 <matjazp> if we use ISO #, I'll just look in my calendar instead :)
13:53:37 <matjazp> what do others prefer?
13:53:51 <ildikov> matjazp: I'm the opposite :)
13:53:55 <matjazp> kmARC ianychoi diablo_rojo_phon
13:54:19 <kmARC> I don't have an opinion TBH :-)
13:55:03 <diablo_rojo_phon> Whatever works. Just let me know.
13:55:03 <matjazp> I'll leave the reservation for every week, though. We may need weekly meetings before the Summit
13:55:35 <matjazp> ianychoi: ? opinions? ISO nrs or week nr of the month?
13:55:44 <ianychoi> I don't have strong opinion to both but 1) docs team now restricts to have one meeting per month. training-guides specialty team requested twice per month. Then just 1st/3rd weeks in month would be more logical 2) For my usual schedule, following ISO weeks is better, since my local upstream training study in Korea will be bi-weekly :)
13:56:19 <matjazp> oh.. right. I talked with Lana and she's OK with meetings twice a month
13:56:38 <ildikov> if we try to recruit more people I think ISO weeks is easier to follow
13:56:48 <matjazp> ildikov: :)
13:56:57 <ildikov> although we can separate mentor and actual training format activity from the material
13:57:31 <ildikov> if we think that makes sense and then we can have the schedule of this meeting according ot the regular docs guidelines
13:57:37 <matjazp> ok, lest just use ISO week numbers, like other projects do, ok? any objections?
13:57:48 <ianychoi> Then.. I think at least one needs to attend docs team IRC meeting regularly. I think the main purpose of such restriction is that many speciality teams attend their meetings but do not attend docs team meetings..
13:58:06 <matjazp> ianychoi : I'll take care of that
13:58:23 <matjazp> ianychoi : I can also report to Lana over mail
13:58:33 <ildikov> matjazp: cool, tnx!
13:58:36 <matjazp> I was dont that to the Etherpad anyway
13:58:42 <ianychoi> matjazp, thanks! :) Actually new meeting time is good but it is 6am in Korea.. T.T
13:58:44 <matjazp> dont==doing
13:59:01 <ianychoi> Then me also +1 for ISO weeks  :)
13:59:26 <matjazp> #info we follow ISO week numbers for the IRC meeting
13:59:37 <ianychoi> final question.. then may be
13:59:37 <matjazp> time's up
13:59:42 <ianychoi> even? or odd weeks?
13:59:49 <ianychoi> current week is even week:)
14:00:11 <ianychoi> Let's finish and discuss on #openstack-doc irc channel
14:00:16 <matjazp> ok
14:00:18 <matjazp> bye all
14:00:19 <ildikov> I'm fine with even if we don't want to confuse ourselves more :)
14:00:27 <matjazp> #endmeeting