13:00:54 <matjazp_> #startmeeting training-guides
13:00:55 <openstack> Meeting started Tue Nov 29 13:00:54 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:58 <matjazp_> hey all
13:00:58 <openstack> The meeting name has been set to 'training_guides'
13:01:02 <matjazp_> roll call
13:01:07 <ianychoi> matjazp_, hello!
13:01:30 <matjazp_> hi ianychoi
13:02:04 <ianychoi> How are you going? November is almost being finished..
13:02:47 <matjazp_> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:03:16 <matjazp_> ianychoi: busy.. preparing for the December madness, I guess ;)
13:03:56 <ianychoi> Yep.. December seems to be short.. And I have lots of things to do in December..
13:04:55 <matjazp_> looks like there's just the two of us.. ildiko is in a conference call (notified via ML)
13:05:04 <matjazp_> #topic Review of action items from the previous meeting
13:05:17 <matjazp_> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-11-15-13.01.html
13:05:28 <ianychoi> Aha.. I see
13:05:44 <ianychoi> I did cleanup for Launchpad and also sandbox repository
13:05:55 <ianychoi> #link https://bugs.launchpad.net/openstack-dev-sandbox
13:06:05 <matjazp_> #info Upstream training article in Superuser magazine: http://superuser.openstack.org/articles/openstack-upstream-training-revamp/
13:06:06 <ianychoi> #link http://git.openstack.org/cgit/openstack-dev/sandbox/tree/
13:06:20 <matjazp_> great!
13:06:45 <ianychoi> Yep I have read this article so great!
13:06:46 <matjazp_> #info ianychoi cleaned Launchpad and sandbox repo
13:07:33 <matjazp_> that's it for past action items
13:07:35 <matjazp_> moving on
13:07:37 <matjazp_> #topic Upstream training
13:07:38 <ianychoi> Yep
13:08:03 <matjazp_> looking at agenda
13:08:12 <matjazp_> you have a proposal?
13:08:19 <ianychoi> Yep.. I wrote an idea
13:08:58 <ianychoi> I think it would be great if upstream training participants will have exact Stackalytics userinfo through actual upstream training
13:09:25 <matjazp_> you mean like a copy just for the training?
13:09:35 <matjazp_> fake stackalytics?
13:10:07 <ianychoi> No. Current Stackalytics has both Stackalytics development sources and userinfo data
13:10:12 <matjazp_> or do you propose that they commit their data into the real Stackalytics as an exercise?
13:10:52 <ianychoi> I am suggesting to add userinfo on real Stacklytics but to do that separation of userinfo from current openstack/stackalytics repository is needed
13:10:54 <matjazp_> oh, now I get it.. split current Stackalytics into two repos?
13:11:01 <ianychoi> Yep :)
13:11:31 <ianychoi> And then.. I think having core rights for upstream training leader(s) would be acceptable
13:11:33 <matjazp_> that's is not the scope of the training guides... we should discuss this with stacklaytics team?
13:12:22 <ianychoi> I already discussed with Stackalytics team and ildikov is the right person for this topic. That's why I have brought this proposal with upstream training plan.
13:13:13 <matjazp_> why is this important? surely participants can wait a few days to get their patches merged into the repo... stackalytics is not real time service anyway... as I understand, it works in batches, right?
13:13:26 <matjazp_> stackalytics team is for the split?
13:14:05 <ianychoi> For Stackalytics, OpenStack Foundation has a plan to migrate from stackalytics.com into stackalytics.openstack.org.
13:14:20 <matjazp_> yes, I know
13:14:35 <matjazp_> but the team that manages it will stay the same, or not?
13:14:41 <ianychoi> I think one of strengths in upstream training is that right and fast feedback during actual training
13:15:10 <ianychoi> matjazp_, good question. I do not know much.. for details
13:15:47 <ianychoi> What I currently know is that I met Ilya Shakat, a key Stackalytics developer on Barcelona Summit
13:15:55 <ianychoi> And.. Ilya Shakat said that he spoke with Ildiko Vansca [ildikov] on the perspective to give Foundation more governance on the Stackalytics tool.
13:16:00 <matjazp_> I think that an exercise at the training where they commit a patch with their data into stackalytics is a good one
13:16:47 <ianychoi> So... currently, I wanted to discuss 1) is this kind of exercise good or not? and 2) how to accomplish this
13:16:55 <matjazp_> but eho is or isn't in the core team for it is a separate question
13:17:13 <matjazp_> eho=who
13:17:59 <ianychoi> matjazp_, I agree. But at least having one core member in actual upstream training will be needed
13:18:13 <matjazp_> why?
13:18:38 <matjazp_> results are not fed into stackalytics in real time, right?
13:18:45 <ianychoi> In my opinion, participants may have errors for their patches
13:18:50 <matjazp_> so it makes no sense to speed up the patch merging
13:19:41 <matjazp_> yes, they can make mistakes, so anyone at the training can review their patch
13:20:02 <matjazp_> why is it important to merge their patches as soon as possible?
13:20:13 <ianychoi> Yep.. just reviewing their patches would be also sufficient
13:20:39 <matjazp_> so who is or isn't in the core team is not connected to the actual training ecent, right?
13:20:44 <matjazp_> ecent=event
13:21:16 <ianychoi> I just thought that accomplishing one thing during upstream training will give more satisfaction. You're right
13:21:48 <matjazp_> exercise is good, though
13:21:59 <matjazp_> can I make you an action intem?
13:22:23 <ianychoi> Hmm.. one possible action item is to discuss with ildikov :)
13:22:35 <ianychoi> to listen to Foundation's perspective on Stackalytics
13:23:24 <matjazp_> ok, then just bring this up on the ML, and we can discuss this there
13:23:51 <ianychoi> ok :)
13:23:52 <matjazp_> so you won't develop an exercise for nothing, if we decide against
13:24:08 <ianychoi> Aha development as an exercise.. okay
13:24:27 <ianychoi> I will take care if you agree with it
13:24:27 <matjazp_> #action ianychoi sends a proposal to develop an exercise for inserting participants info into a Stackalytics on the ML
13:24:43 <matjazp_> is this ok with you?
13:24:50 <ianychoi> matjazp_, yep thanks
13:24:54 <matjazp_> we can discuss it there
13:25:11 <matjazp_> since we have twice monthly IRC meetings
13:25:44 <ianychoi> Yep next meeting would be also nice
13:26:36 <matjazp_> #info actively looking for ppl to join the project, see http://lists.openstack.org/pipermail/openstack-docs/2016-November/009382.html
13:28:13 <matjazp_> review queue is empty
13:28:29 <matjazp_> anything else here?
13:28:39 <ianychoi> Nope for review que
13:28:42 <ianychoi> queue
13:30:10 <matjazp_> hmm.. was the branching model in review https://review.openstack.org/#/c/403315/ really missing? or is it something old that was not deleted from slide-index and now we reinserted it again in the main landing page?
13:31:00 <matjazp_> what bothers me is that it's file name is not in the new format, so maybe it is an old content
13:31:10 <ianychoi> AFAIK.. there were opinion(s) that branching model would not be best fit into current upstream training
13:31:54 <ianychoi> I could not track all of things but... it would be correct.. just from my rememberance
13:32:47 <ianychoi> In my opinion, revising content on branch model would be good for Boston upstream training
13:32:59 <matjazp_> anyway, we do have some duplication in content that we need to fix, see bugs queuehttps://bugs.launchpad.net/openstack-training-guides/+bug/1642691
13:32:59 <openstack> Launchpad bug 1642691 in OpenStack Training Guides "Upstream training slides have duplications" [Undecided,Confirmed]
13:33:52 <ianychoi> What would 'Duplication' means..?
13:33:58 <matjazp_> if it's an old content, we can move it to the archive later
13:34:24 <matjazp_> more than one slide about the same content, as I understand it
13:35:22 <matjazp_> we still have a mixture of the old and new content, with some overlapping
13:35:42 <ianychoi> I agree with this: some part duplicates
13:36:40 <matjazp_> ok, so this bug will take care if the branching model is an old content
13:36:43 <matjazp_> moving on?
13:36:50 <ianychoi> okay
13:36:53 <matjazp_> #topic training guides
13:37:01 <matjazp_> nothing new here
13:37:22 <matjazp_> still very slow progress
13:37:40 <ianychoi> #info http://git.openstack.org/cgit/openstack/training-guides/tree/README.rst updated training-guides description
13:38:14 <matjazp_> yes, but that is for both projects
13:38:20 <ianychoi> yep :)
13:38:53 <matjazp_> ok, moving on to the AOB?
13:39:19 <ianychoi> +1
13:39:21 <matjazp_> #topic any other business
13:39:34 <matjazp_> anything left to discuss?
13:40:54 <ianychoi> Thanks for caring with updating specialty team: http://lists.openstack.org/pipermail/openstack-docs/2016-November/009352.html
13:41:28 <matjazp_> oh, no problems.. will do the same this week
13:42:10 <ianychoi> :) Now I am planning for my participation on PTG.
13:42:21 <ianychoi> Do you want to discuss more on training-guides during PTG?
13:42:47 <ianychoi> I think Ildiko will open a topic for encouraging upstream training participation I think..
13:42:52 <matjazp_> I don't think I can be there... clashes with my schedule at the Uni
13:43:15 <ianychoi> That's unfortunate..
13:43:38 <ianychoi> Aha and, I have another question
13:44:01 <ianychoi> In your country, will it be the Christmas holiday from Dec 24 to Jan 1?
13:44:13 <matjazp_> yes
13:44:26 <ianychoi> In my country (Korea), Dec 27 is not a holiday.. (Oh my ... T.T)
13:44:35 <ianychoi> Then Dec 27 meeting will be canceled :)
13:45:13 <matjazp_> I think so, but we can discuss this at the next meeting
13:45:43 <ianychoi> Okay
13:45:45 <matjazp_> I'll write this down so we can remember
13:45:50 <ianychoi> +1
13:46:32 <matjazp_> #action decide about IRC meeting on Dec 27
13:46:53 <matjazp_> so we don't forget to discuss this on the next meeting
13:47:05 <matjazp_> anything else? I'm good.
13:47:08 <ianychoi> Good
13:47:16 <ianychoi> No more items from me
13:47:24 <matjazp_> ok, let's wrap this up
13:47:29 <matjazp_> thanks for your time!
13:47:41 <ianychoi> Thaks matjazp_ !
13:47:43 <matjazp_> see you in two weeks!
13:47:45 <matjazp_> bye
13:48:03 <ianychoi> bye!
13:48:06 <matjazp_> #endmeeting