13:01:06 <matjazp> #startmeeting training-guides
13:01:07 <openstack> Meeting started Tue Dec 13 13:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:10 <openstack> The meeting name has been set to 'training_guides'
13:01:16 <matjazp> hi
13:01:20 <matjazp> roll call
13:01:55 <ildikov> o/
13:02:08 <kmARC> o/
13:02:21 <matjazp> hey ildikov kmARC
13:02:27 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:02:38 <diablo_rojo_phon> Hello :)
13:02:42 <matjazp> hey diablo_rojo_phon
13:03:07 <matjazp> #topic Review of action items from the previous meeting
13:03:26 <matjazp> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-11-29-13.00.html
13:03:48 <matjazp> ianychoi you here?
13:04:23 <ildikov> I read the Stackalytics idea in the meeting logs
13:04:35 <ildikov> I think it's too much effort for minimal outcome
13:05:07 <matjazp> well I guess Ian changed his mind also, since there were no email to the ML
13:05:25 <ildikov> I would rather invest in putting together something dummy in the Sandbox repo and have groups of people hacking on that
13:05:38 <ildikov> matjazp: I didn't see one either
13:05:57 <diablo_rojo_phon> ildikov: +1
13:06:00 <ildikov> I thought to share my views here, so it's documented
13:06:52 <matjazp> ildikov: trainees could update their affiliation into the Stackalytics at the end, that's not a lot of effort
13:07:25 <matjazp> ildikov : we could put that in the finalizing activities/exercises
13:07:42 <ildikov> matjazp: we ran out of time during the last occasion
13:08:20 <matjazp> ok, it's not important
13:08:26 <ildikov> matjazp: and I think we should work more on having more time on the code/docs and practice on those things to make people interested enough to stay
13:08:40 * mhayden stumbles in late
13:08:46 <matjazp> moving on, we'll talk about Dec 27 at the AOB topic
13:09:00 <matjazp> #topic Upstream training
13:09:04 <matjazp> hey mhayden
13:09:10 <ildikov> mhayden: hi. thanks for joining :)
13:09:24 <mhayden> glad to join!
13:09:30 <diablo_rojo_phon> mhayden: hello :)
13:09:30 <matjazp> ildikov: nice feedback for the Superuser article :)
13:09:58 <ianychoi> hi all
13:10:02 <ildikov> matjazp: thanks, co-production with kmARC and diablo_rojo_phon :)
13:10:14 <ianychoi> I am participating another meeting I will follow up
13:10:21 <matjazp> ok ianychoi
13:10:26 <ildikov> as promised I created the bug regarding duplications in the material
13:10:30 <ianychoi> hi diablo_rojo_phon and ildikov !
13:10:37 <ianychoi> hi kmARC :)
13:10:39 <ildikov> ianychoi: hi :)
13:11:11 <ildikov> as a starting point on improving what we have I put together a list of exercises we have today: #link https://etherpad.openstack.org/p/upstream-training-exercises
13:11:50 <matjazp> great
13:12:08 <ildikov> I think we need more and also more group exercises as people worked well together and that's a good practice anyhow
13:12:20 <matjazp> I was also talking with Training labs team (Roger and Pranav) at the summit
13:12:23 <diablo_rojo_phon> Agreed
13:12:49 <ildikov> matjazp: what was the outcome of that?
13:12:50 <matjazp> they'll be working on devstack instalation
13:12:59 <matjazp> roger has a PoC
13:13:13 <matjazp> anyone interested in testing it before it goes public?
13:13:46 <ildikov> matjazp: FYI, we have a full VM image put together by kmARC currently for the upstream training
13:13:57 <matjazp> ildikov : I know
13:14:22 <matjazp> Taining labs solution is pure bash
13:14:30 <ildikov> matjazp: do you have the link handy for that PoC?
13:14:58 <matjazp> just a moment
13:15:04 <matjazp> I have it on the email
13:15:17 <matjazp> https://github.com/ideaship/training-labs.git
13:15:25 <matjazp> Just switch to the branch devstack_02 and run ./osbash.sh -b devstack.
13:15:41 <matjazp> Roger: It should set up a VM for devstack, create a stack user and install
13:15:41 <matjazp> devstack (just to see if it works :)). I was at least able to log into the
13:15:42 <matjazp> dashboard. Is this going in the right direction for you?
13:15:52 <diablo_rojo_phon> Why does he not just put a wip together and push it to Gerrit?
13:16:00 <matjazp> ^ that was form Roger's mail
13:16:30 <diablo_rojo_phon> Just curious. Would be easier to give feedback.
13:16:42 <matjazp> that's the next step
13:17:01 <matjazp> I guess he wants to test it in "private" beta before pushing it
13:17:21 <matjazp> sadly, I dodn't have time to test it yet
13:17:40 <matjazp> this December workload is maddening
13:17:58 <ildikov> is this multi-node by default?
13:18:07 <matjazp> not sure
13:18:15 <matjazp> their original cluster is
13:18:39 <matjazp> but it was not a good fit for us because it's not devstack baased
13:19:02 <matjazp> and we need to teach developers how to use devstack
13:20:03 <ildikov> it seems slightly a duplicated effort to what kmARC is doing to me
13:20:40 <diablo_rojo_phon> ildikov: +1
13:21:13 <diablo_rojo_phon> And it will be harder to use in class because it won't be uniform across all students systems.
13:21:15 <matjazp> it al depends if it lowers the barrier for some
13:21:41 <matjazp> bash based vs vagrant based
13:22:08 <matjazp> diablo_rojo_phon: why different?
13:22:36 <matjazp> if I understood correctly, it works on all systems, linux, mac and windows
13:22:52 <diablo_rojo_phon> The VM provided the same environment for all the students.
13:22:56 <ildikov> matjazp: lowers the barrier in the sense of running a command and getting a Devstack env in a VM or?
13:23:19 <matjazp> no, vagrant has its issues
13:23:24 <diablo_rojo_phon> Made it delightfully easy to answer questions and have the students help one another.
13:23:25 <matjazp> try to use it on suse
13:23:46 <matjazp> diablo_rojo_phon : yes, the same env for all is a must
13:24:20 <matjazp> so what I'm saying is not that we should support both options, but should use on or the other
13:24:49 <ildikov> we provide the full image to people too IIRC
13:25:15 <ildikov> kmARC: can you look into the training-lab activities?
13:25:39 <kmARC> Yes I will
13:26:07 <matjazp> we should definitely choose one solution only
13:26:11 <ildikov> kmARC: cool, thanks
13:26:34 <ildikov> training-lab I guess can be a landing repo for the option we choose
13:26:54 <matjazp> we're spread really thin here, so maybe "outsourcing" a piece like this could release some of the capacity for other tasks
13:27:18 <matjazp> ildikov: yes, my thought exatly
13:27:18 <ildikov> kmARC's solution/image worked like a charm during the training
13:27:37 <diablo_rojo_phon> ildikov: +1 :)
13:27:42 <matjazp> they would be glad to help us maintain whatever we choose
13:28:06 <diablo_rojo_phon> matjazp: Good to know.
13:28:15 <ildikov> that sounds good overall, I was more thinking about the space at this point
13:28:28 <matjazp> ildikov : space?
13:28:35 <ildikov> matjazp: thanks for the info
13:28:42 <ildikov> matjazp: repo logistics I meant
13:28:52 <matjazp> oh, the location for the training VM?
13:29:34 <ildikov> matjazp: we were thinking about where to upload kmARC's artifacts after the training
13:30:13 <matjazp> if the trainig labs will take care of maintaining the VM, it should be in their repo
13:30:24 <ildikov> matjazp: and the corresponding files to create it
13:30:36 <matjazp> if they wont, we can always just use our repo
13:30:47 <ildikov> matjazp: kmARC's image also contains IRC client and python IDE IIRC, so it's more than just Devstack
13:31:10 <matjazp> ok, to sum it up
13:31:22 <matjazp> 1. kmARC will look into Rogers PoC
13:31:29 <matjazp> kmARC: ok?
13:31:59 <matjazp> 2. we can sync with them if they are willing to maintain our training VM
13:32:38 <kmARC> matjazp: OK
13:32:54 <kmARC> ildikov: My image doesn't have IDE YET, but I'm working on it
13:32:57 <matjazp> 3. if not, we publish it in our repo instead and automate the building
13:33:12 <ianychoi> I think training-labs usually follows the steps in install-guides but including IRC client and python IDE for dev environment is good
13:33:33 <ildikov> kmARC: sorry, I mixed up the current state with the plans :S
13:34:24 <matjazp> #action kmARC looks into the Training labs devstack PoC
13:34:42 <ildikov> ianychoi: is that still the case if they build their things on Devstack?
13:34:55 <matjazp> #action matjazp syncs with Training labs to see if they are interested into maintaining a Devstack VM for training
13:35:48 <ianychoi> ildikov, the use of DevStack will be good if training participants will test API calls, but trystack can replace with such case..
13:36:32 <ildikov> ianychoi: I was just wondering how much it follows the install-guide in that case, I've never compared the two
13:36:51 <matjazp> based on the both tasks we can decide later (at the next meeting?) what we can use and where to publish it
13:37:00 <ildikov> matjazp: +1
13:37:33 <diablo_rojo_phon> Are we done with upstream training now? I wanna go back to bed :)
13:37:41 <ianychoi> ildikov, AFAIK training-labs now tries to extract bash commands from install-guide to prepare the same environment described in install-guide as much as possible
13:38:20 <matjazp> ianychoi : yes, that is their cluster solution
13:38:20 <ildikov> diablo_rojo_phon: mostly I think, please look into the etherpad with the exercises :)
13:38:36 <matjazp> ianychoi : Roger prepared just for us a PoC with devstack
13:38:39 <diablo_rojo_phon> Will do :)
13:38:49 <matjazp> good night, diablo_rojo_phon
13:38:55 <ianychoi> matjazp, oh nice :)
13:39:00 <ianychoi> diablo_rojo_phon, good night!
13:39:09 <ildikov> mhayden: we could use some thoughts and ideas from you too in the etherpad I posted above
13:39:12 <diablo_rojo_phon> Well it's morning, but early. Night :)
13:39:21 <mhayden> ildikov: i'll give it a look
13:39:24 <ianychoi> haha
13:39:28 <matjazp> diablo_rojo_phon : in that case, I take it back ;)
13:39:34 <ianychoi> mhayden, oh hi!
13:39:37 <ildikov> mhayden: greate, thank you
13:40:10 <mhayden> i like how some of the less technical, more social stuff is covered here
13:40:10 <ildikov> mhayden: if you add new ideas please keep the authorship colors or add your name so we know who to ask if there are any questions to it, etc.
13:40:12 <matjazp> ok, moving on? or is there anything left to discuss for Upstream training?
13:40:13 <mhayden> good thinking
13:40:37 <ianychoi> I agree to move on
13:41:05 <matjazp> #topic training guides
13:41:06 <ildikov> mhayden: I would like to make the lectures part of the training more social and interactive too, kind of "learn by playing" approach or more professionally using problem based learning more
13:41:25 <ianychoi> For training-guides, I do not have any new things to do... sorry
13:41:35 <ianychoi> to do or report..
13:41:47 <matjazp> ildikov : ah, should I switch the topic back to upstream?
13:42:15 <ildikov> matjazp: if there are no questions to the approach then we can move on
13:42:27 <matjazp> I'm good
13:42:37 <ildikov> currently I would like to collect ideas and then update the material based on what we collected
13:43:08 <ianychoi> ildikov, I agree to re-organize exercise and combine them if possible
13:43:35 <matjazp> ildikov : and of course shorten the training to one day, right?
13:43:52 <kmARC> :-S I don't want that
13:44:03 <kmARC> we don't have enough time like this either
13:44:16 <ildikov> matjazp: no, or at least I'm not aware of that
13:45:00 <matjazp> oh, right. we were discussing that for user groups and openstack days
13:45:49 <ildikov> matjazp: we were thinking about bringing some smaller modules to local events if we can make the parts of the material more let's say standalone
13:46:02 <ianychoi> For local upstream training, I think one day would be better but I do not want to shorten upstream trainings before Summit. Participants would so expect and enjoy 2 days!
13:46:20 <matjazp> ok, nothing to report about Training guides, maybe we should just move on to the AOB?
13:46:28 <ianychoi> +1
13:46:38 <matjazp> #topic any other business
13:46:53 <matjazp> decide about IRC meeting on Dec 27
13:47:15 <matjazp> I won't be there, so maybe we can just skip it
13:47:24 <mhayden> i can't make that one :/
13:47:32 <ianychoi> I think most people will be holidays.
13:47:42 <ildikov> I can be around, but I think it's better to just skip it, most people are out
13:47:47 <matjazp> agree
13:47:48 <ianychoi> +1 for skipping
13:48:04 <matjazp> #info we skip the Dec 27 IRC meeting
13:48:52 <matjazp> so see you all again on Jan 10, ok?
13:48:57 <ianychoi> Okay :)
13:49:04 <ildikov> matjazp: sounds good to me :)
13:49:10 <ianychoi> ildikov, will you have a meeting for upstream training during PTG?
13:49:32 <matjazp> heheehe.. no need to put that up for a vote
13:49:45 <ildikov> ianychoi: I plan to, will start to organize early Jan
13:50:15 <ildikov> ianychoi: I think most people can only think of the holidays by now anyway and trying to close last minute things before that :)
13:50:29 <ianychoi> ildikov, thanks. I am asking because it seems that most PTG meetings will be room-based according to PTG homepage..
13:51:04 <ianychoi> ildikov, yep let's discuss it next year!
13:51:07 <ildikov> ianychoi: I will look into that
13:51:24 <ildikov> ianychoi: thanks for the heads up
13:51:44 <ianychoi> ildikov, it's my pleasure :)
13:52:57 <matjazp> anything else left to discuss?
13:53:47 <matjazp> if not: Marry Christmas (if you celebrate it) and a happy New Year to all :)
13:54:08 <ildikov> Happy Holidays Everyone! :)
13:54:15 <ianychoi> Today, I was leading to study with about 10 Korean people for local upstream training
13:54:38 <ianychoi> I have felt that many people still struggle with git review authentication (e.g., git review -s failure)
13:54:43 <ianychoi> 1. no gerrit username
13:54:43 <ianychoi> 2. no contact information on gerrit
13:54:43 <ianychoi> 3. no ICLA
13:54:43 <ianychoi> 4. duplicated configs for gerrit.username
13:54:43 <ianychoi> 5. Community member, not Foundation member
13:54:44 <ianychoi> 6. E-mails are different (www.openstack.org and review.openstack.org)
13:54:46 <ianychoi> 7. different SSH keys
13:55:04 <ianychoi> Those are what I have found common errors for beginners...
13:55:43 <ianychoi> Documenting such common error cases for git setup would be a good idea ? :)
13:55:56 <ildikov> ianychoi: I think we can write up an article or blog about common mistakes and link it to the training web page
13:56:49 <matjazp> Or just put that stuff into the lanfding page
13:56:54 <ildikov> ianychoi: as the steps are already written down to at least 3 places clearly and people don't read them, but they like blog posts :)
13:56:59 <ianychoi> ildikov, thanks.. I will more describe it! But not now... may be early of next year? :)
13:57:03 <matjazp> these are really common errors
13:57:19 <matjazp> maybe we can make a FAQ page?
13:57:50 <ildikov> ianychoi: I can put together a material with the above items and send it to you to check
13:58:05 <ianychoi> ildikov, good :)
13:58:13 <matjazp> 2 mins left
13:58:24 <ianychoi> No more from me :)
13:58:52 <ildikov> not from me either
13:59:01 <matjazp> thanks all for your time
13:59:11 <matjazp> see you all next year
13:59:12 <ianychoi> Thank you! and see all next year maybe?!
13:59:22 <matjazp> in the mean time, we can sync over ML
13:59:34 <matjazp> as we wont see eachother for a month
13:59:40 <matjazp> tahe care
13:59:44 <ildikov> yeap, let's keep that as a sync place
13:59:54 <ildikov> take care and see you next year! :)
14:00:04 <matjazp> #endmeeting