13:00:27 <matjazp> #startmeeting training-guides
13:00:28 <openstack> Meeting started Tue Feb  7 13:00:27 2017 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:32 <openstack> The meeting name has been set to 'training_guides'
13:00:33 <matjazp> roll call
13:01:09 <ildikov> o/
13:02:07 <matjazp> hey ildikov
13:02:26 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:02:39 <ildikov> matjazp: hi :)
13:02:55 <matjazp> nothing special on the agenda
13:03:36 <kmARC> o-
13:03:39 <matjazp> lets wait a bit, it's weird that attendance is so low
13:03:39 <kmARC> oops
13:03:41 <kmARC> o/
13:03:49 <kmARC> I'm here! :-)
13:04:11 <ildikov> kmARC: hi :)
13:04:27 <matjazp> hey kmARC
13:05:09 <matjazp> see meeting minutes at http://eavesdrop.openstack.org/meetings/training_guides/2017/training_guides.2017-01-24-13.01.html
13:05:41 <matjazp> no action items from the last meeting
13:05:49 <matjazp> clean slate :)
13:06:06 <matjazp> #topic Upstream training
13:06:39 <asettle> Oops, sorry, bit late again
13:06:40 <asettle> o/
13:06:44 <matjazp> hey asettle
13:06:48 <asettle> Hey matjazp :)
13:06:55 <ildikov> asettle: hi :)
13:07:01 <asettle> Hello helloooo
13:07:09 <matjazp> we just started a topic about Upstream
13:07:18 <asettle> Cool :) please continue, sorry to interrupt!
13:07:36 <matjazp> anything to report here?
13:08:06 <asettle> Um
13:08:07 <asettle> Sort of
13:08:08 <asettle> Haha
13:08:19 <asettle> I would like to try and integrate a proper docs training schedule if possible
13:08:31 <asettle> I know there was some jotted down notes on the etherpad (which I can't find right now)
13:08:48 <ildikov> matjazp: I sent out the mail to look for mentors to the upstream training, I will follow up with those who volunteered already
13:09:30 <matjazp> asettle: look at the meeting minutes for the last meeting (link is few lines up)
13:09:35 <ildikov> asettle: the exercises etherpad you mean?
13:09:40 <asettle> Thank you, yes.
13:09:49 <ildikov> #link https://etherpad.openstack.org/p/upstream-training-exercises
13:10:23 <ildikov> asettle: we had deep dive sessions in Barcelona and we would like to keep that
13:10:35 <matjazp> ildikov: what is the response rate? what are the numbers?
13:10:44 <ildikov> asettle: so if you have ideas on how to improve the docs deep dive that would be great!
13:10:46 <asettle> ildikov: keep what?
13:10:47 <asettle> Oh right!
13:10:49 <asettle> Yes, okay, will do.
13:10:59 <asettle> Got it. Yeah, I want to try and come up with a scenario for training. I noticed that trevormc had suggested building reno notes but I'm not entirely too sure that's best case scenario but it could be setup to be apprpriate.
13:11:06 <asettle> Let me think some more on this and I will get back to you.
13:11:15 <asettle> I'll leave a note for me to action this in the etherpad.
13:12:06 <ildikov> asettle: the deep dive was the block, where students were sitting together with with a mentor in groups and got deeper into the code and/or documentation
13:12:23 <ildikov> asettle: how to build docs, modify things, etc
13:12:49 <asettle> 'the block' ?
13:12:53 <ildikov> asettle: in case of code how to run tests, how to use devstack to debug, how to find why a test is failing, etc.
13:13:33 <ildikov> asettle: we had modules/blocks during the training teaching relevant things to new contributors
13:13:55 <ildikov> asettle: check here: http://docs.openstack.org/upstream-training/
13:14:40 <ildikov> matjazp: we have about 5 people so far
13:14:42 <asettle> Makes sense. But nothing for docs, except for: http://docs.openstack.org/upstream-training/docs.html#6
13:15:00 <ildikov> matjazp: I haven't reached out to the new PTLs yet, that's the next step
13:15:27 <matjazp> ildikov: yes, but it is still a bit early for this, right?
13:15:32 <ildikov> asettle: Christian didn't upload slides that's why that content is missing
13:15:47 <ildikov> matjazp: from the actual training perspective yes
13:16:12 <ildikov> matjazp: on the other hand I would like to get some more community engagement to onboard new contributors
13:16:39 <asettle> ildikov: so, perhaps I am confused but there is no planning training exercises for documentation in the etherpad or in the upstream-training page you linked me to. THat's why I am offering help. If there IS already something, then I have misunderstood :)
13:17:56 <matjazp> ildikov: agree
13:18:43 <ildikov> asettle: sorry, I was just trying to explain the training format in general
13:18:52 <asettle> Oh! Oh I'm so sorry I got really lost there!
13:18:56 <asettle> Makes perfect sense :)
13:19:18 <matjazp> asettle: but nevertheless - please contribute some exercises for the docs
13:19:19 <ildikov> asettle: and as the docs part is not documented and less in shape, it's great and perfect that you offer your help!
13:19:31 <asettle> Right right! Hahaha I am so sorry guys I just messed this section up real bad
13:19:32 <ildikov> asettle: as we need it much :)
13:19:38 <asettle> *head desk*
13:19:53 <ianychoi> hi sorry fir late
13:19:56 <ianychoi> for
13:20:01 <matjazp> #action asettle will make some exercises for the Docs part of the Upstream training
13:20:10 <ildikov> asettle: nah, it's all fine, I will send out a follow up mail to those, who help out and will summarize things
13:20:18 <asettle> ildikov: perfect :) Thank you
13:20:32 <ildikov> asettle: including how we ran the training last time, so it will be more clear to everyone
13:20:37 <matjazp> hey ildikov
13:20:40 <matjazp> ups
13:20:42 <ildikov> asettle: sorry I haven't done it so far
13:20:44 <matjazp> hey ianychoi
13:20:50 <ildikov> matjazp: no probs :)
13:20:58 <ildikov> ianychoi: hi :)
13:21:05 <asettle> ildikov: not at all!
13:22:39 <matjazp> any other action items?
13:23:56 <matjazp> anything else left to discuss/report about Upstream training?
13:24:08 <asettle> Nope :)
13:24:26 <matjazp> #topic training guides
13:25:07 <matjazp> still very slow progress
13:25:19 <matjazp> any ideas how to reignite this topic?
13:25:37 <matjazp> Upstream is flourishing, but Training guides... ehh.. :(
13:26:15 <asettle> SO, matjazp I remember there being a brief discussion at the last summit about moving the training guides to live similarly to the deployment guides
13:26:25 <ildikov> matjazp: do yuo know how much it is used?
13:26:34 <matjazp> ildikov: nope
13:26:43 <matjazp> it's still in draft http://docs.openstack.org/draft/training-guides/
13:26:48 <matjazp> #link http://docs.openstack.org/draft/training-guides/
13:27:03 <matjazp> some progress, but not a lot
13:27:04 <asettle> Hmm, matjazp is it in decent enough format to be brought out of the draft state? What would you recommend?
13:27:16 <matjazp> asettle: no, it's not
13:27:41 <asettle> Hmmm, okay. Is there an etherpad, list, bug reports anything that would alert users to potentially required content?
13:27:47 <asettle> Sorry, potentially asking all the obvious questions.
13:28:11 <matjazp> asettle: the idea was to create the material that our Meetups /Openstack days/ community events could quickly use/reuse for the basic openstack intro
13:28:18 <matjazp> so not for developers, for users
13:28:36 <asettle> Sure - but people still need to know where they can go to help work on the content.
13:28:41 <matjazp> asettle: the bugs are in our bug list on LP
13:28:47 <asettle> Okay, cool, so there is bugs.
13:28:56 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/
13:29:00 <asettle> Was there ever an 'action plan' of sorts? Perhaps with deadlines?
13:29:14 <matjazp> they are marked with [training guides]
13:29:19 <spotz> Ha Ben sitting in the wrong room. Morning all
13:29:29 <asettle> o/
13:29:31 <matjazp> asettle: nope .. there were never enoughcontributors
13:29:43 <matjazp> hey spotz
13:30:04 <asettle> matjazp: might be worth thinking about regardless. If someone offers to contribute, where do you tell them to start?
13:30:20 <matjazp> with a bug
13:30:33 <matjazp> there are some smaller ones
13:30:45 <matjazp> but maybe we could expand this slist or make it more explicit
13:31:19 <matjazp> I know that it is hard to start a whole "chapter", but enhancing an existing one is much easier
13:31:44 <asettle> Perhaps? I mean, I'm just think-tanking but whenever I've been trying to push documentation action items I find people respond better to a plan rather than just picking up bugs (unless the actual action item is to pick up bugs)
13:31:56 <ianychoi> Hmm... yep still slow progress on training-guides
13:32:03 <spotz> matjazp Do you mark them low hanging fruit?
13:32:06 <matjazp> so it's much better to quickly merge the content, it is published as draft anyway, and then reiterate and improve
13:32:14 <ianychoi> For training-guides, using a spec would be a good idea for enhancing training-guides?
13:32:26 <matjazp> spotz: no, i dont think so
13:32:41 <asettle> That might be one helpful item, good idea spotz
13:32:54 <ianychoi> I recently have thought that openstack-training-101 for training-guides
13:32:56 <asettle> I think ianychoi might be right about creating a spec too. Having a more detailed outline of what you want to achieve for Pike
13:32:57 <ianychoi> would be a good
13:33:16 <spotz> I know when I look to join a new project that's something I look for
13:33:32 <ianychoi> IMO upstream training is like openstack-contribution-101 and training-guides is like openstack-usage-101
13:34:04 <matjazp> perhaps.. but I'm afraid that it will just create more overhead
13:34:18 <matjazp> ianychoi: yes, you could look at it that way
13:35:30 <asettle> So, I guess it's worth looking at: 1. who uses the training info, 2. Can we get in contact with those people to help contribute, 3. If we can't get those people, how can we do it ourselves
13:36:04 <ianychoi> asettle, thanks a lot for your insight
13:36:07 <ianychoi> +1
13:36:08 <matjazp> asettle: how can you get info about #1?
13:36:44 <ildikov> we can always try an ML thread
13:37:09 <spotz> +[ also ask during the training in Boston
13:37:19 <ildikov> if we have material out then we can try to look into how much the page is used, won't give us names though, but at least ideas about how much it is used
13:37:37 <asettle> matjazp: we can probably use the google analytics to take a look
13:38:01 <matjazp> ildikov: yes, but material in this stage is still to incomplete to be useful
13:38:05 <ianychoi> Hmm.. maybe certified OpenStack training institutes use simliar documentation for openstack-usage-101?
13:38:07 <asettle> I'm trying to get access at the moment, but let's see if we can get Anne to take a look - see what the numbers are. If there are good numbers, maybe we can put a call out to the mailing list(s) on ops, dev, and doc to find out
13:38:33 <matjazp> ianychoi: sure they do, but they are usually their IP
13:38:44 <asettle> matjazp and ildikov - so, I guess teh one positive about having a draft guide up on the main page is at the very least people can *see* that there are gaps to be filled.
13:38:47 <asettle> It's kind of what they did with the HA guide
13:39:06 <matjazp> IP=intellectual property
13:39:31 <matjazp> asettle: where do you propose to publish the link?
13:39:37 <matjazp> not on the main page
13:39:45 <ianychoi> matjazp, I see :)
13:40:45 <asettle> matjazp: I don't know, to be completely honest. Perhaps we release it with Ocata.
13:40:58 <ildikov> asettle: yep, it's important to make it visible if we are fishing for help and feedback
13:41:37 <asettle> Personally, that's what I would do. But I understand if you don't want to publish half finished work.
13:41:43 <ianychoi> IMO moving from http://docs.openstack.org/draft/training-guides/ to like http://docs.openstack.org/training-guides/ would be a good idea (without releasename like install-guides)
13:41:46 <spotz> Yeah w take the info and make it our own. But let's be real there's only one way to CLI and create a server so all training is similar but not the same.
13:41:56 <matjazp> how do other guides publish their early draft conent?
13:42:13 <spotz> Sorry trying to follow the meeting and get a horse ready to ride,
13:42:16 <ianychoi> But I think matjazp 's question is related where such early draft site (training-guides) needs to be linked
13:42:39 <asettle> I think what ianychoi said about moving it to docs.o.o/training-guides would work.
13:43:20 <matjazp> asettle: could we use d.o.o/training-guides URL and mark it as an early draft?
13:43:39 <matjazp> that would increase visibility
13:43:48 <matjazp> visibility == more contributors
13:43:52 <asettle> In theory, yep. matjazp - send an email to Andreas Jaeger and Brian Moss and see if they can do it.
13:43:55 <asettle> They're our tools team.
13:44:09 <asettle> I can't promise anything, but it's worth starting that conversation with them.
13:44:16 <asettle> We can then work with the team to have DRAFT stamped on the guide
13:44:56 <matjazp> asettle: what is the "graduation" procedure for other guides? when are they good enough to publish?
13:45:28 <matjazp> can we publish them from the VERY early stage onward?
13:45:37 <asettle> matjazp: to be fair, that's a pretty hard question to answer. Most we tend to publish as long as they have updated content. Install/config/cli guides are released, but the others just are continuing
13:46:12 <asettle> matjazp: that second questino you're probably better addressing to Andreas - to be completely honest. Not that I *can't* answer it, I'm fairly sure you can publish it. But the tools team might have a different idea of what's best for the guides.
13:46:44 <ianychoi> Aha tools team
13:46:52 <matjazp> ok, lets thing about this and we can discuss this again over ML or the next IRC meeting
13:46:56 <ianychoi> asettle, btw, tools team also deal with openstackstheme?
13:47:00 <asettle> ianychoi: yes :)
13:47:02 <ianychoi> sorry openstackdocstheme
13:47:06 <asettle> So, tools lead is now Brian Moss from Rackspace
13:47:16 <asettle> And Andreas Jaeger and Christian Berendt also help out.
13:47:17 <ianychoi> I see wow cool
13:47:41 <asettle> Brian is also our release manager for Ocata matjazp - so he will be the best person to talk to about getting docs released.
13:47:46 <asettle> The other person is Maria Zlatkova
13:48:12 <ianychoi> It would be nice if they will have an idea how slide style can be enhanced with better UI/UX for training-guides and also upstream-training
13:48:13 <matjazp> #info we discuss about the best way to increase Training guides visibility again on the next meeting
13:48:27 <asettle> ianychoi: they might be able to help with that :)
13:48:38 <matjazp> we have only 12 minutes left, so maybe we can move on?
13:48:40 <asettle> Sorry!
13:48:41 <asettle> YEs :)
13:48:43 <ianychoi> asettle, great :)
13:48:44 <ianychoi> Yep!
13:48:53 <spotz> :)
13:48:56 <matjazp> #topic any other business
13:49:02 <ianychoi> #link http://openstack-kr.github.io/upstream-training/2017/index_en.html
13:49:16 <ianychoi> Korean local upstream training will be held on this upcoming Saturday
13:49:40 <ianychoi> I am preparing it with local community members so I was late for today meeting..
13:50:58 <ianychoi> kmARC, I will use your VM image during local upstream training :)
13:51:00 <matjazp> great: dont forget to send a report into our local events archive
13:51:13 <ianychoi> matjazp, yep sure :)
13:51:32 <matjazp> there was a discussion over email about the status of Training guides Coordinators group on LP
13:51:35 <ildikov> ianychoi: sounds great :)
13:52:34 <matjazp> I suggested that we can just make a list the same as for cores (https://review.openstack.org/#/admin/groups/360,members)
13:52:43 <matjazp> is averyone ok with that?
13:53:14 <spotz> Sounds good to me
13:53:26 <matjazp> just to clarify: only Tom and Sean Robers were admins in that group, and Lana was making some cleaning up effort
13:53:34 <ianychoi> matjazp, I agree + when asettle will be included in openstack-training-guides-core
13:53:34 <ianychoi> ? :)
13:53:41 <matjazp> the group is practically not used for much
13:53:57 <matjazp> ianychoi: asettle is already a member - via docs core
13:54:06 <asettle> matjazp: am I?
13:54:07 <asettle> Coolio :)
13:54:16 <asettle> I will add it to my review list.
13:54:17 <matjazp> and of course, she's replacing Lana in it directly
13:54:25 <ianychoi> matjazp, aha yep. cool
13:54:29 <asettle> Well, that's true. I'll do anything I can to help
13:54:33 <asettle> Ping me when/if you need anything
13:54:43 <asettle> I will do my best to attend meetings and keep up to date with everything!
13:54:56 <ianychoi> #link https://launchpad.net/~openstack-upstream-training-coordinators
13:55:05 <matjazp> so is it ok with everyone to make this LP group the same as core group?
13:55:08 <asettle> matjazp: I'm most likely going to be sending out my first newsletter report this week, I am happy to highlight a need for contributors to the trainin-guides if you want to send me a quick summary of things?
13:55:15 <ianychoi> This might be replaced with  openstack-training-guides-core?
13:55:24 <kmARC> :-) of course ianychoi. Sorry people, I need to go now to a meeting :-|
13:56:00 <matjazp> asettle: sure. The main point is what ianychoi  said: we are building a openstack-101 for users (upstream is for develpers)
13:56:09 <asettle> matjazp: cool, well let's get hte word out.
13:56:22 <spotz> I'll try to make meetings but it'll be from the stable.But I've got approval to come early and help in Boston
13:56:26 <matjazp> ianychoi: i dont know how
13:56:40 <matjazp> I guess gerrit and LP groups are separate
13:57:00 <matjazp> spotz: thnx
13:57:08 <matjazp> kmARC: bye
13:57:11 <ianychoi> matjazp, actually neither do I. I just followed some instructions how to create openstack-dev-sandbox launchpad and included all the upstream training leaders on last Barcelona
13:57:31 <matjazp> ianychoi: yes, but the are separate groups, right?
13:57:39 <ianychoi> matjazp, yep separate groups
13:57:40 <ildikov> spotz: great news! :)
13:57:56 <ildikov> spotz: glad you can come earlier to Boston
13:58:25 <ianychoi> spotz, wow let's see on Boston. :)
13:58:39 <ianychoi> during upstream training
13:58:43 <matjazp> ianychoi: can this be automated? or linked?
13:58:56 <matjazp> hard deadline in 1 min
13:59:06 <matjazp> any last time announcements?
13:59:09 <ianychoi> matjazp, IMO launchpad cores are manually managed not automated..
13:59:20 <ianychoi> Yep...
13:59:20 <matjazp> ianychoi: i think so too
13:59:26 <ianychoi> Thanks for all today!
13:59:34 <matjazp> thanks for your time all
13:59:41 <matjazp> see you in 2 weeks
13:59:44 <matjazp> bye!
13:59:58 <spotz> Laters
14:00:03 <matjazp> #endmeeting