13:01:36 <matjazp> #startmeeting training-guides
13:01:37 <openstack> Meeting started Tue Aug  8 13:01:36 2017 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:41 <openstack> The meeting name has been set to 'training_guides'
13:01:46 <matjazp> hi ianychoi
13:02:02 <matjazp> how are you?
13:02:21 <matjazp> #link Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
13:02:46 <ianychoi> fine although i am now a little busy
13:02:50 <ianychoi> how about u?
13:03:08 <matjazp> ok
13:03:22 <matjazp> I'm still in Dublin, I'll be back in Slovenia in September
13:04:07 <ianychoi> Aha.. and how was in Korea?
13:04:26 <matjazp> Great
13:04:37 <ianychoi> :)
13:04:47 <matjazp> too bad that we didn't have time to meet
13:05:03 <matjazp> but I was there only for a few days
13:05:34 <matjazp> if you're busy, lets just start
13:05:52 <matjazp> #topic Moving from Hieroglyph for rendering slides
13:06:09 <matjazp> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120598.html
13:06:34 <matjazp> #link https://bugs.launchpad.net/openstack-training-guides/+bug/1708240
13:06:34 <openstack> Launchpad bug 1708240 in OpenStack Training Guides "Incompatible requirements" [Undecided,New]
13:06:44 <ianychoi> yep I reas it
13:06:52 <ianychoi> s/reas/read
13:07:28 <matjazp> we already talked about moving to something else
13:07:55 <matjazp> now it seems that we have to do it, otherwise we will have problems with new versions
13:08:12 <matjazp> of openstackdocstheme
13:08:35 <matjazp> there are few suggestions on the ML
13:09:13 <matjazp> rst2html5
13:09:28 <matjazp> pandoc
13:10:26 <matjazp> hovercraft
13:10:32 <matjazp> that's it I guess
13:11:23 <matjazp> does you know perhaps if the conversion with rst2html works? or Pandoc? I think I remember that we already tried a few (years?) back and that it wasnt the best output
13:11:31 <ianychoi> hovercraft.. I don't know
13:11:52 <ianychoi> I want to try them :)
13:12:25 <matjazp> hovercraft was suggested by Markus Zoeller on the Docs ML
13:12:31 <matjazp> its his tool
13:13:12 * ildikov steps in and hides at the back of the room :)
13:13:16 <matjazp> maybe the process of conversion is better now
13:13:24 <matjazp> hi ildikov
13:13:32 <ildikov> how quickly do we need to decide and move?
13:13:38 <ildikov> matjazp: hi :)
13:14:01 <ildikov> sorry for being late, I have a parallel meeting
13:14:16 <matjazp> well, we can stay on older version of the openstackdocstheme for a while, but the real problem is sphinx
13:14:29 <matjazp> np ildikov
13:14:55 <matjazp> hieroglyph does not work with sphinx >= 1.6.0
13:15:20 <ildikov> so it's not Sphinx but hieroglyph that got so out of date we cannot use it anymore
13:15:22 <matjazp> and honestly, I think it's more or less a dead projectso we should move from it
13:15:33 <matjazp> ildikov: yes
13:15:34 <ildikov> yeah, agreed
13:16:13 <matjazp> I think that reveal,js is the obvious candidate
13:16:31 <matjazp> but it has a problem of natively supporting MD, not RST
13:16:34 <ildikov> do we have any constraints from infra side?
13:16:42 <ildikov> besides the Sphinx version
13:17:14 <matjazp> well I remember that this was one of the reasons we chose hieroglyph in the first place
13:17:37 <matjazp> support for it was already there, since it's just a addon for sphinx
13:17:38 <ildikov> hmm, it would be great not to switch to another file format as well
13:18:01 <matjazp> yes, there are converters
13:18:06 <matjazp> rst2html
13:18:09 <matjazp> pandoc
13:18:41 <matjazp> maybe we could use this to just render slides from the same source
13:18:45 <matjazp> this would be ideal
13:19:09 <matjazp> but I expect problems with this - it never works OOTB
13:19:50 <matjazp> we also have this integration with bug reporting
13:20:16 <matjazp> you know - that little bug link on the slides that directs you directly to the proper bug queue
13:20:46 <matjazp> so users can report bugs on the particular slide with one click
13:21:39 <fungi> i thought rst2html5 looked promising since you could still maintain your content in rst but render it to reveal.js like you were wanting
13:22:12 <ildikov> I guess we need to try it out and see how it works
13:22:14 <matjazp> fungi: yes, but we have to see how it renders slides
13:22:45 <fungi> granted you'd likely need to reformat the current corpus of slides some, but at least wouldn't need to switch to a completely different markup language than is used for other documentation in the community
13:22:53 <matjazp> I remember that we tried that a long time ago and results were not so good and we stick with hieroglyph
13:23:07 <fungi> ahh, too bad :/
13:23:11 <matjazp> fungi: yes, I don't want to switch to MD
13:23:28 <matjazp> fungi : but things could improve in the mean time
13:23:41 <matjazp> maybe even pandoc works now :)
13:24:14 <ildikov> fungi: yeah, it's a priority not to change to another format
13:24:34 <fungi> great
13:24:38 <matjazp> hmm.. iare there any hard time limits regarding sphinx version from the infra?
13:24:43 <ianychoi> Personally I prefer to use rst2html5 but I do not have experience. Pandoc means that we need to convert to another format?
13:25:00 <ildikov> I wonder whether we could work with pdf files
13:25:16 <matjazp> ildikov: how do you mean?
13:25:57 <ildikov> I was just thinking out loud on what format we could render the slides to that we could use for trainings
13:26:38 <ildikov> let's start with trying out what we have and see where we are first
13:27:09 <matjazp> fungi: is from the infra point of view older sphinx ok? or what is the time frame for us to switch to >1.6? So we plan
13:27:37 <fungi> matjazp: if you can successfully install it from pypi, i don't think we care what version of sphinx you're on
13:28:06 <matjazp> fungi: great, I believe that buys us more time
13:28:21 <matjazp> but we'll be stuck with older version of openstackdocstheme
13:28:45 <matjazp> so migration is inevitable
13:29:06 <fungi> yeah, as long as your job/tox env/whatever you're using specifies the version(s) of sphinx you want (in a requirements.txt file maybe? i haven't looked at how yours is set up) then it should work just dandy
13:30:36 <matjazp> great. So we should just try rst2html and pandoc... any volunteers? :)
13:31:29 <ildikov> matjazp: I can take one
13:31:31 * matjazp is still on secondment in Dublin (so unfortunately no time for this)
13:31:42 <matjazp> ildikov: great
13:31:55 <matjazp> ildikov: rst or pandoc?
13:31:56 <ildikov> has either of you tried either of the options?
13:32:08 <fungi> #link          https://twitter.com/faidonl/status/894694365154738176
13:32:16 <fungi> #undo
13:32:26 <fungi> sorry, prepping link from the wrong buffer
13:32:33 <fungi> chair will have to #undo
13:32:47 <ildikov> fungi: np, good message :)
13:32:50 <matjazp> #undo
13:32:51 <openstack> Removing item from minutes: #link https://twitter.com/faidonl/status/894694365154738176
13:32:52 <ildikov> matjazp: rst
13:32:59 <fungi> thanks, sorry
13:33:01 <matjazp> np
13:33:44 <matjazp> #action ildikov tries the conversion of slides with rst2html
13:33:45 <ianychoi> I want to try them but not  now - maybe from September..
13:33:45 <ildikov> matjazp: I need to look into these, I'm less knowledgable when it comes to presentation formats
13:34:16 <ildikov> matjazp: do you know how big work it would be to fix up hieroglyph?
13:34:33 <matjazp> ildikov: no, but is it even worth it
13:34:44 <matjazp> it's not maintained anymore
13:34:59 <matjazp> so we'll run into troubles later for sure
13:35:06 <ildikov> well, it depends what we find to replace it
13:35:28 <ildikov> so i just asked as plan C
13:35:48 <matjazp> I don't see no other long term options besides migration to something that is maintained - unless WE adopt maintenance of hieroglyph
13:36:27 <fungi> which, while noble, is not a decision to be taken lightly
13:37:41 <matjazp> agree
13:37:45 <ildikov> sure
13:38:05 <ildikov> was just an innocent question really :)
13:38:09 <matjazp> this looks like the problem with hieroglyph https://github.com/nyergler/hieroglyph/issues/124
13:38:41 <matjazp> ildikov: sure, maybe we'll need plan C, so good thinking
13:39:32 <matjazp> ok, so for a while, we're OK, as long we use the older version of sphinx and openstackdocstheme
13:40:02 <ildikov> matjazp: maybe someone likes it enough to fix it :)
13:40:04 <ianychoi> matjazp, yep - just we might need to specify sphinx version in test-requirements in training-guides repository?
13:40:18 <ildikov> matjazp: +1, hopefully we find a good enough alternative
13:41:06 <ianychoi> oh already specifyed: http://git.openstack.org/cgit/openstack/training-guides/tree/test-requirements.txt
13:41:24 <matjazp> ildikov: I'm still hoping that conversion will save us ;)
13:41:42 <ildikov> matjazp: fingers crossed :)
13:42:01 <ianychoi> :)
13:42:19 <matjazp> that's it for this topic, I guess
13:42:30 <matjazp> switch to AOB?
13:42:59 <ianychoi> Nope from me
13:43:09 <ildikov> nope from me either
13:43:12 <matjazp> #topic any other business
13:43:40 <ildikov> if either of you played with either of the alternatives earlier and have any heads ups I'm happy to learn them :)
13:44:03 <ildikov> otherwise, I'll play with it and see how things go
13:44:05 <fungi> oh, the actual link i meant to post
13:44:09 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120771.html New code contributors no longer forced to join the foundation
13:44:17 <matjazp> ildikov: I'll try to look for that old stuff
13:44:42 <fungi> that presumably has some impact on the upstream institute materials
13:44:44 <ianychoi> I was out of my home for about 20 minutes but if rst2html5 installation and testing works well, then I think choosing rst2html5 would be best - the change of rst syntaxes (from hydroglpyh to rst2html5 supported syntaxes) would be less then other options
13:45:32 <ildikov> fungi: looks good, thanks for the reminder
13:45:41 <fungi> i wasn't sure if the content managers for the training guides had seen the announcement on the change to the onboarding workflow
13:45:48 <ianychoi> fungi, thanks :)
13:45:57 <ildikov> fungi: yep, we will need to update a few slides
13:46:11 <matjazp> was that even a problem?
13:46:21 <matjazp> "forcing" to join I mean
13:46:41 <ildikov> fungi: always a good approach to give a heads up considering how busy the mailing list is :)
13:47:18 <matjazp> ildikov: yes, especially now that we'll merge docs ML with dev ML
13:47:21 <ildikov> matjazp: there are always complaints about that and the ICLA as far as I remember
13:47:22 <fungi> matjazp: yes, because you had to join the foundation before trying to sign the icla, and if your e-mail address didn't match perfectly between the foundation member profile and gerrit or you chose the wrong member type then you got a cryptic error message
13:47:30 <matjazp> so A LOT more mails in ML
13:48:27 <matjazp> fungi: yes, I know about those problems, but what I mean is that ppl will still join the Foundation, I believe
13:48:35 <ildikov> fungi: at least a half an hour on the training to figure out the root case of those errors... :)
13:48:57 <fungi> matjazp: not to mention, casual contributors (those coming from other free software communities, not so much the upstream institute audience) were potentially turned off by being required to join an organization just to push patches
13:49:07 <ildikov> fungi: as you need to fill out the contact info in Gerrit as well and there are issues time to time too, all joy :)
13:49:17 <ianychoi> ildikov, you are encountering some errors?
13:49:29 <fungi> yeah, no more contact info bits in gerrit
13:49:40 <matjazp> fungi: huh, yes, that's true... I all you want is to contribute a small patch, than joining was a bit of overkill
13:50:08 <ildikov> ianychoi: just the process to have the students signed up everywhere is always tricky
13:50:26 <ildikov> ianychoi: easy to make a mistake and not always easy to figure out which step went wrong
13:50:31 <fungi> i'm setting my sights on finally being able to drop icla enforcement in gerrit in another cycle or two, but that's a pretty major undertaking
13:50:49 <ianychoi> ildikov, aha I see. I think ICLA signing user interfaces in Gerrit does not seem user friendly
13:51:06 <ildikov> fungi: sounds good, I think we are having good progress to the right direction
13:51:36 <ildikov> ianychoi: with ICLA it's more about corporate concerns and so forth
13:51:53 <ianychoi> ildikov, aha yep also.. got it - thanks :)
13:51:55 <matjazp> ok, anything else left to discuss?
13:52:10 <ildikov> I'm good
13:52:16 <ianychoi> Nope from me - thanks, matjazp for  organizing today meeting
13:52:27 <fungi> yeah, we've cleared the board of directors/foundation legal hurdle on dropping icla enforcement and switching to the dco a while back, but the mechanics of making that happen will still take a while
13:52:50 <matjazp> thanks a lot for your time
13:53:04 <matjazp> see you around in 2 weeks
13:53:10 <ildikov> thanks all!
13:53:22 <ianychoi> Thank you all!
13:53:31 <matjazp> bye all
13:53:33 <ildikov> fungi: yeah, those things are never easy
13:53:54 <matjazp> #endmeeting