18:01:02 <dbite> #startmeeting training-labs
18:01:03 <openstack> Meeting started Mon Jul 11 18:01:02 2016 UTC and is due to finish in 60 minutes.  The chair is dbite. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:07 <openstack> The meeting name has been set to 'training_labs'
18:01:21 <dbite> #topic PXE Feature
18:01:24 <julen> hi dbite
18:01:25 <dbite> Hello
18:01:30 <dbite> good to see you julen
18:01:31 <rluethi> hello everyone
18:01:34 <dbite> rluethi: Hello
18:01:43 <julen> hi rluethi
18:02:01 * dbite should have waited for the greetings part before starting the topic <<faceplam>>
18:02:24 <rluethi> very keen on hearing about the PXE patch, are you?
18:02:40 <rluethi> so, one patch up for review right now.
18:02:49 <rluethi> then, there's another one depending on it.
18:02:55 <dbite> the topic is for PXE
18:03:02 <rluethi> then, I can post the updated PXE patch.
18:03:07 <dbite> is that related to PXE feature?
18:03:10 <dbite> Ok
18:03:13 <rluethi> it depends on the other two.
18:03:23 <dbite> makes sense, can you link them here just for the sake of minutes
18:04:40 <rluethi> #link https://review.openstack.org/340217
18:05:48 <dbite> rluethi: I think I have already tested this patch
18:06:03 <dbite> I will merge it
18:06:29 <dbite> What updates do you have with the new PXE patch that you are talking about
18:06:43 <rluethi> there's another one, then the updated PXE patch.
18:06:51 <dbite> and the other frustrating bit for you may be to rebase your change set with the current upstream one since I rebased w.r.t. master.
18:07:12 <rluethi> don't worry about it, I am on top of it.
18:07:16 <dbite> ok
18:07:19 <dbite> phew!
18:07:30 <dbite> julen: Anything from your side for the PXE patch?
18:07:56 <julen> I was working on the 305991
18:08:12 <julen> (the "work in progress")
18:08:38 <julen> I made the pxe instance to boot with fixed IP
18:09:30 <julen> as rluethi suggested, I tried with the preseed, but it didn't work, so I did a workaround with a rc.local script
18:09:32 <dbite> julen: Awesome, may be you could wait for Roger to send his updated PXE patch and then rebase on top of it and push again.
18:09:57 <dbite> julen: It should work with static IP from Preseed itself.
18:10:12 <dbite> But from my prespective its better to control it from the DHCP server on the PXE server node.
18:10:18 <rluethi> I am afraid that won't be necessary. I thought Julen was away for the weekend and without Internet, so I hacked away and solved all problems.
18:10:24 <julen> now I was trying to make the pxecluster script work. So, to launch a VM, install the OS and re-attach it to the installer
18:10:33 <dbite> rluethi: Awesome!
18:11:09 <julen> I was... I came back yesterday in the evening ;)
18:11:13 <rluethi> I used julen's idea (static ip). I think it's a good solution for now.
18:11:27 <julen> rluethi: does it work with your preseed?
18:11:31 <rluethi> yes.
18:11:55 <julen> oh.. I have to check what did I do wrong...
18:11:58 <rluethi> well, I had to amend it because it wouldn't work with a machine with several disks attached.
18:12:22 <rluethi> it didn't know which disk to use.
18:12:26 <julen> but, does it perform the installation with the IP 240, or does it use dhcp during the installation and set the IP on reboot?
18:13:10 <rluethi> now that is a good question.
18:13:23 <julen> the advantage of using dhcp during the installation is, that we can install two machines at the same time (with some little time in between)
18:13:28 <rluethi> why don't you test it once it's up and tell us? :)
18:13:36 <julen> sure
18:14:10 <rluethi> julen: but then you have to be sure that the time windows, as small as they may be, are always separate.
18:14:18 <dbite> Ok, anything else on PXE topic?
18:14:24 <julen> but another point is, that so much complexity is starting to make the thing a little crazy... I think it's better to keep things simple, and focus on openstack
18:14:36 <julen> yes
18:15:02 <dbite> julen: We have already solved the OpenStack related problems with good results for Mitaka
18:15:05 <rluethi> yeah, I don't like how much PXE-specific code is left in the PXE patch.
18:15:19 <julen> so... rluethi: functions-host.sh and scripts.ubuntu-pxecluster. How could I get it working?
18:15:28 <dbite> It makes sense to wait for another release (code to be written) before we think of supporting it ;)
18:16:08 <rluethi> julen: I am happy to answer any specific question you may have, but I suspect most will be answered when you see the updated patch.
18:16:14 <julen> dbite: sure I meant the same as rluethi
18:16:33 <julen> looking forward to test it :)
18:16:39 <rluethi> it's really not all that difficult, the difficulty lies in coming up with a simple solution that works.
18:16:48 <julen> when do you expect to commit it?
18:16:49 <dbite> julen: This should allow us to do more cooler things with OpenStack with bare-metal or mixed VM's and baremetal eventually :)
18:17:19 <rluethi> the new PXE patch depends on one patch that is under review and another patch that depends on the first patch.
18:17:20 <dbite> julen: As rluethi said after his dependent patch gets merged so I would say sometime tonight
18:17:31 <rluethi> so merge two patches and the next one is the PXE patch.
18:17:33 <dbite> rluethi: I merged the other patch
18:17:44 <dbite> So just one more.
18:17:46 <dbite> :)
18:18:07 <rluethi> It's not merged-merged yet, so I can't put the next one up.
18:18:16 <julen> well.. so let's do that. I'll wait to see the new patch and continue from that
18:18:52 <dbite> no worries, lets move on.
18:19:01 <dbite> #topic new_preseed_file
18:19:23 <dbite> rluethi: I think the new preseed ssh v3 file that we had is not really being used
18:19:26 <julen> did you see the way I handled the last line of the preseed file?
18:19:35 <dbite> I noticed it while rebasing the PXE patch
18:19:53 <rluethi> dbite: correct. it will be, though.
18:20:00 <dbite> julen: Yes, there are some inherent design flaws with that and we should move that topic to the ML
18:20:29 <rluethi> The nodes booting via PXE need it.
18:20:37 <dbite> rluethi: Shall we wait a bit for me to get the parser bits done and then I will update the base disk installation part
18:20:44 <dbite> rluethi: does that sound good to you?
18:21:08 <dbite> so we should only have one way to install the baremetal and the VM's and that should be possible
18:21:25 <dbite> by injecting the ram disk and the kernel image
18:21:39 <rluethi> Sorry, I think I missed the boat.
18:21:53 <rluethi> Are you guys talking about the same thing?
18:22:02 <rluethi> julen: what last line?
18:22:04 <julen> hmm... the preseed file?
18:22:13 <dbite> rluethi: he meant for the PXE patch
18:22:13 <julen> the last line of the preseed file
18:22:19 <rluethi> dbite: update base disk installation part for what?
18:22:29 <dbite> rluethi: we discussed this point this weekend what julen was mentioning
18:22:51 <dbite> rluethi: I meant to say the better way to install the OS even for the VM's (basically the base-disk part)
18:23:09 <dbite> rluethi: But that could be done later as a wishlist item for sure.
18:23:28 <rluethi> julen: yes, I saw that. check out my updated patch and tell me if you still think it's needed.
18:24:09 <julen> dbite: I meant that the last line of the preseed file contains a super complex and difficult to read command. But instead, I wget-ed an script which does all that and even more, and it is easier to read
18:24:14 <rluethi> dbite: yes, we could, for instance, cache the packages or even pull them out of the ISO which is in the pxeserver node anyway.
18:24:34 <dbite> rluethi: yes
18:24:35 <julen> rluethi: true, true... I'll wait
18:24:43 <rluethi> julen: actually, that change of yours I did like.
18:24:53 <dbite> julen: Can we use that idea for making rluethi's patch's preseed file look cleaner?
18:25:04 <rluethi> julen: I see that as a separate patch that you could submit independently.
18:25:12 <rluethi> dbite: yes, we can.
18:25:33 <dbite> julen: Or rather thats a task for you to do but we should really move on the another topic, since we all agree on these topics it does not make much sense to discuss them in this much detail here.
18:25:37 <rluethi> that would be preseed...v4, though.
18:25:40 <julen> rluethi: include the packages on the iso, or... use the same pxeserver as a local caching repo... ;)
18:25:40 <dbite> julen: Want to do that?
18:26:17 <dbite> julen: We could wget it from the training-labs git repository. No need to worry about the cache. That is something for after merging the basic feature to start with.
18:26:19 <rluethi> julen: something like that. but that's not needed for the initial patch. let's keep it simple.
18:26:20 <julen> sure
18:26:49 <dbite> #topic any other buisness
18:26:55 <dbite> Anything else that we need to discuss?
18:26:59 <julen> so, just clean the preseed the include the script, right?
18:27:22 <dbite> My apologizes for being a bit pushy, we should try to keep these discussions a bit away from low level details ;)
18:27:23 <julen> dbite: what about the python version! :P
18:27:28 <dbite> oh yeah!
18:27:34 <dbite> #topic Python_Port
18:27:37 <julen> and the parser!
18:27:52 <dbite> rluethi: Pushed the VirtualBox Python POC to his github
18:28:15 <dbite> We have already demonstrated although in a very crude way for POC with libvrt and python
18:28:23 <rluethi> yes. it's a pretty direct port of osbash to python.
18:28:30 <rluethi> will need refactoring over time.
18:28:38 <julen> and cleaning...
18:28:50 <rluethi> it is missing some of the features I just added to osbash.
18:29:00 <dbite> now there is the architecture which we discussed and I will finalize the entire Python POC which should contain a couple of POC's together and then present it to everyone hopefully during the next OpenStack summit.
18:29:29 <rluethi> it is one of the reasons I would like to push the python port and drop the bash version. maintaining and developing both is putting a strain on my resources.
18:30:01 <dbite> yes, there is a lot of work involved there, most of the important pieces are already demonstrated but its no where near to even demonstration phase where we could show a sneak peak
18:30:07 <rluethi> dbite: what PoCs are you talking about?
18:30:23 <dbite> rluethi: Your VirtualBox, my Architecure stubs, KVM-Libvirt POC
18:31:04 <dbite> rluethi: THe thing I did with distro switch and another one which I will do soon which provides a cleaner way to work around with dependency installation
18:31:49 <rluethi> okay.
18:32:04 <julen> dbite: and... now that you are rewriting from scratch... so, did you think about making the thing more modular?
18:32:08 <dbite> rluethi: would you consider them as some sort of mini/sub-POC's for the bigger one?
18:32:26 <dbite> julen: Its really modular or as modular as we could practically try to make it ...
18:32:40 <julen> for example, making a single "vm_launcher" function, which can launch either KVM or VB depending on the arguments..
18:33:29 <dbite> julen: Yes
18:33:53 <dbite> julen: Its exactly doing this in the architecture design but we need to finish and finalize the entire thing.
18:34:02 <rluethi> dbite: I would like to merge the python port soon and then work from there, because it's a lot of work keeping that much code synced.
18:34:35 <julen> dbite: great! :)
18:35:22 <dbite> rluethi: That is true. Lets discuss the dead lines for this in the ML. We could try to ship the python version by the end of this release. But lets use a better metric for the same.
18:35:52 <dbite> #action Figure out the deadlines for the Python Port.
18:36:24 <julen> well... pxe working by the end of august?
18:36:36 <dbite> #topic parser
18:36:46 <dbite> julen: lets keep it after the parser topic
18:37:24 <dbite> So till now I have the most complex bits figured out for the parser. Thankfully the install guides team will not change the syntax for the scope of this release at-least!
18:37:55 <dbite> I have also decided to sit for all the install guides meetings regularly its just quite early in the morning for me but should not be a big problem.
18:38:51 <dbite> The architecure is quite well argued and viewed by many eyes and also the most important part is that I am fairly optimistic in being able to finish this and automate the hell out of all the install guides supported OpenStack services!
18:39:37 <dbite> I am trying my best to the POC out by end of this week (Sunday probably) and should be a good starting point to showcase this to the community and then merge it upstream
18:40:06 <julen> dbite: is that in python or bash?
18:40:08 <dbite> #LINK
18:40:41 <dbite> #link https://github.com/dguitarbite/rst2bash
18:40:56 <dbite> julen: its in Python
18:41:33 <dbite> julen: there is a minor bug in there where in I forgot to add pass to one of the functions but this is just a crude work in progress for the time being
18:41:57 <dbite> julen: Also I will be re-writing the entire history of this repository after finishing the initial work.
18:42:14 <dbite> rluethi: julen anything else in mind for the parser topic?
18:42:35 <rluethi> dbite: nope, not today
18:42:42 <dbite> ok
18:42:51 <dbite> #topic any other buisness
18:43:02 <rluethi> the patch didn't merge
18:43:23 <rluethi> Maybe it's the conflict that gerrit reports.
18:43:25 * dbite is checking
18:44:13 <dbite> rluethi: Gerrit was not working for a couple of minutes, may be something is being fixed in there. Dunno!
18:44:45 <rluethi> okay, I'll try to post the next patch in the queue as soon as this one's merged.
18:44:53 <dbite> rluethi: ok
18:45:03 <julen> rluethi: and send a link :)
18:45:12 <dbite> julen: Hopefully by tomorrow morning the updated PXE patch should be merged.
18:45:33 <dbite> julen: It would be great if you could start reviewing patches for training-labs
18:46:00 <dbite> julen: that should give you a good idea on other features and different things and also test the changes ...
18:46:19 <julen> dbite: I'll try
18:46:34 <dbite> rluethi: I manually triggred the jenkins job, now it should hopefully get merged in a couple of minutes.
18:46:46 <dbite> julen: you could configure gerrit to send you notifications for training-labs
18:47:02 <julen> dbite: I'll look into that
18:47:08 <rluethi> dbite: if that works, I may be able to submit the next one today.
18:47:08 <dbite> julen: Thanks, that would be great :)
18:47:30 <dbite> rluethi: I see it on the status.openstack.org/zuul waiting to get merged :D
18:47:39 <dbite> Alright, any other buisness?
18:47:42 <dbite> Anything else?
18:47:46 <julen> yes
18:47:46 <rluethi> I'm good.
18:47:50 <dbite> julen: hit me
18:48:00 <dbite> s/me/us/
18:48:09 <julen> I'm gonna be here on the weekend, and I'll have plenty of time. If you want we could meet
18:48:24 <dbite> julen: Lets take this offline
18:48:31 <dbite> off meeting rather
18:48:32 <julen> dbite: ok
18:48:37 <dbite> julen: any other buisness?
18:48:42 <julen> dbite: nope
18:48:50 <dbite> ok, lets end it then.
18:49:06 <rluethi> die, meeting, die.
18:49:06 <dbite> Bye guys, thanks for coming! I'm glad we all made it today :D
18:49:14 <dbite> rluethi: Oye!!!
18:49:18 <rluethi> :)
18:49:24 <julen> bye rluethi and dbite
18:49:27 <dbite> I have the powers to make you still till 9 pm :P
18:49:30 <dbite> #endmeeting