18:00:10 <dguitarbite> #startmeeting training-labs
18:00:10 <openstack> Meeting started Mon Jul 25 18:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is dguitarbite. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:13 <openstack> The meeting name has been set to 'training_labs'
18:00:19 <dguitarbite> Hello
18:01:02 <rluethi> dguitarbite: hi
18:02:18 <julen> hi dguitarbite rluethi
18:02:24 <rluethi> hi julen
18:02:25 <dguitarbite> #topic pxe feature
18:02:27 <dguitarbite> hello all
18:02:39 <dguitarbite> Happy to see that we finally merged the initial PXE patch!
18:02:40 <rluethi> hey all
18:02:46 <julen> yeah! :)
18:02:48 <dguitarbite> julen: Thanks for adding this feature.
18:02:57 <dguitarbite> rluethi: Thanks for making this patch awesome!
18:03:26 <rluethi> julen did the hard part :)
18:03:35 <julen> well.. thank you guys for all the help... it wouldn't be possible without you both :)
18:03:54 <dguitarbite> :)
18:04:28 <dguitarbite> Any ideas on how to proceed further with the PXE patch?
18:04:51 <rluethi> dguitarbite: yes, some :)
18:05:11 <julen> the bridged option..
18:05:29 <rluethi> dguitarbite: first, I need to get the Windows version working again.
18:05:36 <rluethi> I broked it :(
18:06:44 <dguitarbite> ok, so lets come back to the PXE feature next week.
18:06:52 <dguitarbite> #topic Windows Suport
18:07:03 <dguitarbite> NVM the typo ;)
18:07:39 <dguitarbite> julen Lets come back to the PXE bits a bit later. There is the next OpenStack release that we need to think about.
18:08:14 <julen> sure
18:08:31 <dguitarbite> rluethi: So what are the issues with the Windows support?
18:08:42 <rluethi> julen: as far as I am concerned, we can work more on PXE, I just need to fix the stuff I broke first.
18:09:25 <rluethi> dguitarbite: I introduced a new command "shutdown", but forgot to check whether it makes it into the Windows batch files.
18:09:27 <julen> rluethi: sure, let me know if I can help
18:09:55 <dguitarbite> rluethi: Sounds like a good idea to fix it in Windows and find a few more issues.
18:09:56 <rluethi> I could just reintroduce the shutdown_controller.sh script, but I want to fix it properly.
18:10:18 <dguitarbite> julen: I think from my side, you could think about getting the PXE patch running on KVM if you have nothing else which is interesting for you.
18:11:05 <julen> dguitarbite: right now I am with the login script
18:11:27 <rluethi> julen: excellent, we need more automated regression testing.
18:11:28 <dguitarbite> julen: Ok.
18:11:30 <julen> but I can put it on the queue
18:11:35 <dguitarbite> julen: Yes, more testing is awesome.
18:11:39 <dguitarbite> #topic testing
18:11:52 <julen> there we go
18:11:58 <dguitarbite> julen: rluethi Could we think about adding tempest tests for our cluster too?
18:11:58 <julen> I have a couple of comments...
18:12:33 <dguitarbite> Also I would predict around one month of free time for working on these things! After that we have to move our focus on updating training-labs to the newer release.
18:12:33 <julen> dguitarbite: that would be really pro! :D
18:13:05 <rluethi> dguitarbite: last time I checked tempest was quite difficult to set up and took forever to run. I think it would be a nice addition to have once we've covered the basics.
18:13:24 <dguitarbite> rluethi: What coveres basics?
18:13:42 <dguitarbite> rluethi: Also IMHO setting up and running tempest should not be such a big deal.
18:13:56 <dguitarbite> rluethi: But I could be totally wrong or missing something important.
18:14:15 <rluethi> dguitarbite: can we build a base disk and a cluster on virtualbox and kvm? can we launch an instance VM inside these clusters? that kind of thing.
18:14:56 <dguitarbite> rluethi: Gotchya
18:14:59 <rluethi> with our current smoke tests, we can build the whole thing and run all the tests in under half an hour.
18:15:08 <julen> so, I was trying to do the script based on curl, because I think it is more simple, easy to understand, and more osbash-ish, but I haven't managed to get it working yet. I also tried with python, but as far as I understand, selenium needs X11 and plenty of dependencies, right?
18:15:18 <dguitarbite> rluethi: It would become increasingly important to do these tests once we have the parser set in motion.
18:15:30 <julen> uff.. too long of a sentence... it come out off topic already
18:15:53 <dguitarbite> julen: Does it really? Can you check how the horizon guys are testing their UI?
18:15:59 <julen> yes, I did
18:16:03 <julen> they use selenium
18:16:16 <julen> actually, maybe we could use their tests directly...
18:16:43 <rluethi> julen: interesting. that would be a good argument for selenium, although I'd rather not add more (especially large) dependencies to the basedisk.
18:16:48 <julen> https://github.com/openstack/horizon/tree/master/openstack_dashboard/test/integration_tests
18:17:19 <rluethi> julen: can you check how much space these additional dependencies would require?
18:17:24 <dguitarbite> julen: rluethi The scope of testing the UI should not require us to run these things in side the cluster
18:17:32 <julen> the advantage of that, is that they already have plenty of tests.. including login and checking all the stuff
18:17:40 <dguitarbite> It could rather be run on the host machine altogether!
18:18:07 <julen> dguitarbite: totally agree
18:18:16 <rluethi> dguitarbite: all our test scripts run on the controller VM as of now, and for a reason: it is an environment we have under control.
18:18:18 <julen> it's kind of, nicer
18:18:21 <dguitarbite> rluethi: Would you still want to stick to curl?
18:18:35 <julen> also, it would test that the machine is accessible from the outside
18:18:43 <dguitarbite> rluethi: julen Lets discuss the details after a short research phase, does that make sense?
18:18:56 <dguitarbite> julen: I think I kind of get Roger's point here.
18:19:15 <dguitarbite> julen: We need not test horizon's UI but rather if the UI is working.
18:19:18 <julen> yes, I also agree with him
18:19:26 <rluethi> dguitarbite: yes. I think the person writing the code should pick the tool, but it should not run against the goals we set for the project.
18:19:49 <dguitarbite> rluethi: I think its easier if we test with curl to see if we get expected HTML format which could be easily figured out from the horizon templates from its repository upstream.
18:19:50 <rluethi> installing lots of dependencies on the host machine would be a no-go for regular users.
18:20:04 <dguitarbite> And then test keystone for checking if logging in works.
18:20:08 <dguitarbite> rluethi: What do you think:?
18:20:15 <julen> this is why I think curl would be better... even if it just tests the login and launching an instance
18:20:25 <dguitarbite> julen: We do not have to test Horizon ... we just need to check if it is working as expected.
18:20:42 <dguitarbite> rluethi: julen Did you guys understand what I was saying?
18:20:45 <rluethi> julen: that would not be "just", that would be a lot and very useful.
18:21:16 <rluethi> dguitarbite: I don't know. In such cases, I try to play around with all the options to get a feel for what is the best solution.
18:21:31 <julen> well.. the "just" was just as a comparison with the horizon tests...
18:22:05 <rluethi> julen: the horizon tests try to cover everything, like tempest.
18:22:10 <rluethi> it's not what we need.
18:22:15 <julen> well.. give me a little bit more time, so I try to get it with curl. If it doesn't work, we can keep discussing
18:22:57 <dguitarbite> rluethi: julen I agree. Lets move on.
18:23:06 <dguitarbite> suggestions for the next topic?
18:23:36 <rluethi> dguitarbite: parser-script-generator?
18:23:43 <dguitarbite> #topic parser
18:23:44 <julen> rluethi: I am a little worried because I still don't master the cookies part with curl, and also because there might be the case that we need javascript support
18:24:28 <rluethi> julen: we'll have to figure it out :).
18:24:41 <dguitarbite> rluethi: julen The parser is almost done, I have already made a few commits, a lot of the work is local under progress. I need to clean up and get it pushed soon.
18:24:59 <dguitarbite> julen: rluethi There is nothing much from my side at present on this topic..
18:25:21 <dguitarbite> #topic any_other_buisness
18:25:23 <rluethi> so can you create a working client-side script for keystone?
18:25:45 <dguitarbite> rluethi: Almost, let me clean up and push the remaining code by tomorrow evening.
18:25:47 <julen> using the keystone API? that should be quite simple...
18:26:01 <dguitarbite> rluethi: For the time being you  just need to copy paste the *.sh files into the scripts folder.
18:26:39 <rluethi> julen: generating the setup_keystone.sh script from the install-guide's RST file.
18:26:57 <julen> aha.. I understand now
18:27:29 <rluethi> dguitarbite: logo. do we qualify?
18:28:10 <dguitarbite> rluethi: Realistically speaking, I am not that motivated for the logo at present. There are so many more interesting and important things for me to do.
18:28:18 <dguitarbite> rluethi: Do you think its worth spending time on the logo?
18:28:39 <julen> rluethi: dguitarbite, which logo? do you have some draft already?
18:28:57 <rluethi> dguitarbite: I was hoping that with your connections, it should be too hard to find out if we qualify.
18:29:19 <dguitarbite> julen: There is some sort of logo initiative for projects under Openstack.
18:29:25 <julen> rluethi: qualify, for using the openstack image?
18:29:30 <rluethi> dguitarbite: if we do, all we have to do is think of something that fits their scheme and have their illustrator draw it for us.
18:29:32 * dguitarbite is looking like a big shot! Shh... rluethi ;)
18:30:00 <dguitarbite> rluethi: How about thinking about this bit for the next release? I will snoop around and see if we qualify
18:30:18 <rluethi> I want a praying mantis :).
18:30:32 <rluethi> it's cute and cuddly like our scripts.
18:30:33 <dguitarbite> rluethi: If we do, then lets decide if we should have the logo. AFAIK, we could also shelter under the Docs banner and logo :D
18:30:53 <julen> dguitarbite: rluethi, I personally think that it would give a lot of color to the product... look at BOMSI with the "O" looking like a CD and the "I" like a pendrive :)
18:31:19 <dguitarbite> rluethi: Alright, praying mantis is ok for me but how in the hell is it cuddly?? I could still think its cute ;(
18:31:22 <dguitarbite> *;)
18:31:23 <rluethi> dguitarbite: A cool mascot is excellent marketing.
18:31:44 <rluethi> dguitarbite: kidding, I could live with lots of other logos.
18:31:45 <julen> rluethi: definitely
18:31:47 <dguitarbite> rluethi: Ok Ill push for it.
18:32:00 <rluethi> dguitarbite: but having a professional logo is very helpful for recognition.
18:32:11 <dguitarbite> rluethi: I am fine with the logo, I just would not cuddle a mantis over a panda ;)
18:32:42 * dguitarbite was kidding :| like the cuddly cute praying mantis
18:33:05 <dguitarbite> Alright anything else that we should think about?
18:33:19 <dguitarbite> #action dguitarbite Get a praying mantis as the mascot for training-labs
18:33:35 <dguitarbite> #action rluethi Fix broken shutdown bits for windows
18:33:55 <dguitarbite> #action dguitarbite publish the parser POC ASAP. Hopefully tomorrow evening.
18:33:59 <rluethi> julen: as usual, if you have any questions or problems, contact us anytime.
18:34:04 <julen> #action julen, write the curl script
18:34:17 <rluethi> btw, I am still working on the Python port.
18:34:17 <dguitarbite> #action julen Implement basic UI testing for Horizon
18:34:21 <rluethi> cleaning up.
18:34:32 <dguitarbite> #action dguitarbite Roger continue work on python port.
18:34:36 <dguitarbite> #topic python-port
18:34:40 <rluethi> and porting the new features (PXE booting).
18:34:52 <dguitarbite> #action dguitarbite continue working on python port with lower priority
18:35:09 <dguitarbite> rluethi: I was looking at your repository today early morning :)
18:35:40 <rluethi> dguitarbite: I haven't figured out how to rebase and push the github repo. so the public repo is lagging.
18:35:47 <dguitarbite> rluethi: Its going to be tricky for me time wise, but I am going to go into my cave man mode and hybernate with vibrating fingers on my keyboard ...
18:36:06 <panda> ...
18:36:16 <dguitarbite> rluethi: Lets have a hacking session soon. Do you need to finish this bit before this weekend?
18:36:19 <rluethi> dguitarbite: just wave a magnet over the harddisk and cross your fingers.
18:36:45 <dguitarbite> panda: My sincere apologizes, I was referencing the panda Po from Kunfu Panda.
18:36:53 <rluethi> dguitarbite: I'll try to fix the Windows part this week.
18:37:22 <dguitarbite> rluethi: Alright, so lets have a brief hacking session this weekend. Lets take a look at the python port and also the rebasing issue that you are potentially facing.
18:37:41 <rluethi> OK
18:38:03 <dguitarbite> as of python port, rluethi do you want to finish it by the end of next month?
18:38:47 <rluethi> dguitarbite: I want to finish it today, but forecasts are difficult.
18:38:55 <rluethi> first, catch up with osbash again.
18:39:16 <rluethi> second, clean up enough that it can be submitted and merged.
18:39:22 <dguitarbite> rluethi: Ok, lets think about the forecast bits later, once we finish the work ;)
18:39:39 <rluethi> I don't know how much time that will take nor how much time I will have in the weeks to come.
18:39:47 <rluethi> but I would like to merge it asap.
18:39:59 <dguitarbite> rluethi: Lets do a syncup later on on this topic.
18:40:12 <dguitarbite> #topic last words before the meeting ends
18:40:46 <julen> I'm good
18:41:07 <rluethi> last words.
18:41:19 <rluethi> see you next week.
18:41:28 <julen> see you guys...
18:41:30 <dguitarbite> See you guys.
18:41:36 <dguitarbite> Thanks for the awesome work!
18:41:40 <dguitarbite> #endmeeting