18:02:01 <rluethi> #startmeeting training-labs
18:02:02 <openstack> Meeting started Mon Sep 26 18:02:01 2016 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:05 <openstack> The meeting name has been set to 'training_labs'
18:02:16 <rluethi> alright, julen, what have you got?
18:02:41 <julen> not much...
18:02:51 <julen> I tried the python port but I got an error
18:03:00 <rluethi> #topic python-port
18:03:02 <dguitarbite> hello
18:03:08 <rluethi> hi dguitarbite
18:03:10 <julen> Unable to download http://releases.ubuntu.com/14.04//.
18:03:17 <julen> hi dguitarbite
18:03:23 <rluethi> julen is just telling me that he found an error that he didn't tell me about.
18:03:39 <dguitarbite> rluethi: Everybody finds errors and does not tell you about ;).
18:03:50 <rluethi> I love you guys, too.
18:03:53 <dguitarbite> rluethi: Did we not fix this logic?
18:03:58 <julen> well.. it was yesterday quite late.. :P
18:04:10 <dguitarbite> for this ubuntu bits ... I thought we did :|
18:04:16 <rluethi> so, we're talking about python_port_13!?
18:04:46 <julen> oh... I thought about that, but you sent me the link to the port_3 so I tried that
18:05:00 <julen> was I supposed to try the 13?
18:05:37 <rluethi> julen: I did? oops. sorry. yeah, always try the latest.
18:05:38 <dguitarbite> julen: Yes.
18:05:50 <dguitarbite> rluethi: That is why one branch many commits ;) (look who is talking)
18:05:58 <rluethi> there should be 14+ on, but I didn't get around to clean it up sufficiently.
18:06:22 <rluethi> dguitarbite: you are not completely wrong, I'll give you that.
18:06:31 <julen> with the 13 I just got the same error
18:06:49 <rluethi> julen: how do you call it? what platform?
18:06:49 <dguitarbite> rluethi: :)
18:06:59 <rluethi> julen: can you send me log/stacktrain.log?
18:07:18 <julen> ./osbash.sh -b cluster
18:08:16 <rluethi> julen: osbash may be broken in that tree. I'll check. to try the python port, try ./st.py -b cluster
18:08:18 <dguitarbite> julen: I think you should try something like python st.py -b cluster -p kvm|virtualbox
18:08:27 <dguitarbite> rluethi: +1
18:08:38 <dguitarbite> the ubuntu error is not existing in this.
18:08:48 <dguitarbite> rluethi: I am quite impressed :). Awesome!
18:09:18 <rluethi> huh?
18:09:26 <dguitarbite> rluethi: With the python port I mean.
18:10:28 <rluethi> okay, I will have to clean up my repo and test.
18:10:41 <dguitarbite> yes
18:10:49 <rluethi> thanks julen for the initial report.
18:11:20 <dguitarbite> I still have some libvirt tuning to finish with my new setup.
18:11:32 <dguitarbite> But I should have a long report in email format for the same soonish.
18:12:01 <rluethi> julen: do you think you could take the python port 13 for a spin now that you found it?
18:12:07 <dguitarbite> #action dguitarbite Test python port and send the report. Black box and white box.
18:12:18 <julen> but... one question... for a python port... the osbash.sh script... it's still in Bash
18:12:49 <rluethi> julen: yes, I am keeping the bash version around. we can have both there in parallel for a short time.
18:13:09 <rluethi> they should both work, but maybe I broke osbash.sh when I was focused on python.
18:13:35 <rluethi> julen: the python code is st.py and the files in labs/stacktrain.
18:13:51 <dguitarbite> julen: I guess for the scope of testing the python port it is ok to overlook if the BASH version is broken.
18:14:04 <dguitarbite> julen: This should be tested before/while merging.
18:14:29 <julen> aha! now it works
18:14:35 <rluethi> yes. for me, osbash.sh is still working, but I'll doublecheck.
18:15:11 <dguitarbite> rluethi: julen I have to leave early today. Could we finish up my topics? Parser and Newton Port?
18:15:30 <julen> yes
18:15:33 <rluethi> #topic rst2bash parser
18:15:56 <dguitarbite> I have finally good progress. The parser is now fully functional with some minor and obvious bugs.
18:16:19 <dguitarbite> I have a already charted a plan to push things upstream.
18:16:37 <dguitarbite> I have to rebase and update the openstack-manuals repository which I am currently working on.
18:16:41 <rluethi> oooh, new code in the repo.
18:17:07 <dguitarbite> Additionally there is a bug with distro swich logic in the parser. The code is quite refined but still a bit bruteforcey but runs really fast.
18:17:25 <dguitarbite> I will be further refactoring and optimizing the code (mostly for personal reasons) later on.
18:17:28 <dguitarbite> rluethi: Yes :D.
18:17:36 <rluethi> Who cares about fast if we only run it once every 6 months? :)
18:17:43 <dguitarbite> rluethi: Today I finally nailed the path logic and I have to fix the next things again.
18:18:03 <julen> dguitarbite: once again... the openstack-manuals directory is empty
18:18:14 <dguitarbite> rluethi: Yes and no. This should be run regularly but the optimizations should only make a few ms or nano seconds of difference ;).
18:18:15 <julen> shouldn't it contain the rst files?
18:18:29 <dguitarbite> julen: It is a git submodule.
18:18:47 <dguitarbite> julen: It is linking from https://github.com/dguitarbite/openstack-manuals.
18:19:25 <julen> but it does not download that directory automatically
18:19:26 <dguitarbite> There although needs some way for us to hook the new scripts into training-labs scripts folder. I am trying to find a graceful way for the same.
18:19:31 <rluethi> julen: git submodule init; git submodule update; cd openstack-manuals; git checkout -f
18:19:40 <rluethi> or something along these lines, anyway.
18:19:42 <dguitarbite> +1
18:19:52 <dguitarbite> $ git submodule init; git submodule update;
18:20:09 <dguitarbite> you do not need to do a git checkout -f (you may have to).
18:20:31 <dguitarbite> julen: openstack-manuals is heavily bloated so give it a few minutes to clone.
18:21:02 <julen> yep, I'm on it
18:21:10 <dguitarbite> Anyhow, further plans involve immidiately merging my openstack-manuals clone to avoid my personal fork diverging too much.
18:21:18 <dguitarbite> Updating the contributors guide with new changes.
18:21:33 <dguitarbite> Pushing the parser scripts to doc-tools.
18:21:45 <julen> that's a good idea
18:21:52 <dguitarbite> I have already finished talking to Andreas last week and working to get this done asap.
18:22:06 <dguitarbite> I have a half-updated openstack-manuals repository on my WS at present.
18:22:28 <dguitarbite> Additionally this parser will also act as a linter to parse and vaildate the install-guides rst syntax.
18:22:52 <julen> wow! that sounds great :)
18:22:54 <dguitarbite> Install guides has feature freeze today, look up docs ML.
18:23:21 <dguitarbite> So, I will immidiately after finishing the other tasks, use the parser to generate Newton Scripts.
18:23:40 <rluethi> new topic?
18:23:40 <dguitarbite> Send them for review after testing and confirming that it works as expected.
18:23:50 <rluethi> #topic Newton scripts
18:24:00 <dguitarbite> Install Guides has a feature freeze today.
18:24:34 <dguitarbite> I will use the parser to generate Newton scripts, use this oppurtunity to test the parser and additionally also update the scripts semi-automatically for training-labs Newton release.
18:24:35 <julen> so, are we going automatic, or still manually?
18:24:58 <dguitarbite> julen: Scripts will be generated automatically but there will be manual interventions at a couple of places here and there.
18:25:26 <rluethi> I did a rough Newton port the old-fashioned way last week.
18:25:32 <dguitarbite> I would not count of 100% reliability. Most probably 99%. Especially with all the given work arounds that we have in there.
18:25:37 <rluethi> There are a lot of couple of places.
18:26:01 <dguitarbite> rluethi: You mean you used the parser or plain old manual?
18:26:36 <rluethi> I used the manual and had to fix all kinds of issues not in the manual or even wrong in the manual.
18:27:01 <dguitarbite> rluethi: Even the install-guides is not stable yet. So I am sure that there would be many issues.
18:27:07 <rluethi> the first fun part of the adventure was an update to xenial.
18:27:10 <dguitarbite> rluethi: That is why I was not bothered so much.
18:27:48 <julen> sorry... I went, offline. My connection up here is not so good
18:27:53 <rluethi> New, exciting races, too.
18:27:57 <dguitarbite> Alright I have to run now, but I will be focused on finishing *everything* asap :). Also I have a lot of breathing room to test the python port including my new WS.
18:28:21 <rluethi> okay, we can compare your Newton results to mine.
18:28:24 <rluethi> :)
18:28:38 <dguitarbite> rluethi: Alright :). Man v/s the Machine!
18:28:42 <dguitarbite> Bye rluethi julen :).
18:28:49 <rluethi> bye dguitarbite
18:29:35 <julen> oh.. bye guys
18:29:37 <rluethi> so, julen, what do you plan to work on? do you even have time?
18:29:44 <julen> oh..
18:29:53 <julen> well..
18:30:04 <julen> what do you want me to?
18:30:13 <julen> test the python port and the parser?
18:30:42 <rluethi> there is so much to do, just pick whatever you find interesting and rewarding :).
18:30:56 <rluethi> of course I appreciated feedback on the python port.
18:31:07 <rluethi> and the Newton port, once I have it online.
18:31:10 <julen> well.. I'll go then with the testing and telling you what I find
18:32:10 <rluethi> okay, sounds good to me (of course).
18:32:11 <rluethi> thanks.
18:32:23 <rluethi> #topic anything else
18:32:31 <rluethi> ?
18:32:40 <julen> not from my side
18:33:15 <rluethi> then I don't want to keep you. thanks for being here, let me know if you find something or need help.
18:33:20 <rluethi> otherwise, see you next week.
18:33:55 <julen> yep, see you...
18:34:03 <rluethi> bye, julen
18:34:08 <rluethi> #endmeeting