18:03:25 <julen> #startmeeting training-labs
18:03:26 <openstack> Meeting started Mon Oct  3 18:03:25 2016 UTC and is due to finish in 60 minutes.  The chair is julen. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:29 <openstack> The meeting name has been set to 'training_labs'
18:03:36 <rluethi> well done :)
18:04:28 <rluethi> set a topic.
18:04:30 <julen> I just tried to take a look to the test_horizon, but I forgot to use the last version
18:04:41 <julen> #topic test_horizon
18:04:58 <julen> what was the error?
18:05:08 <rluethi> it returns with status 8.
18:05:33 <rluethi> I looked into it real quick, it says something about POST not being allowed.
18:05:45 <julen> and with which version did you try it?
18:05:48 <rluethi> using horizon manually (browser) seems to work, though.
18:06:00 <rluethi> version of what?
18:06:08 <julen> training-labs
18:06:39 <rluethi> it's not a version of training-labs as such, it's a changeset:
18:06:47 <rluethi> #link https://review.openstack.org/#/c/380852/
18:07:20 <julen> aha.. I'll try with that one
18:08:38 <rluethi> I suspect the test script needs an update, but it wasn't obvious to me what it is.
18:09:14 <julen> sure, I'll try to get the error and I can probably make some quick fix
18:09:16 <rluethi> maybe your script could be a little bit more verbose and tell the user what exactly it is doing.
18:09:23 <rluethi> excellent.
18:09:31 <julen> I'll look into that too
18:09:49 <julen> I wrote comments on the script, but maybe not so many echo-es
18:10:06 <julen> any news about pranav?
18:10:08 <rluethi> you can turn many comments into echos.
18:10:21 <rluethi> I thought he was going to be here, but apparently he's busy.
18:10:40 <julen> today is holiday here in Germany
18:10:50 <rluethi> he did quite a bit of merging today and posted a couple of patches, as you know.
18:10:56 <rluethi> really?
18:11:02 <rluethi> I did not know that.
18:11:13 <julen> I had the feeling of "Sunday" the whole day, good that I kept thinking about the meeting... :P
18:11:46 <julen> he submitted the patch of the 14.04.5 twice, is that a duplicate?
18:12:01 <rluethi> no, one is a backport for another branch.
18:12:15 <rluethi> one for master (newton), one for mitaka.
18:12:41 <julen> aha... it has a "-1", but it was exactly the same as the other patch, so I approved both
18:13:36 <julen> #topic rst2bash
18:14:39 <julen> did you have time to try it?
18:15:15 <rluethi> not recently.
18:15:37 <rluethi> but I just looked at the 14.04.5 patch. It cannot be merged.
18:16:08 <julen> why not? the link looks right...
18:17:18 <rluethi> See my comment.
18:17:21 <rluethi> #link https://review.openstack.org/#/c/380984/1
18:18:50 <julen> there should be a way to download always the latest version automatically...
18:19:04 <rluethi> that is what the function does.
18:19:42 <rluethi> well, it assumes there is only one version on the server which has been true so far.
18:20:04 <rluethi> obviously, there is room for improvement :). but it worked for the last few updates.
18:20:13 <julen> oh... I see
18:20:54 <rluethi> I don't necessarily want to download the latest version.
18:21:02 <rluethi> I would rather go with the version that I know works.
18:21:31 <julen> yes.. that's safer
18:21:38 <rluethi> But Canonical removed the old image as soon as the new one was up, so we kept having scripts that failed to find the ISO image.
18:21:56 <rluethi> That's the reason for the special update function.
18:22:16 <dguitarbite> hello
18:22:26 <julen> hi dguitarbite!
18:22:30 <dguitarbite> Sorry for being late, holiday today, still in holiday mode :|
18:22:34 <rluethi> hi dguitarbite
18:22:47 <dguitarbite> hello rluethi julen :)
18:22:48 <julen> we were talking about the 14.04.5 patch
18:23:29 <dguitarbite> let me scroll through the logs
18:23:38 <rluethi> you botched the ubuntu update patch. bad pranav. no cookies for you.
18:25:27 <dguitarbite> botched?
18:25:29 <dguitarbite> ;)
18:25:51 <rluethi> yup. it borked the update function.
18:26:03 <julen> anything to say dguitarbite?
18:26:29 <dguitarbite> Ahh, I remembered the update function but it was still downloading the older image.
18:26:46 <dguitarbite> Additionally there  is an issue with the MD5 grepper, it assumes the position of the MD5SUM
18:27:02 <dguitarbite> So before the ubuntu guys take down the older image, I thought it would be nicer to update the version.
18:27:24 <rluethi> can you explain "it assumes the position of the MD5SUM"
18:27:25 <dguitarbite> I did test the version and it seems to be running fine although I agree I should have been more vigilant on the regressions I am causing.
18:27:52 <dguitarbite> The grepping logic assumes the image and the md5sum is the second entry in the list.
18:28:23 <rluethi> why would you say that?
18:28:38 <dguitarbite> I have another patch in my mind to have default fallback to 1[4,6].0[4.10] in case grepping is not functional
18:29:01 <dguitarbite> rluethi: I could have mis-understood the code (BASH!!!)
18:29:43 <rluethi> yeah. but there is a problem with the code. it assumes that there is only one matching line.
18:29:51 <rluethi> which was true until this time.
18:29:58 <julen> hmm... doesn't it just grep the ISO name from the MD5SUMS file? this seems to be one of the very few things working in bomsi :P
18:29:59 <dguitarbite> Yes
18:30:02 <rluethi> now they left the old image there.
18:30:32 <rluethi> just add a "| tail -n1"  after the grep and it should work.
18:31:12 <dguitarbite> Yes, that is the issue not the grep the tail -n1.
18:31:35 <dguitarbite> rluethi: Let me fix it the right way, good news at-the-very-worst is that 14.04.5 works :)
18:32:14 <julen> #topic fixing the 14.04.5 patch
18:33:07 <dguitarbite> I have something way more elegant for this, rluethi I will udpate the existing patch, giving -1 till then. Is that a fair deal in return for some cookies?
18:33:21 <rluethi> I think the tail -n1 is the right way, but if you find a better solution, I am happy to learn.
18:33:49 <dguitarbite> rluethi: I agree with tail -n1 I will not change it :).
18:33:56 <rluethi> we'll buy some cookies for you in barcelona, provided that you provide a way more elegant solution.
18:34:11 <rluethi> :)
18:34:15 <rluethi> cookies for everyone.
18:34:36 <julen> :)
18:35:04 <julen> dguitarbite: I used this one, and I am having no issues so far
18:35:07 <julen> cat ${ISO_DIR_PATH}/Ubuntu_${OP_VERSION}_MD5SUMS |grep ${BASE_ISO_NAME} |awk '{print $1}'
18:35:58 <julen> the BASE_ISO_NAME  is the full name of the ISO file
18:36:06 <rluethi> julen: can you fill in the values for the variables?
18:36:15 <dguitarbite> rluethi: Yes, I agree.
18:36:25 <dguitarbite> awk method should work fine too.
18:36:52 <rluethi> I don't understand how it works.
18:37:16 <julen> cat ~/Ubuntu_14.04.5_MD5SUMS |grep ubuntu-14.04.5-server-amd64.iso |awk '{print $1}'
18:37:42 <rluethi> julen: oh, that gives you the md5sum.
18:38:02 <julen> hmm... wheren't we talking about that?
18:38:21 <rluethi> julen: what the other function does is download an MD5SUMS file from the server and look for the name and the md5sum of the latest ISO image.
18:38:24 <rluethi> different problem.
18:39:13 <rluethi> you assume that you already have the ISO image.
18:39:15 <julen> oh, sorry
18:39:28 <dguitarbite> Hehe I agree!
18:41:42 <rluethi> okay, guys, we don't have much time til Barcelona.
18:41:55 <rluethi> Let's plan what we can do before we hit the summit.
18:41:58 <julen> dguitarbite: this is how I check for the image and checksums in the new bomsi
18:42:06 <julen> link: http://pastebin.com/QM1zvjaJ
18:43:22 <julen> rluethi: agreed
18:43:28 <julen> should we move on?
18:43:28 <dguitarbite> Alright
18:43:30 <dguitarbite> julen: Noted.
18:44:17 <julen> rluethi: any news about the python port?
18:44:55 <rluethi> julen: I split out most changes that are not Python-specific.
18:45:04 <rluethi> the remainder is the Python-port
18:45:44 <rluethi> Pranav requested that I submit it to the training-labs repo, so I have to build it on top of what is in that repo.
18:45:46 <dguitarbite> rluethi: Eager to review them :)
18:46:12 <julen> #topic python-port
18:46:20 <rluethi> I didn't get it finished yesterday, there are some differences from my private repo that I have to take into acount.
18:47:04 <rluethi> This is going to be a very busy week at work, so the Python port will probably land on Saturday or Sunday.
18:48:00 <rluethi> (by the time I get home from work, I won't have time to work on the Python port, and the commute won't be enough)
18:48:16 <dguitarbite> Works for me, I have some personal things keeping me very busy till end of this week.
18:48:19 <julen> rluethi: unfortunately I didn't have time to test it yet. Sorry about that :(
18:48:29 <dguitarbite> I should be done with the initial work on my parser by saturday too.
18:49:10 <rluethi> julen: no problem. I suggest you check out Newton and test_horizon for now.
18:49:46 <julen> rluethi: I'm on that
18:50:29 <julen> #action julen fix test_horizon
18:50:32 <rluethi> I am quite optimistic that we can merge a working Python port before the summit.
18:50:41 <rluethi> And Newton.
18:50:43 <dguitarbite> And parser :)
18:50:47 <dguitarbite> And Newton :)
18:51:02 <dguitarbite> I tested Newton too today it did not seem to work. I have to dig deeper
18:51:09 <julen> the parser is going to be a big thing :)
18:51:30 <dguitarbite> I know :) So is the python port.
18:51:38 <dguitarbite> Both of these should give us a huge boost!!!
18:51:42 <rluethi> dguitarbite: can you be a bit more specific than "it did not seem to work"? your bug reporting is really the worst.
18:52:33 <rluethi> dguitarbite: you should lead by giving a good example of how it's done.
18:52:36 <dguitarbite> I know that is why I kept quit, I jsut mean to acknowledge that I am working on it, I have to reproduce the issue and really look out if it was something from our side of the installation guides :).
18:53:11 <dguitarbite> rluethi: I know, how do I phrase this in future? Just meant to say that the newton port does not work in the first attempt :),
18:54:29 <rluethi> dguitarbite: I checked out URL X, I configured Y, I started it with Z, and I got this error: ...
18:54:50 <rluethi> you know, something that other people can try to reproduce.
18:55:31 <dguitarbite> rluethi: Yes, I forgot where it got stuck. I will comment on the review.
18:55:46 <julen> we have just 5 minutes more
18:55:58 <julen> #topic any other business?
18:56:23 <julen> I have one proposal for the preseed file
18:56:30 <rluethi> I am good for now. I think everybody knows what they have to do.
18:56:36 <rluethi> julen: yes?
18:56:38 <julen> choose-mirror-bin	mirror/http/mirror	select	archive.ubuntu.com
18:57:07 <julen> this way it will always chose the mirror closer to your location, instead of the us.archive.ubuntu.com one
18:57:24 <rluethi> julen: if it works, that would be awesome.
18:57:29 <julen> (the above line is supposed to be a preseed command)
18:57:30 <rluethi> did you test it?
18:57:51 <julen> it seems to work in the tests I'm doing...
18:58:13 <dguitarbite> It does seem to work!
18:58:29 <rluethi> Then I suggest you submit updated preseed files with a new version name (v5 or whatever it is going to be).
18:58:29 <dguitarbite> julen: The problem with preseed is that it is not that well documented.
18:59:19 <julen> dguitarbite: tell me about it... :P
18:59:33 <rluethi> It's good to keep old versions of preseed files around for some time because otherwise you cannot easily change them for testing.
18:59:46 <rluethi> okay guys, we have to go.
19:00:08 <rluethi> julen: endmeeting
19:00:08 <julen> rluethi, dguitarbite, thanks for the meeting
19:00:15 <rluethi> thanks everyone
19:00:16 <julen> #endmeeting