20:02:46 <sarob> #startmeeting training-manuals
20:02:47 <openstack> Meeting started Mon Jul 15 20:02:46 2013 UTC.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:51 <openstack> The meeting name has been set to 'training_manuals'
20:03:13 <colinmcnamara> colin is here
20:03:30 <sarob> hey
20:03:39 <colinmcnamara> hey, just had lunch w/ Vinay
20:03:44 <sarob> sweet
20:03:53 <sarob> you seen the agenda?
20:04:04 <colinmcnamara> looking now
20:04:19 <colinmcnamara> k, got it
20:04:33 <sarob> we can add what ever you desire
20:04:41 <sarob> just me thoughts to get started
20:05:20 <colinmcnamara> sounds good to me
20:05:27 <sarob> #topic what todo exists in the blueprint and what exists in trello
20:05:44 <colinmcnamara> probably want to discuss project structure, what to put in this sprint
20:05:50 <colinmcnamara> what timebox to put in the sprint
20:06:00 <sarob> hmm, okay
20:06:05 <colinmcnamara> sorry, adding to
20:06:14 <sarob> np
20:06:19 <colinmcnamara> ok, sorry about disrupting, back on Topic
20:06:38 <sarob> im thinking about trello being useful for sprint topic org
20:07:01 <colinmcnamara> agree
20:07:06 <sarob> communicating with the larger community would be the blueprint and wiki spec
20:07:14 <colinmcnamara> I think that makes sense
20:07:19 <colinmcnamara> one issue that I realized
20:07:27 <sarob> so we just need to find balance
20:07:32 <colinmcnamara> is that there is overlap between the bug tracking system
20:07:33 <sarob> some overlap
20:07:36 <colinmcnamara> and tasks in trello
20:07:47 <sarob> hmm, shouldnt be
20:08:02 <sarob> id keep them separate
20:08:18 <colinmcnamara> I agree, just saying that some people use the bug tracking system as a task tracking system
20:08:25 <sarob> ahh
20:08:26 <colinmcnamara> probably not appropriate though
20:08:41 <sarob> a way to boost your karma perhaps
20:08:56 <sarob> id like to keep them separate
20:09:05 <colinmcnamara> I agree
20:09:23 <colinmcnamara> one thing I do like, is that I can get a visual view of what needs to get done
20:09:30 <colinmcnamara> and that it is reasonably open
20:09:48 <colinmcnamara> oh, and when I subscribe I get notifications on my mobile devices, as well as the online tool (I'm always on the go)
20:09:56 <sarob> so lets write up a para on bugs, trello sprints, and wiki topics
20:10:06 <sarob> right
20:10:35 <sarob> add the para to #link https://wiki.openstack.org/wiki/Training-manuals
20:10:59 <sarob> did I really create a page with caps?
20:11:04 <sarob> argg
20:11:07 <colinmcnamara> is that a task that we need done?
20:11:09 <colinmcnamara> doh
20:11:11 <colinmcnamara> yes you did
20:11:15 <colinmcnamara> Traning
20:11:30 * sarob banging head on the table
20:11:40 <sarob> bad sean
20:12:00 <sarob> moving on
20:12:07 <sarob> #topic core team members status
20:12:35 <sarob> i have not found anyone
20:12:48 <sarob> that i think should be part of core yet
20:13:02 <sarob> well other than seanwinn
20:13:20 <colinmcnamara> what about mestery and mark voelker?
20:13:23 <sarob> and you :)
20:13:29 <colinmcnamara> Thx sean ;)
20:13:43 <sarob> you vote for mark voelker
20:13:44 <colinmcnamara> I think it would make sense to get some other meetup organizers as core
20:13:49 <sarob> and kyle mestery
20:13:51 * mestery is happy to help and be core here, but is on PTO (and just checking his computer for the moment, honest).
20:13:53 <colinmcnamara> yes, I vote for him and kyle
20:13:59 <colinmcnamara> both ATC's in quantum
20:14:06 <colinmcnamara> both meetup organizers
20:14:31 <colinmcnamara> and Voelker is right next to RedHat OpenStack development in RTP
20:14:53 <colinmcnamara> i'm thinking about who could get engagement outside of just SFbay
20:15:09 <colinmcnamara> also, we are going to get to a point where we need to have different people deliver the content
20:15:12 <colinmcnamara> and submit bugs
20:15:27 <colinmcnamara> the more user groups we can get involved, the better (to a point)
20:15:32 <colinmcnamara> just my thoughts
20:15:34 <sarob> mestery: understood
20:16:17 <sarob> yeah, i agree we need user group leader representation
20:16:42 <sarob> i think there are three levels of participation
20:17:00 <colinmcnamara> what are the levels?
20:17:03 <sarob> core would be involved in design and sprints
20:17:36 <colinmcnamara> ok
20:17:39 <sarob> sub-core? would be involved in editing content
20:18:13 <sarob> user groups/community would be involved in using material and submitting bugs
20:18:24 <colinmcnamara> that sounds logical
20:18:33 <sarob> that way we can keep things as is
20:18:38 <colinmcnamara> effectively structure it similar to a full flegded project
20:18:54 <sarob> sfbay user group hackathon turns into communicating status
20:19:07 <colinmcnamara> e.g. core would be quasi PTL and backup
20:19:07 <sarob> and walking through the material
20:19:17 <sarob> should
20:19:22 <sarob> opps, sure
20:19:31 <sarob> right on
20:19:39 <colinmcnamara> makes sense, it gets SFbay back on track
20:19:48 <colinmcnamara> and delivering value that is appropriate for the community
20:19:55 <sarob> yup
20:20:13 <colinmcnamara> e.g. next thursday would be (OpenStack basic install and operation beta review - section 1)
20:20:14 <sarob> i want lots of people to start showing up to the hackathons
20:20:19 <colinmcnamara> agreed
20:20:22 <sarob> cause there is value
20:20:45 <sarob> moving on to next topic?
20:20:59 <sarob> #topic docs refactoring impact on training-manuals
20:21:04 <colinmcnamara> agreed
20:21:32 <sarob> opps, im not setting action items
20:22:04 <colinmcnamara> opps or oops?
20:22:12 <sarob> whatever ;)
20:22:27 <colinmcnamara> not sure if opps was some sort of IRC code ;)
20:22:37 <sarob> so i dont see any problems with the docs refactoring so far
20:22:39 <sarob> you?
20:22:45 <colinmcnamara> no, I went through that email threawd
20:22:52 <colinmcnamara> I think that problems may creep up
20:23:05 <colinmcnamara> and that we need to ensure the CI system test covereage is sufficient
20:23:16 <colinmcnamara> I think there is a gap there, based on earlier merge issues
20:23:46 <colinmcnamara> I was reading up on Maven, and there is a safety check for referenced materials
20:23:52 <sarob> #action colinmcnamara: monitor infra CI test coverage
20:24:08 <colinmcnamara> agreed, and that is reflected in a task on trello right now
20:24:32 <sarob> #action sarob: monitor openstack-docs refactor
20:24:38 <sarob> moving on
20:24:47 <colinmcnamara> I think there is another action in there
20:25:07 <sarob> which?
20:25:26 <colinmcnamara> I think it starts w/ a question. I know that I am way week on maven
20:25:31 <sarob> hard stop in 5min
20:25:43 <colinmcnamara> are you up to speed on Maven enough that you feel we have enough knowlege
20:25:53 <colinmcnamara> or should we try to rope in an outsider to help
20:26:36 <sarob> i on the local side yes, we should ping #openstack-infra channel when we have pipeline questions
20:27:06 <sarob> #action use #openstack-infra for CI test coverage
20:27:09 <colinmcnamara> agreed
20:27:22 <sarob> #topic how to stitch docs together if content is not in the same repo
20:27:47 <sarob> i want to use the material in the operator and developer guides
20:27:57 <colinmcnamara> is that also in github?
20:28:22 <sarob> im thinking to use github.org/openstack/ repo url to stitch the material together
20:28:24 <colinmcnamara> I think I read in the Maven guide that you can call up class from a higher directory
20:28:29 <sarob> in addition to the local xml
20:28:32 <colinmcnamara> exactly
20:28:53 <sarob> there is no higher dir in the local repo
20:29:06 <sarob> but url ref to github should work
20:29:10 <colinmcnamara> I think we need to get one example just for test in the maven pom file
20:29:21 <colinmcnamara> and then use that to define an archeotype
20:29:39 <sarob> when the merge happens, the material gets stitched together
20:29:53 <sarob> as long as the merge process has access, it should work
20:30:05 <colinmcnamara> putting even more importance on CI coverage
20:30:25 <colinmcnamara> because the merge may happen later and later, as well as multiple merges in annes queue
20:30:36 <sarob> i need help on where to pull the material from at the high level
20:30:45 <sarob> true
20:30:55 <sarob> gotta run
20:31:02 <sarob> will tweet some more
20:31:06 <colinmcnamara> sounds good
20:31:08 <colinmcnamara> good meeting
20:31:10 <colinmcnamara> ttyl
20:31:14 <sarob> #endmeeting