20:01:00 <sarob> #startmeeting training-manuals
20:01:01 <openstack> Meeting started Mon Jul 29 20:01:00 2013 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:04 <openstack> The meeting name has been set to 'training_manuals'
20:01:36 <colinmcnamara> sarob: hello?
20:01:37 <sarob> Just started, right on time
20:01:42 <colinmcnamara> perfect
20:02:16 <sarob> I'm going to run down the agenda unless you have something else
20:02:38 <colinmcnamara> i'm good with you running down the agenda. I have nothing else
20:02:51 <sarob> #topic update on getting training published to docs.openstack.org
20:03:28 <colinmcnamara> so, still in progress
20:03:43 <colinmcnamara> I was reading through the jenkins documentation on ci.openstack.org
20:04:02 <colinmcnamara> there is a statement that a release has to be tagged for jenkins/zuul to copy the docs to the site
20:04:26 <colinmcnamara> however, in github there are only releases for major releases (folsom, grizzly, etc)
20:04:52 <colinmcnamara> relevant doc - release section - http://ci.openstack.org/zuul.html#zuul
20:05:00 <sarob> Infra irc channel any help?
20:05:10 <colinmcnamara> that is my next step
20:05:24 <sarob> Sounds good
20:05:51 <colinmcnamara> also to monitor logstash.openstack.org during the next merge
20:05:55 <colinmcnamara> to see what gets pushed where
20:07:35 <sarob> Good idea
20:07:45 <sarob> Move on?
20:07:58 <colinmcnamara> agreed
20:08:29 <sarob> #topic update on contribution levels publish
20:08:48 <sarob> I will write this up today
20:09:37 <colinmcnamara> core / community / others?
20:09:53 <sarob> Right
20:10:26 <sarob> #action sarob write up contribution levels on wiki
20:11:02 <sarob> Moving on
20:11:16 <sarob> #action update on xi:include xpointer
20:11:25 <sarob> Crap
20:11:36 <sarob> #topic update on xi:include xpointer
20:12:47 <sarob> It looks like the content that xpath walks through using xpointer needs to have a structure defined
20:13:11 <colinmcnamara> in the XML, or in the pom.xml file?
20:13:11 <sarob> With DTD or XMLschema namespace
20:13:22 <colinmcnamara> as in an import statement
20:13:36 <sarob> In the XML that is being pointed to
20:14:04 <colinmcnamara> so, each item that we are pointing to needs to have an update to succesfuly import it into openstack-training?
20:14:06 <sarob> Which could mean all source XML would have to be modified
20:14:22 <sarob> Right
20:14:26 <colinmcnamara> sounds like that makes identifying the source docs in the users stories doubly important
20:14:34 <colinmcnamara> as well as submitting bugs for each one
20:14:45 <colinmcnamara> do you think this is something that we should also raise up to Anne?
20:14:50 <sarob> I'm going to run some tests this afternoon to verify
20:14:55 <sarob> Maybe
20:15:49 <sarob> I need to get some feedback from someone that has experience with xpath before I go to Anne
20:16:16 <colinmcnamara> I saw the response on the mailing list
20:16:34 <colinmcnamara> is this something that we should be pulling from the external community on?
20:17:17 <sarob> Yup, cause I'd like bypass using namespaces if possible
20:17:32 <sarob> Heavyweight for what we are doing
20:18:05 <colinmcnamara> any open source communities that impliment something like this?
20:18:09 <colinmcnamara> we could phone a friend
20:18:20 <colinmcnamara> or people within Yahoo, PayPal, Apple, etc?
20:18:33 <sarob> #action sarob test and report xpath options
20:18:50 <sarob> I'm going to try yahoo int next
20:19:25 <sarob> Need to find an XML user group next
20:19:33 <colinmcnamara> good idea
20:19:41 <colinmcnamara> possibly java users  too
20:19:51 <colinmcnamara> since mvn is key to dependancy management in Java
20:20:08 <colinmcnamara> any java / xml FOSS projects we can leverage experience on, maybe pop over to their IRC?
20:20:08 <sarob> Moving on?
20:20:11 <colinmcnamara> Moving on
20:20:42 <sarob> #topic doc-core team members update
20:21:11 <sarob> I haven't worked on getting anyone yet
20:21:25 <sarob> How bout you
20:21:42 <colinmcnamara> I've reached out to Mestery and Shannon Mcfaarland
20:21:52 <colinmcnamara> mcfarland was on holiday, just got back in
20:21:57 <colinmcnamara> mestery was in a sprint
20:22:03 <colinmcnamara> I need to get commitments this week
20:22:59 <sarob> I'm going to troll doc-core
20:23:08 <colinmcnamara> thats smart, get a guru
20:23:18 <colinmcnamara> what was our target membership for Core? 8 right?>
20:23:19 <colinmcnamara> ?
20:23:57 <sarob> I was shooting for 10, thinking we would get half true partipation
20:24:07 <colinmcnamara> ahh cool
20:24:11 <colinmcnamara> then I'll reach out to Cody too
20:24:17 <colinmcnamara> at rackspace
20:24:24 <colinmcnamara> he is working on a couch to openstack program
20:24:26 <colinmcnamara> could tie in
20:24:34 <colinmcnamara> + published the openstack ops guide
20:24:41 <sarob> Sounds good
20:24:59 <colinmcnamara> trying to go after a mix of operators / vendors
20:25:06 <colinmcnamara> I'd love to get Vinay in
20:25:11 <sarob> Ideally
20:25:13 <colinmcnamara> though, he is swamped with PayPal stuff
20:25:20 <sarob> Good mix
20:25:21 <colinmcnamara> maybe you can put a little pressure too
20:25:36 <sarob> Most important firm commitment
20:25:41 <colinmcnamara> agreed
20:25:46 <colinmcnamara> I have lunch at Apple this week btw
20:25:55 <colinmcnamara> I'm going to bring this up with the guys there
20:25:56 <sarob> cool
20:26:18 <sarob> At least get them to use would be good
20:26:22 <colinmcnamara> yup
20:26:36 <colinmcnamara> i'm working on recruiting both Core, as well as community to create / review / etc
20:26:42 <sarob> I gots nothing else
20:26:55 <sarob> Cool
20:26:56 <colinmcnamara> I would be happy to see some of the beta sessions delivered to a mix of operators
20:27:18 <colinmcnamara> I can take a couple days away from my day job to help facilitate
20:27:51 <sarob> Once we get the content out there. I want to blast the community list and user groups for participation.
20:28:03 <sarob> So close
20:28:11 <colinmcnamara> I think we will still have to structure a couple of beta's for instructor delivered content
20:28:22 <colinmcnamara> to kick start a bug squash
20:28:50 <sarob> Lets start brainstorming on that
20:29:10 <colinmcnamara> #action rough out beta format
20:29:12 <sarob> Want to assign an action to yourself?
20:29:18 <sarob> Sweet
20:29:20 <colinmcnamara> sorry, wanted to try the command ;)
20:29:28 <sarob> np
20:29:30 <colinmcnamara> #action rough out beta format : colinmcnamara
20:30:04 <sarob> If nothing else. I'm going run.
20:30:34 <colinmcnamara> one thing
20:30:39 <colinmcnamara> the HP instructor in SF openstack
20:30:54 <colinmcnamara> he may have some good idea's on the beta structure
20:31:01 <colinmcnamara> as well as my friend Joe
20:31:07 <colinmcnamara> he was the CTO of firefly
20:31:14 <sarob> Sure, lets socialize
20:31:19 <colinmcnamara> training.. I am going to start pulling in idea's
20:31:34 <colinmcnamara> other then that, I am find to adjourn
20:32:10 <sarob> Cheers!
20:32:17 <colinmcnamara> Cheers!
20:32:20 <sarob> #endmeeting