20:01:01 <sarob> #startmeeting training-manuals
20:01:02 <openstack> Meeting started Mon Aug  5 20:01:01 2013 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:05 <openstack> The meeting name has been set to 'training_manuals'
20:01:26 <sarob> anyone out there?
20:05:35 <colinmcnamara> colin just found his way online
20:06:00 <colinmcnamara> Sean, you there?
20:06:29 <sarob> yo
20:06:54 <colinmcnamara> yo
20:07:06 <colinmcnamara> sorry about being late. on a remote network with odd securinty controls
20:07:20 <sarob> no problem
20:07:27 <rev> ditto... only my excuse isn't as cool as colin's
20:08:13 <sarob> so to the agenda, which i didnt make much progress on :(
20:08:34 <colinmcnamara> is the #topic what items to cover in the agenda this meeting?
20:08:50 <sarob> yup
20:08:54 <colinmcnamara> I know you were sick, and I was traveling. Arey you feeling better?
20:09:01 <sarob> 100%
20:09:09 <colinmcnamara> I would like to add the topc - section file structure
20:09:17 <colinmcnamara> and share status on publishing of content
20:09:23 <sarob> sure,
20:09:29 <sarob> #topic publishing training to doc.openstack.org
20:10:08 <sarob> i remember something getting merged, was it success?
20:10:12 <colinmcnamara> so, I found that without the shell statemetns in manual.yaml
20:10:23 <colinmcnamara> that zuul won't move the files to the public server
20:10:27 <sarob> ah
20:10:39 <sarob> kinda makes sense
20:10:46 <colinmcnamara> I added those, and the changes got merged on 7/31
20:11:02 <colinmcnamara> however, there is a formal release process
20:11:05 <colinmcnamara> even to trunk
20:11:11 <colinmcnamara> so, the release manager has to tag a release
20:11:21 <colinmcnamara> in openstack-manuals
20:11:41 <sarob> is annie the release manager in this case?
20:11:44 <sarob> anne
20:11:46 <sarob> i mean
20:11:52 <colinmcnamara> I believe so. I wanted to cover it in the office hours this morning
20:11:55 <colinmcnamara> but was on a plane
20:12:18 <sarob> lets ping her after the meeting
20:12:50 <colinmcnamara> sounds like a plan
20:13:19 <sarob> #action colinmcnamara sarob email annegentle on release tag for training manuals
20:13:42 <sarob> good work colin
20:13:46 <sarob> moving on
20:14:00 <colinmcnamara> thx
20:14:19 <sarob> #topic section file structure
20:14:38 <sarob> are you thinking section headings and links back to bug create or something else?
20:15:02 <colinmcnamara> I was thinking of how we break out the chapters
20:15:13 <colinmcnamara> that if we broke out each section as an seperate section xml file
20:15:22 <colinmcnamara> that would ease the headaches of merging
20:15:35 <colinmcnamara> and allow us to further distrubute work on the sections
20:15:36 <colinmcnamara> e.g.
20:15:47 <colinmcnamara> you have set, book, chapter defined
20:16:01 <colinmcnamara> these files are effectively files that capture include statements
20:16:07 <colinmcnamara> and then each section would map to a user story
20:16:24 <colinmcnamara> we could just set up a script to auto gen empty ones, that would align to the stories
20:16:29 <sarob> so like the general chapters would be broken up further
20:16:39 <colinmcnamara> exactly
20:16:41 <sarob> to user stories
20:16:48 <colinmcnamara> yes
20:16:52 <colinmcnamara> each chapter file
20:17:00 <colinmcnamara> would contain a bunch of includes to the section files
20:17:09 <colinmcnamara> that way it makes it easier to have multiple people working on a chapter
20:17:15 <sarob> oxygen would keep track so fine with me
20:17:21 <colinmcnamara> awesome
20:17:36 <colinmcnamara> was thinking once we have the base include template format
20:17:45 <colinmcnamara> we could pre-populate with a script
20:17:58 <colinmcnamara> that way a new contributor can just pull / patch one file at a time
20:18:27 <sarob> could script it, but its a one time deal, right?
20:18:40 <colinmcnamara> could script, or just manually copy
20:18:43 <colinmcnamara> either way works
20:19:05 <sarob> once we build out the user stories, no one else would have to do cause they would be pulling the files
20:19:08 <colinmcnamara> probably good to prepend the section file name with the appropriate chapter name
20:19:15 <colinmcnamara> correct
20:19:47 <sarob> i think id rather do a bit more manual work just to get the files out there asap
20:19:55 <colinmcnamara> cool
20:20:24 <colinmcnamara> btw, here is a sample script that I used to create a readme file out of existing files. could use it to create the include statements - https://github.com/ashleymcnamara/openchimp/blob/master/listing-generator.py
20:20:57 <sarob> so we have to figure out at a high level how to link user stories to existing sections
20:21:09 <sarob> to get the work started
20:21:25 <colinmcnamara> I think there is a manual task of creating - assigning them
20:21:35 <colinmcnamara> easy way is to output the trello board to xls
20:21:49 <sarob> hmm, okay
20:21:53 <colinmcnamara> and use the sprint backlog to create the section names
20:22:09 <colinmcnamara> let me noodle on that while we are dealing with publishing
20:22:11 <sarob> how about we focus on this hackathon to do exactly that
20:22:19 <colinmcnamara> ooh.. great idea
20:22:36 <sarob> whiteboard it for each of four books
20:22:36 <colinmcnamara> probably good topic to cover in this meeting too (adding topic) hackathon agenda)
20:22:49 <sarob> right
20:23:24 <sarob> #action set hackathon agenda in this meeting
20:23:44 <colinmcnamara> did the example xml include xml statement work
20:24:03 <colinmcnamara> so we can put an example structure in each of the files?
20:24:10 <sarob> #action user story equals file included in each general xml file
20:24:26 <sarob> nope
20:24:44 <colinmcnamara> :/
20:24:56 <sarob> im trying to get shaun's attention again as he seems to be the expert
20:25:06 <colinmcnamara> gnome shaun?
20:25:11 <sarob> yup
20:25:18 <sarob> ill keep at it
20:25:35 <colinmcnamara> was he at foo camp all last week?
20:25:50 <colinmcnamara> I know lots of people were hiding out there after OSCON
20:26:17 <sarob> donow
20:26:21 <sarob> dontknow
20:26:51 <sarob> moving on, yo
20:27:00 <sarob> #topic get core members signed on
20:27:26 <colinmcnamara> so, Mestery accepted
20:27:47 <colinmcnamara> core on neutron
20:27:56 <colinmcnamara> now core on openstack-training
20:28:09 <colinmcnamara> still need to verify with shannon mcfarland
20:28:26 <colinmcnamara> I'll be up in Colorado next week, probably pull him aside and have the discussion
20:28:50 <sarob> i was thinking of asking shaun mccance and diane fleming
20:29:04 <colinmcnamara> probably good to get some doc experts
20:29:09 <colinmcnamara> I would recommend asking
20:29:23 <colinmcnamara> I'm definately looking forward to the doc bootcamp
20:32:01 <sarob> monty taylor and tristan goode
20:32:10 <sarob> that my four
20:32:24 <colinmcnamara> you know them better then I do
20:32:28 <sarob> im going to send out emails today
20:32:30 <colinmcnamara> you want to reach out
20:32:59 <colinmcnamara> ?
20:33:04 <colinmcnamara> awesome
20:34:09 <sarob> rev: you spoke up earlier, are you lurking or you interested in getting involved?
20:35:16 <rev> yup
20:35:27 <sarob> #action sarob invite monty taylor, tristan goode, shaun mccance, diane fleming
20:35:48 <sarob> #info mestery joins training manuals core
20:36:07 <rev> I just signed up for Doc Bootcamp
20:36:15 <sarob> #action colinmcnamara invite shannon next week to core
20:37:45 <sarob> cool, so interested working on chapters and fixing bugs?
20:38:49 <sarob> okay, np
20:38:57 <sarob> moving on
20:39:15 <sarob> #topic possible dates for sprint
20:40:08 <colinmcnamara> so, when you define sprint
20:40:15 <colinmcnamara> are you talking about an in person sprint?
20:40:22 <sarob> yup
20:40:35 <colinmcnamara> or, logical scrum structure (I think we should address both)
20:41:11 <colinmcnamara> I suggest spending the day after the docs bootcamp as a sprint day
20:41:32 <colinmcnamara> using all the stuff we learned in the doc bootcamp
20:41:51 <sarob> my though as well
20:42:08 <sarob> we get all core to attend bootcamp
20:42:11 <colinmcnamara> I do have a charity tournement the day after
20:42:27 <sarob> thats bad timing
20:42:52 <colinmcnamara> oh, not the day after the docs boocamp
20:42:56 <colinmcnamara> the day after the day after
20:43:03 <sarob> oh, okay
20:43:10 <colinmcnamara> it's to support wounded warriors.. its for a good cause
20:43:15 <sarob> right
20:43:29 <colinmcnamara> so, block out the day after the doc bootcamp as a sprint day?
20:43:56 <sarob> 11sep2013 as training manuals sprint day
20:44:15 <sarob> #action 11sep2013 training manuals sprint day
20:44:53 <sarob> two more hackathons before sprint
20:45:22 <colinmcnamara> we should probably decompose some capabilities to get people armed with over the hackathons
20:45:33 <colinmcnamara> so that they can come in ready to go in the sprint?
20:45:46 <sarob> actually three hackathons
20:46:09 <sarob> agreed
20:46:14 <colinmcnamara> I would recommend that at each of our hackathons ask what people would want to attend
20:46:23 <colinmcnamara> and make sure they are armed and set up previous on workflow
20:46:49 <sarob> so core would need to show to sprint and rest are optional
20:47:10 <sarob> is that what you are thinking?
20:47:11 <colinmcnamara> Ideally. I'm not sure if Kyle can flyin for a day. but I'll ask if he is in town
20:47:21 <colinmcnamara> is the sprint in person or distributed?
20:47:34 <sarob> hmm, good question
20:48:05 <colinmcnamara> I think distributed is probably harder, but a better goal to strive for
20:48:06 <sarob> not sure why in person would be required, just online and working as a team for the day
20:48:10 <sarob> more important
20:48:18 <colinmcnamara> so we agree, distributed
20:48:25 <sarob> agreed
20:48:35 <colinmcnamara> though, if people are in a geo, it would be good to get in person meeting space
20:48:47 <colinmcnamara> and get an irc channel assigned for the sprint
20:48:50 <sarob> want to allow non-cores to sign up for sprint as well?
20:49:05 <colinmcnamara> probably a bridge / webex to share desktops if we are debugging oxygen issues
20:49:07 <sarob> irc channel makes sense
20:49:08 <colinmcnamara> I think so
20:49:16 <sarob> agreed
20:49:32 <colinmcnamara> we should draw a line in the sand, offering coaching on workflow
20:49:43 <colinmcnamara> so we don't spend the entire sprint getting people through git workflow
20:49:50 <colinmcnamara> is a sign up page necessary?
20:49:59 <colinmcnamara> so we know who will be attending?
20:50:00 <sarob> #action sprint day will be requested in person, distributed team okay, with cores required and rest of team optional
20:50:23 <sarob> docbootcamp?
20:51:21 <colinmcnamara> ?
20:51:27 <colinmcnamara> no, for the sprint
20:51:39 <sarob> ah, right
20:51:43 <colinmcnamara> just thinking that if we get people to sign up in a central place
20:51:49 <colinmcnamara> we will get a notion of location
20:51:54 <colinmcnamara> and can coordinate space
20:51:57 <sarob> how about,.... meetup page?
20:51:57 <colinmcnamara> food / drink
20:52:15 <colinmcnamara> meetup is local to area though
20:52:26 <colinmcnamara> for example, if someone wants to set up a room in RTP
20:52:28 <rev> I don't think WebEx worked very well a the last bi-weekly meetings. Is there any way we can use Yahoo's meeting room phone system? That seemed to be better than cellphones that was used last time.
20:52:28 <sarob> ? how so?
20:52:45 <colinmcnamara> who is the question directed at
20:52:54 <colinmcnamara> rev or colinmcnamara
20:53:23 <rev> I think colin. My question was badly timed
20:53:45 <sarob> colinmcnamara: meetup is kinda local if you are looking for a meeting
20:53:46 <colinmcnamara> my statement was that we should probably set up a google form, or eventbrite, something
20:53:58 <colinmcnamara> I was thinking that if say, two people sign up remotely in the same town
20:53:59 <sarob> eventbrite sounds good
20:54:08 <colinmcnamara> that with that information we could help set up space
20:54:34 <colinmcnamara> for example, if there is a Nexus office in either of those area's. I can usually get a meeting room with inet access
20:54:47 <sarob> do we want to default to sunnyvale? pleasanton?
20:54:49 <colinmcnamara> and if that is not possible, I can usually call someone at Cisco or EMC to provide space
20:55:00 <colinmcnamara> your call
20:55:05 <colinmcnamara> we both live in the east bay
20:55:07 <rev> pleasaton during rush hour is harsh
20:55:19 <sarob> sunnyvale is waay worse
20:55:24 <rev> aren't you guys down here during the day?
20:55:27 <colinmcnamara> correct
20:55:28 <sarob> yup
20:55:38 <colinmcnamara> I can check if I can get the training room at the Nexus Pleasanton office
20:55:48 <colinmcnamara> it fits about 20 comfortably
20:56:29 <sarob> lets get both rooms as placeholders
20:56:40 <sarob> if not too much trouble
20:56:48 <rev> fair enough but anyone in SV must leave at least 2 hours before meeting if going to be there
20:57:01 <sarob> sv to pls?
20:57:10 <sarob> cross commute
20:57:11 <rev> during rushour
20:57:37 <sarob> going north should be about 45-60 min
20:57:37 <rev> if meeting time is 7pm... that's rushhour travel
20:57:48 <colinmcnamara> sv north in the morning is 45 min to pleasanton
20:58:06 <rev> hmmm... previous century I dated a gal out there and it was more like 2 hours
20:58:12 <sarob> we talking sprint
20:58:25 <rev> 45 minutes at noonish or midnight :-)
20:58:25 <sarob> not hackathon
20:58:37 <rev> oh :-[
20:59:20 <sarob> sorry, jumped around there
20:59:31 <rev> my bad. Need to keep up.
21:00:13 <sarob> #colinmcnamara sarob both reserve ~20 person rooms for 11sep2013 training manual sprint
21:00:25 <colinmcnamara> just sent the mail to book the room
21:00:29 <sarob> cool
21:00:37 <colinmcnamara> 5200 franklin drive, pleasanton ca 94583
21:00:37 <sarob> AOB?
21:00:44 <colinmcnamara> AOB = ?
21:00:49 <sarob> any other bus
21:00:53 <sarob> iness
21:01:10 <colinmcnamara> tactical sprint stuff
21:01:17 <colinmcnamara> food / drink? I can cover pleasanton
21:01:43 <sarob> we can let the sprint members choose
21:01:44 <colinmcnamara> other then that. I am good
21:01:50 <sarob> which locale
21:02:03 <sarob> id vote ptown
21:02:37 <sarob> lets defer sprint details for next week
21:02:40 <colinmcnamara> 2nd vote from me , ptown
21:02:44 <colinmcnamara> works for me
21:02:56 <sarob> okay, then lets wrap
21:03:01 <colinmcnamara> dumb question, is this week an in person hackathon week?
21:03:15 <colinmcnamara> and it's a wrap
21:03:16 <sarob> im going to be there
21:03:21 <sarob> in person
21:03:44 <sarob> rev: ill hang over if you have questions
21:04:09 <sarob> #endmeeting