17:06:03 <rl> #startmeeting training-manuals
17:06:04 <openstack> Meeting started Mon May 26 17:06:03 2014 UTC and is due to finish in 60 minutes.  The chair is rl. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:07 <openstack> The meeting name has been set to 'training_manuals'
17:06:24 <rl> so, anyone else besides dguitarbite and me?
17:06:30 <dguitarbite> roll call
17:06:52 <dguitarbite> #topic training-labs
17:07:08 <rl> right. have you seen the etherpad updates?
17:07:17 <dguitarbite> nope, link pelase
17:07:18 <dguitarbite> *please
17:07:31 <dguitarbite> have been really busy past couple of weeks
17:07:32 <rl> #link https://etherpad.openstack.org/p/training-labs-scripts
17:08:09 <dguitarbite> whats your progress in training labs?
17:08:59 <rl> I implemented preliminary support for Fedora 20.
17:09:18 <rl> Just to see what it takes to support an rpm-based distro, too.
17:09:22 <dguitarbite> awesome
17:09:44 <rl> Host-side I have covered.
17:09:55 <rl> There are some issues, but I can work them out.
17:10:00 <dguitarbite> we could come up with some good way to reduce boilerplate for cross platform installation commands
17:10:08 <rl> Guest side is a different story.
17:10:12 <dguitarbite> did you patch them upstream?
17:10:52 <rl> Well, I submitted one detailed but report to Oracle about VirtualBox, but I have yet to hear from them.
17:11:05 <dguitarbite> what exactly seems to be the issue?
17:11:09 <rl> There's a work-around.
17:11:16 <rl> Oh, there's plenty.
17:11:36 <dguitarbite> just add them as info
17:11:43 <dguitarbite> #info Virtual Box issues
17:11:50 <rl> CDs not ejecting, consoles not displaying, kernels not updating, dkms not being installed etc.
17:11:56 <dguitarbite> lets try to see if we can hack our way around them
17:11:58 <rl> Most of it is fixed.
17:12:06 <rl> The real issue is guest side.
17:12:17 <dguitarbite> what is the guest side issue?
17:12:27 <rl> The cross-platform boilerplate stuff you mentioned, it exists.
17:12:39 <rl> That's what puppet and chef do, pretty much.
17:12:47 <dguitarbite> yeah, I know puppet can do that
17:12:49 <rl> And devstack does it, too.
17:12:53 <dguitarbite> but can we do that in shell scripts?
17:13:08 <rl> I started re-using some of the devstack libs.
17:13:20 <rl> Problem is, they are not designed to be used that way.
17:13:26 <dguitarbite> #action reuse devstack scripts in training-labs
17:13:38 <dguitarbite> #action figure-out puppet-openstack scripts for training labs
17:14:13 <rl> Also, I don't know what sort of distribution methods we want to support.
17:14:46 <dguitarbite> I think supporting Ubuntu and CentOS/Fedora should be enough
17:14:50 <rl> matjazp thinks the batch scripts for Windows are useful.
17:15:07 <dguitarbite> training should be kept as simple as possible by eliminating all the cross platform stuff
17:15:08 <rl> We can do Vagrant, of course.
17:15:22 <dguitarbite> batch scripts for Windows?
17:15:29 <dguitarbite> I didn understand this
17:15:36 <dguitarbite> do you mean PowerShell commands?
17:15:46 <dguitarbite> *Powershell Scripts
17:15:48 <rl> I wish. Old Windows shell.
17:15:54 <rl> Let me explain:
17:15:58 <dguitarbite> ok
17:16:32 <rl> The install scripts run on Linux or Mac.
17:16:49 <dguitarbite> sarob: hello
17:16:51 <rl> While they run, they can write a batch file that will do the same thing on Windows.
17:16:59 <sarob> Sorry about that
17:17:07 <rl> No need for Vagrant or ssh.
17:17:09 <dguitarbite> rl: do we need that?
17:17:26 <dguitarbite> no one uses Windows server as base OS for OpenStack deployments
17:17:31 <rl> That is exactly one of the questions I asked (also mentioned on the etherpad).
17:18:00 <dguitarbite> we need to eliminate complex stuff and try to make it simple
17:18:05 <sarob> Agreed
17:18:45 <dguitarbite> sarob: show must go on ;) ... no issues we were discussing Training-Labs blueprint hoping that you will join in :)
17:18:54 <sarob> Thanks
17:19:22 <sarob> Keeping the assoc and oper guides up to date is critical
17:19:40 <sarob> Can you take lead on that?
17:19:56 <dguitarbite> yes
17:20:08 <sarob> I'll focus on getting help from intel and comcast?
17:20:08 <dguitarbite> I will do that
17:20:11 <dguitarbite> #action dguitarbite track progress and update Associate and Operator Guide upto date
17:20:14 <sarob> :)
17:20:47 <dguitarbite> I might me able to convince my new employer to give me some resources for this
17:20:55 <sarob> #action sarob get assoc and oper contributors from comcast and intel
17:20:57 <dguitarbite> but I should be able to do it regardless of their support
17:21:18 <sarob> Do what you can
17:21:39 <sarob> If I can get a few training devs
17:21:57 <sarob> Then we will be in good shape
17:22:27 <sarob> Then I can work with stef tom loic on develop guide
17:22:36 <dguitarbite> ok
17:22:49 <dguitarbite> I am going to come up with OpenStack Koans
17:23:06 <dguitarbite> I have approached some of the online python tutorial designers
17:23:08 <rl> sorry, misclicked.
17:23:23 <rl> matjazp found the Windows shell scripts useful, because many students have Windows on their machines.
17:23:27 <dguitarbite> to discuss how to design Dev. Training Labs
17:23:34 <sarob> Cool
17:23:46 <dguitarbite> rl: using VirtualBOx should be better on Windows Machiens
17:23:48 <sarob> Show them the Dev design off wiki
17:23:49 <dguitarbite> *machines
17:24:11 <rl> dguitarbite, better than what?
17:24:24 <dguitarbite> better than just running the scripts on windows directly
17:24:36 <dguitarbite> also you can emulate multi-node and cool stuff
17:24:44 <dguitarbite> on single machine
17:24:54 <rl> Oh, the scripts just do what they do on Linux. They set up a training cluster in VirtualBox VMs.
17:25:04 <sarob> We should consider prebuilt as well
17:25:16 <dguitarbite> rl: ok, then its fine
17:25:18 <dguitarbite> sarob: yes
17:25:25 <dguitarbite> rl: who will maintain these scripts?
17:25:35 <sarob> Scripts for DIY and ready made ubuntu VMs
17:25:53 <dguitarbite> sarob: DIY?
17:26:01 <sarob> Do it yourself
17:26:05 <rl> good question. host-side, there shouldn't be much maintenance necessary, once they work.
17:26:08 <dguitarbite> ok
17:26:17 <sarob> We should assume trainers
17:26:26 <rl> the real work is going to be one the guest side.
17:26:41 <dguitarbite> sarob: is it feasible to rely on trainers?
17:26:46 <rl> every OpenStack release, every operating system you want to support.
17:26:49 <sarob> Will not be scripters
17:26:58 <dguitarbite> rl: guest side, we have to try n re-use devstack and puppet-openstack
17:27:01 <sarob> For training?
17:27:27 <dguitarbite> sarob: usually trainers may not get the time and funding for working on scripts
17:27:42 <dguitarbite> sarob: unless you can convince someone like Hastexo
17:27:49 <dguitarbite> who do it really well
17:28:04 <sarob> We agree
17:28:17 <sarob> We publish scripts
17:28:43 <sarob> But assume first choice to use trainer VMs
17:28:44 <rl> sarob, can I also point you to the etherpad and ask you to add any comments, thoughts, questions you may have?
17:28:48 <rl> https://etherpad.openstack.org/p/training-labs-scripts
17:28:55 <sarob> That are result of scripts
17:29:32 <rl> sarob: the scripts can produce a three-node OVA right now.
17:29:44 <rl> one image, three VMs with shared COW disks.
17:29:58 <sarob> Hmm, not bad
17:30:02 <rl> (well, base disk is shared, the COW disks obviously not)
17:30:11 <dguitarbite> I can maintain the pre-built images
17:30:17 <dguitarbite> but were do we upload them?
17:30:47 <rl> matjazp offered to host them for the time being.
17:30:56 <dguitarbite> #action dguitarbite figure out how to create vagrantbox for training-labs
17:30:59 <dguitarbite> rl: sounds good
17:31:20 <dguitarbite> may be we could get to a point where we provide these images as vagrantboxes
17:31:25 <sarob> I can prob find dropbox space off infra
17:31:25 <dguitarbite> to make it really simple
17:31:34 <dguitarbite> sarob: sounds good too
17:31:58 <sarob> Use matjazp space for now
17:32:21 <dguitarbite> ok
17:32:26 <sarob> rj add etherpad link to wiki
17:32:36 <sarob> Good stuff
17:32:52 <dguitarbite> #action dguitarbite create MultiNode/Single Node ova's for Havana/IceHouse release
17:33:38 <dguitarbite> sarob: Associate and Operators is still on Havana?
17:33:47 <rl> sarob, I added it to the training-labs blueprint. I didn't find a training-labs wiki page. Only training-manuals.
17:33:48 <dguitarbite> or have we ported it to Icehouse ?
17:34:03 <dguitarbite> rl: training-manuals will do for now
17:34:13 <rl> dguitarbite, Okay
17:34:39 <sarob> #action sarob find trainer script vm results
17:35:20 <sarob> #action sarob find trainer script vm results location for trainers to pull from
17:36:03 <rl> sarob: what's vm results?
17:36:44 <sarob> rl VMs that result from script
17:36:55 <sarob> A bit wordy
17:36:55 <rl> oh, okay.
17:37:26 <dguitarbite> sarob: deep thinker!
17:37:29 <sarob> Wiki linked off blueprint to here #link https://wiki.openstack.org/wiki/Training-manuals
17:37:56 <sarob> Wiki should link to all ideas and plans
17:38:26 <sarob> I want n00bs to start at the wiki
17:38:33 <dguitarbite> #action dguitarbite, rl create training-labs wiki page based on training-labs blueprint
17:38:38 <dguitarbite> yep
17:38:42 <rl> ack
17:38:57 <sarob> :)
17:39:31 <sarob> So I had talks with comcast and intel
17:39:36 <sarob> At the summit
17:39:55 <sarob> Not the devs but those that would task the devs
17:39:55 <dguitarbite> how interested are they?
17:40:05 <sarob> Seems very
17:40:31 <dguitarbite> hmmm... intel seems to be doing lot of processor optimization for OpenStack
17:40:32 <sarob> I need to translate that interest into actual commitments
17:40:58 <sarob> Intel is thrashing around to get involved
17:41:22 <rl> processor optimization for OpenStack? for real? what would they do?
17:41:30 <sarob> I jam to aim them in direction that helps us
17:41:32 <dguitarbite> their input will be really valuable
17:41:42 <sarob> I aim to aim
17:41:50 <sarob> Damn spell chk
17:41:55 <dguitarbite> I would have jammed with you :
17:41:58 <dguitarbite> :|
17:42:04 <sarob> well that two
17:42:15 <sarob> Or too
17:42:59 <dguitarbite> rl: Im not sure how exactly they are doing processor optimization for OpenStack but may be they are making openstack core libs run better on their processors
17:43:40 <rl> I thought they were adding a Python interpreter into CPU microcode :-).
17:44:01 <dguitarbite> rl: that would be python optimization
17:44:21 <dguitarbite> rl: I cannot say much on this topic, I dont know much in this area
17:44:26 <sarob> Python run faster would be okay, but speed was never a big issue for infrastructure usually measured in days
17:44:43 <rl> Hence my question.
17:45:04 <sarob> Ovs and openflow however different issue
17:45:20 <rl> Right.
17:45:25 <dguitarbite> well, reducing overhead and other similar things make an attractive selling point and advantage over their competitors
17:45:34 <sarob> Network flows both data and control plane speed a big deal
17:45:55 <dguitarbite> sarob: agree, or be ready for storms n congestions
17:46:07 <sarob> Which intel is already battling broadcom
17:46:40 <dguitarbite> makes sense
17:47:01 <sarob> Openstack we need to befriend intel folks and direct their energies for critical projects
17:47:10 <sarob> Like training
17:47:20 <rl> Hear, hear.
17:47:30 <sarob> Nova net neutron feature parity
17:47:40 <sarob> Congress and the like
17:48:54 <dguitarbite> ok, and what about comcast?
17:49:14 <sarob> They are deploying internally
17:49:27 <sarob> Dev nfv
17:49:30 <sarob> Both
17:49:38 <sarob> Big push for them
17:49:52 <sarob> They need to train their people
17:50:12 <sarob> They want to own the training
17:50:29 <sarob> Our approach allows them to do that
17:50:43 <rl> It will.
17:50:48 <dguitarbite> yeah, I am happy with the progress in Associate and Operators
17:50:56 <dguitarbite> they can tweak dev training to their needs
17:51:11 <dguitarbite> *as per their needs
17:51:21 <sarob> I need to get another core reviewer
17:51:52 <sarob> Spinning us off to separate project is prob the only way
17:52:50 * rl wonders if the scripts could be integrated with devstack
17:53:03 <sarob> So that's the plan for this cycle
17:53:16 <sarob> rl hmm, that's a good idea
17:53:23 <rl> The big remaining issue is guest side scripts. I started looking into devstack, because it does a lot of the heavy lifting (installing and configuring OpenStack components).
17:53:28 <dguitarbite> rl, may be ... but I dont think so
17:53:46 <dguitarbite> we need to use devstack and may be use it as a submodule
17:54:02 <rl> My favorite solution is for devstack to accept patches that make it easier to use part of their stuff as a library.
17:54:15 <sarob> I leave to you guys to figure it out
17:54:23 <dguitarbite> sarob: ok
17:54:24 <sarob> I trust you
17:54:32 <dguitarbite> rl: lets sit this weekend and discuss this out properly
17:54:55 <dguitarbite> sarob: :)
17:55:15 <sarob> #action sarob publish training-manual incubated plan
17:55:16 <rl> Okay. I'll send you the scripts towards the end of the week so you'll know what we are talking about.
17:55:28 <sarob> Me run now
17:55:37 <dguitarbite> me too
17:55:38 <sarob> Thanks you guys!
17:55:41 <dguitarbite> its getting late here
17:55:57 <dguitarbite> nice talking to you guys, have fun
17:56:04 <dguitarbite> #endmeeting
17:56:45 <rl> #endmeeting