17:00:16 <sarob> #startmeeting training-manuals
17:00:17 <openstack> Meeting started Mon Jun 30 17:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:21 <openstack> The meeting name has been set to 'training_manuals'
17:00:31 <sarob> Roll call
17:00:36 <matjazp> hi
17:00:37 <dbite> hello
17:00:44 <Guest99011> Hello
17:00:49 <rluethi> hey
17:01:00 <annegent_> hey
17:01:08 <annegent_> I can only stay for a few, sorry
17:01:27 <fthamura> greet all :)
17:01:35 * dbite lets cover anne's part first then
17:01:43 <sarob> Annegent_ let's start with docs-specs then
17:01:48 <sarob> Yup
17:02:01 <sarob> #topic docs-specs repo
17:02:12 <annegent_> #link https://review.openstack.org/#/c/103115/
17:02:37 <annegent_> Looks like I need to get the ACLs set, working on that this morning (not sure how yet)
17:02:51 <matjazp> what's with ACLs? new group docs-specs-core?
17:02:59 <annegent_> Ah I'm behind, Andreas is on it
17:03:55 <annegent_> matjazp: yeah, it seems like glance, nova, etc. are setting up separate spec review core teams
17:04:09 <sarob> Annegent_ what's the process plan for getting specs approved?
17:04:51 <sarob> Annegent_ and how narrow specs should be?
17:05:13 <sarob> annegent_ should I start that discussion on the ML?
17:05:26 <annegent_> sarob: re: approval. I'd like two +2s
17:05:32 <matjazp> sarob: or maybe comments on that review?
17:05:54 <annegent_> sarob: but will approve as PTL as oslo and others are doing by sending a note to the mailing list saying "-1 now or forever hold your peace"
17:05:55 <sarob> Both sounds right to me
17:06:22 <sarob> Annegent_ not sure I understand?
17:06:23 <annegent_> sarob: re: scope of spec. I'd like to keep the same as we have now. No blueprint needed for general content changes, but need a blueprint for sweeping changes across multiple books or for tooling changes.
17:06:43 <annegent_> sarob: matjazp: yes comments on that review will certainly hold back approval
17:07:08 <dbite> annegent_: in that case, flat repo structure should do the trick
17:07:27 <sarob> Dbite agreed there
17:07:37 <rluethi> annegent_: tooling changes == different tools, right? not changes regarding tools. that would get tired fast.
17:08:07 <annegent_> rluethi: right, different tools, or new tools
17:08:30 <annegent_> sarob: understand the review? Thinking of the oslo thread here: http://lists.openstack.org/pipermail/openstack-dev/2014-June/037082.html
17:08:37 <matjazp> so BPs are for big changes only? As now, they were used (in Training guides) for more specific, smaller changes
17:08:59 <matjazp> like add a chapter
17:09:02 <annegent_> matjazp: to me, in the docs program, we have used bps for large changes. Smaller changes are bugs and the discussion is in the bug comments.
17:09:23 <annegent_> #link https://blueprints.launchpad.net/openstack-manuals/
17:09:30 <sarob> annegent_ I get that it's the -1 ptl bit I don't get
17:10:30 <annegent_> sarob: in oslo's case, the ptl sent out a note http://lists.openstack.org/pipermail/openstack-dev/2014-June/038423.html that said, "we've talked about this extensively, I'll go ahead and approve unless someone says not to by a particular date"
17:10:53 <sarob> Annegent_ ah, right.
17:11:27 <matjazp> new chapter in guides=bug or BP?
17:11:28 <annegent_> sarob: we can certainly talk more about scope of blueprints and when they are required and when they are not on the ML
17:11:38 <sarob> Okay, so team, are we in agreement to start using the docs-specs repo for our specs?
17:11:47 <sarob> annegent_ roger that
17:11:50 <dbite> matjazp: new chapter == bug/ new book == BP
17:11:53 <matjazp> +1 for specs
17:11:55 <annegent_> matjazp: same for you, ask that question on the ML. I'm inclined towards fewer BPs but that's me
17:12:11 <annegent_> dbite: that's how I'll lean
17:12:26 <annegent_> towards lean. haha
17:12:49 <sarob> Id like to debate through specs reviews new material or books like the Dev guide
17:12:54 <rluethi> sarob: fine
17:13:13 <sarob> Can a get a few more votes?
17:13:27 <sarob> Docs-specs yes or no
17:13:29 <annegent_> sarob: new material can be a bp, such as the ceilometer admin info
17:13:32 <fthamura> question: how will complete and coverehensive the openstack manual will be?
17:13:57 <sarob> Annegent_ got it
17:14:09 <annegent_> fthamura: we try to keep the docs scope tight due to limited resources and needing to prioritize.
17:14:19 <sarob> Dbite matjazp
17:14:26 <dbite> ?
17:14:30 <matjazp> sarob: I allready voted +1
17:14:36 <dbite> +1
17:14:47 <sarob> Okay thx
17:14:49 <rluethi> sarob: whatever facilitates dicussion is good. I am somewhat concerned with the bureaucracy.
17:15:00 * dbite should we think of using #vote?
17:15:05 <annegent_> rluethi: I know, it's a balancing act.
17:15:22 <dbite> rluethi: talking about todays spec merge!
17:15:30 <dbite> nice point
17:15:30 <annegent_> sorry, have to go. I'll catch up in the notes.
17:15:31 <sarob> Dbite next time sure
17:15:47 <sarob> Annegent_ thx
17:16:05 <sarob> #topic reviews
17:16:36 <sarob> Has everyone reviewed at least once last week?
17:16:47 * dbite more than once
17:16:54 <rluethi> me too.
17:16:59 <sarob> Excelllent
17:17:07 <sarob> Anyone else?
17:17:08 <dbite> I am treating the reviews as servers and I am on call :)
17:17:16 <sarob> Me too
17:17:24 <rluethi> aol.
17:17:47 <sarob> Okay well that's a good start
17:18:05 <dbite> I think we have about 12-20 hours before a patch is reviewed at present
17:18:11 <dbite> sarob: I agree
17:18:12 <matjazp> hmmm... we had +2 for accepted.. should we try to use +1's? And save +2s for "emergency"?
17:18:27 <sarob> Config gerrit/review to watch openstack/training-guides
17:18:28 <dbite> matjazp: yes, that is the practise
17:18:49 <dbite> critical stuff is getting instant +2, +1 (workflow)
17:18:53 <rluethi> easy patches get reviewed a lot faster than 12-20 hours.
17:19:08 <sarob> Matjazp that's a good practice. I will work on that
17:19:20 <dbite> other stuff, two reviewers are doing the same thing after +1 from jenkins and +1 from other reviewer
17:19:21 <matjazp> there were quite a few +2.. maybe we should slow down and use +1s
17:19:30 <dbite> rluethi: I meant initial response time
17:19:50 <rluethi> dbite: it's often a couple of hours tops.
17:20:04 <sarob> Let's work on getting multiple reviews same day
17:20:05 <dbite> yep, worst case (weekends) its not more than a few hours
17:20:09 <sarob> At least
17:20:25 <dbite> yep, we have good geo-coverage as of now
17:20:29 <rluethi> split patches into pieces that are easy to digest, and it won't be a problem.
17:20:31 <dbite> till I move to GMT+1
17:20:41 <sarob> #action team reviews same days
17:20:56 <matjazp> dbite:  oh? gmt+1? in my neighbourhood? :)
17:21:04 <dbite> matjazp: yep :)
17:21:19 <sarob> #action core reviewers work on +1 reviews, +2 sparingly
17:21:19 <rluethi> GMT+1 covers quite an area.
17:22:04 <dbite> move on?
17:22:22 <sarob> Shillasaebi any notes from your team?
17:22:59 <sarob> #topic stable team update
17:23:21 <Guest99011> sarob: this is Megan, we are working on breaking down the training guides
17:23:39 <dbite> Guest99011: hi megan
17:24:02 <sarob> Guest99011 gots an etherpad for work so far?
17:24:06 <ShillaSaebi_> sorry - no notes as of now @sarob
17:24:09 <dbite> can we do the initial planning here ? https://etherpad.openstack.org/p/training-guides-install-guide
17:24:43 <Guest99011> I will add information there - we have been working internally, and need to review the email sent this morning
17:24:54 <sarob> Okay
17:25:13 <dbite> I am moving the XML files as per this BP https://review.openstack.org/#/c/103482/
17:25:27 <dbite> before I start with install guides work
17:26:27 <sarob> Dbite hmm, I'm okay with this. We will end up with a common dir too?
17:26:58 <dbite> sarob: I cannot say as of now, may be in future
17:27:24 <sarob> Dbite okay. As long as the team can follow the change
17:27:47 <dbite> I think this change is welcome, it should make our lives very simple for editing XML
17:28:07 <sarob> Dbite what about the naming change we discussed?
17:28:29 * dbite memory loss
17:28:36 <dbite> can you tell me a bit more on that?
17:28:41 <sarob> Dbite normally these two topics would be specs
17:29:04 <sarob> Dbite mentioned desire to rename files
17:29:21 <dbite> yes, its under the same spec
17:30:03 <sarob> Dbite ah. Okay. So next time we do something this big, let's create a spec/bp
17:30:20 <sarob> Dbite for debate transparency
17:30:20 <dbite> mostly, we just modify this spec
17:30:24 <dbite> yes
17:30:34 <sarob> Okay. Anything else?
17:30:49 <dbite> bouncerstation is setup
17:30:55 <dbite> infact I am connected to ZNC as of now
17:31:09 * dguitarbite :| I feel I am ditched ;)
17:31:27 <dbite> *bouncerstation setup is done
17:31:39 <dbite> I will put the docs up after the meeting
17:31:44 <dbite> so others can use it too
17:32:03 <rluethi> dbite: great. thanks.
17:32:11 <sarob> Dbite cool, so you are unable to use your normal handle through znc live?
17:32:16 * dbite welcome
17:32:20 <dbite> sarob: I can use them both
17:32:22 <dbite> as you saw
17:32:30 <dguitarbite> I can use my normal login via. client
17:32:34 <sarob> Dbite okay got it
17:32:55 <dbite> it works fine, my ID's are aliases and auth. to freenode via. SSL and password
17:33:05 <sarob> Dbite thanks. I will review and add mobile config if any
17:33:12 <dbite> and I can use bouncerstation login via. the same client to be more verbose
17:33:22 <dbite> sarob: sure
17:34:15 <sarob> Dbite if like to target Juno-m2 for stable team to have the assoc and oper guides up to icehouse
17:34:27 <sarob> Dbite is that possible?
17:34:31 <dbite> when is Juno-m2?
17:35:08 <sarob> 26jul
17:35:23 <dbite> it should be possible
17:35:40 <sarob> #action stable team icehouse target juno-m2
17:36:16 <sarob> #action core-reviewers use irc bouncer for their irc handle
17:36:48 <dbite> #action setup bouncerstation steps on wiki
17:36:57 <sarob> #core reviewers review at least once per day
17:37:16 <sarob> #topic Dev team
17:37:54 <sarob> So we have stalled with the specs thing in the middle
17:38:58 <dbite> sarob: I think officiating it via. manuals was a bit time consuming
17:38:58 <sarob> I will get the bp discussion restarted on the ML on prereq, labs
17:39:12 <matjazp> I was holding my BPs back (spec repo changing)... but also...now Anne said that new chapters are bugs, right? We kinda used BPs for way smaller tasks for now... should we discuss this (big or "small" BPs)on ML? To be in sync with Docs team... (they use BPs for bigger changes)
17:39:49 <sarob> Matjazp I think we should do what the team feels right
17:40:11 <matjazp> I kinda like smaller BPs.. you guys?
17:40:27 <sarob> Matjazp I think annegent_ can live with us being a bit more active with bps
17:40:40 <sarob> Matjazp I agree
17:41:07 <sarob> Matjazp bp equal storyboard cards for me
17:41:57 <sarob> Matjazp and that maps closer to the storyboard project which we prob will be using by fall
17:42:29 <dbite> matjazp: for your sub-team, its your decision
17:42:42 <sarob> Dbite I like that
17:42:43 <dbite> I still feel that specs provide better documentation for blueprints.
17:42:55 <matjazp> sarob: will Storyboard change specs/BP way of working?
17:43:06 <sarob> Dbite allows for debate and discussion
17:43:06 <dbite> but it adds lot of bureaucracy
17:43:30 <sarob> Dbite true so let's move them reviews
17:44:03 <dbite> yep
17:44:05 <sarob> Matjazp storyboard will likely replace launchpad bp
17:44:28 <sarob> Matjazp but still early days so specs for now
17:45:33 <sarob> #action each subteam will discuss what level of work equals spec/bp
17:45:44 <sarob> Moving on
17:45:57 <sarob> #topic infra team update
17:46:15 <sarob> Irc bouncer was good
17:46:29 <sarob> Any new tests?
17:46:49 <rluethi> nope.
17:47:07 <sarob> We need to work on language support
17:47:36 <sarob> Some time for that
17:47:38 <sarob> ?
17:47:41 <rluethi> sarob: like what openstack-manuals has?
17:47:43 <fthamura> hi all, i posted also this in ML-doc, regarding infra, can you share what is your spec there, to run test? because we are starting develop on it, is 5 intel NUC can become minimum spec for infra?
17:47:46 <sarob> Yeah
17:48:21 <dbite> not yet
17:48:25 <rluethi> sarob: I doesn't look difficult, but the devil's probably hiding in the details.
17:48:29 <dbite> we need to get the install guides up
17:48:47 <rluethi> sarob: and testing locally is tricky.
17:49:06 <sarob> #action infra think on language support by Juno-m3
17:49:13 <sarob> Sound okay?
17:49:21 <dbite> fthamura: we need to decide the specs, I would suggest not yet
17:49:43 <rluethi> sarob: should be doable.
17:50:33 <sarob> Fthamura we have the trainer scripts set for 4 node build. What reason would be to change?
17:50:51 <dbite> rluethi: its you need to take the lead for multi language support, I have no idea in that area
17:51:03 <dbite> s/its//
17:51:42 <fthamura> sarob: not change, i will follow your spec, as first program.. and need to create infra with several variance spec. interest with Intel NUC, because low energy
17:51:53 <rluethi> dbite:  i18n and l10n are not exactly my areas of expertise, either :)
17:52:41 <sarob> Fthamura I think you are confusing the trainer scripts with production like cluster
17:53:10 <sarob> Fthamura let's continue on ML
17:53:12 <fthamura> sarob: i will email in ML, so wont distrub this meeting
17:53:38 <sarob> Infra any thing else?
17:53:39 <dbite> rluethi: I mean my brains point to /dev/null || /dev/rand in this
17:54:10 <sarob> #topic testing team update
17:54:20 <matjazp> sarob: we talked about PPTs some time back... do we still have a set of "core" PPTs in our plans? For Associate guide first...
17:55:12 <sarob> Matjazp we could start with landslide stuff stef pushed
17:55:15 <dbite> I would like to use rst and landslide as stefano does, the ppts are really attractive, any comments?
17:55:20 <dbite> sarob: +1
17:55:51 <matjazp> as soon as spec-repo is finished, I will create specs for BPs for Associate guide (missing quiz chapters)
17:56:16 <sarob> Matjazp Good good
17:56:32 <fthamura> sarob: done, emailed in ML
17:56:32 <matjazp> sarob: where is Stefs stuff? I can take a look...
17:57:12 <dbite> matjazp: https://review.openstack.org/#/c/100999/
17:57:42 <sarob> Anything else?
17:58:01 <matjazp> nope
17:58:04 <sarob> #action matjazp review https://review.openstack.org/#/c/100999/
17:58:28 <sarob> #action testing team specs for missing assoc quizzes
17:58:45 <dbite> one question
17:58:47 <sarob> #topic any other business
17:58:55 <sarob> Dbite shoot
17:59:14 <dbite> testing team will put their content in the same folder or should I create one for them?
17:59:17 <sarob> 1 min warning
17:59:23 <dbite> like associate-guides/testing
17:59:25 <dbite> or just simple
17:59:34 <dbite> associate-guide/*.xml(s)
17:59:35 <dbite> ?
17:59:44 <matjazp> same folder I guess?
17:59:51 <sarob> Hmm, I would think same folder too
18:00:01 <dbite> ok
18:00:06 <matjazp> why separate folder?
18:00:26 <dbite> just asking, since I did not know about it
18:00:32 <dbite> I guess I will keep it in same folder
18:00:32 <sarob> That's it pumpkin time. ML or channel for rest
18:00:40 <dbite> sure I'm done
18:00:43 <matjazp> bye
18:00:44 <sarob> #endmeeting