17:00:21 <sarob> #startmeeting training-manuals
17:00:22 <openstack> Meeting started Mon Jul  7 17:00:21 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:25 <openstack> The meeting name has been set to 'training_manuals'
17:00:33 <sarob> Roll
17:00:42 <matjazp> hi
17:01:25 <Zucan> Hi (Scott Adkins).  Megan is trying to join
17:01:45 <sarob> Hi
17:02:09 <matjazp> hello Zucan
17:02:22 <dguitarbite> hello
17:02:58 <sarob> Hi all
17:03:19 <sarob> #topic stable team update
17:03:46 <dguitarbite> 1. Major updates to the repository structure as per the given blueprint https://blueprints.launchpad.net/openstack-training-guides/+spec/separate-folders-for-books
17:04:06 <dguitarbite> 2. Kickstarted basic-install-guide https://etherpad.openstack.org/p/training-guides-install-guide
17:04:07 <Fthamura> I am in
17:04:17 * dguitarbite waves
17:05:15 <Fthamura> Any task for me?
17:05:21 <dguitarbite> we need to make sure that reviewers are consistently reviewing over the next two weeks till we hit Juno2 (or Juno1?)
17:05:36 <dguitarbite> to push the basic-install-guide content without much delay
17:06:12 <sarob> 26 jun juno-2
17:06:23 <dguitarbite> sarob: thanks
17:06:55 <dguitarbite> comcast team there?
17:08:04 <Zucan> Comcast: yes, we are here... I am helping Megan, looks like she is on now.
17:08:05 <Zucan> sorry.
17:08:15 <dguitarbite> Zucan: kool
17:08:19 <matjazp> sarob: 26 july, not june?
17:08:48 <sarob> Oops 26jul
17:09:05 <dguitarbite> Juno2: July 26th
17:09:24 <dguitarbite> Zucan: we need to collaborate a lot more to get basic install guides section running
17:09:30 <Zucan> Understood.
17:09:38 <dguitarbite> we are trying to finish it before July 26th
17:09:47 <Zucan> Yeah, that time is quickly coming.
17:09:51 <dguitarbite> can you guys give some time on this ?
17:09:58 <MeganR> Let's schedule a meeting for tomorrow or Wed to review in more detail
17:10:01 <dguitarbite> basically port ideas here https://etherpad.openstack.org/p/training-guides-install-guide
17:10:12 <dguitarbite> tomorrow sounds good
17:10:14 <MeganR> I added some information there earlier
17:10:35 <sarob> I want assoc and oper guides to be stable by Juno m3
17:10:42 <dguitarbite> MeganR: Yes, I believe content in green
17:10:49 <dguitarbite> sarob: there is one issue with that
17:10:57 <sarob> And plan for Juno stable soon
17:11:06 <sarob> Yup
17:11:15 <dguitarbite> do you expect Swift's install section to be ready ?
17:11:40 <dguitarbite> the major issue with Swift is that it may not work with VirtualBox multi-node (I need to test it properly)
17:12:28 <dguitarbite> need lot of work to validate and come up with clean and simple set of instructions for complete OpenStack (nova, neutron etc.) + swift running on training-guide's labs (on virtualbox) with single and multi node
17:12:28 <sarob> Should doc prob as bug
17:12:43 <sarob> So other team members can share workload
17:13:05 <dguitarbite> sarob: Nope, swift will work. We need to make it work on Training Labs (VirtualBox VMs)
17:13:13 <dguitarbite> with OpenStack completely running
17:13:25 <dguitarbite> which is something I have not tested properly
17:14:18 <sarob> You are on the right track with the bp
17:14:26 <sarob> And documenting the work
17:14:47 <dguitarbite> which bp?
17:15:07 <sarob> The two you just ref
17:15:15 <Fthamura_> Any url for virtual box vm,  that I can download?
17:15:24 <dguitarbite> yes
17:15:46 <Fthamura_> Any min requirement to start,  so I can d have same spec with all of you?
17:15:48 <dguitarbite> can we put Swift after Juno2?
17:16:23 <dguitarbite> Zucan, MeganR: Can we schedule meeting tommorow? I am on IST (India Std. Time).
17:16:33 <sarob> You tell me what you can do
17:16:34 <MeganR> Certainly
17:16:49 * notmyname sees "swift" and lurks
17:16:50 <sarob> We the people you have
17:17:29 <dguitarbite> sarob: I doubt if Swift can be used for Training Labs, but we can still have install commands for it and put a note that it should be done on actual servers
17:17:39 <dguitarbite> does that sound good?
17:17:40 <sarob> I can push for more help to move the dates
17:18:05 <sarob> For now okay
17:18:09 <dguitarbite> hmm, can anyone take the responsibility for Training Labs part?
17:18:12 <notmyname> dguitarbite: swift on virtual box with vagrant: https://github.com/swiftstack/vagrant-swift-all-in-one  <-- does this help anything?
17:18:41 <dguitarbite> notmyname: the problem is to deliver Swift with other services Nova, Neutron etc.
17:19:01 <dguitarbite> iSCSI starts freaking out on second level virtualization
17:19:23 <notmyname> ok. let me know if I can answer any questions or point in the right direction
17:19:24 <dguitarbite> and using loop devices for emulating multiple hdd's would make it a nightmare
17:19:34 <dguitarbite> notmyname: I need to get it tested
17:20:11 <dguitarbite> like use VirtualBox Single and Multi Node with complete OpenStack (which is current Training Labs) + Swift
17:20:40 <sarob> I'm good with workarounds
17:20:56 <matjazp> dguitarbite: maybe notmyname can test it with swift and report back?
17:20:57 <sarob> Just make sure the workaround is documented
17:21:05 <Fthamura_> All,  are any discussion of this training lab also in doc ml?
17:21:06 <dguitarbite> matjazp: sounds good
17:21:18 <dguitarbite> notmyname: can you test it out?
17:21:28 <notmyname> matjazp: dguitarbite: I don't really have much context here. I don't know what "it" is.
17:21:38 <notmyname> send me an email about it?
17:21:40 <notmyname> me@not.mn
17:21:48 <dguitarbite> notmyname: I can help you get started
17:22:14 <sarob> Thx for pitching in notmyname
17:22:21 <dguitarbite> #action dguitarbite help notmyname with Training-Labs + Swift : email : me@not.mn
17:22:29 <dguitarbite> notmyname: thank you
17:22:31 <matjazp> notmyname: it= Training labs scripts that build test OpenStack instalation
17:22:58 <dguitarbite> matjazp: that will be step 2
17:23:11 <notmyname> heh. I haven't done anything yet :-)
17:23:12 <dguitarbite> first we need to do it manually, get the notes and automate it via. training labs
17:24:48 <matjazp> dguitarbite: hmmm... I was showing swift + other parts of openstack with devstack only on my trainings
17:24:53 <sarob> Notmyname right you are
17:25:19 <dguitarbite> matjazp: does it work properly?
17:25:29 * sarob you honor the code yo
17:26:02 <dguitarbite> matjazp: also Training-Labs installs OpenStack services were as DevStack runs them manually from the repositories
17:26:04 <matjazp> dguitarbite: yes, as far as I can remember.. but it was not a "production" swift version (eg. just with one replica, etc...)
17:26:10 <dguitarbite> there is a lot of difference
17:26:42 <sarob> We need to move on
17:26:46 <dguitarbite> sarob: I think we should move to other topics, we can discuss this later on on #openstack-doc channel
17:26:47 <notmyname> that's ok if you're just looking for an "API target" thing. one replica, one server, etc is fine :-)
17:26:54 * dguitarbite couldnt agree more
17:27:36 <matjazp> dguitarbite: notmyname; yes, for trainings.. it was perfect that way... not so demanding on hw
17:28:01 <sarob> #action Dguitarbite plan for stable features by jm2, jm3 with bp, bug targeted
17:28:15 <sarob> Moving on
17:28:33 <sarob> #topic testing team update
17:28:58 <matjazp> I have two things to discuss
17:29:06 <dguitarbite> #action dguitarbite MeganR Zucan (comcast team) meeting Tuesday Jul08 for basic-install-guide to target Juno2
17:29:50 <matjazp> one... oficial docs-specs repo is up... but docs team is pushing for bp=big change, trainings team is more inclined for bp=smaller task
17:30:45 <sarob> Yup
17:30:50 <matjazp> so will we be using it differently?
17:31:31 <sarob> It's a grey area what's big or small reading annegentle def
17:31:50 <matjazp> ok then.. I'll commit a a spec and see what happens ;)
17:32:01 <sarob> We have a lot a work that req what I would call big changes
17:32:09 <matjazp> another issue: slides with landslide (https://review.openstack.org/#/c/100999/)
17:32:28 <sarob> Training team should be on the spec mostly anyway
17:33:04 <sarob> Matjazp so do we want to just go forward with supporting landslide?
17:33:09 <matjazp> I looked at it... and have few issues to discuss
17:33:33 <sarob> Matjazp oscon is soon
17:33:54 <matjazp> sarob: yes, I'm ok with it... but as I know my colleagues, they are used to PPTs (academics that is)
17:34:01 <sarob> It would be great to have the material merged by the
17:34:03 <sarob> Then
17:34:28 <matjazp> we should at least have slides in PDF
17:34:32 <sarob> Matjazp http doesn't work?
17:34:50 <matjazp> for that, we need PrinceXML (==$$$)
17:35:13 <sarob> Matjazp only HTML to PDF option?
17:35:32 <matjazp> landslide has support for PDFs through PrinceXML
17:35:52 <Fthamura_> +1 for put put edition
17:35:55 <matjazp> ..and.. theres a translation issue (see Toms comments on review)
17:36:28 <Fthamura_> Ppt,  sorry typo
17:36:36 <sarob> Matjazp translation I think is a separate issu
17:36:40 <sarob> Issue
17:36:48 <matjazp> sarob: well... yes and no
17:37:43 <matjazp> sarob: but for now, I agree.. lets just push review and start producing english version, and leave i18n for later?
17:37:55 <sarob> Matjazp agree.
17:38:34 <sarob> Matjazp I still want a plan for languages support for jm3 from infra
17:38:44 <matjazp> but can a tool support be developed latter? we NEED PDFs... PPTs are another issue (and I have no idea how to translate landslide to PPTs)
17:39:14 <matjazp> sarob: shoudl we vote on landslide issue? +1 for pushing as is?
17:39:33 <dguitarbite> I would like to suggest
17:39:34 <sarob> Matjazp sure
17:39:46 <sarob> Pls do
17:39:51 <dguitarbite> that the slides can be delivered via. HTML
17:39:57 <dguitarbite> like Slideshare/slidedeck
17:40:03 <dguitarbite> while the content is in XML
17:40:10 <dguitarbite> it would be nightmare for translation
17:40:21 <dguitarbite> already we have requests multiple languages
17:40:22 <dguitarbite> *for
17:40:43 <dguitarbite> RST kind of defies/makes it difficult the 'Ubiquitous' part
17:40:48 <matjazp> dguitarbite: trainers usuallly modify slides
17:41:27 <sarob> Let's start with the lowest bar to hop
17:41:35 <sarob> We have content
17:41:53 <sarob> In rst using landslide
17:42:14 <sarob> We either need to make met gable as is
17:42:41 <sarob> Or have a plan of what to do with it
17:42:51 <matjazp> sarob: content? youre talking about upstream univ?
17:42:57 <sarob> I hear good ideas but no plan
17:43:02 <sarob> Yes
17:43:41 <sarob> The landslide content is a version of the oper and Dev guides
17:43:50 <sarob> As bootcamp
17:44:21 <sarob> It's been field tested and will be continued to be improved
17:44:27 <Fthamura_> I am working with boot camp here..
17:44:33 <sarob> Let's make use of this opportunity
17:44:59 <matjazp> sarob: true... if I see correctly on review... core team voted with +1's for going with landslide.. so we push as and deal with problems later?
17:45:16 <matjazp> push as is
17:45:52 <dguitarbite> I agree with sarob
17:45:53 <sarob> Dguitarbite agreed?
17:46:01 <dguitarbite> we need to have alteast something to start with
17:46:20 <dguitarbite> sarob: yes +1
17:46:31 <sarob> Excellent. I'll clean up the patch and merge it
17:46:43 <matjazp> sarob: cool
17:46:46 <sarob> Let's move on
17:47:01 <sarob> #infra team update
17:48:06 <Fthamura_> Infra: can we make Intel NUC as micro lab,  inspired from Ubuntu box,  but we create our own
17:48:07 <matjazp> #action sarob cleans up https://review.openstack.org/#/c/100999/ and merge it
17:49:03 <sarob> Language build support by jm3. Can a get a bp/spec on this?
17:49:15 <sarob> Matjazp thx
17:49:41 <matjazp> sarob: youre talking about landslide i18n or what?
17:49:57 <dguitarbite> rluethi is busy
17:50:15 <sarob> Matjazp both
17:50:33 <dguitarbite> infra is waiting for basic-install-guide's rough draft to validate our in-house openstack scripts
17:50:38 <sarob> Dguitarbite okay will push np discussion to next week
17:50:45 <dguitarbite> yep
17:51:14 <sarob> I'll push Dev team till next week
17:51:34 <sarob> #topic any other business
17:52:48 <matjazp> so we're done?
17:52:53 <sarob> Our stats are up
17:53:06 <dguitarbite> sarob: where do you refer the stats?
17:53:09 <sarob> Over last 30 days
17:53:31 * annegent_ is late but scrolling back
17:53:54 <sarob> #link http://stackalytics.com/report/contribution/training-guides/30
17:54:06 <sarob> 8.8 reviews per day
17:55:35 <sarob> It looks good
17:55:48 <sarob> Keep up the good work people
17:56:10 <sarob> I'm very pleased with the progress we are making
17:56:32 <sarob> And the new team members contribution
17:56:55 <sarob> Any last words?
17:56:59 <dguitarbite> sarob: its gonna increase
17:57:08 <dguitarbite> I am just warming up ;)
17:57:18 <matjazp> annegent_: you have anything for us?
17:57:29 <sarob> Dguitarbite exxxccccelent
17:57:36 <annegent_> I talked to a trainer here at Rackspace and want to encourage them to contribute upstream
17:57:46 <Fthamura_> Hope my name in the future..  Sorry no contribution yet
17:57:47 <annegent_> they have ansible scripts for their labs, would that be interesting to this group?
17:58:24 <dguitarbite> annegent_: yes
17:58:27 <matjazp> annegent_: sure
17:58:34 <dguitarbite> we could start collaborating with them
17:58:38 <annegent_> I'll see what I can do to encourage upstream then
17:58:46 <dguitarbite> it would be really valuable for the Architect guide for sure
17:58:50 <sarob> Great!
17:58:59 <annegent_> didn't want to have your team take on another technology if there's not interest
17:59:08 <dguitarbite> I would like to see Ansible, Puppet, Chef for Architect guide
17:59:28 <sarob> Time is up.
17:59:31 <sarob> Thx all
17:59:44 <matjazp> bye
17:59:50 <MeganR> Bye
17:59:52 <Zucan> Have a great week
17:59:56 <sarob> See you on #openstack-doc
18:00:06 <sarob> #endmeeting