17:00:10 <sarob> #startmeeting training-manuals
17:00:10 <openstack> Meeting started Mon Jul 14 17:00:10 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'training_manuals'
17:00:17 <sarob> Roll
17:00:22 <rluethi> hey
17:00:30 <MeganR> Hi
17:00:44 <sarob> Dguitarbite won't be joining us
17:00:48 <sarob> Hello all
17:00:53 <dguitarbite> im here
17:01:03 <sarob> Oh, hi there
17:01:17 <dguitarbite> Mumbai traffic has improved a lot
17:01:21 <sarob> #topic stable update
17:01:25 <sarob> Excellent
17:01:54 <dguitarbite> we are working on basic install guide
17:01:54 <dguitarbite> https://etherpad.openstack.org/p/basic-install-guide-rough-draft
17:02:06 <dguitarbite> rough notes are on the Etherpad link
17:02:40 <dguitarbite> to meet the Juno2 deadline, we will be copying the docs install guide content and slowly start re-using them
17:02:49 <dguitarbite> from install guide
17:02:51 <matjazp> hi guys
17:02:57 <sarob> Hello
17:02:58 <dguitarbite> hello
17:03:06 <sarob> Copy, eh
17:03:22 <sarob> Are you sure that is wise?
17:03:33 <dguitarbite> to meet the dead line
17:03:45 <dguitarbite> and I had some time to think about this
17:04:03 <sarob> How will you back reference the original?
17:04:03 <dguitarbite> and it would be better for us and docs team to have our content to refer to
17:04:17 <dguitarbite> exact copy of the install guides content
17:04:32 <dguitarbite> and break it down as required, then push the changesto docs
17:04:36 <sarob> This is the still that is out of circulation?
17:04:41 <dguitarbite> and fix the url
17:05:02 <dguitarbite> *fix the urls and use xi:include
17:05:10 <dguitarbite> circulation?
17:05:11 <sarob> This material is not currently published?
17:05:19 <dguitarbite> nope
17:05:24 <dguitarbite> it is not currently published
17:05:28 <sarob> Okay then I'm good
17:05:39 <dguitarbite> to be more precise, install guides have lot of content
17:05:43 <sarob> Sound like a good step
17:05:50 <dguitarbite> which should not be included for basic install guide
17:06:01 <sarob> Understood
17:06:14 <dguitarbite> thanks, Roger, Matjazp any comments?
17:06:27 <sarob> What else you got for us?
17:06:28 <rluethi> not for that part.
17:06:52 <matjazp> hmmm.. not too happy about copying.. but I guess it could work
17:06:53 <rluethi> I looked into creating PDFs from landslide presentations.
17:07:22 <dguitarbite> matjazp: we will slowly transition into re-using the copied docs content
17:07:45 <dguitarbite> its too much work in multiple direction to try and attempt it at once
17:08:08 <dguitarbite> slowly transition == about a month
17:08:15 <dguitarbite> rluethi: sorry, continue
17:08:16 <sarob> Spec bp on this?
17:08:36 <rluethi> dguitarbite: without using princexml (proprietary).
17:08:46 <matjazp> dguitarbite: will that have effect on translation infra?
17:09:21 <matjazp> rluethi: did you find anything? I looked a bit around too..
17:09:49 <rluethi> matjazp: I think I may have a solution. I tested it with the initial import that is
17:09:58 <rluethi> matjazp: still under review (?).
17:10:15 <dguitarbite> matjazp: it should not, openstack bot will automatically fix the translation file *.pot file if I am correct
17:10:17 <rluethi> matjazp: there is an alternative which seems to work.
17:10:17 <sarob> Rluethi which review
17:10:39 <rluethi> sarob: "initial import of training slides" or something. don't have an url handy.
17:10:50 <dguitarbite> rluethi: sounds good, I guess you need to push a spec patch and start pushing more patches on it
17:10:55 <matjazp> sarob: the one you'll clean up ;)
17:11:06 <sarob> Rluethi ah right
17:11:08 <dguitarbite> what exactly do you use for converting it to PDF format?
17:11:10 <rluethi> sarob: this one: https://review.openstack.org/#/c/100999/
17:11:56 <rluethi> dguitarbite: epicslide and dependencies.
17:12:07 <matjazp> dguitarbite: yes, but it will create a lot of duplicate translation strings... copied content== duplicate translations strings?
17:12:37 <dguitarbite> initially yes, but we will push the changes in the original location and delete the duplicate files
17:12:48 <dguitarbite> otherwise we will take a few months for the same work
17:13:08 <dguitarbite> as we need to convince install guide guys for each patch, instead just show the existing content
17:13:25 <dguitarbite> for smoother and faster transition
17:14:32 <sarob> Is this going to create a lot more work than just creating PDFs?
17:14:36 <matjazp> dguitarbite: well.. sure, lets try that way...
17:15:09 <matjazp> rluethi: epicslide? you have link?
17:16:29 <rluethi> matjazp: https://github.com/netantho/epicslide
17:17:21 <sarob> Will we need to start supporting it or is it stable?
17:17:41 <sarob> Last activity was a year ago?
17:18:15 <dguitarbite> also its a fork of landslide
17:18:34 <dguitarbite> can we not reuse landslide or port the pdf features as per our requirements?
17:18:35 <rluethi> sarob: if you are talking about landslide, I was thinking the same. but it seemed to work, which is a plus.
17:19:03 <sarob> Okay, just asking
17:19:14 <sarob> Any other stable news?
17:19:54 <dguitarbite> thats it for today
17:19:55 <matjazp> sarob: maybe could we get PrinceXML license from OpneStack Foundation? Like for Oxygen?
17:20:33 <sarob> #action sarob rluethi epic slide port as option for dev reed materials
17:20:49 <sarob> Matjazp worth a look
17:21:00 <rluethi> matjazp: I'm not keen on adding more dependencies on proprietary software. we can't hand it out to everybody who wants to help or test.
17:21:17 <reed> sarob, I looked at xml briefly, I can't make myself like it, sorry...
17:21:18 <sarob> #action sarob princexml licensing to foundation option
17:21:37 <reed> the more I look at the issue, the more I find it depressing
17:21:39 <dguitarbite> rluethi: can we not take the pdf feature n push it to landsilde?
17:21:46 <matjazp> rluethi: yes, I agree - but it's also a mora pragmatic approach ... PDFs will be available for free from our site
17:21:47 <sarob> Reed understood we are working on supporting the rst
17:22:02 <reed> sarob, rst is only slightly less depressing :)
17:22:04 <dguitarbite> reed: whats the exact issue?
17:22:09 <rluethi> dguitarbite: not sure, I haven't looked at the code yet.
17:22:26 <sarob> Reed rst is at least what everyone knows
17:22:36 <dguitarbite> rluethi: lets attempt feature addition to landslide
17:22:46 <reed> dguitarbite, only WYSIWYG for anything involving graphic is not depressing
17:22:54 <rluethi> dguitarbite: go ahead, be my guest :)
17:22:57 <sarob> Rluethi good point
17:23:13 <dguitarbite> rluethi: definatly
17:23:19 <dguitarbite> but only after Junno2
17:23:27 <dguitarbite> s/Junno2/Juno2
17:23:42 <reed> I have some little hopes for webodf
17:24:08 <sarob> Reed well we need it to work today
17:24:13 <dguitarbite> reed: ok, oxygen may be your friend for WYSIWYG
17:24:13 <reed> sarob, indeed
17:24:49 <reed> sarob, I also need to pull in Vince from IBM in this (will email you later)
17:24:53 <sarob> Any other stable news? Or move on?
17:25:00 <dguitarbite> move on
17:25:01 <sarob> Reed roger
17:25:12 <sarob> #topic infra update
17:25:43 <dguitarbite> roger can you update about our chat on friday
17:26:09 <sarob> Updates on tests or something else?
17:26:13 <rluethi> we talked about scripts development, ,mostly short term
17:26:21 <sarob> Ah
17:26:28 <rluethi> it's documented on etherpad
17:26:42 <rluethi> plans for script directories and config directories.
17:26:48 <sarob> Linked anywhere else?
17:26:57 <sarob> Off wiki?
17:26:59 <dguitarbite> also we are planning to add some tests etc.
17:27:09 <rluethi> probably only on the wiki
17:27:16 <rluethi> it's work in progress
17:27:20 <sarob> That's good enuf
17:27:24 <dguitarbite> rluethi: can you paste etherpad link
17:27:25 <dguitarbite> ?
17:27:57 <sarob> We should get in the habit of either matching to a bug or bp for all work
17:28:03 <rluethi> dguitarbite: I don't have it right now, but I can post it later.
17:28:21 <sarob> I can't track via launchpad otherwise
17:28:35 <dguitarbite> sarob: its initial planning stage, we are just evaluating various possibilities based on our observations
17:28:47 <sarob> Okay
17:28:53 <dguitarbite> we will push it once we are certain that our idea works/can be implemented
17:29:01 <dguitarbite> and is not too optimistic
17:29:02 <sarob> Sounds good
17:29:20 <sarob> Any ideas on new lang support?
17:29:41 <sarob> Ja and fr seem like easy wins
17:29:47 <dguitarbite> I dont have much on lang support
17:30:01 <dguitarbite> rluethi any ideas?
17:30:08 <matjazp> sarob: what about fransthamura?
17:30:42 <rluethi> dguitarbite: there was a language patch by andreas jaeger, haven't looked at it yet.
17:31:04 <rluethi> dguitarbite: here's the #link https://etherpad.openstack.org/p/training-labs-scripts
17:31:06 <matjazp> sarob: he could start with Indonesian (?) translations...
17:31:08 <dguitarbite> rluethi: he said that its just temporary and it will transition to openstack-doc-tools
17:31:16 <dguitarbite> I am not 100% sure if it will work
17:31:33 <sarob> #action Fransthamura tasked with helping infra team on Indonesian lang support
17:31:37 <dguitarbite> but we need some expert in the given language which we are targeting for translation
17:31:45 <rluethi> dguitarbite: then I don't want to interfere, let's see how andreas' patch works out.
17:31:56 <dguitarbite> yes
17:32:12 <dguitarbite> I have no experience or leads when it comes to translation
17:32:27 <dguitarbite> sarob: do you have any particular time frame for translations?
17:32:47 <rluethi> dguitarbite: I have some experience in Western European languages i18n/l10n, but it's been a while.
17:32:49 <sarob> I'm targeting jm3 for first lang support
17:33:08 <dguitarbite> sarob
17:33:08 <sarob> I'd
17:33:12 <dguitarbite> : ok
17:33:24 <sarob> Rather you guys team up with the experts
17:33:40 <sarob> and feed them lang experts
17:33:42 <dguitarbite> rluethi: it may be easier for you to check if the French translation is possible and sane enough to publish
17:34:03 <sarob> Our plates are full already
17:34:11 <rluethi> dguitarbite: So is there one in the pipleline already?
17:34:16 <dguitarbite> sarob: for me Juno3 will be to update basic-install-guides and other content for Juno
17:34:18 <rluethi> dguitarbite: haven't seen it.
17:34:23 <matjazp> I'm still not sure, how will XML includes affect translation strings?
17:34:37 <dguitarbite> it will be a bit difficult to work on translations esp. when Ill be moving countries soon
17:35:08 <dguitarbite> rluethi: I guess Tom Fifield will be a good person to ask for translation related queries
17:35:15 <sarob> I think we need to reassess our bugs and bp this week
17:35:23 <rluethi> dguitarbite: ack
17:35:57 <dguitarbite> sarob: I concur
17:36:04 <dguitarbite> also can we have a sprint next week
17:36:17 <sarob> #action whole team take a look at bugs and bp for training
17:36:45 <sarob> If something is missing or already fixed create/update
17:37:10 <sarob> I should be locking down features this week for Juno release
17:37:28 <dguitarbite> sarob: there have been loads of changes in the structure etc. to make many bugs invalid. I guess we have put regressions in our bugs
17:38:04 <sarob> Dguitarbite sprint sounds good if we can rally the troops
17:38:27 <sarob> I will be at oscon so limited help from me
17:38:32 <sarob> :(
17:38:49 <sarob> Let's move on
17:38:52 <dguitarbite> ok
17:39:00 <sarob> Unless something else?
17:39:29 <dguitarbite> move on
17:39:41 <sarob> Moving
17:39:54 <sarob> #topic testing update
17:40:03 <sarob> Matjazp how
17:40:08 <matjazp> unfortunately...nothing new this week... we were moving our Lab to our new building...
17:40:13 <sarob> Goes it?
17:40:23 <sarob> Okay, no
17:40:28 <sarob> Orb
17:40:32 <sarob> Prob
17:40:34 <dguitarbite> matjazp: hmm, it must be painful process
17:41:04 <matjazp> dguitarbite: yes... we were offline for whole weekend... our private cloud and all other stuff from our lab
17:41:53 <sarob> #topic dev update
17:42:42 <sarob> I need work on the reed materials, still outstanding
17:42:56 <matjazp> sarob: at oscon, will you speak with M. Rice from LPI?
17:43:03 <sarob> Haven't got any new feedback
17:43:13 <dguitarbite> is reed Stefano?
17:43:15 <reed> sarob, I should publish the raw odp files somewhere
17:43:18 <reed> dguitarbite, yes
17:43:20 <sarob> Matjazp maybe. Not sure he will be there
17:43:39 <dguitarbite> reed: :)
17:43:43 <matjazp> sarob: I think he will... he was mentioning it on Skype
17:43:50 <sarob> Reed another patch to training is good for that
17:44:07 <reed> sarob, binaries in git? I thought people didn't like that
17:44:14 <sarob> Matjazp anything you want from rice?
17:44:23 <dguitarbite> reed: can you push it to your github repo instead then?
17:44:28 <dguitarbite> how big are the binaries?
17:44:37 * reed checks
17:44:42 <matjazp> sarob: well it would be nice if we knew if the contract went through
17:44:59 <sarob> Matjazp hmm, right
17:45:57 <reed> dguitarbite, ~9Mb
17:46:47 <dguitarbite> ok, i think its not too big, would it be possible to link them via. dropbox/gdrive or aws s3 container?
17:47:09 <sarob> Reed gdrive is pref
17:47:19 <reed> i'll drop them on my rackspace account
17:47:26 <reed> come on, we make openstack :)
17:47:27 <sarob> Reed are
17:47:49 <sarob> Reed are you planning training for oscon?
17:47:57 <sarob> Reed I didn't hear
17:47:59 <sarob> About it
17:48:05 <reed> I'll be in Portland
17:48:11 <reed> no training sessions there
17:48:16 <dguitarbite> reed: haha, sure :)
17:48:29 <reed> Paris is the next one
17:48:31 <sarob> Reed okay. Cloud files to
17:48:33 <sarob> Yo
17:48:47 <sarob> Paris right then
17:49:16 <sarob> Any other dev info?
17:50:02 <sarob> #topic any other business
17:50:14 <dguitarbite> I got something
17:50:23 <dguitarbite> I would like all the sub-team leads to attend our design sessions
17:50:34 <dguitarbite> does that sound reasonable ?
17:50:42 <sarob> Summit?
17:50:48 <dguitarbite> yeah
17:50:54 <sarob> I say yes
17:51:02 <matjazp> sure
17:51:04 <rluethi> dguitarbite: not sure I can make it.
17:51:28 <dguitarbite> sure, we can have you over video chat
17:51:35 <sarob> #action training core reviewers /leads attend all training Juno design sessions
17:51:59 <sarob> And thus it be so
17:52:22 * dguitarbite amen
17:52:45 <sarob> If that is it , I call this meeting concluded
17:52:54 <sarob> 8 mins back to y'all
17:53:00 <MeganR1> Thank you!
17:53:07 <rluethi> bye all.
17:53:07 <sarob> Cheeers!
17:53:12 <dguitarbite> bye
17:53:14 <matjazp> bye
17:53:26 <sarob> #endmeeting