10:31:24 <dguitarbite> #startmeeting traininglabs
10:31:25 <openstack> Meeting started Wed Mar 30 10:31:24 2016 UTC and is due to finish in 60 minutes.  The chair is dguitarbite. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:31:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:31:28 <openstack> The meeting name has been set to 'traininglabs'
10:31:44 <rluethi> hi dguitarbite
10:31:49 <dguitarbite> rluethi: hi!
10:32:08 <julen> hi dguitarbite
10:32:16 <dguitarbite> julen: hi
10:32:26 <dguitarbite> #topic Mitaka-Testing
10:32:56 <julen> rluethi: great job with the update :)
10:33:00 <dguitarbite> rluethi: Thanks for the initial patch! I would say really good job. We have managed to create quite stable scripts this time around.
10:33:09 <rluethi> thx
10:33:21 <rluethi> dguitarbite: what did you mean with 9000 tests in 24 hours?
10:33:50 <dguitarbite> yes, atleast I have 9000 folders in the log files for repeat test
10:33:57 <dguitarbite> I would say may be ~24-36 hours
10:34:05 <rluethi> dguitarbite: must be an error
10:34:34 <rluethi> you can't do several tests per minute.
10:34:52 <rluethi> in fact, you have to fail quite early to achieve that.
10:35:46 <dguitarbite> rluethi: not sure what happened in there to be honest. Although everytime I build the cluster manually it works.
10:35:57 <dguitarbite> I also tested out horizon and ofcourse the test scripts
10:36:15 <dguitarbite> but there are some loose ends and I would be really surprised to see the test scripts succeed at the given moment.
10:36:36 <rluethi> the test scripts do work for me.
10:37:23 <rluethi> can you be more specific? what should fail, and/or why?
10:37:29 <dguitarbite> rluethi: Are you able to launch instances and all other common tasks?
10:37:53 <dguitarbite> last week I was running a devstack cluster and almost everything was working as expected on the master branch which is awesome
10:38:05 <rluethi> the only tests I did was the test scripts (launch_private_instance, heat_stack)
10:38:07 <dguitarbite> But at the same time I would expect some time for the packages to get stable(r)
10:38:28 <rluethi> so yes, launching instances works.
10:38:34 <rluethi> i did not test horizon.
10:38:37 <dguitarbite> wow, I am testing it again.
10:38:51 <dguitarbite> Horizon works for me. I think its quite stable for the current patch.
10:39:24 <rluethi> we should even be able to launch more than one instance, due to the new m1.nano profile.
10:39:32 <dguitarbite> yep!
10:39:46 <dguitarbite> So, can we merge this patch soon?
10:40:28 <rluethi> there are one or two things left that need fixing, grep for XXX, FIXME, or TODO :).
10:41:14 <rluethi> most of them are not urgent, but I think there is at least one left that I need to take care of.
10:41:29 <rluethi> no biggie.
10:41:42 <dguitarbite> Ok, also we could release merge this since Liberty is already an existing release for us.
10:41:55 <rluethi> also, we will have to switch to the proper repo when it's ready, we are on mitaka-staging right now.
10:42:11 <dguitarbite> Oh, I have to branch Liberty
10:42:23 <dguitarbite> I think I should do it soon before merging this patch.
10:43:04 <rluethi> yes
10:43:06 <dguitarbite> Switching the repository can be done later on. It does not make any sense to keep this patch hanging just because of that.
10:43:16 <dguitarbite> We could later on update it as soon as its released
10:43:39 <dguitarbite> julen: Did you test the Mitaka patch? Do you need some help here?
10:44:43 <julen> dguitarbite: sorry... I didn't have the chance yet, but I'll do tomorrow afternoon. I can check in Ubuntu and OSX
10:45:12 <julen> or maybe even today evening
10:45:12 <dguitarbite> julen: That would be great. Just do a $ git review -d <patch_number> and test it as usual
10:45:20 <dguitarbite> I am testing this on MacOSx at present
10:45:31 <dguitarbite> I will start the tests on my WS on openSUSE Leap today
10:47:08 <dguitarbite> anything else on this topic?
10:47:27 <dguitarbite> #action dguitarbite rluethi julen test the current Mitaka Patch and try to remove all the TODO's XXX's if possible
10:47:40 <dguitarbite> #action dguitarbite Release Liberty and follow the new release cycle
10:47:57 <dguitarbite> #action dguitarbite create proper notes (wiki/readme) for the new release cycle
10:48:13 <dguitarbite> rluethi: julen ping, did I dc?
10:48:34 <rluethi> dguitarbite: not that I know of
10:48:37 <dguitarbite> ok
10:48:46 <dguitarbite> #topic kvm
10:49:26 <dguitarbite> rluethi: I heard you saying that KVM has some issues in the email. Do you want to share something here?
10:50:33 <rluethi> dguitarbite: I think I posted fixes for all issues on gerrit.
10:51:16 <dguitarbite> rluethi: ok, I have to test them. Since the only linux machine I have with me is 4GB i3 I really cannot test KVM properly yet.
10:51:33 <rluethi> sorry guys, I gotta go. real life unexpectedly called early.  dguitarbite: please update us on zip fix.
10:51:39 <rluethi> bb
10:51:43 <dguitarbite> rluethi: bye
10:51:46 <dguitarbite> no worries.
10:51:53 <dguitarbite> #topic zip files!
10:52:18 <dguitarbite> I really need to start the conversation on adding Zip files with the infra guys.
10:52:20 <julen> I can do the KVM test on my NUC with 16 GB
10:52:29 <dguitarbite> julen: Yes, that would be great
10:52:39 <dguitarbite> Did you figure out how to search in Gerrit?
10:52:50 <dguitarbite> It took me a couple of weeks to understand it ;)
10:53:25 <julen> It's not so intuitive...
10:53:33 <dguitarbite> #action julen will test the KVM related patches.
10:55:59 <julen> so, priority list for me: test mitaka, test KVM and if I have more time, continue with the PXE functionality, what do you think?
10:56:10 <dguitarbite> Sounds perfect!
10:56:16 <dguitarbite> #topic AOBN
10:56:32 <dguitarbite> julen: Ready for the summit?
10:57:39 <julen> uff.. I hope so. But I still have the talk thing quite raw :P
10:58:09 <julen> let's hope I can get the PXE functionality ready by then. That would be really great ;)
10:58:30 <dguitarbite> julen: Did you get your talk accepted?
10:59:09 <julen> just a short VBrownBag one, but well... I'll manage
10:59:15 <julen> you have a long one, right?
10:59:23 <dguitarbite> Yes, the long one ;)
11:00:14 <dguitarbite> Anything else? Or shall we wrap it up?
11:00:37 <julen> well... this is probably kind of off-topic already. Let's keep doing stuff and I'll get back to you tonight or tomorrow
11:00:46 <julen> yes, I'm good
11:01:03 <dguitarbite> Ok, sounds good. Lets speak on email and hangouts :)
11:01:08 <dguitarbite> thanks for coming. See ya.
11:01:09 <julen> yep
11:01:13 <dguitarbite> #endmeeting