13:04:37 <joehuang> #startmeeting tricircle
13:04:39 <openstack> Meeting started Wed Dec  2 13:04:37 2015 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:42 <openstack> The meeting name has been set to 'tricircle'
13:05:02 <joehuang> #topic rollcall
13:05:16 <joehuang> #info joehuang
13:05:36 <zhiyuan_> #info zhiyuan
13:06:14 <joehuang> #topic development
13:06:45 <zhipeng> hi
13:06:49 <joehuang> a new stateless design proposal is updated at
13:06:49 <zhipeng> sorry i'm late
13:07:07 <joehuang> #link https://docs.google.com/document/d/18kZZ1snMOCD9IQvUKI5NVDzSASpw-QKj7l2zNqMEd3g/edit#
13:07:15 <joehuang> you are welcome
13:07:40 <joehuang> zhiyuan, how about your patch
13:08:38 <joehuang> what's included and what's not include
13:09:48 <zhipeng> joehuang joe how many patches are we working on right now ?
13:09:50 <zhiyuan_> api and db modules are kept, and I removed dispatcher and proxy
13:10:33 <joehuang> the test for api and db should be remained there
13:10:59 <joehuang> and the patch will be submitted to the experimental branch for the stateless poc
13:11:40 <joehuang> currently zhiyuan's patch is being worked, and I'll start a new patch after zhiyuan's patch is ready
13:11:53 <zhiyuan_> yes, and I also added tox.ini for test environment setup, and a tool to automatically generate configuration
13:12:20 <joehuang> #info the stateless PoC will be submitted to the experimental branch
13:12:45 <joehuang> please include the test cases too
13:12:51 <zhiyuan_> oslo.config provides a tool to generate configuration sample from the project's source code
13:13:09 <joehuang> great
13:13:17 <zhiyuan_> of course the original test cases will be kept
13:13:57 <zhipeng> zhiyuan_ could you provide a simple "How to" on the google doc on how to contribute to the stateless branch ?
13:13:59 <joehuang> and for the doc, each activities will be recorded with one unqiue tag in incremtal way
13:14:34 <zhiyuan_> and since we are trying a new model, I think it's time for us to migrate to OpenStack CI, not maintain our third party CI
13:14:39 <joehuang> shall we add the timestamp to our table
13:14:52 <joehuang> sure
13:15:15 <joehuang> #action migrate to OpenStack CI but nor 3rd party CI
13:15:42 <joehuang> to zhipeng, good idea
13:15:46 <zhiyuan_> ok, I will update the google docs tomorrow
13:16:07 <joehuang> #action add guide how to contribute to the stateless PoC
13:16:43 <joehuang> any question on the stateless proposal and networking?
13:17:15 <zhipeng> is there anything different for networking between stateful and stateless?
13:17:51 <joehuang> same
13:18:11 <zhiyuan_> I think it's fine to add time stamp field, oslo db already provides the base class
13:18:53 <joehuang> ok
13:19:28 <joehuang> #action add time stamp to the table
13:19:41 <zhipeng> so i think i could try to work on the networking side since either solution would require it
13:19:59 <joehuang> that's great
13:21:21 <zhiyuan_> do we need to keep the client module?
13:21:41 <joehuang> to bottom OpenStack?
13:21:50 <zhiyuan_> yes
13:22:25 <joehuang> for Nova/Cinder, no need, but we can remove later
13:23:08 <joehuang> for bottom Neutron, we may have to use client, because information comes from DB
13:23:26 <joehuang> or from API
13:23:50 <joehuang> how about your idea/
13:25:17 <joehuang> we don't need to remove the client in a hurry, remove when we make sure we'll not use it.
13:25:19 <zhiyuan_> so we can keep the client module, it is configurable, if we don't use it to access bottom Nova and Cinder, we just remove the related configuration
13:26:32 <joehuang> ok
13:27:17 <zhiyuan_> so after I submit the init patch, I am going to work on new tables
13:28:00 <joehuang> good
13:28:37 <joehuang> after new table, we can start to process the request to novaapigw and cinderapigw
13:28:52 <joehuang> and first to connect one bottom openttack
13:29:33 <joehuang> after one bottom openstack can be connected, then L3 networking between bottom OpenStacks
13:30:02 <joehuang> #action update the todo list in the etherpad
13:31:32 <joehuang> #link https://etherpad.openstack.org/p/TricircleToDo
13:32:02 <joehuang> thanks for attending the meeting. let's end our meeting today
13:32:19 <joehuang> #endmeeting