13:04:09 <joehuang> #startmeeting tricircle
13:04:10 <openstack> Meeting started Wed Dec 23 13:04:09 2015 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:13 <openstack> The meeting name has been set to 'tricircle'
13:04:36 <joehuang> #topic rollcall
13:04:45 <joehuang> #info joehuang
13:04:49 <zhiyuan_> #info zhiyuan
13:05:52 <joehuang> #topic todo list progress
13:06:04 <joehuang> hi Zhipeng
13:06:21 <zhipeng> hi joe
13:06:27 <zhipeng> just got back home
13:06:29 <joehuang> hi, zhiyuan, could you briefly introduce your progress
13:06:37 <zhipeng> the orange tastes great :)
13:07:26 <joehuang> you can have more
13:07:41 <zhiyuan_> ok, the basic function of nova api gateway is done and code has been merged
13:07:42 <zhipeng> haha joehuang
13:08:10 <zhiyuan_> now we can boot a server with flavor, image, az and network
13:08:12 <joehuang> #info the basic function of nova api gateway is done and code has been merged
13:08:37 <joehuang> this is a very good progress, the key step for phase 1
13:08:43 <zhiyuan_> i am working on test cases currently
13:09:04 <joehuang> could you please add some short description about the dhcp to the google doc
13:09:22 <joehuang> this is a very important part for the design
13:09:25 <zhiyuan_> you mean how we handle dhcp port?
13:09:32 <joehuang> yes
13:10:22 <joehuang> zhiyuan lost connection again. the network is not stable
13:10:26 <zhiyuan_> ok, joe could you share the todo link so I can add a work item
13:11:03 <joehuang> it could be found on the tricircle wiki page
13:11:10 <zhiyuan_> ok
13:11:24 <joehuang> #info  https://etherpad.openstack.org/p/TricircleToDo
13:11:40 <joehuang> #action update the design doc about the dhcp part
13:12:54 <joehuang> after the test case added, we can start the phase II
13:13:14 <joehuang> the short summary of progress of my part
13:13:34 <zhipeng> after phase i could we use devstack for a simple demo ?
13:13:55 <zhipeng> for example just creating top and bottom
13:14:02 <joehuang> yes, I think so
13:14:24 <zhiyuan_> i am going to try it after i submit the test cases
13:14:26 <joehuang> yes, one more action, add installation to the readme of the repositore
13:14:40 <zhipeng> nice I will work on the devstack setup, hopefully with vagrant
13:15:22 <joehuang> #action guide to play tricircle with devstack
13:15:25 <zhipeng> one update from my side is that , i got an early copy of kubernetes federation design
13:15:44 <zhiyuan_> DevStack doesn't support more than one region, so maybe we need to do some trick to deploy two regions
13:15:45 <zhipeng> I will distribute to you guys offline tomorrow, since it is not public yet
13:15:56 <zhipeng> zhiyuan_ yep
13:16:37 <zhipeng> Basically I will make many of Tricircle design principle available for k8s community
13:16:58 <zhipeng> and also learn some of their design tricks to help us here
13:17:08 <joehuang> #info the design doc is updated with the region/az/pod/dc/top/bottom concept
13:17:15 <joehuang> and data model
13:17:36 <joehuang> #info the design doc is updated with the region/az/pod/dc/top/bottom concept and data model
13:17:49 <joehuang> that will be helpful, zhipeng
13:18:17 <joehuang> hopefully the data model api and code will be ready to be reviewed tomorrow
13:19:04 <joehuang> and the code for basic volume CRUD from cinder api_gw is almost ready
13:19:06 <zhiyuan_> fine, then we need a migration from old site model to new pod model
13:19:36 <joehuang> yes, we can migrate after the code merged
13:20:02 <joehuang> function of cinder volume will be ready for review later
13:20:40 <zhipeng> #info OpenStack Austin Summit CFP started today
13:20:59 <zhipeng> we should prepare a talk to introduce the stateless design to the community
13:21:07 <joehuang> and zhiyuan, you can start L3 networking after the work we mentioned
13:21:19 <joehuang> yes, may be many talks
13:21:45 <zhipeng> okey
13:22:10 <zhiyuan_> ok, maybe start on Friday or Saturday
13:22:26 <joehuang> any more topic?
13:23:02 <zhipeng> no topic from my side
13:23:12 <zhiyuan_> neither for me
13:23:39 <joehuang> ok. it's holiday seanson, let's conclude the meeting earlier
13:23:51 <zhipeng> marry Xmas XD
13:23:52 <joehuang> thanks for attending the meeting. see you. good night
13:24:01 <zhipeng> see you
13:24:06 <zhiyuan_> good night
13:24:14 <joehuang> have a nice holiday
13:24:20 <joehuang> #endmeeting