13:03:44 <joehuang> #startmeeting tricircle
13:03:45 <openstack> Meeting started Wed Jan 20 13:03:44 2016 UTC and is due to finish in 60 minutes. The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:48 <openstack> The meeting name has been set to 'tricircle'
13:04:10 <joehuang> #topic rollcall
13:04:25 <joehuang> #info joehuang
13:04:42 <joehuang> #info Yipei
13:04:54 <zhiyuan> #info zhiyuan
13:04:59 <joehuang> Hi Yipei, How things going
13:05:21 <Yipei> I feel better this week
13:06:01 <Yipei> I read the data model part and have some questions
13:06:08 <joehuang> pls
13:06:43 <Yipei> in the data model, some data types of fields are not defined, e.g., updated_at, why?
13:07:31 <joehuang> inherited from timestamp class
13:07:51 <Yipei> oh, i got it
13:08:18 <joehuang> models.TimestampMixin
13:08:38 <Yipei> I also read the source code of the API gateway
13:09:15 <Yipei> I found that the tricircle.tricircle.api, tricircle.tricircle.nova_apigw and tricircle.tricircle.cinder_apigw share a similar architecture, which contains controllers and app.py.
13:10:04 <joehuang> yes, they are all web service
13:10:35 <Yipei> The architecture of api gateway looks similar to the facade pattern. A controller defines and encapsulates a series of methods of a module of OpenStack, for instance, nova, cinder and so on. Using these methods provided by controllers, the api gateway can manipulate Tricircle to implement various functionalities. Is that correct?
13:11:35 <joehuang> we use pecan for the framework
13:11:50 <Yipei> yes i saw it
13:12:24 <joehuang> you can refer to this doc: https://pecan.readthedocs.org/en/latest/
13:13:04 <Yipei> OK, I will read it next week
13:13:05 <joehuang> the controller is to process different URI resource
13:14:00 <joehuang> #topic progress of phase 2
13:14:10 <joehuang> let's look at the todo list
13:14:27 <joehuang> Zhiyuan, your progress?
13:14:44 <joehuang> #info https://etherpad.openstack.org/p/TricircleToDo
13:16:25 <joehuang> Zhiyuan's connection is lost
13:18:01 <Yipei> I still have some questions
13:18:33 <joehuang> ok. pls
13:19:22 <Yipei> I know the concepts "volume", "image" and "flavor" in openstack, what is "pod"? it doesn't seem to be a concept in openstack
13:19:56 <joehuang> #info pod is one OpenStack managed by Tricircle
13:20:20 <Yipei> oh i got it
13:20:31 <joehuang> #info pod is only visible to admin, not visible for tenant
13:20:43 <Yipei> i see
13:21:30 <Yipei> I read the source code of RPC Worker XJob, but I cannot understand. Could you please introduce it briefly for me?
13:23:16 <joehuang> #info Xjob is for some async. task which is not good to be finished synchronously in API gateway or Neutron Plugin
13:24:01 <joehuang> #info if this task finished in api-gw or plugin, user experience will be affected for it's time consuming task
13:24:32 <Yipei> i see
13:25:00 <Yipei> no questions now
13:25:25 <joehuang> #info currently the L3 networking will use Xjob to do the extra routing adding job
13:25:46 <joehuang> which is now in Zhiyuan's E-W patch 2
13:25:47 <patchbot> joehuang: https://review.openstack.org/#/c/2/
13:26:08 <joehuang> welcome back zhiyuan
13:26:17 <Yipei> hi zhiyuan
13:27:08 <joehuang> zhiyuan, your progess shortly
13:27:30 <zhiyuan> hi yipei, network in my home temporally down
13:27:38 <joehuang> understand
13:28:01 <zhiyuan> ok, the second patch for cross-pod l3 networking was submitted
13:28:29 <joehuang> I just reviewed the README.md, more review tomorrow
13:29:06 <zhiyuan> so east-west l3 networking functionality is done, README is also updated to introduce how to deploy by DevStack
13:30:23 <joehuang> great job. and Yipei can try to play two nodes deployment from the patch to see if it work
13:31:04 <Yipei> OK
13:31:46 <joehuang> for quota part, I am working on it
13:32:18 <joehuang> and porting most of the quota from the Cinder
13:32:57 <joehuang> for cinder has implemented the hierarchy multi-tenecy
13:33:27 <joehuang> hierarchy multi-tenency quota management
13:33:44 <joehuang> hopefully the first patch will be ready for review this week
13:35:10 <joehuang> zhiyuan, please go on the networking N-S part, so that we can have basic functionality ASAP
13:35:52 <zhiyuan> no problem, will starting coding tomorrow
13:36:13 <joehuang> ok. more topics?
13:36:38 <Yipei> next week, I plan to play two nodes deployment from the patch to see if it work. Further, I plan to read the source code of "RPC Worker XJob", " Tricircle Neutron Plugin" and " Implement Nova API Gateway Controller" in the blueprint. Is the plan OK?
13:36:40 <joehuang> Yipei, if you have any question, you can send it in the openstack-dev maillist
13:36:55 <Yipei> ok, got it
13:36:59 <joehuang> with the [tricircle] in the mail title
13:37:05 <Yipei> ok
13:37:17 <joehuang> great
13:37:38 <Yipei> Hope to catch up with you guys' progress ASAP.
13:37:48 <joehuang> #action Yipei, play two nodes deployment from the patch to see if it work. Further, I plan to read the source code of "RPC Worker XJob", " Tricircle Neutron Plugin" and " Implement Nova API Gateway Controller" in the blueprint.
13:37:55 <joehuang> You'll, sure
13:37:59 <joehuang> :)
13:38:09 <Yipei> thx
13:38:14 <joehuang> ok thanks for attending the meeting, see you next week
13:38:22 <Yipei> see u
13:38:24 <joehuang> #endmeeting