13:01:09 <joehuang_> #startmeeting tricircle
13:01:10 <openstack> Meeting started Wed Jan 27 13:01:09 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:14 <openstack> The meeting name has been set to 'tricircle'
13:01:27 <joehuang_> #topic rollcall
13:01:35 <joehuang_> #info joe
13:01:47 <zhiyuan> #info zhiyuan
13:01:51 <zhipeng> #info zhipeng
13:02:07 <Yipei> #info Yipei
13:02:37 <joehuang_> #topic TODO list review
13:03:19 <joehuang_> hi, before the progress of the todo list, we spent few minutes on the bug in two node installation
13:03:40 <joehuang_> hi Yipei, could you describe the bug you met in the installation
13:03:48 <Yipei> ok
13:04:17 <Yipei> when installing devstack on node2
13:05:47 <Yipei> I encounter an error  "Could not find resource admin", when executing "openstack project show admin -f value -c id"
13:07:36 <zhiyuan> DevStack now injects the environment variable before setting up service account, we set OS_REGION_NAME as Pod2 in node2, but keystone doesn't have admin tenant in Pod2, thus causing problem
13:07:48 <Yipei> I remove all the "create_XXX_accounts" in stack.sh, and I have already finish installing devstack on two nodes
13:08:37 <joehuang_> could you show all endpoint in KeyStone, to check to see if all enpoints registered correctlly
13:08:50 <Yipei> ok
13:09:52 <Yipei> +----------------------------------+-----------+--------------+----------------+---------+-----------+------------------------------------------------+ | ID                               | Region    | Service Name | Service Type   | Enabled | Interface | URL                                            | +----------------------------------+-----------+--------------+----------------+---------+-----------+-----------------------
13:10:00 <joehuang_> ok, would Yipei register a bug in launchpad, and Zhiyuan guide Yipei to fix the bug
13:10:19 <joehuang_> it's a very good start for Yipei
13:11:16 <zhiyuan> fine, for fixing bug, we cannot directly remove "create_keystone_account", should check if keystone already starts in another node
13:11:17 <Pengfei> May you disable the default region?
13:11:43 <joehuang_> hi, yipei, no need to paste all result in the irc, it's not easy to read, just make sure RegionOne, pod1, pod2, and each should have Nova,Cinder,Neutron service
13:11:53 <Pengfei> reference: http://docs.openstack.org/developer/devstack/configuration.html
13:11:54 <Yipei> yes
13:12:06 <Yipei> all the info is shown
13:12:09 <Pengfei> Multi-Region Setup  We want to setup two devstack (RegionOne and RegionTwo) with shared keystone (same users and services) and horizon. Keystone and Horizon will be located in RegionOne. Full spec is available at: https://wiki.openstack.org/wiki/Heat/Blueprints/Multi_Region_Support_for_Heat.  In RegionOne:  REGION_NAME=RegionOne In RegionTwo:  disable_service horizon KEYSTONE_SERVICE_HOST=<KEYSTONE_IP_ADDRESS_FROM_REGION_ONE
13:12:24 <joehuang_> to Pengfei, we reuse the RegionOne for Tricircle services
13:12:52 <joehuang_> great, the link is helpful
13:13:44 <joehuang_> #action register a bug for two nodes devstack setup
13:14:17 <Yipei> ok
13:14:36 <joehuang_> to yipei, you mean RegionOne, pod1, pod2 now with correct configuration in KeyStone?
13:14:54 <zhiyuan> yes, KEYSTONE_SERVICE_HOST is already configured as the ip address of node1, but OS_REGION_NAME is not correct
13:15:32 <zhiyuan> seem like a bug introduced by a recent merged patch
13:15:41 <Yipei> yes, RegionOne, pod1, pod2 now with correct configuration in KeyStone
13:16:00 <joehuang_> ok. let's fix the bug offline
13:16:10 <joehuang_> let's come back to todo list
13:16:29 <joehuang_> hi, zhiyuan, your progress briefly, pls
13:16:45 <joehuang_> #link https://etherpad.openstack.org/p/TricircleToDo
13:17:07 <zhiyuan> ok, patch for l3 EW networking has been merged, now I am working on l3 NS networking
13:17:51 <joehuang_> ok, the AI1, and AI3 will be marked as done, but 3 with one bug left
13:19:29 <joehuang_> for the AI1, one enhancement is left as one AI in phase 3
13:19:39 <joehuang_> reliable and good performance mechanism for long task with multiple bottom pods interaction. Like adding extra route for each involved pod to establish cross pod L3 networking
13:20:44 <joehuang_> for the quota control part
13:21:00 <joehuang_> the algorithm is updated in the design doc
13:21:17 <joehuang_> #link https://docs.google.com/document/d/18kZZ1snMOCD9IQvUKI5NVDzSASpw-QKj7l2zNqMEd3g/edit#
13:22:06 <joehuang_> and now, the db part is mostly ported from Cinder for hierarchy multi-tenancy quota control
13:22:17 <joehuang_> the patch was merged
13:23:04 <joehuang_> and I am now working on api part for quota CRUD, hopefully the patch will be ready for review by the end of the week
13:25:02 <joehuang_> after phase II, we have a very rough base for the tricircle service
13:25:30 <joehuang_> and many important features need to be implemented in phase 3
13:26:41 <joehuang_> so if any one are interested in the action item in phase 3, please mark with your irc handle
13:27:17 <joehuang_> so if any one IS interested in the action item in phase 3, please mark with your irc handle
13:27:36 <zhiyuan> well, I am working on No3, and I will take No10
13:28:16 <joehuang_> great
13:29:46 <Yipei> I still cannot make a decide now, can i reconsider it offline
13:30:08 <joehuang_> no problem, all of us can decide offline
13:30:35 <joehuang_> and just work the interesting one in the todo list
13:30:53 <joehuang_> if you find anything missing in the todo list, please add it
13:31:33 <Yipei> ok
13:32:18 <joehuang_> one action is to update the google doc with the L3 netwoking, I'll do it tomorrow, or the day after tomorrow
13:32:44 <joehuang_> #action update google doc with the L3 netwoking
13:32:56 <joehuang_> good meeting, any other topic?
13:33:10 <zhiyuan> no for me
13:33:17 <Yipei> no for me
13:33:47 <Yipei> Next week i plan to report and fix the bug. furthermore, i will go on playing tricircle with two node deployment.
13:34:00 <zhiyuan> great!
13:34:06 <zhipeng> great Yipei
13:34:08 <Yipei> still need you guys' help
13:34:18 <joehuang_> Yipei, you are doing well, go on please
13:34:24 <Yipei> thank you
13:34:43 <joehuang_> so, thank you for the meeting, see next wwek
13:34:45 <zhipeng> feel free to email any questions
13:34:51 <Yipei> ok. got it
13:35:02 <joehuang_> #endmeeting