13:01:29 <joehuang> #startmeeting tricircle
13:01:30 <openstack> Meeting started Wed Feb  3 13:01:29 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:33 <openstack> The meeting name has been set to 'tricircle'
13:01:53 <joehuang> hi, Bean, could you introduce yourself>
13:02:18 <BeanZhang> ok
13:02:36 <joehuang> hi Pengfei
13:02:49 <Pengfei> hi, Joe
13:02:54 <BeanZhang> i'm an undergraduate student from Shanghai Jiao Tong University.
13:03:11 <joehuang> Could also introduce youself, Pengfei?
13:03:51 <Pengfei> Yep!
13:04:11 <joehuang> Zhiyuan was graduated from SJTU?
13:04:35 <Pengfei> I'm also from SJTU, and also be the student of Pro. Jin
13:04:58 <BeanZhang> i'm new developer of openstack, deployed my first openstack in june, 2015.
13:04:58 <joehuang> great, like a family of SJTU
13:05:13 <zhiyuan> Yes, graduated in 2014
13:05:29 <joehuang> Yipei from HUST
13:05:45 <joehuang> #rollcall
13:05:53 <joehuang> #topic rollcall
13:05:58 <joehuang> #info joehuang
13:06:02 <zhiyuan> #info zhiyuan
13:06:07 <Yipei> #info Yipei
13:06:14 <Pengfei> #info Pengfei
13:06:22 <BeanZhang> #info BeanZhang
13:06:40 <joehuang> #topic progress review
13:06:56 <joehuang> hi, Yipei, how about you
13:07:06 <Yipei> i have already installed devstack in two nodes. i think find a solution to fix the bug, but i am not sure whether it is correct
13:07:19 <joehuang> interesting
13:07:32 <Yipei> i set the OS_REGION_NAME statically as "RegionOne"
13:07:47 <joehuang> in Node2?
13:07:56 <Yipei> yes
13:08:17 <Yipei> when starting cinder, i set it as Pod2
13:08:29 <Yipei> it returns no error
13:09:06 <joehuang> it can run, but will it use the keystone in the node1?
13:09:31 <Yipei> yes
13:09:55 <Pengfei> Now Bean and I want to deploy the tricircle by some Devstack nodes in SJTU's OpenStack, and try to learn more practicely about the project by this way:-)
13:09:55 <Yipei> it shares the keystone with node1
13:10:00 <joehuang> and tricircle may not see the node2 services, you have to manully configure the services in the node1 keystone
13:10:02 <zhiyuan> so the region of services in node2 are registered as RegionOne or Pod2?
13:10:22 <joehuang> yes, make your hand dirty is the fast way
13:11:04 <Yipei> other services are registered as Pod2
13:11:08 <Pengfei> bingo!
13:11:11 <Yipei> except keystone
13:11:26 <joehuang> to Pengfei and Bean, if any help need, just send mail in the openstack dev maillist
13:11:33 <BeanZhang> yeah
13:11:44 <Pengfei> thanks a lot!
13:11:47 <BeanZhang> i receive the maillist all the way
13:12:20 <zhiyuan> not sure if this is a good fix, since OS_REGION_NAME is a configurable option in DevStack
13:12:24 <joehuang> to Zhiyuan, I am afraid it will overlap one Region configuration
13:12:36 <BeanZhang> if we occur some problem or any questions, we will send mail to [openstack-dev][tricircle] maillist
13:12:53 <Yipei> ok, got it
13:13:03 <zhipeng> BeanZhang that is right
13:13:06 <joehuang> that's the correct way to get help
13:13:21 <zhiyuan> to BeanZhang, are you going to install OpenStack on bare metal machine, or virtual machine?
13:13:23 <joehuang> we alwasys watch the mail-list
13:13:45 <BeanZhang> virtual machine
13:14:13 <BeanZhang> any suggestions?
13:14:24 <joehuang> but Chinese new year is approaching, maybe sometime a later response
13:14:36 <Yipei> i can try to verify whether the solution is correct, i just solve it today
13:15:05 <zhiyuan> the l3 networking functionality requires vlan network support
13:15:06 <joehuang> virtual machine ok, but need to be aware of the VLAN configuration, some guide in the github
13:15:26 <joehuang> Go on please, Yipei
13:15:35 <Yipei> ok, got it
13:15:59 <zhiyuan> What I use is vmware vcenter
13:16:12 <joehuang> espeically make sure the service catalog and endpoint in node1 keystone are correct
13:16:36 <joehuang> to Zhiyuan, your progress briefly
13:16:39 <Yipei> ok, got it
13:16:40 <joehuang> pls
13:17:26 <Pengfei> yep! we made devstack with neutron before, and vlan by vlan may cause some problems
13:17:34 <zhiyuan> ok, l3 north-south networking functionality is done, but as Joe commented in the patch, I need to improve the patch
13:18:01 <joehuang> this is a great step
13:18:18 <zhiyuan> If user associate an unbound port to a floating ip, I need to create the port on bottom pod
13:18:24 <joehuang> basic cross pod networking will be ready after the patch merged
13:18:34 <zhipeng> zhiyuan has this patch be merged?
13:19:01 <zhipeng> i may have someone want to review the networking patch
13:19:05 <zhiyuan> not yet for the N-S part, E-W part is merged
13:19:30 <joehuang> helpful more people to do the review
13:19:41 <zhiyuan> yeah!
13:19:53 <zhipeng> okay please add me for the N-S part so that I could add more people to review it
13:20:18 <joehuang> and also zhiyuan can share the test for the distributed query
13:20:34 <zhiyuan> send it to the maillist?
13:20:57 <joehuang> in the meeting now, a short summary
13:21:07 <joehuang> and also good in the ml
13:21:25 <zhipeng> yes that one is good for ml
13:22:52 <joehuang> hi, zhipeng added
13:23:16 <joehuang> Bean and Pengfei, your account to the reviewer list?
13:23:42 <zhiyuan> In my test, I starts two bottom pods. In each pod, N ports are created, so when we query ports from top pod, we get 2N ports. I increase N and count the response time of query operation
13:23:45 <joehuang> or you can add comment in the patch, and then will be listed in the ptach
13:24:11 <joehuang> #link https://review.openstack.org/#/c/274521/
13:24:11 <zhiyuan> three observations
13:24:24 <zhiyuan> (1) Neutron client costs much more time than curl, the reason may be neutron client needs to apply for a new token in each run.
13:24:34 <zhiyuan> (2) Eventlet doesn't bring much improvement, the reason may be we only have two bottom pods. I will add some logs to do a further investigation.
13:24:46 <zhiyuan> (3) Query 1000 ports in top pod costs about 1.5s when using curl, which is acceptable.
13:25:08 <zhiyuan> I will send the detailed data to the mail list later
13:25:18 <joehuang> good, please
13:25:22 <zhipeng> great findings
13:25:34 <joehuang> #action share the distributed query findings
13:26:26 <joehuang> for quota management, the algorithm is updated in the document, please review in the document to see if it applicable
13:26:53 <joehuang> and the patch for quota engin and quota set operation is submitted for review
13:27:23 <joehuang> this is a quite big patch https://review.openstack.org/#/c/274986/
13:28:03 <joehuang> for almost 2/3 of the code ported from the Cinder
13:28:07 <Pengfei> thank joe for the notification! now I add myself in the reviewers ,name: Pengfei.Shi
13:28:30 <joehuang> Great
13:28:59 <joehuang> and for the qutoa management, please also listed yourself to the reviewer, please
13:29:57 <joehuang> The spring festival is coming soon, I hope all of us have a pleasant new year
13:30:31 <joehuang> do you have started your vacation?
13:30:43 <zhipeng> it's already getting warmer at the chat room :)
13:30:45 <joehuang> to Pengfei, Bin, Yipei?
13:30:50 <BeanZhang> yeah
13:30:58 <BeanZhang> we have gone home-:)
13:30:59 <Yipei> me too
13:31:10 <Yipei> i arrived home yesterday
13:31:10 <Pengfei> yeah
13:31:15 <zhiyuan> I have asked for one day leave and will go home on Feb 6th
13:31:19 <joehuang> so you are working at home , SOHO
13:31:49 <Pengfei> now I lying in the bed,hia~hia~
13:31:50 <joehuang> I'll start the vacation tomorrow, forgive me the review will be slower
13:31:57 <joehuang> haha
13:32:04 <BeanZhang> Pengfei and me have a question to ask
13:32:10 <joehuang> pls
13:32:19 <BeanZhang> Pengfei and me deployed nested openstack before. The bare metal network and nested network are VLAN, but the nested network does not work, maybe we will meet the same problem. Do you ever occur similar problem?
13:33:01 <joehuang> you may need to configure the Switch hardware
13:33:13 <joehuang> to let all VLAN network bypass
13:33:34 <joehuang> Zhiyuan, do you think so?
13:34:09 <BeanZhang> would Pengfei add some?
13:34:57 <BeanZhang> i remember the hardware switches have be configured as bypass
13:35:18 <BeanZhang> trunk mode
13:35:20 <Pengfei> our enviroment has some other services so it cannot be set of bypass ....TT
13:35:22 <zhiyuan> If the two OpenStacks are in different bare metal machines, yes, hardware configuration is needed. But I start the two virtual machines running OpenStack in the same machine, so I only need to configure vcenter swtich
13:35:46 <zhiyuan> s/swtich/switch
13:36:20 <zhiyuan> the two virtual machines are connected by a software switch
13:36:39 <joehuang> I think we can discuss this in M-L or tricircle channel, it's a little bit late now
13:37:18 <BeanZhang> deploy all the virtual machines of nested openstack in one compute node is a smart method
13:37:30 <joehuang> so Pengfei and Bin can try one bare matel to see if it works
13:37:36 <BeanZhang> ok
13:37:44 <Pengfei> nice!
13:37:48 <joehuang> good
13:38:06 <joehuang> So happy new year to all of you
13:38:08 <zhiyuan> just to mention that the test result has been sent, please check :)
13:38:24 <BeanZhang> Happy New Year!~
13:38:26 <zhiyuan> happy new year :)
13:38:31 <joehuang> thanks for the attending, see you next year
13:38:35 <Pengfei> Happy new Monkey year!
13:38:36 <joehuang> :)
13:38:52 <joehuang> great work  zhiyuan
13:38:58 <joehuang> #endmeeting