13:00:52 <joehuang> #startmeeting tricircle
13:00:53 <openstack> Meeting started Wed Mar  2 13:00:52 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:57 <openstack> The meeting name has been set to 'tricircle'
13:01:13 <Pengfei> hello joehuang and zhiyuan
13:01:16 <joehuang> ok, it works today
13:01:23 <joehuang> hi pengfei
13:01:27 <zhiyuan> hi pengfei
13:01:35 <Yipei> hi all
13:01:45 <joehuang> hi yipei
13:01:54 <joehuang> #topic rollcall
13:02:00 <joehuang> #info joehuang
13:02:02 <zhiyuan> #info zhiyuan
13:02:03 <Pengfei> thanks for your support! and the L3 cross pod works!
13:02:08 <Yipei> #info Yipei
13:02:13 <Pengfei> #info Pengfei
13:02:30 <joehuang> great, it's a quite good news, you can play it now
13:03:02 <zhiyuan> cool!
13:03:25 <Pengfei> the virtualbox promiscous mode need to reboot, so after reboot and re stack.sh it works
13:03:59 <joehuang> the virtualbox is running in server or desktop
13:04:10 <Pengfei> in server
13:04:18 <Pengfei> using x11 to connect
13:04:20 <joehuang> Linux based
13:04:27 <Pengfei> ubuntu 14.04
13:04:28 <joehuang> or windows based
13:04:30 <joehuang> ok
13:05:04 <joehuang> it's a good idea to use virtual box to setup two nodes environment
13:05:06 <zhiyuan> virtualbox is free and easy to install, so good to hear that Tricircle can be depolyed on virtualbox
13:05:21 <Pengfei> hia,hia~
13:05:42 <joehuang> could you write a blog to have a summary of such an installation story
13:05:54 <Pengfei> bingo!
13:06:20 <zhiyuan> and then add a link in our wiki and readme
13:06:39 <joehuang> #action summary of two nodes installation in virtualbox
13:06:50 <joehuang> hi, xiaojie
13:06:56 <xuxiaojie> hi
13:07:16 <joehuang> could you have a short introduction
13:07:21 <Pengfei> No problems! and I will also implement the verify_cross_pod_install.sh
13:07:48 <Pengfei> hi~
13:07:50 <joehuang> good !
13:08:52 <joehuang> Zhiyuan has submitted two SEG patches, please review the patches
13:09:05 <Pengfei> what's your develop environment? VMs or native servers?
13:09:36 <joehuang> vms running above ESXi, managed by vCenter
13:09:53 <joehuang> and I also submitted the quota-set patch, your comment pls
13:09:59 <zhiyuan> coding on PC, then upload to server to test
13:10:15 <Pengfei> i see.
13:11:20 <joehuang> let's look at the agenda of today
13:11:41 <joehuang> 1. Progress of To-do list review: https://etherpad.openstack.org/p/TricircleToDo
13:12:06 <joehuang> and just have a short summary of the progress for zhiyuan and mine
13:12:18 <joehuang> Pengfei finished the installation
13:12:25 <joehuang> how about Yipei?
13:12:35 <Yipei> i still try to fix the bug of devstack, by the way, i find another bug of devstack
13:12:57 <joehuang> interesting
13:13:14 <Yipei> #link https://github.com/openstack-dev/devstack/commit/29f1ebb6885c22e94a225ba16a268aa26f60131c
13:13:32 <joehuang> do you use clean os to install devstack
13:13:41 <Yipei> yes
13:14:36 <joehuang> the link is not accessible
13:14:55 <zhiyuan> can access under vpn
13:15:29 <joehuang> ok, you can report this bug to devstack
13:15:34 <Yipei> ok
13:15:34 <zhiyuan> yipei, according to the patch, entry point is used, maybe you can update your nova code and try again
13:15:35 <joehuang> hi haixia
13:15:44 <Yipei> ok
13:16:26 <joehuang> ok, Yipei, go on please
13:16:38 <zhiyuan> yipei, you can check the "setup.cfg" file in your nova folder, to see if filter_scheduler is defined
13:16:38 <Yipei> ok
13:17:09 <joehuang> entry_point section?
13:17:34 <Yipei> no, it is not defined
13:17:38 <zhiyuan> yes, if filter_scheduler is defined, can use it for shourt
13:17:45 <zhiyuan> s/shourt/short
13:18:31 <Yipei> in which section? entry_point section?
13:18:35 <joehuang> ok
13:18:41 <joehuang> I think so
13:18:50 <zhiyuan> oh yes, it's defined in the latest nova code
13:19:16 <zhiyuan> check https://github.com/openstack/nova/blob/master/setup.cfg
13:19:26 <zhiyuan> filter_scheduler = nova.scheduler.filter_scheduler:FilterScheduler
13:19:38 <zhiyuan> Ln 196
13:19:46 <Pengfei> just now, i find http://docs.openstack.org/developer/tricircle is 404...
13:20:34 <joehuang> Hi, pengfei you are write, no doc yet
13:20:53 <joehuang> sorry right
13:20:54 <zhiyuan> https://wiki.openstack.org/wiki/Tricircle link for wiki
13:21:10 <Pengfei> ok~
13:21:30 <Yipei> i see
13:21:47 <joehuang> Yipei, please continue your installation and discuss issue in #openstack-tricircle if needed
13:21:55 <Yipei> ok
13:22:14 <joehuang> next topic is reliable async.  job
13:22:28 <joehuang> #topic reliable async. job
13:22:36 <joehuang> hi, zhiyuan, pls
13:23:16 <zhiyuan> i have written a proposal in our design doc(hosted by google doc)
13:23:47 <joehuang> #link https://docs.google.com/document/d/18kZZ1snMOCD9IQvUKI5NVDzSASpw-QKj7l2zNqMEd3g/edit
13:24:17 <zhiyuan> the brief idea is to save job entry in database, and each time only one worker is allowed to operate one specific resource
13:25:00 <joehuang> address race condition by DB record level lock
13:25:31 <zhiyuan> yes, other worker just create a new job entry for that resource with a new timestamp
13:26:34 <liuhaixia> sorry
13:26:43 <joehuang> welcome haixia
13:27:02 <xuxiaojie> hi, haixia
13:27:05 <liuhaixia> something wrong with my wireless network
13:27:16 <joehuang> my concerns is that old expired job should be purged automaticly
13:27:30 <joehuang> especially successful job
13:28:12 <zhiyuan> yes, job entry in "success" and "new"(not the latest one) status can be removed
13:28:52 <joehuang> hi, zhiyuan, should we have timer in xjob to pickup some orphan job?
13:29:32 <zhiyuan> i think so, since if the latest job fails, we need to redo it
13:29:34 <joehuang> or only triggered by async task from api server
13:30:04 <joehuang> so please update the doc with how these jobs will be started
13:30:43 <zhiyuan> ok, so we need a special worker who is responsible to redo failed job
13:31:10 <joehuang> ok, others can comment on the async. design, and check to see if something not included
13:31:36 <zhiyuan> yes, I just would like to say that, pls comment on the doc
13:31:53 <joehuang> so next topic, cross pod L2 networking
13:32:10 <joehuang> #topic cross pod L2 networking
13:32:40 <joehuang> hi, pengfei and haixia, you are all interested in L2 networking
13:32:57 <joehuang> would you mind sharing your ideas?
13:34:01 <joehuang> #action update the doc with how these async. jobs will be started
13:34:06 <liuhaixia> how does bottom openstacks connect l2 netwoks? with overlay netwoks,i think l2gw will implement in future.
13:34:49 <liuhaixia> hi,joehuang,
13:34:54 <joehuang> VxLAN later
13:35:02 <joehuang> hi haixia, please
13:35:15 <joehuang> and could you introduce yourself for a while
13:35:26 <joehuang> this is the first time we meet here
13:35:28 <liuhaixia> but how does vlan connect across openstack?
13:35:46 <liuhaixia> i am studying on it
13:36:04 <liuhaixia> hi,
13:36:37 <joehuang> even for VLAN, I think we can also use what implemented in L2 networking with share VLAN
13:36:56 <joehuang> two openstacks, same VLAN network means same L2 network across pod
13:37:32 <joehuang> and we can use physical VxLAN gateway to connect two same segment VLAN into one L2 network
13:38:21 <joehuang> but it rely on physical networking device
13:38:41 <joehuang> I am not sure it's clear or not
13:38:58 <liuhaixia> all. i am an engineer in huawei.for recent years,working on sdn for l2 and l3 netwoks in datacenter.
13:39:10 <joehuang> for this way, the number of cross openstack L2 networking will be quite limited
13:40:14 <joehuang> thanks haixia
13:40:33 <joehuang> hi, pengfei, your ideas on cross pod L2 networking?
13:41:31 <Pengfei> sorry, i do something just now
13:42:05 <Pengfei> i know a little about the knowledge with this, maybe i need to think more
13:42:11 <liuhaixia> i am sorry for reacting  so slowly, for i have to join meeting with my cellphone
13:42:32 <joehuang> it's hard mode
13:42:51 <liuhaixia> does vtn can sovle this?
13:43:22 <zhiyuan> i think so, i am using vpn now
13:43:51 <joehuang> yes, VPN used
13:43:53 <liuhaixia> i bought vpn,
13:45:20 <joehuang> ok, for L2 networking, some rough design were added in the google doc, please review and let's talk next time to see which one we start first, and how to work on it
13:46:31 <joehuang> the last topic, quota management, just one patch submitted
13:46:40 <BeanZhang> Hi, all
13:46:43 <joehuang> more patch needed for quota control
13:46:45 <BeanZhang> sorry for late
13:46:50 <joehuang> Hi Bean, longtime no see
13:46:57 <BeanZhang> i just finish an interview
13:47:32 <BeanZhang> pls continue
13:47:53 <joehuang> please review the patch, thanks
13:48:10 <joehuang> any other topics?
13:48:18 <zhiyuan> not for me
13:48:20 <Yipei> no for me
13:48:48 <BeanZhang> ok, i will try to review
13:48:55 <joehuang> thanks
13:48:56 <BeanZhang> no topic for me
13:49:09 <joehuang> so let's conclude the meeting
13:49:21 <joehuang> #endmeeting