13:01:44 <joehuang> #startmeeting tricircle
13:01:45 <openstack> Meeting started Wed Mar 23 13:01:44 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:48 <openstack> The meeting name has been set to 'tricircle'
13:02:16 <joehuang> #topic rollcall
13:02:24 <joehuang> #info joehuang
13:02:48 <Yipei> #info Yipei
13:03:03 <zhiyuan_> #info zhiyuan
13:03:15 <Huiji> #Huiji
13:03:22 <Huiji> #info Huiji
13:04:13 <joehuang> #topic mitaka release
13:04:23 <ztang> hello
13:04:36 <joehuang> hi zyang
13:04:40 <joehuang> ztang
13:04:49 <ztang> hi joe
13:05:02 <joehuang> for mitaka release is approching for openstack
13:05:27 <joehuang> we need to release tricircle too, so that for mitaka we have a preview release to run
13:06:06 <joehuang> this is not production ready release, but would rather call it preview release
13:06:28 <joehuang> only very basic functions developed during the mitaka cycle
13:06:49 <joehuang> let's look at https://etherpad.openstack.org/p/TricircleToDo
13:07:10 <joehuang> and check to see if some new basic features need to be included in the mitaka
13:09:00 <joehuang> #info preview release aligned with openstack mitaka
13:12:13 <Huiji> hi,Joe, in the command of tricircle, there is some waring. such as the VM crearting  and so on. i think we can reduce this kinds of waring
13:13:26 <joehuang> Do you mean the microversion support or something else
13:13:59 <Huiji> yes
13:14:29 <joehuang> ok, add one todo item in the https://etherpad.openstack.org/p/TricircleToDo
13:14:34 <Huiji> and i try to modification the microversion and it was not work
13:15:10 <joehuang> #action add todo item for support microversion
13:16:55 <joehuang> Let's also prioritize and pickup the items to work in next release - Newton release
13:19:43 <joehuang> Hi, Yipei, how about your environment setup?
13:20:30 <Yipei> still have some problems, but i think i need to learn to solve them myself
13:20:43 <zhiyuan_> joe: so not all items in phrase4 will be finished in Newton circle?
13:20:57 <joehuang> And which topic you would like to work in Newton release
13:21:59 <joehuang> we need to prioritize them, maybe more or less, depends on how much we can do
13:23:37 <zhiyuan_> i think cross-pod l2 networking should have high priority
13:24:09 <Huiji> hi, Joe.  The area RegionOne and Pod1 were set in the same PM and should they separated?
13:24:12 <zhiyuan_> and also update, delete operations on network, subnet, etc which we only support creating currently
13:24:50 <zhiyuan_> only when we support full operation on resource can we start to involve tempest test
13:26:43 <_lxq_> Hi, Joe, I am a student. I focus on reading the source code of openstack recently. I am thinking that whether it is a good way for developing the tricircle project or not. In other words, would it be enough for me to read the documents of the openstack learning to use  openstack API and be familiar with the architecture of the openstack?
13:27:13 <joehuang> agree cross pod L2 networking will be high priority
13:27:20 <ztang> @Joe, _lxq_ is a member of our team.
13:28:03 <joehuang> to Huiji, it's ok in same physical server, we usually install them by devstak in same VM
13:29:06 <joehuang> to Zhiyuan, part of CRUD operation missing for some objects
13:29:24 <joehuang> welcom lxq
13:29:39 <zhiyuan_> joe: yes, resource in Neutron and server in Nova
13:29:56 <joehuang> you can follow the google doc and this launchpad to study the tricircle
13:30:35 <Huiji> i mean in the production environment, should they separated or the area Pod1 must adhere to the area Region One
13:30:38 <joehuang> #link https://blueprints.launchpad.net/tricircle/+spec/implement-stateless
13:30:54 <zhiyuan_> _lxq_: directly dig into the source code may be a bit hard to understand OpenStack, maybe you can read some blogs and understand the architecture of OpenStack first
13:30:55 <joehuang> in production, it'll be seperated
13:31:13 <Huiji> ok i get it
13:31:27 <_lxq_> thanks. i have read the tricircle source code mostly
13:31:52 <Yipei> @joe, i am interested in cross neutron l2 networking. but i think i am incapable of developing all by myself. maybe i can assist somebody or chose another less complicated item
13:32:17 <joehuang> great, it's also helpful to read openstack arhitecture and be family with api and features
13:33:15 <joehuang> I remember that Yipei is also interested in pod scheduling, currently no one working on it
13:33:19 <_lxq_> ok.thanks joe and zhiyuan_
13:33:28 <joehuang> for L2 networking, Xiaojie is also interested in that
13:33:35 <_lxq_> Another problem, the current version of the source code is what we download from the github. How to get the newest version in time?
13:33:40 <Yipei> ok, i will take pod sceduling, multiple pod binddings per AZ
13:34:35 <zhiyuan_> _lxq_: do a "git pull" in your repos folder to sync the newest code
13:34:56 <joehuang> using devstack you can also get the latest version
13:36:19 <joehuang> ztang, have you succeeded in tricircle installation for two pods?
13:36:24 <_lxq_> thanks.
13:37:39 <joehuang> hi, Khayam
13:37:56 <Khayam> hi
13:37:58 <ztang> just one pod now. Some preparatory work we still have to do. But we hope we can start quickly.
13:38:21 <Khayam> didn't got much time to work on tests for exception. currently working on it.
13:39:12 <joehuang> to ztang, good, you can refer to pengfei's blog to install two pods environment http://shipengfei92.cn/play_tricircle_with_virtualbox
13:39:52 <joehuang> to Khayam, thanks a lot, if you have any question, feel free to talk in @openstack-tricircle or mail-list
13:40:02 <ztang> thanks very much! This is our required
13:40:10 <joehuang> sorry, #openstack-tricircle
13:40:33 <joehuang> ok
13:40:48 <Khayam> sure
13:41:06 <joehuang> to Khayam, I'll be in Austin next month, would it possible to meet you there?
13:41:12 <ztang> And we are intalling in some physical node, not VM.
13:41:16 <joehuang> for the summit
13:41:43 <joehuang> it'll be easier in VM, especially for multiple pods networking
13:42:28 <Huiji> to joe , thank u so much and we run the devstack in the the real physical environment and the updates of software is a headache questions to us
13:43:49 <joehuang> o, that's a big issue. Is there any other way for fast and easy connection
13:43:59 <Khayam> Sorry no. my visa duration is ending. need to go back to Pakiatan. Hopefully be back in August
13:44:13 <joehuang> A little pitty
13:44:33 <Huiji> we now try to use the vpn to over the wall
13:44:35 <Khayam> yeah. no other reason to miss austin summit :(
13:44:47 <joehuang> ok, it's time to end our meeting, I have to leave now
13:44:54 <Huiji> and the speed is not optimistic
13:45:06 <joehuang> please keep contact in #openstack-tricircle
13:45:20 <ztang> OK, see you
13:45:25 <zhiyuan_> see you
13:45:27 <joehuang> and think over prioritization of todo list items
13:45:29 <Khayam> ok bye
13:45:35 <joehuang> bye
13:45:41 <Yipei> bye
13:45:41 <joehuang> #endmeeting