13:01:18 <joehuang> #startmeeting tricircle
13:01:19 <openstack> Meeting started Wed Mar 30 13:01:18 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:22 <openstack> The meeting name has been set to 'tricircle'
13:01:59 <joehuang> #topic rollcall
13:02:04 <joehuang> #info joehuang
13:02:14 <zhiyuan_> #info zhiyuan
13:02:16 <Yipei> #info Yipei
13:02:35 <Ronghui> #iinfo Ronghui
13:02:38 <Ronghui> #info Ronghui
13:02:48 <joehuang> #topic agenda
13:02:57 <ztang> #info ztang
13:03:07 <joehuang> we have three topic to be discussed in today's meeting
13:03:20 <joehuang> #info cross pod L2 networking
13:03:31 <joehuang> #info pod scheduling
13:03:47 <joehuang> #info reliability async. job
13:04:03 <joehuang> #topic cross pod L2 networking
13:04:45 <joehuang> #info cross pod L2 networking is one of most important feature in next release
13:05:16 <joehuang> and will be used both for tenant L2 networking, and L3 networking(bridge network)
13:05:20 <Ronghui> hi, joe i meet a problem   i  run the destack on node2 and could not find resoure admin and interrupt the devstack
13:05:54 <joehuang> did the node1 run normal
13:05:58 <Ronghui> yes
13:06:56 <Ronghui> and VM is success running
13:08:05 <zhiyuan_> so it's the problem we met before?
13:08:05 <joehuang> ok, do you guys have any topics about L2 networking
13:08:23 <joehuang> and at the same time, help Ronhui solve the issue
13:08:38 <joehuang> and question about L2 networking
13:08:56 <Ronghui> i run on the physical server
13:09:40 <joehuang> have you -export OS_REGION_NAME=$REGION_NAME +export OS_REGION_NAME=RegionOne
13:10:10 <joehuang> fix the script in the devstack
13:11:11 <Ronghui> ok  it run the keystone  create_keystone_accounts:379 openstack project show admin -f value -c id
13:11:12 <zhiyuan_> check this: https://github.com/openstack/tricircle#prerequisite
13:11:34 <Ronghui> and Could not find resource admin
13:11:40 <joehuang> for L2 networking cross pod, maybe inside one AZ, or across AZ
13:12:21 <joehuang> Hi Ronghui, could add --debug to see where the command was sent to
13:12:53 <Ronghui> ok
13:14:04 <joehuang> xiaojie, how about your recent work about L2 networking
13:14:43 <Ronghui> @zhiyuan_    i did not set the admin-openerc  on node2
13:16:20 <zhiyuan_> no, the environment variables are exported by DevStack
13:17:30 <xuxiaojie> @joehuang,today ,i start to think about thant,we can discuss friday, ok?
13:18:26 <Ronghui> i got it  and in the local.conf i and miss the command OS_REGION_NAME=$REGION_NAME
13:19:28 <Ronghui> hi ,Joe the -export OS_REGION_NAME=$REGION_NAME is in the local.conf or just a command
13:20:14 <zhiyuan_> oh, that is a diff result of stack.sh
13:20:20 <zhiyuan_> not in local.conf
13:20:21 <joehuang> no, you need to update the script, replace export OS_REGION_NAME=$REGION_NAME with export OS_REGION_NAME=RegionOne
13:21:13 <joehuang> I think Shinobu is correct, we need either trainning, or review the README.MD in github
13:22:10 <Ronghui> u mean in the admin-openerc in node1?
13:22:52 <joehuang> stack.sh
13:22:53 <Yipei_> @ronghui, modify devstack/stack.sh in node2
13:23:19 <Ronghui> ok
13:23:40 <Ronghui> i got it   i try to modify the keystone  but failed
13:23:44 <zhiyuan_> yeah, but i feel a bit strange that after updaring all the projects, i didn't change stack.sh but devstack starts successfully
13:24:15 <joehuang> Hi, Yipei, your segment error need a patch which caused by Neutron. https://github.com/openstack/tricircle/commit/d8d1940b9e43bd11e74017399ae3ba296214cf63
13:24:48 <joehuang> Maybe devstack already fix the bug for multi-region setup
13:24:49 <Ronghui> @zhiyuan_ u are run in the virtual environment or truth?
13:25:15 <zhiyuan_> virtual machine
13:25:22 <Yipei_> yes, i think i can try it tomorrow
13:25:49 <joehuang> for L2 networking, I think we need a team working on it, it's quite a big features
13:25:54 <Ronghui> i thought  it is in the truth so this problem happened
13:26:28 <joehuang> if you have phiscial server, you can run virtual box like what pengfei didi
13:26:37 <joehuang> pengfei did
13:27:09 <Ronghui> i have 2 physical server
13:27:10 <zhiyuan_> we can design the framework for l2 networking first, then we can code together
13:27:10 <joehuang> Hi, Zhiyuan and Yipei, how do you think about the L2 networking
13:27:11 <ztang> I think we spent many time in the system congiguration.  Not like i in the Spark resource project, some module are easy to modify and rewrite directly.
13:27:34 <Ronghui> so i run in diff physical node
13:27:40 <Ronghui> not virtual box
13:28:40 <joehuang> run VM will be easy to destroy devstack and dependency package. just create a new VM and get latest devstack
13:28:53 <Yipei_> @joe, sorry, I do not have much idea about the L2 networking. i think i still need to do more research on it
13:29:59 <joehuang> Spark is single application, may be modulated better.
13:30:32 <joehuang> agree with Zhiyuan, we can have a framework for L2 networking first
13:30:59 <zhiyuan_> joe, as you mentioned before, we need to build a plugable mechanism for l2 networking, so i think we need to list all the scenario we want to support first
13:31:33 <zhiyuan_> then we can abstract the model and logic
13:31:41 <joehuang> great
13:31:47 <Ronghui> i agree with zhiyuan_
13:32:09 <joehuang> How about ztang and ronghui, your idea about L2 networking
13:32:23 <zhiyuan_> may discuss with xiaojie on Friday
13:33:09 <joehuang> #action let's discuss L2 networking in #openstack-tricircle on Friday
13:33:40 <Ronghui> i think we should list all the scenario with nova cinder nerturn before framework
13:34:30 <Ronghui> the vedio about cascading is simpleness
13:34:43 <joehuang> Yes, so we can add one ether pad for the discussion, to put some items in the etherpad to be discussed
13:35:01 <ztang> I agree with zhiyuan, the framework should be a plugable.
13:35:49 <joehuang> pluggable to deal with different scenario
13:36:07 <joehuang> #info L2 Networking framework should be pluggable
13:36:45 <joehuang> ok create a new etherpad for L2 networking discussion
13:36:51 <joehuang> #link https://etherpad.openstack.org/p/TricircleCrossPodL2Networking
13:37:47 <Ronghui> should we consider the migration?
13:38:28 <joehuang> you mean VM/volume migration?
13:38:40 <Ronghui> yes
13:39:08 <joehuang> of course, are you interested in this topic?
13:40:06 <Ronghui> i have done before the migration of VM between diff node in physical enviroment
13:40:40 <joehuang> great, if you are interested in this one, it would be great to work on it in tricircle
13:41:08 <ztang> I have researched some algorithms about VM migration using bin-packing method
13:41:54 <joehuang> can it be applied in cross pod scenario, for tricircle is more about coordinator for different bottom openstack instances
13:42:02 <ztang> but some experiments are implemented under cloudsim platform.
13:42:36 <ztang> hi joe. i hava read the tricircle resource and also read the keystone and nova and cinder doc,but i dont familiar with the neutron ,can you give some suggestions about how to start joining  project for me?
13:42:39 <joehuang> o, a little different with OpenStack, but some technology may be reused
13:43:20 <ztang> lxq can not connent xchat, the above question is proposed by him.
13:43:57 <ztang> from lxq: hi joe. i hava read the tricircle resource and also read the keystone and nova and cinder doc,but i dont familiar with the neutron ,can you give some suggestions about how to start joining  project for me?
13:44:13 <joehuang> ok. I think you can find some material on SlideShare for neutron, and some blog in mirantis/redhat are also very good
13:45:36 <Ronghui> the migration before is based on shared storage on compute node  and  in tricircle is same or diff?
13:46:08 <Ronghui> and i done it on L2 networking
13:46:18 <joehuang> I suggested that we have a meeting in #openstack-tricircle on Friday about L2 networking, at UTC+8(China time, 4:00pm)
13:46:48 <ztang> we must over the wall to access the SlideShare
13:46:49 <joehuang> it's different, because no shared storage between pod
13:47:05 <zhiyuan_> oh sorry joe, i would like to ask for a leave Friday afternoon
13:47:38 <Ronghui> yes there is no shared storage between pod
13:47:55 <joehuang> ok, what time you suggest would better work for you
13:49:07 <zhiyuan_> I am leaving on 3pm
13:49:14 <joehuang> you can try VPN service, Zhiyuan can give you some infomation
13:49:34 <joehuang> so let's have meeting 9:00AM, friday
13:49:43 <zhiyuan_> that's fine for me
13:50:26 <ztang> that's great
13:50:48 <ztang> @zhiyuan what about your email address?
13:50:52 <joehuang> Ok, Let's continue the discussion on Friday. And if you have any question on devstack, we can communicate in the channel #openstack-tricircle daily
13:51:24 <joehuang> you can ping zhiyuan in #openstack-tricircle, or me
13:51:32 <zhiyuan_> luckyvega.g@gmail.com
13:51:41 <Ronghui> thank for answero for all of u
13:51:44 <zhiyuan_> what about xiaojie? time is ok?
13:52:05 <joehuang> ok. We have two topics not discussed today, let's discuss next time
13:52:08 <zhiyuan_> actually you can send mail to openstack-dev maillist
13:52:15 <joehuang> xiaojie, are you online
13:53:11 <joehuang> yes, like what Yipei did
13:53:25 <joehuang> ok, Xiaojie's connection is lost.
13:53:31 <joehuang> let's end the meeting.
13:53:45 <joehuang> #endmeeting