13:02:46 <joehuang> #startmeeting tricircle
13:02:46 <openstack> Meeting started Wed Apr  6 13:02:46 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:49 <openstack> The meeting name has been set to 'tricircle'
13:03:00 <joehuang> #topic rollcall
13:03:04 <zhiyuan_vega> really? the status is still "confirmed"
13:03:10 <joehuang> #info joehuang
13:03:16 <zhiyuan_vega> #info zhiyuan
13:03:17 <Yipei> #info Yipei
13:03:19 <Ronghui> # Ronghui
13:03:25 <Ronghui> #info Ronghui
13:03:52 <Ronghui> change the stack.sh in node2
13:04:11 <joehuang> #topic cross OpenStack L2 networking
13:05:00 <joehuang> ok, so now the devstack scripts issue is not clear being fixed or not
13:05:24 <joehuang> but would like to know whether there is any issue in ztang's environment?
13:05:25 <zhiyuan_vega> i can submit a patch to fix the upstream bug
13:05:54 <Ronghui> we also meet the same problem in node2
13:06:01 <joehuang> #action submit a patch in devstack to fix the multi-region installation issue
13:06:41 <joehuang> ok, last friday, we have a very good discussion on cross OpenStack L2 networking
13:07:00 <joehuang> #link https://etherpad.openstack.org/p/TricircleCrossPodL2Networking
13:07:06 <zhiyuan_vega> i have made a summary in etherpad
13:07:22 <Ronghui> multi-region problem and change the stack.sh where OS_REGION_NAME=RegionOne instead of OS_REGION_NAME=RegionTwo
13:07:25 <joehuang> thanks to zhiyuan :)
13:08:05 <joehuang> #info and in OPNFV, there is a real use case need the feature of cross openstack l2 networking
13:08:19 <zhiyuan_vega> @Ronghui, yes, we need to merge this change in DevStack code tree
13:08:31 <joehuang> #info two openstack instances in two sites
13:09:00 <Ronghui> yes  the solution now is to fix the stack.sh
13:09:20 <joehuang> and deploy vRouter service VM in each OpenStack
13:09:47 <joehuang> #info and deploy vRouter service VM in each OpenStack
13:10:30 <joehuang> #info these two vRouters in different subnet needs to connect with each other through cross OpenStack L2 network
13:11:14 <joehuang> The L2 networking feature is the top1, for OPNFV wants to use this feature in OPNFV D release
13:11:36 <joehuang> and the project is IPv6
13:11:56 <joehuang> so we also need to check Tricircle can work compatible with IPv6
13:12:18 <joehuang> #action Tricircle should be able work in IPv6
13:12:56 <joehuang> ok. zhiyuan, could you have a short summary about last week's dicussion
13:15:14 <zhiyuan_vega> We discussed the scenarios cross pod L2 networking needs to support and how Nova API gateway can handle the network segmentation information on top OpenStack and bottom OpenStack
13:17:05 <zhiyuan_vega> We finally figured out that we mainly have two kinds of scenarios: shared segmentation ID and different segmantation ID
13:17:06 <joehuang> #link https://etherpad.openstack.org/p/TricircleCrossPodL2Networking
13:19:25 <joehuang> #info one more scenario needs to be added: a default network type should be configured, because tenenat is not able to specify network type and segment id
13:24:22 <zhiyuan_vega> I remember that Neutron has a "default tenant network" configuration option
13:25:25 <joehuang> yes, this configuration could be reused
13:26:22 <joehuang> we have a very rough framework for L2 networking
13:26:41 <joehuang> we need to file a spec, and review just like code
13:26:42 <Ronghui> hi , Joe what is file the  spec
13:26:57 <joehuang> submit a spec
13:27:04 <joehuang> for example
13:28:13 <Ronghui> hi ,Joe  we will try this work
13:28:14 <joehuang> #link https://review.openstack.org/#/c/270786/
13:28:19 <joehuang> great
13:29:23 <ztang> Joe, i think we are interested in this work. this can make our team member to be familar with this architecture. And our other member, Long asks for leave tonight. In this week, the code work go more smoothly than before.
13:29:25 <joehuang> and register a BP just like https://blueprints.launchpad.net/tricircle/+spec/implement-stateless
13:30:02 <joehuang> very good
13:30:56 <joehuang> #action spec and bp for cross pod l2 networking, based on https://etherpad.openstack.org/p/TricircleCrossPodL2Networking
13:31:50 <joehuang> do you have any question on spec and BP
13:32:53 <joehuang> just create a folder under tricircle root, for example, in https://github.com/openstack/tricircle add one more spec folder
13:33:07 <Ronghui> we try this work and if meet some problem we email u guys or discuss on openstack-tricircle
13:33:15 <joehuang> and the spec is writen in .rst for review
13:33:27 <joehuang> or mail-list
13:33:43 <joehuang> great
13:34:09 <zhiyuan_vega> rst short for reStructuredText
13:34:55 <ztang> joe, for i am very busy in this month for other projects. tommorrow, i will have a meeting with our group, how to start and finish the current works.
13:35:18 <joehuang> understand
13:35:18 <Ronghui> the theme is L2 networking?
13:35:34 <ztang> thx
13:36:22 <joehuang> any things to be discussed can use openstack-dev maillist or #openstack-tricircle channel
13:37:02 <Ronghui> yes , i gain a lot from the channel tircircle
13:37:14 <joehuang> and for the second topic, pod schedulin
13:37:40 <joehuang> I would like to have a discussion similar as the L2 networking
13:38:15 <Ronghui> what u mean for pod schedulin?
13:38:34 <joehuang> for one AZ including several pods
13:38:55 <joehuang> one AZ in Amazon can support 50000+ servers
13:39:08 <zhiyuan_vega> have we discussed this use case in our doc?
13:39:27 <joehuang> OpenStack is very not good at large scale AZ
13:40:18 <joehuang> Yipei, are you still interested in this area?
13:40:25 <Yipei> some description has been made in #link https://docs.google.com/document/d/18kZZ1snMOCD9IQvUKI5NVDzSASpw-QKj7l2zNqMEd3g/edit#
13:40:26 <Yipei> yes
13:40:48 <Yipei> but i think i still have some questions
13:41:08 <joehuang> This feature has already required for some production cloud, it's quite meaningful
13:41:11 <joehuang> please
13:41:20 <ztang> Ronghui, how about your tools to over wall?
13:41:25 <Yipei> pod scheduling means scheduling resource or scheduling pods from one AZ to another?
13:41:51 <Yipei> i think pod binding is clear enough
13:42:01 <joehuang> no, select proper pod to provision VM, and VM volume co-location
13:42:14 <Yipei> i see
13:42:33 <joehuang> yes, it's how to dynamicly binding tennant to a pod
13:42:49 <Ronghui> u mean choose the best pod to provision VM?
13:42:50 <joehuang> and especially in capacity expansion, it's a little complex
13:42:55 <joehuang> yes
13:42:59 <Yipei> i think i understand the basic idea of pod scheduling
13:43:28 <Yipei> i am interested in this topic
13:43:37 <joehuang> so let's have a dicussion in this friday in #openstack-tricircle
13:43:44 <Ronghui> should we need to monitor the date of resources of each pod?
13:43:58 <ztang> is pod scheduling based on nova?
13:43:59 <joehuang> the time is UTC+1 (Beijing time 9:00AM)
13:44:12 <Yipei> ok, got it
13:44:34 <joehuang> it could be very complex, but we can do step by step
13:44:52 <zhiyuan_vega> ok
13:44:54 <joehuang> just like nova scheduler has a lot of filters
13:45:08 <joehuang> we also need pluggable binding mechnism
13:45:26 <joehuang> binding better than scheduling? isn't it?
13:45:38 <Ronghui> i think we meet all the diff filters of diff pod
13:46:02 <joehuang> not so fine granlular
13:46:03 <Ronghui> diff pod will have diff filers
13:46:12 <joehuang> two layer
13:46:22 <joehuang> tricircle is coarse grain
13:46:36 <joehuang> and bottom pod is fine grain scheduling
13:47:24 <joehuang> #action discuss pod binding in #openstack-tricircle this friday UTC+1(Beijing 9:00AM)
13:47:39 <Ronghui> combined two pod sheduler and get a best mechanism to deploy the VM
13:48:14 <joehuang> And for the last topic, Zhiyuan has already submitted pacth for review
13:48:40 <joehuang> and Ronghui, ztang could you review Zhiyuan's patch, how to add you to the reviewer list?
13:49:17 <ztang> ok, I'm glad to
13:49:27 <Yipei> @Zhiyuan, in my environment, simply set OS_REGION_NAME as RegionOne is not enough, i still need to remove "create_volume_types"
13:49:27 <Ronghui> me too
13:50:10 <joehuang> ok, please zhiyuan send the patch link in mail-list, so that ztang and ronghui can review and comment it.
13:50:20 <ztang> It's my pleasure
13:50:21 <zhiyuan_vega> fine
13:50:37 <joehuang> ok, let's end today's meeting
13:50:45 <joehuang> thanks for your time
13:50:45 <zhiyuan_vega> @Yipei, check it tomorrow
13:50:51 <Yipei> ok
13:51:04 <joehuang> #endmeeting