13:01:18 <joehuang> #startmeeting tricircle
13:01:19 <openstack> Meeting started Wed May 18 13:01:18 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:23 <openstack> The meeting name has been set to 'tricircle'
13:01:51 <joehuang> hello, Zhiyuan is attending the OSCON in Austin, USA
13:02:03 <joehuang> so he will not attend the meeting
13:03:01 <joehuang> and he will have a joint session with google engineer to talk about tricircle and ubernets(Kubernets cluster federation) in OSCON
13:03:14 <joehuang> #topic rollcall
13:03:20 <joehuang> #info joehuang
13:03:28 <Ronghui> #info Ronghui
13:03:52 <Yipei> #info Yipei
13:04:44 <joehuang> #topic cross pod L2 networking and dynamic pod binding
13:05:13 <joehuang> we have several round review of these specifications
13:05:47 <joehuang> do you have any questions in implementation and comments
13:07:38 <Yipei> i submit a patch to add resource_affinity_tag
13:07:47 <Yipei> but encounter following errors
13:07:53 <Yipei> It is likely that your change has a merge conflict. You may resolve it in the working tree now as described above and then run 'git review' again, or if you do not want to resolve it yet (note that the change can not merge until the conflict is resolved) you may run 'git rebase --abort' then 'git review -R' to upload the change without rebasing.
13:08:17 <Ronghui> wait for a moment  qiongqiu's network is not stable
13:08:30 <joehuang> because your base has been changed
13:08:41 <joehuang> you have to do the code rebase
13:09:07 <joehuang> and you'd better to have your own branch, but not directly modified in the master branch
13:09:25 <Yipei> yes, i create a new branch
13:11:11 <joehuang> you can try  'git rebase --abort'
13:11:13 <joehuang> before you run this command
13:11:29 <joehuang> please backup your modification
13:11:44 <joehuang> then git clone the latest code
13:12:03 <joehuang> and create your own branch and switch to this branch
13:12:11 <Yipei> ok, got it
13:12:17 <joehuang> then edit your code, and test it
13:12:42 <joehuang> after everything is ok, including pep8, py27 test...
13:13:03 <Yipei> ok, got it
13:13:08 <joehuang> then git add/commit/review
13:13:41 <Yipei> i execute git commit -a -amend
13:13:48 <Yipei> then git review
13:14:30 <joehuang> no, for the first time, don't use -amend
13:15:37 <Yipei> ok
13:16:55 <lxq> hi. Sorry for late
13:17:02 <joehuang> you are welcome
13:17:18 <Yipei> i think i still need to do some research on measurement
13:20:46 <joehuang> measurement is not the key
13:20:57 <joehuang> the key is the framework
13:22:36 <lxq> is dynamic pod bingding visible to end user?
13:22:54 <joehuang> no
13:23:07 <joehuang> it's not visible to end user
13:23:24 <joehuang> only admin can query the binding information
13:23:29 <lxq> you mean it is just suppled to admin?
13:23:47 <lxq> ok, i understand
13:24:20 <joehuang> any doubts on L2 networking?
13:24:52 <Ronghui> L2 networking is so complex ~
13:24:59 <Ronghui> that is our feeling
13:25:45 <joehuang> yes, it's a little complex
13:26:16 <joehuang> what's the concrete issues for you
13:27:43 <Ronghui> first  should we have to change the network model of pod  for text different use case
13:29:08 <joehuang> it's configuration to use vlan or vxlan, of course if vlan is used, you have to make the provider network support this
13:30:26 <joehuang> there are lots of bugs reported recently
13:30:29 <joehuang> https://bugs.launchpad.net/tricircle
13:31:28 <joehuang> would you like to fix some of them
13:32:37 <joehuang> through the bug fix, and try to run tricircle, you will become family with the code
13:32:44 <lxq> ok,i will try it
13:32:52 <joehuang> sorry, familar
13:33:14 <Yipei> ok
13:34:32 <joehuang> good to see the new patches from you
13:36:03 <joehuang> so any other topics?
13:36:43 <Ronghui> i have a question
13:36:53 <joehuang> please
13:36:56 <Ronghui> about the dynamic pod bingding
13:37:32 <joehuang> and Yipei, please register a blueprint in https://blueprints.launchpad.net/tricircle for dynamic pod binding
13:37:51 <Ronghui> when the dynamic pod bingding happend , whether it is effect on VMs?
13:38:03 <joehuang> and link the bp in the spec commit message, just like that in cross pod L2 networking
13:38:27 <joehuang> just for later new provisioned VMs/Volumes
13:38:48 <joehuang> #action register a blueprint in https://blueprints.launchpad.net/tricircle for dynamic pod binding
13:38:51 <Yipei> ok
13:39:09 <joehuang> #action link the bp in the spec commit message and spec, just like that in cross pod L2 networking
13:39:36 <joehuang> more questions, ronghui?
13:39:43 <Ronghui> A situation occurred
13:39:53 <Ronghui> that  at the same PM
13:40:18 <Ronghui> the VM will in different pod ?
13:40:51 <joehuang> what's PM, you mean baremetal machine? or physical server?
13:41:07 <Ronghui> physical server
13:41:27 <joehuang> no physical server only belongs to one bottom pod
13:41:46 <joehuang> no, physical server only belongs to one bottom pod
13:41:47 <Ronghui> before dynamic pod bingding the PM will in pod1 bingding on AZ1
13:42:08 <Ronghui> but bottom pod not only belongs to one AZ
13:42:12 <Ronghui> right?
13:42:24 <Yipei> @joe, there already exists a blueprint of dynamic-pod-binding
13:42:26 <joehuang> no, one pod only inside one AZ
13:42:56 <Ronghui> i mean that  bottom pod not just belongs to one AZ
13:43:28 <joehuang> ok, please add link in the spec
13:43:37 <Yipei> ok
13:43:37 <joehuang> and commit message
13:43:47 <Ronghui> it just belongs to one AZ but the bingding will change the belong to
13:44:07 <joehuang> one bottom pod just belongs to one AZ
13:44:38 <joehuang> no, the binding is about the relationship of tenant and pod
13:44:44 <Yipei> i am not allowed to edit the spec url
13:44:45 <Ronghui> when dynamic pod bingding happened it also not change?
13:45:22 <joehuang> to Yipei, you need to change the asignee
13:45:32 <joehuang> yes
13:45:38 <joehuang> to Ronghui, yes
13:46:04 <Ronghui> AZ>>>>>pod>>>>tenent    the change happened in pod>>>>>tenent?
13:47:02 <joehuang> a tenant can be bound to different pod in different AZ
13:47:25 <joehuang> you can read the google doc blueprint for the relationship of these concepts
13:47:42 <Ronghui> ok  i know
13:48:00 <Ronghui> i confuse the migration and bound..
13:48:12 <joehuang> ok, let's end the meeting
13:48:18 <Ronghui> ok
13:48:36 <Yipei> how to change the assignee
13:49:25 <joehuang> have you log on to the site, if yes, you should be able to add yourself as the asignee
13:49:46 <Yipei> yes i have logged on the site
13:50:35 <joehuang> I have asigned the bp to you
13:51:06 <joehuang> ok, see you
13:51:10 <Yipei> i works
13:51:11 <joehuang> #endmeeting