13:02:32 <joehuang> #startmeeting tricircle
13:02:33 <openstack> Meeting started Wed May 25 13:02:32 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:37 <openstack> The meeting name has been set to 'tricircle'
13:03:14 <joehuang> #topic rollcall
13:03:22 <joehuang> #info joehuang
13:03:28 <zhiyuan_cai> #info zhiyuan
13:03:29 <Yipei> #info Yipei
13:04:59 <joehuang> L2 networking work group has a meeting today
13:05:12 <joehuang> good to see the progress in this feature
13:06:16 <joehuang> and yipei, how about the progress in pod binding
13:06:41 <Yipei> sorry about my progress, i have been busy with my graduation last week. it will end on next Monday i will speed up next week
13:07:12 <Yipei> and a new master student will join in in June
13:07:20 <joehuang> ok, please update the spec when you are available
13:07:24 <joehuang> good news
13:08:18 <Yipei> ok, i will
13:09:01 <joehuang> just talked with zhiyuan this afternoon, we also need to consider the rolling upgrade impact on the db access and rpc message
13:09:55 <Yipei> what do you mean rolling upgrade?
13:10:10 <joehuang> that means the components and db may be not working in the same version during upgrade period
13:11:21 <AshNFF> hi , I have problem with my Mitaka compute node from nova log I get this error :  Instance failed network setup after 1 attempt(s)
13:11:43 <joehuang> for example, some Nova-APIGW upgraded to Newton release, but some Nova-APIGW are still working in Mitaka release, and DB has been upgrade to Newton
13:12:03 <lxq_> sorry for late
13:12:26 <joehuang> so these components should be able to work in mixed version environment.
13:12:27 <AshNFF> from the controller nova log Failed to bind port 4215e6bb-b0fa-492c-a479-f4f7f20700df on host nu-vrs1 for vnic_type normal using segments [{'segmentation_id': 62, 'physical_network': None, 'id': u'b6f9bf32-54b8-4d25-bd27-37151024048d', 'network_type': u'vxlan'}]
13:12:40 <joehuang> welcome lxq
13:12:59 <Yipei> i see
13:13:19 <zhiyuan_cai> we can investigate versionedobject library
13:13:43 <Yipei> how to do that?
13:13:43 <zhiyuan_cai> it deals with multi-version issue of data models
13:13:50 <joehuang> And XJOB and Nova-APIGW may also working with different version during upgrade period
13:14:11 <joehuang> that means RPC also need to take care of version compatibility
13:14:46 <joehuang> ok, zhiyuan, is there any OSLO lib for versionedobject?
13:15:26 <joehuang> to AshNFF, sorry, we are in Tricircle meeting
13:15:35 <zhiyuan_cai> yes
13:15:46 <AshNFF> sorry thanks joehuang
13:15:57 <zhiyuan_cai> https://github.com/openstack/oslo.versionedobjects
13:17:25 <joehuang> ok, to zhiyuan, thanks for the link, so let's add one item in todo list, to support tricircle being able to do rolling upgrade
13:18:16 <joehuang> #action add one item in todo list, to make tricircle being able to do rolling upgrade
13:18:50 <joehuang> #info including versionedobject for DB access and versionedRPC for rpc message
13:20:58 <zhiyuan_cai> added
13:20:59 <joehuang> to lxq how about the volumetype patch?
13:21:45 <joehuang> great
13:22:19 <lxq_> i  will run the path in our enviroment before i submmit
13:22:43 <lxq_> today i learn some konowledge about running
13:22:54 <lxq_> like scree tool and others
13:23:25 <joehuang> good, if you have any question, feel free to ask in #openstack-tricircle
13:23:26 <lxq_> sorry, it is screen tool
13:23:59 <lxq_> it is my first time to use the tool, it is confued me at begging
13:24:12 <joehuang> if you have workable devstack, you can just replace the code of tricircle, and re-run the cinder-apigw
13:24:40 <lxq_> ok. i just konw it.:)
13:25:20 <joehuang> and you can use curl just like that in tricircle github readme to test cinder-apigw
13:25:35 <lxq_> understand!
13:26:05 <zhiyuan_cai> for cinder-apigw, using CLI to test is also fine
13:26:45 <lxq_> ok. :)
13:26:57 <joehuang> to zhiyuan I think so
13:27:04 <joehuang> yes, cinder volume CRUD is tested by cinder-client
13:27:16 <lxq_> yes.
13:27:42 <lxq_> i can run the command like cinder type-list
13:31:27 <joehuang_123> sorry, my previous connection was lost
13:31:56 <joehuang_123> in pycharm, you can run test cases, and see the code coverage
13:33:08 <joehuang_123> can you see my message
13:33:19 <lxq_> yes
13:33:20 <lxq_> i can
13:33:52 <joehuang_123> in pycharm, you can run test cases, and check the code coverage, to see which branch is not coverd
13:34:19 <joehuang_123> any topics
13:34:28 <joehuang_123> \nick joehuang
13:35:23 <joehuang> any other topics?
13:35:28 <Yipei> no for me
13:35:33 <zhiyuan_cai> no
13:35:34 <lxq_> not any more
13:35:50 <joehuang> ok, let's conclude the meeting early today
13:35:55 <joehuang> have a good day
13:36:03 <joehuang> #endmeeting