13:01:23 <joehuang> #startmeeting tricircle
13:01:24 <openstack> Meeting started Wed Jun  8 13:01:23 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:28 <openstack> The meeting name has been set to 'tricircle'
13:02:13 <joehuang> hello, tomorrow is China's public holiday
13:02:17 <zhiyuan> hi
13:02:41 <joehuang> I am afraid some team members will not be available
13:02:48 <joehuang> #rollcall
13:02:55 <joehuang> #topic rollcall
13:03:01 <joehuang> #info joehuang
13:03:11 <Yipei> #info Yipei
13:03:43 <joehuang> hi Zhiyuan
13:03:55 <zhiyuan> #info zhiyuan
13:04:43 <joehuang> #info the PyPI package has been registered and the publish to pypi job also has been configured
13:05:38 <joehuang> so it would be good to have a release to test the process work or not, that means if there is a new tag or release
13:05:56 <joehuang> the package should be able to be published to pypi
13:06:11 <joehuang> and can install Tricircle through pip install
13:07:05 <joehuang> so I prepare a list of patches which could be cherrypick to the stable/mitaka branch, so that we can have a new tag like 2.0.1 release
13:07:21 <joehuang> please have a look in the maillist
13:07:35 <joehuang> check to see whether it's ok
13:07:43 <zhiyuan> but previously we tried to cherry-pick to stable/mitaks branch and failed
13:08:01 <joehuang> now this issue has been fixed by infra team
13:08:17 <joehuang> and all patches were successfully merged now
13:08:34 <zhiyuan> cool
13:09:34 <joehuang> #action cherrypick select patches to stable/mitaka, then have a new tag 2.0.1 in stable/mitaka branch for release
13:10:16 <joehuang> ok, Yipei, how about your progress in dynamic pod binding?
13:12:19 <Yipei> i read the source code of nova scheduler, but still don't have idea about how to start designing the framework
13:12:39 <Yipei> it seems a lot work to do
13:13:16 <Yipei> design a filter first?
13:14:08 <zhiyuan> i think not a filter, but a framework to allow the filter to work
13:14:47 <joehuang> zhiyuan is correct
13:15:17 <zhiyuan> when nova api gateway starts, load the filters. when provision VM, apply filters to select a pod
13:15:57 <zhiyuan> you should design the interfaces of the filters
13:16:42 <zhiyuan> like what functions should be implemented, what parameters these functions should have
13:16:45 <joehuang> it's a common functionalities both for Nova and cinder
13:17:24 <Yipei> ok. i see
13:17:35 <zhiyuan> oh, then cinder api gateway also loads the filters
13:17:56 <joehuang> Hello, Zhiyuan, there is a good news from L2GW?
13:18:00 <Yipei> ok. got it. i will take it into consideration
13:19:18 <zhiyuan> yes, i have successfully connected two OpenStack instances with L2 gateway. the original L2 gateway plugin is extended to support remote L2 gateway. also, hardware_vtep schema needs to be extended.
13:20:11 <Yipei> another problem, when i execute unit tests by tox, the error "no module named cinderclient". does it mean i need to run unit tests in complete openstack environment?
13:21:04 <joehuang> Great news, zhiyuan
13:21:26 <joehuang> #info successfully connected two OpenStack instances with L2 gateway. the original L2 gateway plugin is extended to support remote L2 gateway. also, hardware_vtep schema needs to be extended
13:22:26 <zhiyuan> strange, i remember that tox will install the dependency and cinderclient is in the requirement list
13:22:39 <Yipei> python-cinderclient is installed in my environment
13:22:41 <joehuang> the cinderclient should be installed in the venv when you execute the tox
13:23:37 <joehuang> tox will start a venv and install dependency in the venv
13:24:49 <Yipei> i first execute tox -e py27 --notest, and tox install all the dependency
13:25:08 <Yipei> in py27 environment
13:26:03 <joehuang> no need to plus --notest
13:26:24 <joehuang> and try in a clean environment
13:26:46 <Yipei> ok, i will try again
13:26:54 <joehuang> good
13:26:54 <Yipei> in a clean environment
13:27:13 <joehuang> other topics?
13:27:22 <Yipei> about my spec file
13:28:00 <Yipei> do i miss any content in spec file?
13:28:59 <joehuang> Shinobu's comment not covered
13:29:06 <joehuang> and new patch is needed
13:30:37 <Yipei> ok, i will add some description about key concept, and update the commit message
13:31:12 <joehuang> The title of " Add specification file of dynamic pod binding" is not good
13:31:54 <Yipei> ok, i will revise it
13:31:57 <joehuang> Add specification for dynamic pod binding will be better
13:32:17 <joehuang> "Add specification for dynamic pod binding" will be better
13:32:38 <joehuang> other topics could be discussed in next weekly meeting
13:32:56 <Yipei> ok
13:33:15 <joehuang> let's end the meeting here
13:33:26 <joehuang> #endmeeting